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1 Overview

Licensed features
Production-mode software is activated via dongle-based licensing or, in
Prinergy workflows, via floating license. Each license type offers a basic
feature set and additional capabilities for specific industry applications.

License types

● Preps® Digital includes the basic feature set, tailored for smaller-
scale digital presses with a maximum 2-up sheet size.

● Preps Plus is tailored for the commercial printing industry, and it
offers the same feature set as Preps Digital, with the addition of
support for all available sheet sizes and tiling.

● Preps Digital Pro adds JDF workflow support and binding data
output, CIP3 cutting data output, and the AutoGang feature (which
is semiautomated in stand-alone Preps and fully automated via
AutoGang hot folders for Prinergy floating licenses).

● Preps Pro meets the needs of both the on-demand and commercial
printing industries. It supports all of the above capabilities, and adds
publication assembly planning for products—including support for
multiple products that can use mixed binding styles in their parts, a
dynamic Assembly view, and web growth compensation.

Basic feature set

The following feature set is provided with all licenses:

● Advanced run-list management in a Pages view
● Press Runs view that combines job layout manipulation and content

previews
● Media, stock, mark, and layout resources for drag-and-drop layout

creation
● Custom layout searches of existing templates and fold patterns
● Multiple sections per press sheet
● Manual drag-and-drop ganging
● Fold pattern resources for on-the-fly impositions
● SmartMarks® and mark groups



● Output to JDF, PJTF, PDF, and PS files
● Multiple-language support

Feature comparison

The following chart compares the additional features that are activated
by each license type.

Feature Preps Pro Preps Plus Preps Digital
Pro

Preps Digital

Unlimited sheet size, up to
maximum supported

yes yes Limit is 2-up size Limit is 2-up size

Mixed binding styles yes

Assembly view yes

Web growth compensation yes

Multiple products and parts yes

JDF input yes yes

JDF auto signature matching (ASM) yes yes

JDF auto signature creation (ASC) yes yes

AutoGang for semiautomation yes yes

* AutoGang hot folders for full
automation

yes yes

JDF binding data output yes yes

CIP3 cutting data export (JDF, PPF,
PJTF)

yes yes

Automatic and custom tiling yes yes

Fold pattern resource yes yes yes yes

* This feature is available only with a Prinergy Connect or Prinergy Evo
floating Preps Pro license.

Note: The Preps User Guide describes the full feature set that is included with the
most comprehensive license (Preps Pro). If you see information about a capability
that is not available in your copy of the software, it is possible that your license
does not support that feature.
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Task-based views
Tab between dynamically updated views as you work on a job's pages,
press runs, or product assemblies, with an interactive workspace and
supporting list panes in each view.

● In the Pages view, set up the product run lists with blank,
placeholder, or PDF content pages; preview individual pages and
page details; adjust the trim boxes; and reposition, scale, or rotate
the PDF content.

● In the Press Runs view, create and interactively edit and preview
any number of sheetfed and multiweb press runs to accommodate
the job’s pages. Manage the stock, media, marks, and layout for
each sheet or web either individually or for linked press runs.

● In the Assembly view, provide the product intent for a customer job,
which can include multiple products and parts, and mixed binding
styles. Interactively plan the binding assembly of each products
part’s and sections, and autogenerate the press runs based on your
planned details.

Working with the views

The way that you use the views can be affected by such factors as the
job types, product requirements and complexity, the number of people
who work on jobs, the feature set supported by your software license,
and personal preferences.

Here are a few possibilities:

● For ganged jobs or for basic single-product, single-part jobs, you
might work entirely in the Press Runs view.

● Or you might first use the Pages view to collect the input files or
define file placeholders and set up the run list, and then switch to
the Press Runs view to build the press-run layouts.

● For intelligent setup of ganged press runs, you might use the
AutoGang feature in the Press Runs view.

● Jobs for complex publications might be done in stages.

For example, a planner, customer service representative, or senior
prepress operator might start a job by providing the product intent
in the Assembly view (license-dependent). The job can then be

Task-based views 3



completed by a prepress operator who creates the layouts and
prints the press runs.

● In a JDF-based workflow, you use the Assembly view to provide any
information that was not received via JDF, and then check the
autogenerated press-run layouts in the Press Runs view.

User interface tools

● Drag-and-drop functionality for placing and moving items
● Toolbars and keyboard shortcuts for most tasks
● Context (right-click) menus for managing the resources
● Arrow icons for expanding or collapsing the panes
● Adjustable dividers for resizing the panes
● Instant access to properties of items that you select in the workspace
● Dynamic updating in all affected areas when edits are made in any

area
● Menus and dialog boxes for less frequently performed tasks
● The Help menu for user information and demonstration movies

User interface regions

The user interface panes are grouped by general purpose in the left
side, center area, and right side of the window:

● The left side of the window contains lists of job assets, from which
you can select elements for building a job.

● The center region is your primary job-building area.
● The right side gives you detailed control over selected job elements.

All information is dynamically updated as you make changes in related
areas.

1 Products Use the Products pane to view and manage the job
structure.
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For manual layouts, you can select and drag sections to the
Press Runs workspace.

2 Files In the Files list, you add customer PDF input files, create
placeholder files, and select file pages to add to a run list
or press-run layout.

3 Resources Use the Resources pane to select and manage your
resources for building press runs.

● Media list
● Stock list
● Marks list
● Layouts pane:

❐ Templates list
❐ Fold Patterns list
❐ Search tool

4 View tabs Toggle between views for primary aspects of a job

● Pages view
● Press Runs view
● Assembly view

5 Workspace Review, rearrange, and edit items in the workspace to
dynamically update the properties.

● In the Pages view, preview pages and check trim boxes.
● In the Assembly view, plan multiple products and parts.
● In the Press Runs view, build and check press-run

layouts.

Use viewing tools and menu options to control which
details are displayed.

6 Summary
lists

In each view, manage a list of all applicable job items. You
can arrange the rows and columns, change the sort order
and width of columns, and expand or collapse the rows.

Select an item in the Press Runs List or Pages List to
display it in the workspace. In the Assembly workspace,
you can toggle between graphical and list formats.

7 Properties Use the Properties pane to view and edit the settings of
selected job items. All applicable panes and lists are
dynamically updated with your changes.

Select an item in a workspace, summary list, or Products
list to display its settings in the Properties pane.
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2 Jobs

Many of your jobs can be completed using variations of a few basic
tasks.

General tips
This list summarizes useful tips, such as how to select, delete,
rearrange, and access the properties of items.

Option Description

Selecting an object in the workspace or
Products list

Displays its settings in the Properties
pane

Selecting a press run, sheet, web, or
surface in the Press Runs List

Displays the layout in the workspace
(or the first layout of multiple webs,
with the web-selection list); if a press
run is selected, also displays its settings
in the Properties pane

Selecting a page in the Pages List Displays its preview in the workspace
and its settings in the Properties pane

Double-clicking an imposition in the
workspace

Displays its Modify Imposition dialog
box

Double-clicking a stock, media, mark,
or template in a Resources pane list

Adds that resource to the layout in its
default position

Right-clicking an item in a Resources
pane list or in the Products list

Displays a context menu of options for
that item or list

Double-clicking inside an editable text
box or column

Makes it editable, and in some cases,
displays a selection list

Tabbing out of a text box that you edited Applies your edit and moves the cursor
to the next text box, if applicable



Option Description

Deleting versus removing Typically, removing takes an item out of
the workspace but retains it in the job,
and deleting makes it permanently
unavailable

Pressing Delete versus Option/Alt
+Delete to remove a ganged page

To remove a ganged content page and
its template page, select the page and
press Delete; to remove only the
content page, press Command/Ctrl
+Delete

Dragging rows in the Press Runs List Rearranges the press runs for your
viewing convenience

Dragging sections in the Assembly
workspace

Can be used to combine sections or
change their binding style or sequence;
updates the page and section
numbering accordingly

Editing a property with multiple values
( --, Mixed, Multiple)

When multiple selected items are set
to different values, your edit sets them
all to the same value.

Summary of job steps
The following steps summarize the main aspects of most single-
product jobs. Not all steps must be performed in a specific order, many
can be combined or automated, and there are flexible ways to perform
most steps.

Requirements:

You should have a solid prepress background and understanding of
imposition concepts and workflow.

1. Optionally define the product intent, including the product and part
page counts.

2. (Skip this step for unpopulated jobs.) Add the input files to the job.

3. (Skip this step for ganged jobs.) Set up the run list with PDF,
placeholder, or blank pages.

4. Add media and stock to a press run.

5. Create a press-run layout with page positions, content, marks, and
trims, as needed.
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6. Continue building the press runs to accommodate the pages for this
job.

7. Save the job, and print the output files.

8. Optionally save the job as a template or fold pattern for reuse.

Creating different job types
The way that you create jobs can be affected by such factors as the job
types, product requirements and complexity, the number of people who
work on jobs, the feature set supported by your software license, and
your preferred way of working.

This topic provides brief summaries of the steps involved. For details,
see the applicable topics.

Note: Work on only one job at a time.

Choose a method:

Job type Steps

Basic jobs 1. Select File > New.
2. Set up the run list in the Pages view.
3. Build the layouts in the Press Runs view.

Manual ganging jobs,

Jobs with a single product and binding style

1. Select File > New.
2. Set up the Files list.
3. Build the layouts in the Press Runs view.

Jobs with multiple products, parts, binding styles

(without using product intent or the Assembly view)

1. Select File > New.
2. Use the Products list and Properties pane to

define the parts and sections.
3. Set up the run list in the Pages view.
4. Build the layouts in the Press Runs view.
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Job type Steps

Jobs planned via product intent in the Assembly view 1. Select File > New Job With Product Intent and
provide the available information.

2. If another product is needed in this job, select File
> Add New Product Intent.

3. Check and refine the job structure and properties
in the Assembly view.

4. Click Generate Press Runs.
5. Set up the run list in the Pages view.
6. Check and finalize the layouts in the Press Runs

view.

JDF automation jobs 1. Select File > Open.
2. Locate and open the JDF file.
3. Check and refine or complete the generated job

structure and properties in the Assembly view.
4. If you made structural changes, regenerate the

press runs.
5. Set up the run list in the Pages view.
6. Check and finalize the layouts in the Press Runs

view.

AutoGang jobs (stand-alone) 1. Select File > New.
2. Set up the Files list.
3. Set up the AutoGang list.
4. Generate the autoganged press runs.
5. Check and finalize the layouts in the Press Runs

view.

Basic steps for printing the output
When you print the output, you provide basic information, such as the
print range, and you can also set up advanced options for color
mapping and web growth compensation.

1. Optional: In the Preferences dialog box, load a suitable profile or set
options as needed on the Output tab.

You can set default values for:

● Output type (PS, PDF, PJTF, JDF, or PPF)
● CIP3/PPF (Generate multipage cut blocks, CIP3 units)
● JDF (Include JDF folding data, Include HTML for WST

equipment setup)
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● PDF (Split File Name)
● Display punch mark
● Print side center marks
● Ignore split file output errors
● Print crop marks for bleed bounds
● Auto rotate for best fit
● Center image on media
● Output PS marks flats for PJTF/JDF
● Print page and sheet bounding boxes
● Skip device warning
● Scale shingled pages (Proportionally or Anamorphically)
● Shingle crop marks

2. Select File > Print.

3. In the Send to list in the Print dialog box, select the output file type
or Printer.

4. Accept or change the Media.

Any change that you make to the media selection applies to the
entire output.

5. Set up other print options on the dialog box tabs as needed.

6. Click Print.

7. If you are printing divided output and the Print File ID dialog box
appears, type an identifier to include in each file name, and click OK.

8. If printing to file, specify a file name and folder location for the output.

If you generate divided output for media configurations that are set
up with divided output paths, the files are placed in those folders
and you cannot redirect the output.

Saving and closing a job and template
After generating the output, you can optionally store a job and its
layouts for future reuse.  If you save a job as a template, information
about each unique press-run layout is stored as a template signature.

1. To save the job, select File > Save or Save As, and accept or change
the file name and location.

The default location is the same folder that was used for the last save.

The job is saved with a .job file name extension. The job file stores
all the necessary data to allow it to be reopened and printed again, if
needed.
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2. To store any unique layouts in the job for future reuse, select File >
Save as Template.
The template is saved with a .tpl file name extension.

3. To close the job window, select File > Close.

4. To close the software, select File > Exit.
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3 Pages

Manage the product run lists in the Pages view, and in the Press Runs
view, manage the placement of pages on the layouts. You can also
create your own lists of folio and color names to use as resources for
describing individual pages.

Page terminology
Many terms can be used for pages, depending on the context.

Pages being prepared for layouts

Each file page in a job’s Files list is either a PDF page or a placeholder
page.

In the Pages view, you create a product’s run-list pages by adding PDF
pages, blank pages, or placeholder pages to the Pages List.

You can also sort a multipart product’s run-list pages by parts and part
pages.

Pages being planned for layouts

In the Assembly view, you create planned pages when you specify a
page count for a product, part, or section.

Before you add a layout resource (fold pattern or template) to a press
run or assembly, its pagination scheme defines a conceptual low folio
page, which is page 1. When you create a new press-run section from a
layout resource, the low folio page is occupied by the first page that
flows into this section from the run list.

Pages in layouts

In the Press Runs view, each content page on a layout occupies the
position that is defined by its corresponding template page.

A template page can represent an imposition page or a ganged page:

● An imposition page is one page position within an even grid of same-
size pages that will be folded together to form a book signature. Each



imposition page respects the folds and bleeds of adjacent
imposition pages.

● An ganged page is a page position in a flat-work layout that will not
be folded and bound. Care must be taken to prevent content overlap
with adjacent page content. Ganged pages can also be referred to as
an independent page.

Each content page on a press run represents an imposed run-list page
or a ganged instance of a page from the Files list.

Input files
Customer content is provided either as PDF files or as source
document files that you must convert to PDF. You can also work with
placeholder files.

Setting up the Files list
Collect customer PDF input or placeholder files in the Files list.

Requirements:

Although the source documents might be created in various software
products, they must be submitted as PDF input files.

Input files can include:

● Single-page or multiple-page PDF documents from various other
software sources

● Individual PDF page files that were exported by a prepress system
● File placeholders and pages

Choose a method for building the Files list:

● Drag PDF files from a local or network folder location to the Files
list, or select File > Add, and locate and add the files.

● Drag files directly to a run list in the Pages view or to a layout in
the Press Runs view.

● To add file placeholders, select Job > Add Placeholder, give the
placeholder a name, and specify the number of placeholder pages.

● When setting up a run list, use the Add Pages tool in the Pages
view to create placeholders.
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Next:

Select and drag PDF or file placeholder pages from the Files list to a
product run list in the Pages view or directly to a press sheet in the
Press Runs view.

Note: The original files are not affected by any adjustments that you make within
your job. Job input files and information about any page adjustments that you
make in the layouts remain associated with the job after it is saved.

Files list
The Files list displays information about the input files and pages,
including the number of times each page appears on a press run in the
job.

File Name Displays the name of each file or file placeholder that
you add to the job. Multipage files can be expandeed
to show their list of sequentially numbered pages. This
page number is appended to the File Name in the
Pages List.

Count A dynamically updated value appears beside each
page to indicate the number of times that the page
appears on a press run in the job.

Pages Displays the number of pages that each file contains

Trim Displays the dimensions the PDF page or placeholder
page. If a PDF input file does not specify the trim box
size, the bleed box or media box size is used.

Colors Displays the colors that are specified in the PDF input
file

[+] and [–] Click to locate and add files or to remove selected files.

Preparing suitable PDF input files
Generate suitable PDF input files from customer source files by
following guidelines for configuring the PDF export settings in Adobe
Acrobat Distiller job options or other desktop software.

Note: Settings that are not mentioned here are optional. For specific details, see
the documentation for the software that you use to generate the PDF files.
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Files

● Keep the default compatibility settings, or set the appropriate PDF
file-type version for the job. For example, for files that contain
transparencies, use PDF 1.5 or later.

● The recommended resolution is 2400 dpi.
● Do not use:

❐ Object level compression
❐ Auto-rotation of pages
❐ Embedded thumbnails
❐ Optimization for web viewing

Images

● For color and grayscale images, use ZIP compression.
● For monochrome images:

❐ Use CCITT Group 4 compression.
❐ Do not use downsampling.
❐ Do not anti-alias to gray.

Note: To create smaller files, you may use downsampling and JPEG compression if
they are acceptable to you and/or your customer. However, there will be some
data loss.

Color

● Do not use an Adobe Color Settings file.
● Leave color unchanged (no color management).
● Apply the default document rendering intent.
● Device dependent: Enable under color removal and black

generation, and preserve any transfer functions that are found.

Fonts

● Embed fonts. For maximum font information, include 100% subset
fonts.

If you do not embed fonts in the PDF file and the outline font used in
the source file is not available, Acrobat may substitute the Multiple
Master fonts.

● Allow processing to continue if embedding fails.

Advanced settings

● Convert gradients to smooth shades.
● Preserve level 2 copypage semantics.
● Preserve overprint settings, with a nonzero default level.
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● Save Adobe PDF settings inside the PDF file.
● Save original JPEG images inside the PDF file, if possible.
● Process DSC comments.
● Preserve EPS information from DSC.
● Preserve OPI comments.
● Preserve document information from DSC.
● Resize page and center artwork for EPS files.

● Do not permit:

❐ PostScript® file to override Adobe PDF settings
❐ PostScript XObjects
❐ Conversion of smooth lines to curves
❐ Saving Portable Job Ticket inside PDF file
❐ Using prologue.ps and epilogue.ps
❐ Logging DSC warnings
❐ A compliance standard

● Also, do not apply a compliance standard (such as PDF/X-1a).

Previewing pages
Preview a job's pages in the Pages and Press Runs workspace panes.

1. In the View menu, select the features that you want to preview.

2. Select a page to preview its content and trim box alignment:

● To preview an input file page before adding to a run list, use your
Adobe Acrobat software to open the file from its folder location.

● To preview a run-list page in the Pages view , select a page in the
Pages List.

● To preview a content page in the Press Runs view, select the
press run, sheet, web, or side that contains the section in the
Press Runs List.

Run-list pages
A run list organizes a product’s pages in front-to-back sequence, so
that the pages will flow correctly through the template pages in a
layout. To help you plan the distribution of pages on the press runs, you
can provide detailed information and notes about each run-list page.
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Setting up a product run list
As you set up a product run list, you can add details about each page to
help ensure that all the pages are correctly placed in the run list and on
a press run.

Depending on the job, you might set up a product run list either before
or after preparing the press-run layouts.

For gang-only jobs, you do not set up a run list. Instead, you add file
pages directly to a press run.

For multiple-product imposition jobs, you set up a run list for each
product.

1. Go to the Pages view.

2. On the Pages List toolbar, set the View by option to Product.

Note: With basic license types, the list can be viewed only by product.

3. Choose a method:

● To add an entire file: Click and drag the file (or file placeholder)
from the Files list, or directly from a folder location onto the
product name in the Pages List.

● To add an individual page or placeholder page: Click and drag the
page from the Files list onto the product name, to a specific run-
list position, or onto a page to replace it. Press Shift, then click
and drag to select and add multiple pages.

● To add empty placeholder pages, use the Add Pages icon in the
Pages List toolbar: Double-click or drag the icon, and in the
dialog box that appears, select the product, name the
placeholder, and specify the page count and position in the list.

● To insert a single blank page, use the Add Blank Pages icon: Drag
the icon to a specific run-list position, or drag it onto a page to
replace the page.

● To drag a specific number of blank pages using the Add Blank
Pages icon: Press and hold Option/Alt as you drag the icon,
specify the page count in a pop-up dialog box, and drop the
pages at an insertion point.

● To add multiple blank pages at a specific location using the Add
Blank Pages icon: A

The run-list position numbers are updated according to where you
placed the new pages:
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Inserting between page
positions

Renumbers the run-list page positions in sequence
from the insertion point. If you previously applied
folios, they are retained, and you will need to apply
folios to the new pages.

Replacing page positions Retains the numbering of the page or pages in the
selected position.

Note: If you drag multiple pages onto a single
existing page position, then the additional new
pages replace the corresponding number of
following page positions, and new page positions
are added if needed.

4. Adjust the Pages List to ensure that the run-list pages are in reader
sequence:

● To rearrange the pages: Drag the page rows as needed.
● To remove pages: Select the pages and click Delete. This does

not affect the Files list.
● To cut or copy and paste a page: Select the page, select Edit >

Cut or Copy, click the page that should be after the pasted run-
list pages, and select Edit > Paste.

5. Edit the settings in each row, as needed.

You can assign folios, edit the placeholder names and planned
colors, and write notes.

6. If the product contains parts (license-dependent), select Part in the
View by area of the toolbar, and drag pages as needed to organize
them into part-page positions.
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Working with placeholders
Create multipage file placeholders or individual placeholder pages, and
replace them as content becomes available, or keep the placeholders to
print output for unpopulated workflows.

Use placeholders when customer input files are not yet available, or if
content is to be added by a downstream workflow system.

Choose a task:

Add a file placeholder to the Files
list

1. Select Job > Add File Placeholder.
2. Specify the page trim size and number of pages, and provide an

optional name.
3. Click OK to add the file placeholder and its placeholder pages to the

file list.
4. Add the placeholder pages to the job’s press sheet layouts.

The file and its pages appear in green text to indicate that they are
placeholders that can be replaced with content files when available.

Replace a file placeholder 1. In the Files list, select the placeholder file.
2. Select Job > Add File Placholder.
3. If the page count of the placeholder file and the new content file are

different, your response to the message that appears depends on
whether you still need to fill the exact number of pages that were in
the placeholder file.

● The file name is updated.
● Any new content pages automatically replace any corresponding

placeholder pages that were already placed.
● If the page count was different, the file list is adjusted. For example,

if the replacement file contained fewer pages than the placeholder, a
new placeholder file might appear for the pages that were not yet
replaced by new content pages.

Add placeholder pages to a run list 1. Double-click the Add Pages tool in the Pages List toolbar.
2. In the Add Pages dialog box, select the product, give the new file

placeholder a name, and specify the page count and position
information.

The placeholder pages are inserted into the run list, and the placeholder
file appears in green text in the Files list.

20 Chapter 3—Pages



Replace a placeholder page Drag a PDF page or the Blank Page icon onto the placeholder page in
the run list or on a press-run layout.

Replace a file placeholder 1. In the Files list, select the file placeholder.
2. Select Job > Replace File PlaceholderJob, and locate and open the file.

If the page counts are different, a message prompts you to resolve
the difference.

The new file replaces the placeholder file in the Files list, and new
content pages replace the corresponding placeholder pages.

If the page count was different, the Files list is adjusted according to
your response to the message.

Pages view reference
In the Pages view, set up the product run lists with blank, placeholder,
or PDF content pages; preview individual pages and page details; adjust
the trim boxes; and reposition, scale, or rotate the PDF content.

Pages workspace
Use the workspace in the Pages view to check the alignment of the
content within the trim box.  You can reposition the content by
dragging the page, or fine-tune the positioning by directly editing the
dimension text boxes.

Select a page in the Pages List to display it in the workspace. Selecting
a page also displays its settings in the Properties pane.

Tip: To control which details are displayed, use the View menu and workspace toolbar.

Page trims You can view the following trims:

● Trim box: Dark blue rectangle that initially
represents the PDF file or the default page size for
a placeholder page. After the run-list page is
placed on a press run, the trim box is derived from
the template page.

● Bleed box: Red rectangle that is relative to the trim
box
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● Page size: Green lines that show a PDF page
relative to the trim box, adjusted when you
reposition, rotate, or scale the PDF run-list page

● Planned page size box: Pink rectangle that appears
only if specified for an assembly’s product intent

Select  For pages that are already assigned to a layout,
use this tool to select and drag the trim guides to
reposition the content within the trim box.

Rotate
 Rotates the content of the previewed page in 90-

degree increments without changing the template-
page orientation

Pan
 Moves your view of the workspace

Zoom
 Either click the object or general area that you

want to inspect more closely, or drag a marquee
around a specific area.

Show Page
Previews

 Displays a preview of all page content

Show
Dimensions

 Displays the page dimensions, including any
distances between the template-page trim box and
the PDF content trim box. You must select View >
Show Trim Box to use this option.

Page preview
navigators

 Select a page in the Pages List
to display, and then use the arrow keys to scroll
through the other pages in the current list.

The text box displays the run-list number of the
currently previewed page, followed by the total
number of pages in the current list.

To jump to a specific page within the currrent list,
type its run-list number into the box.

View menu in the Pages view
The View menu lets you control the details that you see in the workspace.

You can toggle these menu items between showing and hiding the
specified items.

Show Dimensions Displays the layout dimensions, including
distances between section or ganged page
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edges or centers (depending on Preferences).
Dimension text boxes become editable when
you click a page or section.

Show Page Previews Displays a preview of all page content

Show Page Sizes Displays the page width and height dimensions

Show Trim Boxes Displays a dark blue box that indicates the
page trim size

Show Bleed Boxes Displays a red box that shows the page bleed
margins

Show File Page
Numbers

Displays the input file’s page number on each
page

Show File Names Displays the input file name on each page. If
Show File Page Numbers is also selected, the
page number is appended to the file name.

Show Folio Displays the folio that you assigned in the
Pages List

Pages List
Manage the product run-list pages in the Pages List in the Pages view,
and immediately preview a page that you select in the list.

Note: For gang-only jobs, you add the PDF file pages to the Files list and then work
directly in the Press Runs view. You do not set up a Pages List. For licenses that
support multiple products, the ganged pages also appear as two-page (front,
back) products in the Pages List.

Toolbar

Add Pages  Double-click or drag the icon, and in the dialog
box that appears, select the product, name the
placeholder, and specify the page count and position
in the list.

The new placeholder file and file pages also appear
in the Files list.

Add Blank Pages  To insert a single blank page: Drag the icon to a
specific run-list position, or drag it onto a page to
replace the page.

To drag a specific number of blank pages: Press and
hold Option/Alt as you drag the icon, specify the
page count in a pop-up dialog box, and drop the
pages at an insertion point.
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To add multiple blank pages at a specific location:
Double-click the icon, and in the dialog box that
appears, select the product, and specify the page
count and position in the list.

Folio list Lists the standard folio sets that are provided with
the software and any common folio resources that
you add.

Note: These folios are for reference only. Page lists can be
ordered only by product or page numbers.

Select a folio set to autoapply to the page list, based
on the binding style, or select User-defined to edit
the page folios directly in the list.

To ignore the binding style and apply sequential
numbers from front to back, select 1, 2, 3....

Increment  Sequentially increments and applies the
alphanumeric or roman numeric folio of the
currently selected page to the remaining page rows
in the list. You can use this tool in the Folio column.

Repeat  Copies the selected cell text into the remaining
page rows. You can use this tool in the Folio,
Planned Colors, and Notes columns.

C, M, Y, K
Throughout

 Sets the Planned Color of the page list to CMYK.
You can also edit this value for individual pages.

Black
Throughout

 Sets the Planned Color of the page list to black.
You can also edit this value for individual pages.

View by Note: Basic licenses that support only one product per job
do not include this option.

● Product: For each product, lists all of its pages in
Run List order, from the front to the back of the
product. The Part Page column shows the part
page numbers that occupy each run-list position.

● Part: For each product, lists the pages per part in
Part Page order, in collapsible tree lists. The Run
List column shows the run-list positions that
each part page occupies.
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List columns

Tip: Drag the column edges to adjust their widths. Drag the column headers to
rearrange the columns.

Part Page (License-dependent) Displays the page numbers
according to their position within a part, and
indicates whether each page is assigned to a press
run. The presentation of this list depends on your
current View by selection:

● By Part: Part Page is the first column and provides
a collapsible tree view of product names, part
names, and the pages, numbered according to
their position in the part.

● By Product: Run List is the first column, and each
page number is decribed by its part name.

Folio Click this cell and select a common folio resource
from the list, or double-click and edit the value. You
can use the Increment or Repeat tools to apply your
folio to the remaining pages in the list.

Note: If you insert new pages between pages with
incremented folios, reapply the selected folio set or manually
edit the folios to reflect the correct sequence.

Run List Defines the reader sequence of the pages in one
product, from front to back. The auto-assigned run-
list numbers cannot be edited. When you view the
Pages List by product, the Run List column is the first
column.

File Name Displays the editable placeholder name or the
noneditable PDF file name of the content page. For
placeholder pages, you can double-click and edit the
value.

Planned Colors Click this cell and select a common color resource
from the list, or double-click and type a descriptor to
serve as a placeholder for the expected actual color.
When the actual color is updated, you can check for
discrepancies and resolve or ignore them, as needed.

The list includes the standard CMYK process colors,
standard coatings, your predefined common color
resources, and any custom colors that are used in this
job.

You can use the Repeat tool to apply your color
selection to the remaining pages in the list.
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Press Shift and click to select multiple items from the
list, and use a comma to separate multiple typed
values.

Actual Colors Displays the actual colors that are provided by the
input file, which are updated whenever a color is
mapped to another color separation in the Press
Runs view

Notes Type or view a note for your own reference or for/
from another operator.

Run list page properties
Select a page in the Pages List to display its trim boxes and content in
the workspace and its settings in the Properties pane.

Part Name Displays the part to which this page is assigned

Run List Position Displays the sequential position of the page within
the product, derived from the Run List column in
the Pages List

File Name Displays the editable file placeholder name or the
noneditable PDF file name

Page Size, W, H Depends on the current state of the page that
occupies this run-list position:

● If the page is not yet placed on a press-run
layout: Displays the dimensions of the PDF page
or placeholder page. If a PDF input file does not
specify the trim box size, the bleed box or media
box size is used.

● If the page is placed on a press-run layout:
Displays the Finished Page Size that is defined in
the Template Page properties.

Folio Displays the current value of the Folio column in the
Pages List. Your edits are updated in both locations.

Planned Colors Select a common color resource from the list, or
type a descriptor to serve as a placeholder for the
expected actual color.

Actual Colors Displays the actual colors that are provided by the
input file, which are updated whenever a color is
mapped to another color separation in the Press
Runs view
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Content page section

Position ● Center in template page
● Use trim offsets: Select this check box to be able

to manually position the content within the
template page.

You can specify the width and height distances
between the lower-left corner of the content page
and the lower-left corner of the template page, or
drag the page in the workspace to update these
values.

Note: The lower-left corner of a content page is defined in
terms of either the trim box or the bleed box, depending on
how the page size is defined in the input file.

Scaling Scaling is based on either the trim box or the bleed
box, depending on how the page size is defined in the
input file.

● None: Applies no scaling (default)
● Scale the content to fit template page: The results

depend on the Constrain proportions setting:

❐ If proportions are constrained: Scales the height
and width of the content page to the best
possible fit within the template page, while also
ensuring that the new proportions of the
content page match its original dimensions.

❐ If proportions are not constrained:
Automatically scales the height and width by
separate factors as needed for the best possible
fit to completely fill the template page, with no
extra space.

● Set Scaling: Specify scaling percentages or new
page dimensions for the width and height.

❐ If proportions are constrained: Typing one value
automatically sets the other value
proportionately.

❐ If proportions are not constrained: You can
specify separate values for the width and height.

● Select the Constrain proportions to retain the
original proportions of the content page, or clear it
if you need to change the proportions
anamorphically.

Note: If you do not constrain proportions, skewed images can
result.
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Page Rotation You can rotate a content page within the template
page in 90-degree increments. The content rotates
around the page center, independent of the template
page.

Comments Type or view a note for your own reference or for/from
another operator.

Pages on press runs
Every content page on a press-run layout has a corresponding template
page that defines the placement of its content on the sheet and within
the final trim box. You control the details to preview, and you can edit
page properties either directly in the layout or in the Properties pane.
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Managing pages on press-run layouts
Access the template and content page properties for fine-tuning the
pages on press runs, and replace placeholders with content pages as
they become available.

Choose a task:

Acess page properties In the workspace, select the page or pages:

● Use the Select tool to select an independent or
ganged page, or all the pages in an imposition.

● For imposition pages, use the Page Select tool.
● For pages within a ganged page group, use the

Ungroup tool before selecting.

Make your edits in the Properties pane on the
Content Page and Template Page tabs.

Replace a content or placeholder page Drag the new content page to the target page
position, and release the mouse when the recycle
symbol appears. All same-numbered template pages
are updated with the new content.

To replace one content page without updating all the
other same-numbered pages, press Option/Alt and
drag.

Move a ganged page Select and drag the page, and release the mouse
when guide lines indicate a suitable position. To fine-
tune its position, edit its gutter and/or margin text
boxes.

In the workspace, use the Select tool to:

● Move a page

Select an ungrouped ganged page or a page group.
● Press and hold Shift while clicking multiple pages.
● To select pages within a ganged page group, use

the Ungroup tool before selecting
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Adding content pages directly to a layout
For ganged jobs, you can place pages directly on a press-run layout
without first setting up a run list in the Pages view.

1. Select the pages using any of these methods:

● In the Files list, select a PDF file or file placeholder.

Note: If the content files are not yet available, select Job > Create File
Placeholder to add the required number of placeholder pages to the Files list.

● In the Files list, expand a multipage file to view its list of pages.
Select a single page, or press Shift+click to select multiple pages.

● Select a PDF file from an accessible folder in the file directory.

2. For press runs that already contain a layout resource, drag the
selected file, page, or pages onto a template page.
The first page is assigned to the template page position, and any
additional new content pages flow through the available template
pages in sequence.

Note: Any existing content on the affected template pages is replaced.

3. For manual ganging, drag the selected pages to a position on the
press sheet.

● If you drag the pages to an empty area, the pages cascade onto
the sheet, and you can arrange them.

● If you drag a page to a position near an existing page on the
sheet, it snaps into the default snap position that is defined in the
Preferences dialog box.

● If you drag the selected pages onto a template page, the first
page is assigned to the template page position, and any
additional new content pages flow through the available
template pages in sequence.

Note: Any existing content on the affected template pages is replaced.

4. To place any remaining content pages, you can either duplicate the
press run, or insert a new sheet via the Jobs menu, and repeat the
steps as needed.

5. In the Pages view, check the run list that was generated.

The Count column in the Files list is updated with the number of
instances of each page on a press run. A value of 0 (zero) appears
beside any page that is not yet assigned to a press run.
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Press Runs view reference for pages
Use the Press Runs view to manage the placement of pages on the
layouts.

View menu in the Press Runs view
The View menu lets you control the details that you see in the workspace.

You can toggle these menu items between showing and hiding the
specified items.

Show Dimensions Displays the layout dimensions, including
distances between page edges or centers
(depending on settings in the Preferences
dialog box) and between adjacent pages and
press sheet edges. Select a layout element to
edits its text boxes.

Show Page Previews Displays a preview of all page content

Show Page Sizes Displays the width and height of the selected
page, page group, mark, stock, or media

Show Trim Boxes Displays a dark blue box that indicates the
page trim size

Show Bleed Boxes Displays a red box that shows the page bleed
margins

Show File Page
Numbers

Displays the input file’s page number on each
page

Show File Names Displays the input file name on each page. If
Show File Page Numbers is also selected, the
page number is appended to the file name.

Show Template Page
Numbers

Displays the page numbers at the center of
each page

Show Marks, Show
Pages

Displays or hides the pages or marks. For
example, turning off the display of pages
makes it easier to check or select marks.

Show Tiles Displays the tiles and tile marks, if applicable

Show Group Count Displays the number of pages in each ganged
or step-and-repeat page group
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Show Folio Displays the folio that you assigned in the
Pages List

Content page properties
In the workspace, select a page, and in the Properties pane, select the
Content Page tab to display its settings. The customer’s original files
are not affected by any changes that you make to the page in the
layout, and any rotation or scaling that you apply affects only the
selected page.

File Name Displays the full path and name of the customer
input file

Page Number Displays the sequentially assigned number, derived
from the input file in the Files list

Page Size, W, H Displays the dimensions the PDF page or placeholder
page. If a PDF input file does not specify the trim box
size, the bleed box or media box size is used.

Position ● Center in template page
● Use trim offsets: Select this check box to be able

to manually position the content within the
template page.

You can specify the width and height distances
between the lower-left corner of the content page
and the lower-left corner of the template page, or
drag the page in the workspace to update these
values.

Note: The lower-left corner of a content page is defined in
terms of either the trim box or the bleed box, depending on
how the page size is defined in the input file.

Scaling Scaling is based on either the trim box or the bleed
box, depending on how the page size is defined in the
input file.

● None: Applies no scaling (default)
● Scale the content to fit template page: The

results depend on the Constrain proportions
setting:

❐ If proportions are constrained: Scales the
height and width of the content page to the
best possible fit within the template page,
while also ensuring that the new proportions
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of the content page match its original
dimensions.

❐ If proportions are not constrained:
Automatically scales the height and width by
separate factors as needed for the best
possible fit to completely fill the template
page, with no extra space.

● Set Scaling: Specify scaling percentages or new
page dimensions for the width and height.

❐ If proportions are constrained: Typing one
value automatically sets the other value
proportionately.

❐ If proportions are not constrained: You can
specify separate values for the width and height.

● Select the Constrain proportions to retain the
original proportions of the content page, or clear
it if you need to change the proportions
anamorphically.

Note: If you do not constrain proportions, skewed images
can result.

Page Rotation You can rotate a content page within the template
page in 90-degree increments. The content rotates
around the page center, independent of the template
page.

Template page properties (common)
In the Press Runs workspace, select a page, and in the Properties
pane, select the Template Page tab to display its settings. Template
pages define the positioning of content pages on press-run layouts.

Page Number,
Section

The front and back page numbers and the section
numbers determine the flow of the run-list pages.

When you duplicate or copy ganged or
independent pages, the template page numbers are
retained. However, if you duplicate an entire press
run that contains a layout, the page numbers
increment sequentially in the new press run.

Finished Page
Size, W, H

The final width and height of the printed and
trimmed product page. The default dimensions are
defined on the General tab in the Preferences
dialog box.
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Reference Point The corresponding corner or center point on both
the sheet and the page, from which Position on
Sheet offsets are measured.

This point remains constant when rotation is applied.

Position on
Sheet, H, V

The horizontal and vertical offset distances
between the reference point and the lower-left
page corner

Locked Imposition pages are always locked into their
Position on Sheet and Reference Point, which is
always the lower-left corner. Rotation can be
applied, because it does not change the reference
point.

Page Orientation The head direction of the template page, which can
be up, right, down, or left

Content Bleed
Limits

The maximum bleed to allow on each page edge.
By default, all four edges use the default bleed limit.

To be able to edit the values, use the check boxes:

● Select the Use default check box to apply the
default limit that is defined on the General tab
in the Preferences dialog box.

● Select the Use symmetrical margins check box
to apply the Top width to all four edges.

● Clear the Use symmetrical margins check box
to activate all the text boxes, and then specify
the individual widths.

Page rotation and shingling for imposition template pages
When an imposition section is folded, its pages might bottle (also
known as skew) due to the number of pages, the thickness of the paper,
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or the folding equipment. You might also need to set or disable
shingling for specific pages in a book.

In the Press Runs workspace, select a page, and in the Properties
pane, select the Template Page tab to display its settings. Template
pages define the positioning of content pages on press-run layouts.

Page Bottling
(Rotation)

To compensate for bottling, you rotate the pages in
the opposite direction. You specify either a positive
or negative degree of bottling:

● A positive amount rotates the pages
counterclockwise relative to the head direction on
the press sheet front.

● A negative amount rotates the pages clockwise
on the press sheet front. The back side pages
automatically rotate to line up with the front side
pages.

Specify the Degrees and the point Around which to
rotate the pages.
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Top left corner Top right corner

Lower left corner Lower right corner

Arbitrary point Center

Note: If you select Arbitrary Point, also specify the X and Y
coordinates of the point.

Shingling
(Creep)

Use these settings to override a book’s creep
compensation, such as when images spread across
adjacent pages.

Shift Page Content: Select the direction for shifting
the image area to override the default setting that is
derived from the product.

Amount

● Automatic: Applies the Shingling (Creep)
compensation that this product currently uses.

● Custom: Overrides the product’s Shingling
(Creep) compensation by your specified amount.
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Common resources for planning pages
Use common resources to provide information about pages to help you
organize a product’s run list, its part page lists, and the distribution of
pages on the press-run layouts.

Managing the common colors
Customize the planned colors that you can assign to pages by adding
your own color names to the common colors that the software
provides.

1. Select Resources > Common Colors.

2. Choose a task:

● Click [+] and type the new color name.
● Select an existing color, click Edit, and type a new name for the

color.
● To delete a color, select the color and click Delete.

The revised list is immediately available in all Planned Color lists. The
software stores the list details in a commonColors.xml file in the Re-
sources folder.

Managing the common folios
Customize the folios that you can assign to run-list pages by either
adding your own folios or customizing the standard folio sets that the
software provides.

1. Select Resources > Common Folios.

2. Choose a task:

● Click [+] and type the new folio name.
● Select an existing folio, click Edit, and type a new name for the folio.
● To delete a folio, select the folio and click Delete.

The revised list is immediately available in the Folio column of the
Pages List. The software stores the list details in a commonFolios.xml
file in the Resources folder.
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Standard page size conversion
These lists provide horizontal and vertical scaling percentages required
to convert common page sizes to other standard sizes.

Tabloid ANSI B (11 x 17 in.; 279 x 432 mm)

Convert to: H % V %

Legal 77 82

Letter 77 65

Half-letter 50 50

ISO A3 106 97

ISO B4 90 82

ISO A4 75 69

ISO B5 63 58

ISO A5 53 49

Legal ANSI B (8.5 x 14.0 in.; 216 x 356 mm)

Convert to: H % V %

Tabloid 129 121

Legal --- ---

Letter 100 78

Half-letter 65 61

ISO A3 138 118
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ISO B4 116 99

ISO A4 97 83

ISO B5 81 70

ISO A5 69 59

Letter ANSI A (8.5 x 11.0 in.; 216 x 279 mm)

Convert to: H % V %

Tabloid 129 155

Legal 100 128

Half-letter 65 77

ISO A3 138 151

ISO B4 116 127

ISO A4 97 106

ISO B5 81 90

ISO A5 69 75

Half Letter (5.5 x 8.5 in.; 140 x 216 mm)

Convert to: H % V %

Tabloid 199 200

Legal 154 165

Letter 154 129

ISO A3 212 194

ISO B4 179 163
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ISO A4 150 138

ISO B5 126 116

ISO A5 106 97

ISO A3 (11.7 x 16.5 in.; 297 x 420 mm)

Convert to: H % V %

Tabloid 94 103

Legal 73 85

Letter 73 66

Half-letter 47 51

ISO B4 84 84

ISO A4 71 71

ISO B5 59 60

ISO A5 50 50

ISO B4 (9.8 x 13.9 in.; 250 x 353 mm)

Convert to: H % V %

Tabloid 112 122

Legal 86 101

Letter 86 79

Half-letter 56 61

ISO A3 119 119

ISO A4 84 84
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ISO B5 70 71

ISO A5 59 59

ISO A4 (8.3 x 11.7 in.; 210 x 297 mm)

Convert to: H % V %

Tabloid 133 145

Legal 103 120

Letter 103 94

Half-letter 67 73

ISO A3 141 141

ISO B4 119 119

ISO B5 84 84

ISO A5 70 71

ISO B5 (6.9 x 9.8 in.; 176 x 250 mm)

Convert to: H % V %

Tabloid 159 173

Legal 123 142

Letter 123 112

Half-letter 80 86

ISO A3 169 168

ISO B4 142 141
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ISO A4 119 119

ISO A5 84 84

ISO A5 (5.8 x 8.3 in.; 148 x 210 mm)

Convert to: H % V %

Tabloid 189 206

Legal 146 170

Letter 146 133

Half-letter 95 103

ISO A3 201 200

ISO B4 169 168

ISO A4 142 141

ISO B5 119 119
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4 Press runs

The way that you prepare a job's list of press runs depends on factors
such as the product types and press requirements. Each press run
targets a media for a specific press, or it can target a virtual media if
press selection will be made downstream for downstream. You
designate the stock for each sheet or web in a press run that will run in
one pass through a printing press, and then add the layouts for one or
more product sections and ganged products.

Flexible tools for creating layouts
You might use the same tools for most jobs, or you might switch
between several methods to match the variations in jobs. Tools include
stock and media resources, layout resources and searches, manual and
automated ganging, product intent and assembly planning, and JDF
automation.

Press-run creation tool Useful for:

Stock and Media lists Manually targeting a specific sheet and device, including for last-minute
changes that do not affect the layouts and pages

Layouts Search Quickly finding suitable layout within a large collection of templates or fold
patterns, based on various search criteria, including page count, binding
style, and name

Templates list Repeating the same layouts for multiple products and jobs that require
specific page and sheet sizes, binding styles, and page numbering

AutoSelect Generating press runs for a single-part product’s run list whose page count
can be efficiently imposed using a standard binding style

Fold Patterns list Building layouts on the fly for products and product sections that vary in
page count, page size, stock, media, and binding style; also for flexibility in
orienting a section to match the folds to the stock grain, or for customized
content transformations for different bind edges

Fold patterns quickly create press-run sections with prenumbered page
grids. The default or planned sheet and page size are automatically applied,
and you can change these properties on the fly, or rotate or flip the grid on
the press sheet.



Manual ganging Placing ganged flat-work pages with full drag-and-drop control; stepping
and repeating ganged pages and page groups on press runs

AutoGang Saving time by allowing the software to gang multiple products in flatwork-
only jobs, based on your settings and priorities

AutoGang hot folders Fully automated ganging in a Prinergy workflow

Create Imposition dialog box Legacy way of creating an imposition section with fixed gutters, which you
can use in the current job and/or to save as a template

Product Intent dialog box Starting a new multipart product by copying all the known requirements
into a single dialog box, perhaps by copying from a printed job ticket. If
enough detail is provided, you can proceed directly to autogenerating or
manually completing the press runs.

Assembly view Revising, refining, or completing the product intent details for jobs with
multiple products, parts, and binding styles before autogenerating or
manually completing the press runs

JDF automation Deriving the product intent from a JDF file, which can support auto
signature creation (ASC), auto signature matching (ASM), or both

Section terminology
A section is a container for an imposition grid of pages that will be in
the correct sequence when folded and bound. However, the actual
definition can depend on whether you are discussing a planned product
component in the Assemby view or a production component in the
Press Runs view.

Press-run sections

A section on a layout is referred to as a press-run section. (This is also
known as a book signature, or in JDF, as a BinderySignature.)

You can manually create a press-run section by adding a template
signature or fold pattern to a layout, or creating an imposition for a layout.

After a press sheet is printed and cut, each section is folded and
trimmed, and arrives at the finishing equipment as one folded
signature.

Product sections

When setting up a book structure in the Assembly view or in the
Products list, you organize its text part into sequentially numbered

44 Chapter 4—Press runs



product sections. A product section represents a specific planned page
range within a product assembly, which can be imposed or ganged with
other product sections on a press run

You can also create press-run sections by autogenerating the press
runs from product intent, or by dragging product sections from the
Products list.

Multiple sections

Each section on a press-run layout represents one instance of a product
section, depending on how you plan your press runs. There are many
ways to create a press run with multiple sections, including these
examples:

● Renumbering a fold pattern or an imposition on a layout so that it
contains two low-folio pages (that is, both are page 1) breaks it into
two press-run sections.

● Ganging a product section by dragging it twice to the same press
run results in two identical signatures for two copies of the same
product.

● You can also gang product sections from different products to
create a multisection press run.

Resources for press runs
When building a press run, use the lists of predefined resources to
select and add the media, stock, marks, and layouts. The software ships
with sample resources, and you can configure additional resources for
the lists.

About setting up the resource lists
Set up resource lists with your commonly used media, stock, marks,
and layouts for building press runs, and manually drag the resources to
a layout, or use various tools for generating the layouts.

The Resources pane provides the following lists:

● The Stocks list contains the available sheet sizes. Each stock
resource represents a press sheet that will be printed on one or both
sides to produce the final printed product. When adding a stock, you
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specify its dimensions and characteristics for your own reference—
such as manufacturer, weight, and grain direction.

● The Media list contains the software’s predefined standard media
and the media resources that you configure to target specific
devices. You can also store tile sets for specific media resources.

● The Marks list contains the predefined marks and the mark files
that you create, which are based on the Kodak® SmartMarks
software technology.

● The Layouts pane contains a Templates list, a Fold Patterns list,
and a Search tool for filtering the lists.

❐ The Templates list contains complete, reusable layouts that
predefine the press-sheet dimensions and template page sizes,
positions, and numbering for specific binding styles.

The software includes a selection of sample templates, and you
can save frequently repeated jobs as templates. When setting up
the software, you might create noncustomer jobs with layouts for
the purpose of creating templates.

Note: You can also migrate and continue to use existing templates from
previous installations.

❐ The Fold Patterns list contains dimensionless, prenumbered
page grids that you drag to press runs to build imposition layouts
on the fly. You can edit the default binding style, page size, page
numbers, and trims that are automatically applied to the
resulting press-run section.

The software includes standard fold patterns that are derived
from the CIP4 Pagination Catolog (also referred to as the JDF Fold
Catalog). You can also create and save new fold patterns or
variations of standard fold patterns.

❐ Use the Layouts Search tool to find a specific layout in large
collections of templates and fold patterns.

Fold patterns
Fold patterns quickly create press-run sections with prenumbered page
grids. The default or planned sheet and page size are automatically
applied, and you can change these properties on the fly, or rotate or flip
the grid on the press sheet.

A fold pattern describes the sequence of folds that the folding machine
will apply. A standard set of fold patterns is included with the software,
and you can create and store custom fold patterns. Although you
cannot change the standard JDF fold patterns, you can save them
under different names to suit your operations.

Each reusable fold pattern resource defines an imposition section’s lay
direction on the press sheet. By default, the lower-left corner is the
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reference point, and you can flip it to place the section’s lay corner on
and rotate it before or after adding it to a press run, and define trims as
needed for production.

Fold patterns provide dynamic flexibility in creating jobs:

● Add a fold pattern directly to a sheetfed or web press run, and then
autogenerate duplications to build the Press Runs List for the
product’s run list.

● Select a fold pattern for an assembly part to set the default for its
sections, and then change the selection for individual sections as
needed.

● Use the Layouts search function to quickly find a fold pattern, based
on criteria such as page count, binding style, and name.

● Using fold patterns reduces the need for maintaining large
collections of templates.

❐ Use one fold pattern instead of multiple templates that are the
same except for the page and sheet sizes.

❐ The search function also makes it easy to find all the templates
that use the same fold sequence.

● Use custom profiles to store default page and sheet sizes for
frequently repeated jobs, or set the sizes on the fly for each job.

You can also change a fold pattern’s pagination in a press-run section.
When you select the Page Numbering tool, highlighting indicates all
suitable candidates that can be used for page 1 without changing the
fold pattern.

For specific bindery requirements, experienced users can define and
store a content transformation with a custom fold pattern. Instead of
changing template page orientation settings in the Press Runs view,
you can flip and rotate the entire grid’s pages relative to the bind edge,
such as for calendars and right-bound books.

Fold information is included in JDF output, for use by JDF-enabled
bindery equipment.

Creating a custom fold pattern resource
To add a resource to the Fold Patterns list, you select a fold pattern on
which to base the custom fold pattern.

For example, you might need to rotate a fold pattern’s orientation on
the sheet so that its folds can follow the stock grain. You can either
apply the rotation on the fly for the one job, or you can store it as a
reusable fold pattern resource.
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Experienced users can also create fold patterns that change the
orientation of pages in reference to the bind edge, such as for books
that are bound on the right side or calendars with head-to-foot pages.

1. Choose a method to access the Select a Fold Pattern dialog box:

● Select Resources > Fold Patterns.
● In an assembly job, define a part with values for its Planned Page

Count and Largest Section, select a section to display its
properties, and in the Fold Patterns list, select Browse for fold
pattern.

2. In the Fold Sets pane, choose a method to specify the fold pattern
on which to base the new resource:

● Select a fold pattern from the search results in the Available Fold
Patterns list, or scroll through the JDF or custom fold patterns
and select a fold pattern.

A thumbnail of the selected fold pattern appears in the Preview
pane.

● Select a fold set to display thumbnails of its fold patterns in the
Preview pane.

3. In the Preview pane, select a fold pattern thumbnail to activate its
Rotate and Flip buttons.

4. To change the orientation of the fold pattern, click Rotate and Flip,
as needed.
The thumbnail shows how the fold pattern will appear in the
workspace when you add it to a press run.

5. Skip this step if you do not need to designate a different bind edge.

Note: This is an advanced task for experienced users.

a. Ensure that the correct thumbnail is selected in the Preview
pane, and click Bind Edge.

b. In the Transformation list in the Bind Edge dialog box, choose a
rotation or flip increment to change the orientation of the pages
in reference to the bind edge.
For example, for a calendar, you might rotate right-side binding,
the pages might need to be flipped once.

c. When the desired transformation is displayed in Preview, click
Select.

In the Select a Fold Pattern dialog box, the adjusted fold pattern
thumbnail is selected, and its buttons are activated.

6. Click Save As.

Note: When you click away from the thumbnail, its buttons revert to text that
display the current rotation amount and flip status.

7. Give the fold pattern a name, and optionally assign the fold pattern
to a new or existing fold set.

The fold pattern name and the name of its base fold pattern appear in
the Custom Fold Patterns list in the Fold Sets pane lists, in the Fold
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Patterns list in the Layouts resource and Properties panes. The
software stores the list details in the FoldingPatterns.xml file in the Re-
sources folder.

Note: Standard fold patterns are never affected by edits that you make when
creating a custom fold pattern.

Select a Fold Pattern dialog box
Select, customize, and save a fold pattern under a new name,and
optionally group it with other fold patterns in a custom fold set.

Adding a fold pattern to a layout creates one imposition section in a
specific production orientation on the sheet, and you can rotate or flip
the section on the sheet.

Each fold pattern contains prenumbered template pages in a specific
orientation relative to the bind edge. For special binding requirements,
you can access another dialog box for transforming the pages relative
to a different binding edge.

Fold Sets

Available Fold
Patterns

Lists the patterns that match your specified page
count

JDF Fold Pattern Lists the available standard JDF patterns, which
are based on a left-side binding for production
purposes

The JDF fold pattern sets are grouped according
to the number of pages in each pattern. For
example, select F8 to display thumbnails of all
the standard 8pp fold patterns.

Custom fold
patterns

Displays the unique fold patterns that you
created, listed either individually or under the
group names that you defined

Preview

The Preview pane displays the fold pattern or fold set that you select in
the Fold Sets list. If you open this dialog box after filtering it by page
count, it displays the patterns in the Available Fold Patterns list.

For standard JDF patterns, the CIP4® fold catalog identifier for this fold
pattern is displayed. For more details, see the CIP4 Pagination Catalog,
available at http://www.cip4.org/.
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The following items appear for each previewed fold pattern.

Pattern name
and grid

The name of the standard or custom fold pattern is
followed by the number of horizontal and vertical
pages in this pattern’s grid.

Thumbnail
diagram

Each diagram shows the template page positions
relative to the bind edge.

● A  symbol indicates the page head direction.
● Cut lines are dashed, and fold lines are solid.
● A solid line with gray shading indicates the bind

edge.
● A red solid-line symbol indicates the lay corner,

and it is dashed when the fold pattern is flipped.

Rotate Clicking the fold pattern thumbnail activates this
button.

When the thumbnail is not selected, it displays the
current rotation.

Set the degree of clockwise rotation, relative to the
sheet's grip edge. Each successive click of the
activated button rotates the pattern thumbnail by 90
degrees.

Flip Clicking the fold pattern thumbnail activates this
button.

When the thumbnail is not selected, it displays
which side of this fold pattern will by default be
placed on the front of the press sheet for production
purposes.

The default state is No (not flipped), as indicated by
the lay corner indicator at the lower-left. Select No to
flip the fold pattern and change its flipped state to
Yes (flipped).

Save As Click to save the currently displayed thumbnail,
rotation, flip status as a custom fold pattern. You can
also save an unchanged standard fold pattern as a
custom pattern if you want to use a different name,
or place it in a custom group.

In the Save Custom Fold Pattern dialog box, you can
perform any of the following actions:

● Give the fold pattern a Custom Name.
● Select an existing fold set in the Group list.
● Type a new group name to create a fold set that

contains this fold pattern.
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Bind Edge Displays the Bind Edge dialog box

Experienced users can apply flip and rotate
transformations to change the orientation of the
pages relative to the bind edge.  For more details, see
the CIP4 Pagination Catalog, available at http://
www.cip4.org/.

Templates
Templates are standalone files that store complete information about
reusable layouts for a specific binding style. Information about each
unique layout is stored in a template signature within the template,
including its media, press sheet size, work style, template page
positions, and marks. Templates are useful for frequently repeated jobs.

The Templates list contains complete, reusable layouts that predefine
the press-sheet dimensions and template page sizes, positions, and
numbering for specific binding styles.

The software includes a selection of sample templates, and you can
save frequently repeated jobs as templates. When setting up the
software, you might create noncustomer jobs with layouts for the
purpose of creating templates.

Note: You can also migrate and continue to use existing templates from previous
installations.

The Layouts search tool makes it easy to find the right template for an
imposition. However, if you must store and retrieve a unique template
for most jobs, it can be more efficient to use a fold pattern resource
instead, which allows you to change the stock, page sizes, and
individual trims on the fly.

Note: When you apply a template resource to a job, the layouts are added to the
JOB file, and the original template is no longer referenced. If you separately edit
and resave the template that you used for this job, the changes are not
automatically applied when you reopen the job. To apply the changes, you must
reapply the template.

Saving a job’s layouts as a template
Store frequently repeated jobs or press-run layouts as a reusable
template resource.

1. Start a job and build the layouts that you want to save as a template.
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2. To save the layouts as a template, select File > Save As Template,
give the template a name, and select a location in the Templates folder.

● Mac OS®: The name can be up to 31 characters long, including
the .tpl file-name extension. Avoid using special characters,
particularly if you might open this file on a computer that is
running Microsoft® Windows®.

● Windows: The name can be up to 50 characters long, including
the .tpl file-name extension. The name can contain spaces, but
cannot contain any special characters, such as \ | : “ " ? <
> / .

Each unique press-run layout is stored as a template signature
within the template’s TPL file in the Templates folder. The new
resource appears in the Templates list in the Layouts pane.

Note: When you apply a template resource to a job, the layouts are added to the
JOB file, and the original template is no longer referenced. If you separately edit
and resave the template that you used for this job, the changes are not
automatically applied when you reopen the job. To apply the changes, you must
reapply the template.

Creating a new media resource
To add a resource to the Media list, you prepare a media configuration
for a specific target device. You can set up a media configuration for
any valid size that is defined in the device-specific PostScript Printer
Description (PPD) files in the Printers folder.

The software DVD provides several PPD files, and you can get the most
current PPD files directly from the manufacturer of your imaging
device. If a device is already installed on your operating system, you
can use a copy of the system’s PPD file.

1. (Skip this step if the PPD file is already installed.) Copy the new
device PPD file and paste it to the \Printers\ppd\ folder.

The name of the PPD file must end in .ppd, and contain no special
characters.

2. Select Resources > New Media.

3. Select the Media Type.

The Media Type list displays all the media for which a device PPD
file exists in the \Printers\ppd\ folder.

Note: To create a virtual media configuration that is equal to or larger than the
stock size, select Press Sheet Size.

4. Provide a meaningful nickname for the new media configuration,
and click OK.
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5. In the Media Configuration dialog box that appears, select the size,
and set any other options that you need.

Note: For Press Sheet Size media configurations, you cannot change the Size
(PressSheetSize). However, you can optionally increase the size of the output by
specifying top, bottom, and side margins. You cannot set margins for other media
types.

6. Close the dialog box.

The new media resource appears in the Media list in the Resources
pane. The software stores the details for each media in a MediaName
\printer.ppd file in the Printers folder.

Creating a new stock resource
To add a resource to the Stocks list, you define its press sheet size and
provide additional details for your own reference.

A list of sample stock sizes is provided to help you get started. The
following procedure bases a new resource on an existing resource.

1. In the Resources pane, click Stock to expand the list.

2. Select an existing stock that is similar to the new stock resource that
you want to define.

3. Right-click the stock, and select Duplicate.

4. Edit the properties, and save the stock with a new name.

Information that you can store includes the stock name,
manufacturer, dimensions, weight, and grain direction. Web-fed
stock dimensions represent the size of the roll width by the cutoff
length.

The new stock appears in the Stock list in the Resources pane. The
software stores the list details in the sheets.xml file in the Printers folder.

Creating a new mark resource
To add a new resource to the Marks list, you define a mark that is
based on an existing SmartMarks (SMK) file. You can create, edit, and
duplicate individual marks or groups as needed.

1. On the Folders tab in the Preferences dialog box, set the default
Templates, Marks, and Resources path for this installation.
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2. Choose a method to create or modify a mark:

● Select  Resources > New SmartMark, choose a mark type, and
edit its name and properties.

● In the Marks list, right-click a mark to use as the basis, select
Duplicate or Edit, edit its name and properties, and save the
mark or a copy of the mark under a new name.

3. Save the mark to a location in the /Marks/SmartMarks/ folder.
The mark’s positioning information is stored in its MarkName.smg
file.

Important: Only marks that are stored in this folder appear in the Marks list.

4. Optionally, create a group of marks that can be added and
automatically positioned all at once:

a. Create a new subfolder within the SmartMarks folder, with a
name to identify this mark group.

b. Drag or copy the SMK files for this group into the new folder.

An info.smg file stores the information about the group in the same
folder as the individual SMK files.

The marks and groups that you create appear in the Marks list in the
Resources pane.

Press Runs view reference
In the Press Runs view, create and interactively edit and preview any
number of sheetfed and multiweb press runs to accommodate the job’s
pages. Manage the stock, media, marks, and layout for each sheet or
web either individually or for linked press runs.

View menu in the Press Runs view
The View menu lets you control the details that you see in the workspace.

You can toggle these menu items between showing and hiding the
specified items.

Show Dimensions Displays the layout dimensions, including
distances between page edges or centers
(depending on settings in the Preferences
dialog box) and between adjacent pages and
press sheet edges. Select a layout element to
edits its text boxes.
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Show Page Previews Displays a preview of all page content

Show Page Sizes Displays the width and height of the selected
page, page group, mark, stock, or media

Show Trim Boxes Displays a dark blue box that indicates the
page trim size

Show Bleed Boxes Displays a red box that shows the page bleed
margins

Show File Page
Numbers

Displays the input file’s page number on each
page

Show File Names Displays the input file name on each page. If
Show File Page Numbers is also selected, the
page number is appended to the file name.

Show Template Page
Numbers

Displays the page numbers at the center of
each page

Show Marks, Show
Pages

Displays or hides the pages or marks. For
example, turning off the display of pages
makes it easier to check or select marks.

Show Tiles Displays the tiles and tile marks, if applicable

Show Group Count Displays the number of pages in each ganged
or step-and-repeat page group

Show Folio Displays the folio that you assigned in the
Pages List

Press Runs List
Use the tools and settings in the Press Runs List to manually build and
manage a job’s press runs. You can also use AutoGang, AutoSelect,
product intent for assemblies, or JDF automation to generate the list.
Selecting a press run, sheet, web, or side in the Press Runs List
displays it in the workspace.

Tip: Drag the column edges to adjust their widths. Drag the column headers to
rearrange the columns.

Duplicate Sheet
 Adds a copy of the current press run with

layout and without content.

You can also use the following shortcuts instead of
using the Job menu:
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● Press Alt+click this tool to display the Add dialog
box for adding and linking a blank press run with
the default stock.

● Right-click this tool to insert a duplicate of the
current press-run layout as a new web in the
same press run. Adding a web to a sheetfed
press run converts it to a web press run.

Delete Sheet
 Removes the current press run and any layouts

that it contains.

Move Down,
Move Up

 When you move a press run, the Press Run
ID numbers are updated accordingly. Moving a
press run up or down does not change the product
section numbers.

Linked icon
 Indicates a linked press run. Any autogenerated,

duplicated, or copy-and-pasted press runs with the
same layout and stock are automatically linked.
Linked press runs share the same page positions,
trims, marks, and stock. All members are
automatically updated when you change any
member of a linked group.

Press Run ID This column lists the press runs by a sequentially
assigned number, which simply describes its
position in the list. You can expand a press run to
display its component sheets, webs, or sides.
Selecting a press run in this list displays it in the
workspace and its settings in the Properties pane.

Work Style View or select the work style that describes how the
press physically prints the press sheet:

● Sheetwise
● Work and Turn
● Work and Tumble
● Perfector
● Single-sided

Sections Lists each product section that appears on this
press run one or more times, identified by the
product letter and product section number

Colors Displays the actual content colors that are defined
in the PDF input files (not editable).

Note: Use the Pages view to check for discrepancies
between planned and actual colors.
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Stock The name of the stock resource that you assigned to
this press run

Media The name of the media resource that you assigned
to this press run

Template If a template was used to build this press run,
displays the template name. Otherwise, a default
Untitled name is assigned, with a number that
increments for each existing Untitled template in
the Templates list. If you save the current job as a
template, the new name is displayed.

Template
Signature

If a template was used to build this press run,
displays the template signature name. Otherwise,
an editable default name is assigned, starting at
Untitled Sig 1 and incrementing for each unique
layout.

Run Length The number of times that this press run must run
through the press to print the required product
quantity.

For example, if a customer requires 5000 copies of
a flat-work product, and you gang the product 5-up
on the press run, then you will specify a Run Length
of 1000.

Generate Press
Runs

If the product intent is sufficiently defined, the
required number of press runs and impositions is
automatically generated, and the run-list pages flow
into position according to the template page
numbering.

Work styles for press sheets and webs
Each press sheet or web in a press run is assigned a work style, which
describes how the press sheet will run on the press.

The default work style is defined on the General tab in the Preferences
dialog box, and can be sheetwise, work and turn, work and tumble,
perfector, or single-sided.

Sheetwise

Sheetwise is one of the most common work styles. Different plates are
used to print the front and back of the press sheet.
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The paper is run through a press to print the front side of the sheet. It is
then turned over on the vertical axis and run through the press again
using the same gripper edge, and a second plate is used to print the
back side of the sheet.

Web presses also use the sheetwise style, but they print both sides in a
single pass.

For digital and on-demand output, you usually use the sheetwise work
style, and the press sheet size is the size of the paper on which the job
is printed.

Work and turn

For a work-and-turn work style, both sides of the imposition are imaged
on the same plate.

The imposition is divided in half at the vertical center so that the
images for the front are on one half and the images for the back are on
the other.

After the first side of a work-and-turn imposition is printed, the sheet is
turned over on the vertical axis so that the second side can be printed
using the same gripper edge. After printing, the sheet is cut in half
before folding, creating two identical copies.

Work and tumble

For a work-and-tumble work style, both sides are imaged on the same
plate.
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The imposition is divided in half at the horizontal center so that the
images for the front are on one half and the images for the back are on
the other.

After the first side of a work-and-tumble imposition is printed, the
sheet is turned over on the horizontal axis so that the second side can
be printed using opposite grippers, gripping first the leading edge, then
turning the sheet over to grip from the tail edge.

After printing, the sheet is cut in half before folding, creating two
identical copies.

Perfector

The perfector work style is used for a sheetfed perfecting press.
Perfecting presses print both sides of the paper in one pass.

After the first side of the press sheet is printed, it is turned over on the
horizontal axis, changing the gripper to the opposite edge so that the
second side can be printed.

For a perfector work style, the back side of the press sheet is
automatically rotated 180 degrees.

Single-sided

For a single-sided work style, the press sheet has only a front side.
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This work style is commonly used for flat work such as posters,
business cards, and labels.

Work styles in the workspace

Your work style selection affects how the press sheet and pages appear
in the workspace.

For example, the workspace displays an entire side of a work-and-turn
or work-and-tumble sheet. A dashed line indicates where the sheet will
be cut after the first side is printed, the sheet is turned, and the other
side is printed, resulting in two identical copies per sheet.

Whenever you place a page at one side of the sheet in the workspace, a
mirrored image of its back page appears on the other side, because that
is where it will be when the sheet runs through the press the second
time. Marks and gutters are similarly reflected, and you can reposition
pages on either side to automatically update both sides.

The following example shows a work-and-tumble layout with one page
ready for step and repeat:

You can change a press sheet’s work style at any time, and the layout is
updated immediately in the workspace.

The following example shows the result when you change a Sheetwise
layout to Work and Turn:
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Press Runs workspace
Use the Press Runs workspace to interactively build, preview, and
adjust a job’s press-run layouts.

Select a press run, sheet, web, or side in the Press Runs List to display
it in the workspace. Selecting an element in the workspace displays its
settings in the Properties pane.

Dimensions can be edited directly in the workspace by typing in the
text boxes or by dragging items.

Tip: To control which details are displayed, use the View menu and workspace
toolbar.For information about specific layout elements in the workspace, see the
applicable topics.

Select  Use this tool for most mouse tasks.

● Click an object to select it.
● Press and hold SHIFT while clicking multiple

objects.
● Drag a marquee around multiple objects.
● Click one page in a group to automatically select

all of the pages in the group.

Direct Select  Select an item within another object, such as an
imposition page inside an imposition.

Page Numbering
 Click this tool and then select a page to

automatically number or renumber it.

To manually renumber a selected page, edit the
Page Number box that appears under the tool bar.

Note: Imposition pages can be dynamically renumbered
when you use a fold pattern. For all other impositions, you
must manually number or renumber the pages.
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Pages in fold patterns are prenumbered, and you
can renumber them.

● When you select this tool after placing a fold
pattern in the workspace, the valid low-folio page
positions are highlighted.

● Clicking a highlighted page designates it as a low
folio.

● The remaining pages are automatically numbered.
● Designating more than one low folio creates

multiple sections.
● If you renumber a page, the remaining pages are

automatically renumbered.
● Clicking or renumbering a nonvalid page changes

the fold pattern.

Impositions that you create using the Create
Imposition dialog box must be manually numbered
or renumbered. Impositions that are based on a
template can be renumbered.

● After selecting the tool, the first page that you
click is the low folio, and you can click the
remaining imposition pages in sequence to
number or renumber all the pages.

● To create multiple deliveries of the same product,
designate multiple pages as page 1.

Pan
 Drag your view of the workspace

Zoom
 Either click the object or general area that you

want to inspect more closely, or drag a marquee
around a specific area.

Step and Repeat  In the settings that appear under the tool bar
when you click this tool, select how the repeated
pages or sections are to be separated, and then drag
the mouse across the area.

● Trim to trim (default): The trim edges touch, and
any inner bleed margins are automatically
removed.

● Bleed to bleed: The inner bleed margins are
automatically adjusted to half their original width.

● Gutters: When you specify the horizontal and
vertical distances, any overlapping bleed margins
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are automatically adjusted to split the width
equally.

AutoGang
 Generate the job’s AutoGang list from all Files

list pages.

Show Page
Previews

 Displays a preview of all page content

Show
Dimensions

 Display the layout dimensions, including
distances between edges or centers, depending on
your Preferences and View menu selections.

Rotate
 Rotate the selected section or template page.

The content follows the template page orientation.

Group, Ungroup
 Create or break apart a group of selected

sections or ganged pages.

Flip
 Flip your view of the sheet. The result depends

on the selected work style:

● Sheetwise: Flips on the vertical axis. The grip
edge still appears at the bottom.

● Perfector: Flips on the horizontal axis. Your view
of the grip edge position changes.

Transparency
 Slide the control button to adjust

the transparency to better your view of the press
sheet, as if it were on a light table.

Layout selector Switch the workspace between multiple webs that
you selected in the Press Runs List.

Layout dimensions in the workspace
Set preferences, select View menu options, and click workspace tools
to control the display of dimensions in the workspace.

● The default unit, distance measurement type, and snap type are
defined on the General tab in the Preferences dialog box.

● In the workspace, most applicable text boxes become editable when
you click a page or section. Some can be edited only in the
Properties pane.

● Measurements that are not in an editable state appear in dimmed
text boxes with no borders.
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● A blue border around a measurement text box indicates that it is
editable.

● A lock icon  appears on any pages or sections that cannot be
repositioned. (Marks are locked by default.) Objects that can be
locked or unlocked include a check box in their Properties pane, or
you can use the Objects menu.

● If you edit the distance between a locked page and an adjacent
page, the locked page does not move, even if it is the page that you
selected. Only the adjacent page moves.

Measurement Description

Page or page group dimensions Select Show Page Sizes to display gray lines and text
boxes for the width and height of a selected object. A
dashed blue border indicates a selected group.

Finished page dimensions can be edited only on the
Template Page tab in the Properties pane.

The dimensions of a placed media or stock cannot be
edited in the workspace.

Margins between stock edge and selected page,
section, or media edges

Black lines and text boxes indicate sheet margins, and
you can edit the text boxes to reposition the objects.
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Measurement Description

Center to center distances Select Show Dimensions to display cyan lines and text
boxes for the distances between the centers of equal-
sized and aligned objects.

Trim edge to trim edge distances Select Show Dimensions to display black lines between
the edges of a selected object (page or section) and
any adjacent edges of the same object type, such as to
show gap, gutter, or trim widths.

Notes:

● A gutter is the space between the trim edges of any two rows of pages or
sections on a press sheet, as in pages within a ganged page group or an
imposition page grid.

● A gap is the space between two independent (or ganged) pages on a press sheet.
● A trim is a gutter or margin area that will be trimmed from a final page.

Press run properties
In the Press Runs List, select a press run to display its settings in the
Properties pane.

Page Count The number of template pages on this press-run
layout

Fold Pattern Select from the filtered list of fold patterns that
match the section page count, or click Browse for
fold pattern to display the Select A Fold Pattern
dialog box.

Template Name If a template was used to build this press run,
displays the template name. Otherwise, a default
Untitled name is assigned, with a number that
increments for each existing Untitled template in the
Templates list. If you save the current job as a
template, the new name is displayed.
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Signature Name If a template was used to build this press run,
displays the template signature name. Otherwise, an
editable default name is assigned, starting at
Untitled Sig 1 and incrementing for each unique
layout.

Auto Select
Signature

If you select this check box (default), the Auto
Select option is added to the context menu for this
template signature in the Layouts resource pane.

Section Count The number of times that you added a product
section to this press-run layout. You can add one or
more product sections to a single press run,
including the same product section multiple times
or multiple different sections, typically for the same
product.

Binding Style Determines the sequence in which content pages
flow through the template pages on the press-run
layouts:

● Flat Work (no binding)
● Perfect Bound
● Saddle Stitched
● Come and Go
● Cut and Stack
● Mixed (more than one binding style)

Work Style View or select the work style that describes how
the press physically prints the press sheet:

● Sheetwise
● Work and Turn
● Work and Tumble
● Perfector
● Single-sided

Stock The name of the stock resource that you assigned
to this press run

Media The name of the media resource that you assigned
to this press run

Width, Height The dimensions of the stock for this press run

Punch Distance ● If the media has a punch, specify the distance
from the press sheet edge to the punch center.

● If the media has no punch, specify a positive
value that moves the virtual punch location off
the press sheet.
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The punch is the hole on which the media can be
anchored on pins for accurate alignment (also
referred to as setback).

Binding styles
The binding style determines the sequence in which job pages flow
through an imposition’s template pages. You can set a general default
binding style in the Preferences dialog box, optionally change the
default for a specific product or part, and assign binding styles to
individual product sections.

The following binding styles are available.

Perfect Bound Content pages flow through the template pages in
their run-list sequence.

Saddle Stitched An equal number of pages flow from the beginning
and the end of the run list through the sections,
starting by default with the largest section.

Come and Go In a come-and-go job, the entire run list flows twice
through the same press runs, which are
automatically divided into two press-run sections.
The template pages are numbered so that the run list
first flows through the first section in run-list
sequence, and through the second section in reverse
sequence. The resulting two identical books are
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perfect-bound together on a common edge, and then
cut apart.

Cut and Stack This binding style lays out an entire book on one
multisheet press run with two (or more) template
pages per sheet. The necessary number of sheets
and impositions are automatically generated to
accommodate the content. The first half of the run
list flows sequentially through one template page
position on all the sheets, and the second half flows
through the other template page position. The
printed sheets are split into two correctly paginated
book blocks that are stacked to form a complete
book.

Flat Work (no
binding)

Select this binding style for products that are not
bound, such as posters, inserts, business cards, and
leaflets.

Mixed binding
styles

If a part’s product sections use multiple binding
styles, the Binding Style property is Mixed.

Press-run section properties

Select a section in the Products list or workspace to display its settings
in the Properties pane.

The Part Name, Part Type, and Binding Style are derived from the part
properties.

The ability to edit properties can also depend on whether you are
viewing a press-run section in the Press Runs view or a product section
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in the Assembly view, and whether you create the imposition in the
section from a fold pattern or a sheet-based imposition.

Part Name Use or edit the default name.

Part Type Can be Cover, Text, Folder, or Flat work

Section The number that determines the binding order of
the product sections. If the product sections are
rearranged in the workspace, the section numbers
are automatically adjusted to reflect the new
sequence.

Lock Select this check box to prevent this product
section from being rearranged within the assembly.

First Page
Number

Determines the starting page and range of run-list
pages that will be printed in this section, based on
its page count

Trim Size The planned width and height of the printed
product page, after it is bound and trimmed. The
default dimensions are defined on the General tab
in the Preferences dialog box.

Template Name If a template was used to build this press run,
displays the template name. Otherwise, a default
Untitled name is assigned, with a number that
increments for each existing Untitled template in
the Templates list. If you save the current job as a
template, the new name is displayed.

Page Count The number of pages in this component

Fold Pattern Select from the filtered list of fold patterns that
match the section page count, or click Browse for
fold pattern to display the Select A Fold Pattern
dialog box.

Binding Style The style that determines the sequence in which
the run-list pages flow through the template pages
on the press-run layouts

Reference Page Applies only to sheet-based impositions that you
create or add from a template.Select the
orientation of the section’s lower-left page, which
serves as the reference for the other pages in this
section.

Lay out
additional page

Applies only to sheet-based impositions that you
create or add from a template. Select the
orientation of the other pages in this section,
relative to each other, based on the reference page.
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Planned Colors Select or type the names of the colors that are
planned for this item.

Colors Displays the actual content colors that are defined
in the PDF input files (not editable).

Note: Use the Pages view to check for discrepancies
between planned and actual colors.

Comments Type or view a note for your own reference or for/
from another operator.

The following properties can be edited only in the Press Runs view:

Fold Flip Select No to flip the fold pattern and change its
flipped state to Yes (flipped).

Fold Rotation Set the degree of clockwise rotation, relative to
the sheet's grip edge.

Bind Edge Experienced users can apply flip and rotate
transformations to change the orientation of the
pages relative to the bind edge.  For more details,
see the CIP4 Pagination Catalog, available at http://
www.cip4.org/.

Head Trim, Foot
Trim, Face Trim,
Spine, Front Lip,
Back Lip

The applicable gutter or margin widths that will
be trimmed from the page edges; applies only to
impositions that are based on a fold pattern;
editable after you select a Fold Pattern.

In addition to setting individual trim margins, you
can set a spine width (such as for the backbone
of a book cover) and lip widths (such as to create
overfold edges on the front or back page of the
folded signature).

Using the Layouts Search tool
Use the Layouts Search tool to quickly find a suitable layout resource
for a press run.

1. On the Layouts pane, click the Search tool.

The search options that appear depend on whether you already
used this tool.

2. If no criteria selection list appears, click [+].

3. In the criteria selection list, choose Page Count, and specify how
many page positions are required in the layout.
This filters the lists in the Layouts pane.
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4. Click [+] as needed to add criteria and narrow the search results.
You can specify:

● Name
● Binding Style
● Work Style
● Page Size
● Stock
● Page Grid (horizontal: X, vertical: Y)
● Section Count

5. Review the filtered list of layouts.

6. If the results are not satisfactory, repeat the search with different
criteria. You can:

● Change criteria selections.
● Click [–] to remove a criteria.
● Click Reset to clear all your criteria selections, and start over

again with new selections.

Next: Select and add the resource to a press run, and continue defining
the layout.

Building press runs on the fly
Use the Layouts Search tool to quickly find a suitable fold pattern or
template for creating a press-run layout. When you use fold patterns,
you can also change the default page and sheet sizes as needed.

1. On the Layouts pane, click the Search tool.

The search options that appear depend on whether you already
used this tool.

2. If no criteria selection list appears, click [+].

3. In the criteria selection list, choose Page Count, and specify how
many page positions are required in the layout.
This filters the lists in the Layouts pane.

4. Click [+] as needed to add criteria and narrow the search results.
You can specify:

● Name
● Binding Style
● Work Style
● Page Size
● Stock
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● Page Grid (horizontal: X, vertical: Y)
● Section Count

5. Review the filtered list of layouts.

6. If the results are not satisfactory, repeat the search with different
criteria. You can:

● Change criteria selections.
● Click [–] to remove a criteria.
● Click Reset to clear all your criteria selections, and start over

again with new selections.

7. Select a Templates or Fold Patterns layout, and drag it to the press
sheet.
The result depends on whether you select a template or a fold pattern.

If you select a fold pattern:

● The template pages are prenumbered according to the fold
sequence.

● The page size is derived from the General tab on the Preferences
dialog box.

● The Properties pane displays the section’s properties, including
the fold pattern name.

If you select a template:

● The template pages are numbered by the template.
● The page size is derived from the template signature.
● The Properties pane displays the section’s properties, including

the template and template signature name.

And in either case:

● In the Press Runs List, the Section column for this press run
displays a sequentially-assigned product and section number for
the new imposition, and the same information appears on the
new section’s pages in the workspace.

● In the Pages List, a run-list page position is created for each
imposition page position.

● The Products list includes a new section and section page count.

8. In the Press Runs List, select the press run.

9. In the Properties pane, select the Auto Select Signature check box.

10. Drag the customer’s PDF file from its folder location or the Files list
to the low-folio position of the imposition.

● The pages flow through the template pages in sequence.
● The required number of press runs and impositions is

automatically generated to accommodate the run-list pages,
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which flow into position according to the template page
numbering.

● If you switch to the Pages view, you will see that the run list
contains the PDF file’s pages. It shows the file name and actual
color for each page, including any pages that are not yet placed.

11. In the workspace, check and adjust the layouts and trims as needed.

If you used a fold pattern, you can edit individual head, foot, face,
spine, and lip trims. If you used a template, you can edit one gutter
to apply the same gutter width to every page in the page grid.

12. In the Marks list, select and double-click marks or a mark group to
add them to the currently selected press-run layout.
Each mark is also added to all linked layouts, and its name remains
highlighted in the Marks list until you delete or edit the placed
instance of this mark.

Using AutoSelect to generate press runs from a run list
Autoselecting a template or fold pattern imposes a product’s run list by
flowing its pages into the required number of autogenerated press runs.

This method works best for products with standard page counts that
can be evenly divided into the autoselected page grid.

Autoselecting a template instead of a single page grid (fold pattern or
template signature) applies the template signatures that will print the
fewest possible pages.

1. In the Pages view, set up the product’s run list.

2. In the Layouts pane, select and right-click a template or fold pattern.

3. Choose Auto Select.
The run-list pages flow into position in the generated press runs.

4. In the Press Runs view, check and adjust the results as needed.

Creating an imposition without using a Layouts resource
When you do not use a fold pattern or template Layouts resource, an
imposition’s fold sequence is determined by the section binding style
and manual page numbering.

Note: In this guide, the term imposition typically refers to a fold-based layout for
bound products.
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You typically use this method when no available fold pattern or
template matches a product’s requirements for gutters, page
numbering, and page orientation.

1. Start a new job—either for an actual job or just to set up a new template
—and optionally set up a run list.

2. Select Job > New Sheet to start a new press run.
A new press run is added in the Press Runs List and displayed in the
workspace.

3. Change the stock and media selections, if needed.

4. Select Job > Create Imposition.

5. Define the imposition page grid by specifying the page size and the
number of horizontal and vertical pages.

The default page size is defined on the General tab in the
Preferences dialog box.

6. Specify the page orientation for the reference page and the other
pages in the grid.

Note: You can do this only if the Fold Pattern is None.

7. Click OK.

● The press run in the workspace contains the page grid that you
defined.

● The template pages are numbered according to the default
binding style.

● If the run list is set up already, the run-list pages flow
automatically through the template pages.

8. If the run list contains more pages to place, click the Duplicate
Sheet tool in the Press Runs List toolbar as often as needed to
place all the pages.

9. In the layout, select a press-run section to display, and select the
binding style and set other options as needed in the Properties pane.

You can optionally double-click the section to display its Modify
Imposition dialog box.

10. In the layout, click and edit the gutter text boxes to set the face, foot,
and head trims, and drag a section or edit its margin text boxes to
reposition it on the press sheet.

Note: The same gutters and margins are applied to each duplicate of this press run.
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11. Number or renumber the template pages as needed:

a. In the workspace, click the Page Numbering tool.
In the layout, any page that is a suitable low-folio candidate is
highlighted.

b. Click a template page to designate it as the low folio for this press-
run section.
The back page is automatically numbered, and any page that is a
candidate for the next page number is highlighted.

c. Click pages in succession until all pages are numbered according
to the binding style and your desired fold sequence.
The same numbering scheme is applied to each duplicate of this
press run, and the run-list pages now flow through the press-run
sections according to the new page numbering.

12. In the Marks list, select and double-click marks to add to the layouts.

13. To save the layouts as a template, select File > Save As Template,
give the template a name, and select a location in the Templates folder.

● Mac OS: The name can be up to 31 characters long, including
the .tpl file-name extension. Avoid using special characters,
particularly if you might open this file on a computer that is
running Microsoft Windows.

● Windows: The name can be up to 50 characters long, including
the .tpl file-name extension. The name can contain spaces, but
cannot contain any special characters, such as \ | : “ " ? <
> / .

Each unique press-run layout is stored as a template signature
within the template’s TPL file in the Templates folder. The new
resource appears in the Templates list in the Layouts pane.

Multiple imposition sections on a press run
A press-run layout can contain multiple identical or unique product
sections to control placement of pages.

Identical sections can be used to print multiple deliveries of a product
or product section on the same press run, or you can organize an
imposition into multiple sections to flow the pages through different
press runs and still be able to collate them correctly.

You can use multiple imposition sections for a variety of purposes. For
example, use them to:

● Run a few color pages of a job on the same press sheet. You can use
normal collation marks and text marks to identify the sections,
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without additional custom marks. You can restrict marks to print on
specific sections.

● Print two or more sections of a book product on a single sheetfed or
multiple-web press run as the content becomes available.
Identifying marks can be used to collate the parts and produce the
correct final page order.

● Print sections with different binding styles on the same press run.
● Break up a large printing job into press runs.
● Run the color sections in one press run, and run the black and white

sections in the other press runs.
● Print similar sections from different products on one press run.
● Print product sections out of order if some of the input files are not

yet available.
● Run a job on a very large sheetfed or web press run.
● On one press run, print multiple small sections that small folding

equipment can accommodate.
● Avoid problems by splitting sections when more folds are required

than can be accommodated by the paper or folding equipment, or
when media is difficult to fold.

Managing multiple sections

Each page is identified by a section number as well as a page number,
to define the page flow.

All sections on a press run respect shingling and marks, including press
sheet sluglines ($sig variable) and collation marks.

You can also renumber the sections and pages, including locked page
numbers, such as to reprint or replace pages in a completed job. Or, if
you print selected sections for an incomplete product, the collation
marks might need to stay in the correct order.

Working with layout sides
In the Press Runs view, edit or check both sides of a sheet or web that
uses a two-sided work style.

Choose a task:

● To preview a specific surface in the workspace, expand the press
run in the Press Runs List, and select the front or back of a sheet,
or the top or bottom of a web.

● To view the next web in the current press run, select it in the drop
list at the top-right corner of the workspace.
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● To access the other side of the currently displayed layout for
editing, click the Flip tool.

● To check back-to-front layout alignment as if using a light table,
pull the Transparency slider tool to around the middle.

● To autonumber the pages on the back of a press sheet or bottom
of a web, number the front pages.

Manually adding press runs
You can create a new press run in the Press Runs List by inserting an
empty sheet or web before adding the layout, or by duplicating or
copying a press run after completing its layout.

Choose a method:

● To insert an empty press run that uses the default stock, select
Job  > New Sheet, or press Alt+click the Duplicate Sheet tool in
the Press Runs List toolbar.

● To insert a new press run that contains the same layout as the
currently selected press run, without content, click the Duplicate
Sheet tool in the Press Runs List toolbar, or select Job >
Duplicate Sheet.

● To insert an exact copy of the currently selected press run, with
content, select Edit > Copy and then Edit > Paste. The new press
run contains copies of the layout’s content and template pages.

● To add a web that duplicates the currently selected web or sheet,
select Job  > Web > Insert New Web, or right-click the Duplicate
Sheet tool in the Press Runs List toolbar. Adding a web to a
sheetfed press run converts it to a web press run.

A new press run is inserted in sequence after the selected press run,
and its first sheet side appears in the workspace.

Multiweb layouts
You can create a web press run with any number of webs, and then
insert, delete, move, or copy webs as needed. Maintain the same zoom
level and relative focal point as you toggle between the webs in the
workspace.

Webs provide flexible options for working with sections:
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● When you duplicate a web that contains an imposition section, the
imposition is duplicated, and the page numbering is auto-upated
across all the webs.

● You can also number or renumber the pages on each web individually.
● The pages for one product section can be laid out across all the

webs in a press run.
● The printed press sheets that are cut from the web rolls can be

placed on top of each other and folded to form a single signature.
● Each web in a press run can be shared by multiple sections.
● For example, when three sections are laid out across two webs in a

press-run layout, the printed press sheets are cut from the web rolls
and cut again to split out the three sections. Each section results in
one signature.

Adding or replacing a press run’s stock or media
Add or change the sheet and media size for a press run at any stage of
a job.

Follow these steps to manually start up a new press run, or to change a
press run’s resources after creating a layout using any of the available
methods. New press runs appear with the default stock.

1. Select the press run in the Press Runs List, or insert a new press run.

You can change the stock and add a media as needed.

2. In the Press Runs List, select the press run.

3. To specify the plate size, double-click an item in the Media list.
A scaled gray rectangle appears in the workspace.

Note: If you do not select a media now, you can select it when you print the output.

4. To specify the press-sheet size, double-click an item in the Stock list.
A scaled white rectangle appears in the workspace.

Note: If you add both a media and a stock, the stock rectangle snaps onto the
media’s defined punch location.
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Adding marks to a press-run layout
When you add a mark to a press run, it is anchored and positioned
automatically according to its defined properties.

In the Marks list, select and double-click marks to add them to the
currently selected press-run layout.
You can add individual marks, mark groups, and selected marks
from within a group to a press-run layout.
The marks are also added to any linked press runs, and the name of
each placed mark remains highlighted in the Marks list until you
delete or edit it.

The job file references any mark files that it uses. However, if you edit
or move a placed mark so that its properties no longer match a stored
SMK file, the mark data is embedded and stored in the job file.

Bleed margins for sections with bottling
Bleed margins for bottled pages are restricted to the original position of
the page bleed margins, so that the bleeds do not overlap with adjacent
pages.

In this example:

● The dashed lines represent the original position of the page bleed
margins.

● The solid lines represent the position of the bottled pages.
● The solid double lines indicate where the bleeds are retained.

Shingling the page images for creep compensation
Creep in a book can cause content to be trimmed due to pages pushing
out when the sections are folded. You compensate for creep by
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progressively shingling the page image areas towards the binding to
decrease the page gutter or margin width, without affecting content. If
you must maintain the gutter and margin widths, you can choose to
progressively scale the images instead of shifting them.

The amount of creep in a book is affected by the number of folds and
by paper thickness, and the affected pages depends on the binding style:

● In a saddle-stitched books, the increased thickness at the fold can
cause the inside section to push out.

● In perfect-bound books, creep is limited to the inner pages in each
individual section.

Note: To additionally compensate for page skew that might be due to the number
of pages, the thickness of the paper, or the folding equipment, you can apply Page
Bottling rotation in the template page properties. You can also override a product’s
shingling settings for specific template pages.

1. Configure the related settings on the Output tab in the Preferences
dialog box as needed:

Scale shingled
pages

Choose the default scaling type:

● Anamorphically (Horizontally): Changes
the vertical and horizontal ratios

● Proportionally: Retains the vertical and
horizontal aspect ratio

Shingle crop marks Shifts the crop marks along with pages that
are shingled for creep

2. Determine the amount of shingling to apply, using either the
approximate formula or exact method.

Approximate formula: (number of sheets/4) × stock thickness

The value that you use for the number of sheets depends on the
binding type:

● If perfect bound: pages per section
● If saddle-stitched: pages per product or part

Tip: The value of stock thickness is measured in microns. Use a micrometer or
obtain the measurement value from the paper supplier.
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3. Exact method:

a. Make a folding dummy using the same kind of paper and the
same folding equipment that you plan to use for the job.

b. Measure the amount of creep with a precise instrument.
c. Measure the difference between the outer edge (face) of the

outermost page and the outer edge of the innermost page. This
is the total creep compensation amount that is needed, which
you can apply to either the innermost or outermost pages or
divide between the inner and outer pages.

4. In the Shingling (Creep) property, optionally select the Scale check
box to preserve the margins and progressively scale the images
instead.

5. In the Inner and Outer boxes, specify the distance and direction to
move the innermost and outermost page edges.

● If Scaling is not selected, positive values move the image area
toward the bind edge of the page, and negative values move the
image area away from the bind edge.

● If Scaling is selected, positive values reduce the image area, and
negative values increase the image area, based on the
Preferences settings.

● For a perfect-bound or come-and-go product or part, the Inner
amount shifts or scales the innermost pages of each section. The
specified amounts are applied to the largest sections, and
shingling on any smaller sections is scaled back so that all
sections match each other after binding.

● For a saddle-stitched product or part, the Inner amount shifts or
scales the innermost pages.

6. To override the shingling for specific pages, edit the template page
properties.

For example, to prevent image distortion in crossover text or images
that spread across adjacent pages, you can apply zero shingling and
zero-bleed margins.

Ganged layouts
A ganged layout consists of independently positioned pages on a press
sheet. You can rotate, scale, align, group, and step-and-repeat the
pages, and edit the margins and gaps directly in the workspace or in the
Properties pane. Ganged layouts can be manually generated, or you
can use the AutoGang feature.
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Ganged flat-work layouts
You can arrange independent pages to create ganged layouts that make
effective use of the press runs.

Mixed-size, flat-work products can be ganged on the same press run:

You can step and repeat a page to fill a selected area on the press sheet
with duplicates, which is useful for jobs such as business cards.

For nested work, you overlap pages, typically for press sheets that are
being finished with die-cutting. The input files require transparent
backgrounds.
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You can completely overlay independent pages, resulting in what is
traditionally called a double burn. The final imposed page combines
two or more images, depending on how many pages you overlay.

This technique is useful for products that use the same content on each
page plus additional or changing information.

Depending on the intended use, the input files of the overlaying pages
might require transparent backgrounds.

Manually creating a ganged layout
Ganged pages have no dependency on adjacent pages, and you have
full control over their positioning.

Requirements:  On the General tab in the Preferences dialog box, select
a snap option for placing pages.

Note: For gang-only jobs, you add the PDF file pages to the Files list and then work
directly in the Press Runs view. You do not set up a Pages List. For licenses that
support multiple products, the ganged pages also appear as two-page (front,
back) products in the Pages List.

1. Select the pages using any of these methods:

● In the Files list, select a PDF file or file placeholder.

Note: If the content files are not yet available, select Job > Create File
Placeholder to add the required number of placeholder pages to the Files list.

● In the Files list, expand a multipage file to view its list of pages.
Select a single page, or press Shift+click to select multiple pages.

● Select a PDF file from an accessible folder in the file directory.

2. For manual ganging, drag the selected pages to a position on the
press sheet.

● If you drag the pages to an empty area, the pages cascade onto
the sheet, and you can arrange them.

● If you drag a page to a position near an existing page on the
sheet, it snaps into the default snap position that is defined in the
Preferences dialog box.

● If you drag the selected pages onto a template page, the first
page is assigned to the template page position, and any
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additional new content pages flow through the available
template pages in sequence.

Note: Any existing content on the affected template pages is replaced.

3. In the Marks list, select and double-click marks to add to the layouts.

4. Select File > Save to save the job.

Step-and-repeat layouts
Use step-and-repeat to quickly fill an area with copies of a page, page
group, or multiple pages, while retaining the same template page
numbers and settings as the original pages. The pages are
automatically grouped and function as a single object that can be
ungrouped.

To create a step-and-repeat group, you can use the Step & Repeat tool,
or you can apply advanced settings in a dialog box.

● When you click the Step & Repeat tool, a new toolbar appears with
options for separating the pages in the group of copies that you will
create.

As you drag a page across an area, the number of copies that will fit
is displayed and updated. In this example, the lower-left page was
used to create a step-and-repeat group of 42 pages that flowed
around an existing page.

● Use the Duplicate dialog box when you need to create a step-and-
repeat group with particular requirements.

For example, you can choose to fill the press sheet with as many
repeated pages as will fit and whether to flow around existing pages
or marks.
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Step and repeat options (Duplicate dialog box)
Use advanced options when you need to create a step-and-repeat
group with particular requirements.

Select a page in the workspace, and select Edit > Duplicate.

Fill press sheet with
stepped pages

Fills the press sheet with as many stepped
pages as will fit

Apply specific
number of steps

Repeats the page by the number of horizontal
and vertical steps that you specify

Arrange pages ● Trim to trim (default): The trim edges touch,
and any inner bleed margins are
automatically removed.

● Bleed to bleed: The inner bleed margins are
automatically adjusted to half their original
width.

● Gutters: When you specify the horizontal
and vertical distances, any overlapping bleed
margins are automatically adjusted to split
the width equally.

Step around existing
pages, Step around
existing marks

Select these check boxes to prevent the page
copies from covering any existing pages or marks.

Center the result on
the press sheet

Select this check box if you want the group that
will result from the step-and-repeat action to be
centered on the sheet.

If this check box is cleared, the pages are
stepped to the right and down from the original
page.

Working with ganged page groups
Ganged page groups are treated as single objects.

Requirements: Use these tasks to organize ganged pages into groups
after adding them to a press run.
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Choose a task:

Group selected pages in their current position Drag a marquee to select the pages, and click the
Group tool.

Group selected pages and apply uniform gutters 1. Select a reference page for the group.
2. Optionally lock the page to its position on the

sheet, in the template page properties.
3. Drag a marquee to select the pages.
4. Edit the reference page gutter text boxes.
5. Click the Group tool.

The same gutters are applied throughout the group.

Break a group apart Select the group and click the Ungrouptool.

Step and repeat a selected page or group Choose a method:

● Basic: With the page selected, click the Step &
Repeat tool, select how the repeated pages are to
be separated, and drag the page to the opposite
corner or side of the area.

● Avanced: Select Edit > Duplicate, and set the
options that appear.

Replace a content page within a group Drag the new content page to the target page
position, and release the mouse when the recycle
symbol appears. All same-numbered template pages
are updated with the new content.

To replace one content page without updating all the
other same-numbered pages, use Option/Alt + drag.

Edit gutters in a selected group 1. Click the Ungroup tool.
2. While the ungrouped pages remain selected, edit

one page’s gutter text boxes. The same gutters
are applied throughout the group.

3. Click the Group tool to regroup the pages.

Access the properties of all pages in a group Select the group, and in the Properties or workspace,
make any required edits. Unedited settings for
individual pages are not affected.
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Rotate a page group Select the page and cick Rotate. Rotating a group
rotates the entire group as if it were one object:

Rotate one page in a group 1. Ungroup the pages.
2. Click elsewhere so that the pages are no longer

selected.

If you apply rotation while the pages are still all
selected, page overlap will result:

3. Select the page and click Rotate.
4. Edit the gutters if necessary.
5. Regroup the pages.

View the dimensions of a group Select View > Show Page Sizes, and select the group.

View the page counts of groups Select View > Show Group Count.

A dashed line forms a blue rectangle around grouped pages.

Setting gutters between ganged page rows

1. Select a page to use as the reference for the pages for which you
want to set common gutters.

2. Optionally lock the page into position.

3. Drag a marquee around all of the pages that you want to arrange in
a uniform layout, including the page that you will use as reference.

4. To set the vertical and horizontal gutters for all of the selected
pages, edit the reference page’s gutter text boxes. For example, if
you are using the lower-left page as the reference, you will edit its
top and right gutters.
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Removing a ganged page from a press run

● To remove a content page with its template page, select the content
page and press Delete.

● To remove a template page that has no content, select the template
page and press Delete.

● To remove a content page without removing its template page, use
Command/Ctrl + Delete.

Note: Removing a template page that has content on its other side also removes
both content pages from the layout.
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5 Assembly

The Assembly view gives experienced prepress operators or planners a
visual and efficient way of planning a complex product’s sections before
creating the press runs. You can define or edit product intent, compare
your settings with any JDF-specified values, and use drag-and-drop or
manual editing to make adjustments.

Note: Access to the Assembly view and the Products list is license-dependent.
This also applies to the corresponding ability to work with multiple products, parts,
and binding styles in a job.

Product intent and assembly planning
Start a product assembly by entering the available product intent that
describes the customer’s product requirements, or by opening a JDF file
that prefills this information.

The Assembly view provides access to all the information and settings
that you need for planning a job’s product assemblies:

Use this: To view or edit this:

Product Intent dialog box The job information and product intent
for the first product in a job

Assembly workspace The assembly of each product’s parts
and sections in graphic or list format,
with visual indicators for items that
require your input

Products list The basic structural components, with
visual indicators for items that need to
be added to a press run

Properties pane The detailed settings for a selected
item, with visual indicators for settings
that require your input. For JDF-based
jobs, you can expand this pane to
compare your settings with the original
JDF requirements.

Product intent can also be accessed from other views:



● In all views, you can view the basic structural components in the
Products list.

● In the Press Runs view, you can edit any of the press-run section
properties that are linked to the corresponding product section’s
intent, such as the stock, fold pattern, or colors.

Notes:

● Other details that you add in the Press Runs view, such as marks and content
page adjustments, have no relationship with product intent.

● To make significant structural changes, such as increasing or decreasing a
product’s total page count, you must edit the product assembly.

● For basic jobs that do not consist of multiple products, parts, or binding styles,
you can ignore product intent and work entirely in the Press Runs view, using
Pages view when needed.

● If you reopen a job that was created in an older version of the software that did
not yet support multiple products and parts per job, then that entire job is
treated as a single product with a single part.

Product parts

You can plan the following part types for a product assembly:

● Cover: The outermost part of a bound product. You typically choose
a standard fold pattern for covers, depending on the binding type.

● Text: The body part of a bound product, consisting of sections that
will be perfect-bound or saddle-stitched along the spine edge

● Folder: A single-section part that is cut and folded only, for products
such as a gatefold brochure. A folder spine is not stitched or glued.

● Flat work: A single-section part that consists of only one front and
(for two-sided work) one back template page, with no anticipated
folding or binding, such for book marks.

Preparing a job assembly
You typically start planning a new product assembly when you receive
the job ticket from an estimator or the MIS.

Note: Access to the Assembly view and the Products list is license-dependent.
This also applies to the corresponding ability to work with multiple products, parts,
and binding styles in a job.
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Adding a product via the Products pane
From either the Press Runs view or the Assembly view, you can use
the Products pane to quickly add products and parts for new jobs or in-
progress assembly jobs.

New jobs always contain one default product, and if your license
supports multiple products, you can add products.

1. In the Products list, right-click a product, and select New Product.

2. Select the new product that appears in the list.

The Properties pane displays the settings for this item.

3. Switch to the Properties pane to define the details:

a. Rename the product (if desired).
b. Specify the total Page Count.
c. Select a Binding Style.
d. Provide values for the other properties (as required).

4. In the Products list, right-click the product and select New Part.

5. Select the new part that appears in the list.

The Properties pane displays the settings for this item.

6. In the Properties pane, define the details:

a. Rename the part (if desired).
b. Select its Type.
c. Specify the total Page Count.
d. Specify the number of pages that are to be in its Largest Section.
e. Provide values for the other properties (as required).

The part name in the Products list is updated to show the page
count, and the part now contains its list of sections.

7. Repeat as needed to add parts and products.

Starting an assembly job with product intent
Set up the assembly for the first product in a multiproduct job by
entering the available intent details in a single dialog box.

Requirements: This procedure assumes that the necessary resources
are already configured.

Note: Access to the Assembly view and the Products list is license-dependent.
This also applies to the corresponding ability to work with multiple products, parts,
and binding styles in a job.
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Product intent information is shared between the Product Intent dialog
box, the Products pane, the Assembly workspace, and the Properties
pane for a selected product component.

Note: Only one job can be open at a time.

1. Select File > New Job With Product Intent.

2. In the Product Intent dialog box on the Products Intent pane,
provide the product assembly requirements, including its total page
count.

3. In the Comments box, optionally type a reminder or memo that you
or other operators can review and edit in the Properties pane for
this item at any time.

4. On the Parts Intent pane, define the part assembly requirements for
each part in this product:

a. To add a part, click [+].
A new expanded tab of blank properties appears, labeled with
the default name for the part.

b. Rename the part (if desired), select its Type, specify its total
Page Count, and provide values for the other properties. (After
closing this dialog box, you will still be able to edit or provide any
missing values via the Properties pane.)

c. Repeat as needed to define all the parts for the product.

You can click the tabs in the Parts Intent pane to toggle between
multiple parts.

5. When you finish defining the product parts, click OK to close the
dialog box.

6. If additional products are required for this job, select File > Add New
Product Intent, and repeat the above steps as needed.

7. If you need to define more parts after you close the Product Intent
dialog box, you can click [+] in the Parts area of the product’s
Properties pane.

The product structure appears in the Products list and workspace.

Next:

You can continue to refine the assembly, until you are ready to generate
the press runs.

Managing product assemblies
Based on the product intent and the bindery’s requirements for a
product, organize the product assembly in the Assembly workspace.

Requirements: You already defined the intent for one product and now
need to make changes.
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Note: Access to the Assembly view and the Products list is license-dependent.
This also applies to the corresponding ability to work with multiple products, parts,
and binding styles in a job.

Choose your tasks:

Note: Although there are typically multiple ways to perform a task, this list
describes only one way of performing each task. For example, you can manipulate
an object in the workspace or edit its settings in the Properties pane to
immediately update both.

Option Description

Edit product
section
properties:

In the workspace, select the product section, and in the
Properties pane, edit its settings as needed.

Edit part
properties:

In the Products list, select the product, and in the
Properties pane, rename it and edit its settings as
needed.

Rearrange and
renumber
sections:

In the workspace, drag the sections into the desired
sequence.

Change a
section’s binding
style in relation
to other
sections in a
part:

In the workspace, drag a section to visually change its
binding relationship to another section in the part.

● For perfect binding, drop one section directly under
or above and left-aligned with another section, so
that they appear stacked.

● For saddle-stitched binding, drop one section at the
right side of another section, so that a connecting
line indicates a nested relationship.

Combine
sections into a
single section:

In the workspace, drag one section directly onto
another section.

Add sections
and pages to a
part:

In the Products list, click the part, and in the
Properties pane, edit its page count. The required
number of additional sections appear in the workspace
and in the Products list, based on the part’s default
binding style and largest section size.

Edit a product’s
page count

In the Products list, click the product, and in the
Properties pane, edit its page count. Sections are
automatically added or removed as needed, which you
can adjust as needed.

Add parts to a
product

In the Products list, click the product, and in the
Properties pane in the Parts area, click [+] to add
parts to the list. Double-click a part in the list to display
its settings.
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Option Description

Split a section 1. In the workspace, select the section, and click the

 Split Section tool.
2. Specify the number of sections to create from the

selected section, and click [+].

A list appears with the sections and page counts
that can be created to total the original page count.

When all pages are accounted for, a running tally
indicates that zero pages remain to be placed.

3. If you prefer to split the section differently, edit the
results by overtyping the page counts for each
section. You can type a page count into the extra
placeholder to increase the number of sections in
the split.

4. When you are satisfied with the distribution of the
pages, click OK.

The new sections appear in the workspace,
replacing the original section.

5. Drag the sections as needed to define the sequence
and binding styles.

Delete a part or
section

In the Products list or workspace, click the part or
section, and press Delete. To avoid an error condition,
also edit the product’s page count.

Add a product Select File > Add New Product Intent, and provide the
details.

Edit a product’s
properties

Edit a product's initial properties using the Product
Intent dialog box. This sets the default values for any
parts and sections that you might later add.

To edit an existing product, select the product in the
Products list to display its settings in the Properties
pane.

After you close the Product Intent dialog box, you can
edit only the the product name, job ID, customer name,
due date, and comments, and you can add and delete
parts. The remaining values are read-only and reflect
the sum total of the parts and sections.

The section properties and page ranges are automatically updated in all
applicable panes when you change the section binding styles, page
counts, and sequential position within the part.
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Using drag and drop to edit an assembly
Edit the binding styles and section sequence using your mouse.

Requirements: Define the product intent, and view it in the Assembly
workspace.

In the Assembly view, choose a task:

● Change the section sequence or binding type.

As you drag, a guideline and wireframe section box indicates the
nearest drop point. For example, drag a saddle-stitched section
to the left to convert it to a perfect-bound section:

● Create a part with mixed binding styles.

In this example, one section is saddle-stitched to another, and
the resulting booklet is perfect bound to the third section.

The Binding Style in the Properties pane for section 1 will
display a value of Multiple, and the page range is dynamically
updated.

● Combine two sections and their page counts.

Dragging a section onto another section creates one merged
section—drop the dragged section when the target section
becomes highlighted:
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The section properties and page ranges are automatically updated in all
applicable panes when you change the section binding styles, page
counts, and sequential position within the part.

Generating an assembly’s press-run layouts
After defining a product assembly, you can trigger automatic
generation of the press-run layouts.

1. In the Assembly view, ensure that the product is fully defined.

Note: If it is only partially defined, do not use this procedure. Instead, you can
manually finish defining its parts and sections and creating the press-run layouts
in the Press Runs view.

2. Select the product in either the workspace or in the Products list.

3. Click Generate Press Runs.
If the press-run layouts are successfully generated, the view
switches to the Press Runs view. If they fail to be generated, you can
edit the settings and try again, or switch to Press Runs view and
manually complete the job.

Next: In the Press Runs view, check and adjust the generated press-run
layouts and trims as needed, and print the output.

Assembly view reference
As you define and edit an assembly’s properties in the Product Intent
dialog box, Assembly workspace, Properties pane, and Products
panes, the corresponding settings are updated in all of these areas.

Products list
The Products list maintains a summary of the job’s products, parts, and
sections. You can select a component to display its settings in the
Properties pane. When manually building press runs, you can drag the
product sections from this pane to to create press-run sections.

Note: You can right-click any item in the Products list to access a context menu for
adding products and parts.

Product and part
details

Collapse and expand your view of products as
needed. The following information about each
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product is displayed and updated as you make
changes:

● Product: Color-coding, name, planned page
count

● Part: Color coding, name, page count, planned
colors

● Sections: Color coding, number, part name,
section page count

Assembly workspace
In the Assembly workspace, you can toggle your view of each
product’s assembly between a graphical format and a more compact
list format. You can drag sections to rearrange or merge them or to
change their binding styles.

Split Section tool
 This tool displays the Split dialog box.

Specify the number of sections to create from
the selected section, and click [+].

Pan
 Drag your view of the workspace.

Toggle product view /  Switch between viewing a product in
a graphical format or a more compact list format.

Color coding A unique color code identifies the corresponding
products in the Products list and the Assembly
workspace.

Product and part
details

Collapse and expand your view of products as
needed. The following information about each
product is displayed and updated as you make
changes:

● Product: Color-coding, name, planned page
count, page size

● Part: Color coding, name, page count, planned
colors, page range

● Sections: Color coding, number, part name,
section page count, planned colors, page range

Visual
information

The arrangement of the sections indicates the
binding type:
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Saddle-stitched sections: 

In list format, smaller icons are used: 

Perfect-bound sections: 

Generate Press
Runs

If the product intent is sufficiently defined, the
required number of press runs and impositions is
automatically generated, and the run-list pages
flow into position according to the template page
numbering.

Product properties (assembly intent)

Product Name Use or edit the default name.

Job ID Optional; blank by default; accepts alphabetic
characters and numbers

Due Date The date that you type appears in the format yyyy-
mm-dd. This information is currently for your own
reference only.

Planned Page
Count

The product page count, which is initially
specified in the product intent, can be updated
only by changing the part page counts.

Binding Style Determines the sequence in which content pages
flow through the template pages on the press-run
layouts:

● Flat Work (no binding)
● Perfect Bound
● Saddle Stitched
● Come and Go
● Cut and Stack
● Mixed (more than one binding style)

Planned Colors Select a predefined common color resource, or
type a new descriptor as a placeholder for the
actual color.
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Comments Type or view a note for your own reference or for/
from another operator.

Parts Click [+] to add as many parts as needed, which
derive their default properties from the product.

To display a part and its properties, double-click the
part name.

Generate Press
Runs

If the product intent is sufficiently defined, the
required number of press runs and impositions is
automatically generated, and the run-list pages
flow into position according to the template page
numbering.

Part properties (assembly intent)

Part Name Use or edit the default name.

Part Type Can be Cover, Text, Folder, or Flat work

Planned Page
Count

The number of pages that you expect this part to
contain

Trim Size The planned width and height of the printed
product page, after it is bound and trimmed. The
default dimensions are defined on the General tab
in the Preferences dialog box.

Binding Style Determines the sequence in which content pages
flow through the template pages on the press-run
layouts:

● Flat Work (no binding)
● Perfect Bound
● Saddle Stitched
● Come and Go
● Cut and Stack
● Mixed (more than one binding style)

Largest Section The highest number of pages that will be in the
page grid of the largest section. This value filters
the fold pattern list and determines the product
sections that are created, based on the part’s page
count.

Planned Colors Select a predefined common color resource, or
type a new descriptor as a placeholder for the
actual color.
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Stock When you select a stock resource from this list, its
defined press-sheet dimensions are also displayed.

Product section properties

Select a section in the Products list or workspace to display its settings
in the Properties pane.

The Part Name, Part Type, and Binding Style are derived from the part
properties.

The ability to edit properties can also depend on whether you are
viewing a press-run section in the Press Runs view or a product section
in the Assembly view, and whether you create the imposition in the
section from a fold pattern or a sheet-based imposition.

Part Name Use or edit the default name.

Part Type Can be Cover, Text, Folder, or Flat work

Section The number that determines the binding order of
the product sections. If the product sections are
rearranged in the workspace, the section numbers
are automatically adjusted to reflect the new
sequence.

Lock Select this check box to prevent this product
section from being rearranged within the assembly.

First Page
Number

Determines the starting page and range of run-list
pages that will be printed in this section, based on
its page count

Trim Size The planned width and height of the printed
product page, after it is bound and trimmed. The
default dimensions are defined on the General tab
in the Preferences dialog box.

Template Name If a template was used to build this press run,
displays the template name. Otherwise, a default
Untitled name is assigned, with a number that
increments for each existing Untitled template in
the Templates list. If you save the current job as a
template, the new name is displayed.

Page Count The number of pages in this component

Fold Pattern Select from the filtered list of fold patterns that
match the section page count, or click Browse for
fold pattern to display the Select A Fold Pattern
dialog box.
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Binding Style The style that determines the sequence in which
the run-list pages flow through the template pages
on the press-run layouts

Reference Page Applies only to sheet-based impositions that you
create or add from a template.Select the
orientation of the section’s lower-left page, which
serves as the reference for the other pages in this
section.

Lay out
additional page

Applies only to sheet-based impositions that you
create or add from a template. Select the
orientation of the other pages in this section,
relative to each other, based on the reference page.

Planned Colors Select or type the names of the colors that are
planned for this item.

Colors Displays the actual content colors that are defined
in the PDF input files (not editable).

Note: Use the Pages view to check for discrepancies
between planned and actual colors.

Comments Type or view a note for your own reference or for/
from another operator.

The following properties can be edited only in the Press Runs view:

Fold Flip Select No to flip the fold pattern and change its
flipped state to Yes (flipped).

Fold Rotation Set the degree of clockwise rotation, relative to
the sheet's grip edge.

Bind Edge Experienced users can apply flip and rotate
transformations to change the orientation of the
pages relative to the bind edge.  For more details,
see the CIP4 Pagination Catalog, available at http://
www.cip4.org/.

Head Trim, Foot
Trim, Face Trim,
Spine, Front Lip,
Back Lip

The applicable gutter or margin widths that will
be trimmed from the page edges; applies only to
impositions that are based on a fold pattern;
editable after you select a Fold Pattern.

In addition to setting individual trim margins, you
can set a spine width (such as for the backbone
of a book cover) and lip widths (such as to create
overfold edges on the front or back page of the
folded signature).
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6 Output printing

When you print a job, you generate the output the files that contain its
layout and imaging data, or you can print directly to a connected device.
A job’s output can target multiple media resources and can be split by
component type.

Basic steps for printing the output
When you print the output, you provide basic information, such as the
print range, and you can also set up advanced options for color mapping
and web growth compensation.

1. Optional: In the Preferences dialog box, load a suitable profile or set
options as needed on the Output tab.

You can set default values for:

● Output type (PS, PDF, PJTF, JDF, or PPF)
● CIP3/PPF (Generate multipage cut blocks, CIP3 units)
● JDF (Include JDF folding data, Include HTML for WST

equipment setup)
● PDF (Split File Name)
● Display punch mark
● Print side center marks
● Ignore split file output errors
● Print crop marks for bleed bounds
● Auto rotate for best fit
● Center image on media
● Output PS marks flats for PJTF/JDF
● Print page and sheet bounding boxes
● Skip device warning
● Scale shingled pages (Proportionally or Anamorphically)
● Shingle crop marks

2. Select File > Print.

3. In the Send to list in the Print dialog box, select the output file type
or Printer.

4. Accept or change the Media.

Any change that you make to the media selection applies to the
entire output.



5. Set up other print options on the dialog box tabs as needed.

6. Click Print.

7. If you are printing divided output and the Print File ID dialog box
appears, type an identifier to include in each file name, and click OK.

8. If printing to file, specify a file name and folder location for the output.

If you generate divided output for media configurations that are set
up with divided output paths, the files are placed in those folders
and you cannot redirect the output.

Printing job layout reports
Print layout mockups and press-run summaries in a report, which you
can use for your own reference or provide to another operator.

1. Select File > Print Job Layout Report.

2. In the Send to list, select the output type (typically PDF or Printer).

3. In the Job Report Media list, select the media size.

Note: Selecting Generic PostScript Printer applies the printer’s default page size.

4. Click Print.

The report includes a mock-up of and details about each press run,
including press run ID and sheet or web number, sheet size and
utilization, run length, and color separation names.

Output Preferences
The output settings that are defined in the currently loaded profile are
applied by default when you print a job.Use a custom profile to store
and load specific print settings that you define on the Output tab in the
Preferences dialog box.

In Mac OS: Select Preps  > Preferences > Output.

In Microsoft Windows: Select Edit > Preferences > Output.

Defaults

Output Type ● Printer: Prints to the printer that is selected in the
Connection dialog box. Divided output is not
available.

● PS: Generates one or more PostScript files
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● PDF: Generates one or more PDF output files
● PJTF: Generates an Adobe Job Ticket file for

workflows that require Portable Job Ticket Format
job data

● JDF: Generates a Job Definition Format file
● PPF: Generates one Print Production Format cutting-

data file per press sheet

CIP3/PPF

Generate multipage
cut blocks

Clearing this check box configures the cutting
data in PPF output to correctly handle adjoining
cut blocks for perfect-bound and saddle-
stitched impositions.

CIP3 units Select the measurement unit that is required by the
cutting equipment.

JDF

Include JDF folding
data

Forwards the CIP4 folding data that is received in
a qualified MIS JDF job file, for the setup of CIP4-
compliant folding equipment

Include HTML for
WST equipment
setup

For automation of Wafer Systems Technology
(WST) equipment only. Select this check box to
add HTML postpress information to a JDFMarks-
Flats subfolder in the output folder.

Notes:

● The job notes must include JobID and JobName values.
● The Output PS marks flats for PJTF/JDF preference

must be enabled.
● The press-run layouts must include WST bar code

marks (PDF for working on the layouts, PS for output).

PDF

Split File Name Generates divided output file names according to the
format that you specify. You can include literal text
and file-name variables.

● Use {} curly brackets to enclose the variable name followed by its
limits, which are enclosed in <> angle brackets. The variable names
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must not contain spaces, although any spaces that exist in the
substituted value or any literal text are maintained.

● Use <> angle brackets to indicate how many characters will
represent the value. For example, <3> uses 3 characters, and a value
of 2 will appear as 002.

● Use [] square brackets to enclose any literal text that is to appear
“as is”.

The following list of available variables shows the software maximum
characters in the angle brackets, which you can edit.

● Up to the first 19 characters of the job’s identifier (including spaces)
can be used. Choose a variable:

❐ {PrintID<19>} derives the value from the Print File ID dialog box.

❐ {JobName<19>} derives the value from the job’s file name and
includes the .job or .jdf extension, except when it is saved
without an extension in Mac OS.

❐ {JobID<19>} derives the value from the job notes.

Note: If you include JobName instead of PrintID and are printing divided PDF
output to a network folder, ensure that the folder and contents are correctly set
up with read and write privileges for Group and Other.

● {Device<19>}, derived from the Media resource for the press run
● {Sig<3>}, derived from the Press Run ID in the job’s Press Runs List
● {Side<2>}. The value will be:

❐ All sides: the number 0
❐ Separated sides: a letter incrementing from A to Z

● {XTile<1>}{YTile<1>}. The following numbers identify the tiles:

❐ All tiles: Number 0
❐ Selected X tiles: Numbers incrementing from 1 to 9
❐ Selected Y tiles: Letters incrementing from A to Z

● [FileNameExtension]. Use literal text to specify the file type. For
multiple output types, [.m] is used.

● {ColorNum<2>}. The following numbers identify the separations:

❐ Process colors: The numbers 00 to 04 (00=multiple colors,
01=cyan, 02=magenta, 03=yellow, 04=black)

❐ Spot colors: The numbers 05 to 98, according to the list on the
Color Separations tab in the Print dialog box

❐ Composite: The number 99

Note: Remember to reduce the size of the other variables if needed.
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General

● Display punch mark
● Print side center marks
● Ignore split file output errors: Prevents an error from interrupting a

divided (split file) output operation. You can check the Status or Job
Log window for output error information.

● Print crop marks for bleed bounds
● Auto rotate for best fit
● Center image on media
● Output PS marks flats for PJTF/JDF: For advanced users. Select

this check box if you have special production marks that are written
in PostScript and that must be included with PJTF or JDF output.

Note: A PDF version of each PostScript mark is required for building the layouts
and editing the SMK properties.

● Skip device warning: Suppresses the message that appears when
the selected media is smaller than the stock, such as when tiling

Scale shingled
pages

Choose the default scaling type:

● Anamorphically (Horizontally): Changes the
vertical and horizontal ratios

● Proportionally: Retains the vertical and
horizontal aspect ratio

Shingle crop marks Shifts the crop marks along with pages that are
shingled for creep

Common Print options
These options appear on every tab in the Print dialog box.

Select File > Print. The following options appear on all tabs of the Print
dialog box.

Send to Lists all available output types, and displays the
current output type. You can select a different output
type each time you print.

● Printer: Prints to the printer that is selected in the
Connection dialog box. Divided output is not
available.

● PS: Generates one or more PostScript files
● PDF: Generates one or more PDF output files
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● PJTF: Generates an Adobe Job Ticket file for
workflows that require Portable Job Ticket Format
job data

● JDF: Generates a Job Definition Format file
● PPF: Generates one Print Production Format cutting-

data file per press sheet

The default type is defined on the Output tab in the
Preferences dialog box.

Copies Specify the number of copies to be printed.

Comment text Type text or text-mark variables to build the the
$Comment text mark for this job.

Media Lists all available media resources, including any tile
sets that you create, and displays the job’s media
selection. The default media is Press Sheet Size.

If Multiple appears, then the output targets more than
one media size and will be imaged by one or more
devices:

● Changing this setting applies the selection to the
entire output.

● The lowest supported capabilities apply to the
entire output.

● One JDF, PJTF, or PDF output file contains the
separate media information for each press sheet.

● JDF or PJTF output also includes a separate marks
flat per media.

● PDF output generates a single file that contains the
different media sizes, and only the applicable press
runs are printed by each device. (To send separate
files, you can use divided output.)

Connection Displays the connected printer that is currently
selected in the Connection dialog box for the target
media; not displayed for multiple media.

Print Sends the output to the Send to selection. The default
output path is defined on the Folders tab in the
Preferences dialog box.

If the Print ID dialog box appears, type an identifier
that is prepended to the file name of each output file
generated. The maximum number of characters for
the Split File Name is defined on the Preferences
Output tab.
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If the Print ID dialog box does not appear, it indicates
that the split file name format in Preferences uses a
different identifier.

General Print options
Use the General tab in the Print dialog box to set up the basic output
requirements.

Select File > Print > General.

Specify print
range

Select this check box to print a partial job.

Use a dash to indicate a range, and use a comma
to separate multiple values (1-4,9-12,21-24). Do
not insert spaces.

Output Format,
Divide by

For PS or PDF output, specify the components by
which to divide a job’s output. A separate file is
generated for each component of that type.

● Optionally, use this setting in conjunction with a
print range.

● Set up to 999 divisions for a job, with multiple
output files generated per division.

● Without divided output, full jobs are printed by
default, and if a problem is encountered, printing
stops.

● With divided output, printing skips a problem file
and goes to the next component file.

● Divided output files can be automatically placed
into media-specific target folders, which you
define in the Media Configuration dialog box.

● Divided output is not available for JDF, PJTF, or
PPF output.

The split file name format for divided output is
defined on the Output tab in the Preferences dialog
box.

Color Handling None: Passes any color information through “as-is”.

PDF Color mapping: Activates the Color
Separations tab.
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● If you print to PDF output, the RIP derives the
color mapping information from the composite
PDF output files.

● You can set up PS or Printer color-mapped
output and print to PostScript devices that
support in-RIP separations.

● Or, after setting up the mappings, switch the
output type to PDF and generate color-mapped
composite PDF output files.

Emulsion side
down

Prints the job with the emulsion side down. The
media device setting can override this setting.

Embed CIP3
cutting data

Adds the CIP3 cutting data to PJTF or JDF output files

Color separations setup
After enabling color mapping on the Print General tab, define the ink
colors for each plate on the Color Separations tab. For example, you
can map a spot color to print on its process equivalent plates or
another spot color.

Setting up the color separations

1. Select File > Print.

2. On the General tab in the Print dialog box, select PDF Color
Mapping to activate the options on the Color Separation tab.

3. Click the Color Separations tab.

4. In the Color column lists, select the colors that are to print on their
own separations.

5. Ensure that all required spot colors are in the job’s color list and, if
needed, are defined with suitable process builds.

6. Specify how any spot colors are to print:

● To print a spot color on its own separation: Select the spot color’s
check box and its own color name in the color’s Output As list. If
the spot color is not yet on the list, you can add it.

● To print a spot color with its process equivalents: Select Process
Colors in the color’s Output As list and select the spot color’s
check box. The spot color is printed on CMYK separations
according to its defined process build.
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● To print a spot color with a specific separation: Select the
process color separation in the spot color’s Output As list.

● To print all spot colors as their process equivalents: Click All
Spots as Process.

● To reset all the spot colors to print separately when the output
settings for the spot colors are varied: Click All Spots Separately.

7. Change the Overprint\Knockout settings, if needed for any
SSiCustomColor separations.

8. Change the Line Screen and Screen Angle settings, if needed.

Defining a spot color’s process equivalent
To define the process build for a spot color, you need to specify the
required CMYK color percentages.

1. On the Color Separations tab in the Print dialog box, click Build
beside the color for which you want to define or redefine a process
build.
The Defined build CMYK percentages are derived from the input
file and updated as you make changes.

2. In the Process Build dialog box, specify the New Build percentages.
The Use new build check box is automatically selected, and the
Defined build percentages are updated as soon as you type a new
value.

3. To save the build, ensure that the check box is selected before
closing the dialog box.

You can change the values as often as needed by clearing this check
box to revert to the previous build.

4. To map the spot color to the corresponding process color
separations in the output, on the Color Separations tab in the Print
dialog box, select Process Colors in the spot color’s Output As
column.

Adding a spot color to a job’s color list

1. On the Color Separations tab in the Print dialog box, click Add
Color.

2. Type the exact name of the color as identified in the originating
specification, with identical capitalization and spelling.
The new spot color appears in the Color list. If this color will print on
its own separation, skip step 3.
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3. If you need to map the new spot color to process colors, click Build,
and specify the New Build percentages.

Color Separations Print options
Select File > Print, select a media and output type that support color
handling, select PDF color mapping, and click the Color Separations tab.

Option Description

Color list and check boxes

Lists all the colors in the output, including CMYK
process colors, spot colors, and mark SSiCustomColors.

All process and spot colors print by default.

In JDF output, to prevent unexpected results with spot
colors that are set in the input files to overprint, turn
spot colors off.

Output As

Indicates the color separation on which to print all of
the page content that uses the selected color. Each
process color and each spot color maps by default to its
own separation.

To map the color to another color separation, select the
color in the Output As list. To map a spot color to its
process equivalents, select Process Colors.

Overprint/Knockout

Derived from the PDF input files; cannot be changed.
SSiCustomColors in marks are set by default to pass
through as overprint.

Pass through

Retains the input file settings for
the selected color. By default, all
colors are set to pass through
without overprinting or knocking
out.

Overprint
Prints the selected color on top of
other colors and can result in a
totally different color. Use with care.

Knockout

Knocks out a space for the
selected color on the other
separations and retains its original
color. Use with care.

Line Screen
You can apply one line screen to each color separation.
For mapped spot colors, the line screens for each of the
process colors apply.
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Option Description

Screen Angle

When you use a line screen that is not defined in a PPD
or PPX file, screen angles of 15, 75, 90, and 45 are
assigned by default to cyan, magenta, yellow, and
black, respectively. If you change the line screen for a
selected color, the screen angle remains the same
unless you change it.

Add Color
Define a missing color when a spot color used in a job
fails to appear in the color list.

Build Displays the Process Build dialog box for this spot color.

All Colors On/Off Select or clear to select or clear all the color check boxes.

All Spots as Process / Separately

To map spot colors all at once instead of individually:

● Click All spots as process to change all spot colors
to their process equivalents.

● Click All spots separately to change all spot colors
to “output as” their own separate plate.

Web growth
Web growth occurs when large rolls of thin or lower quality paper such
as newsprint run through the color units of a web press. Use the Print
Web Growth tab to compensate by applying scaling the color
separations.

Scaling to compensate for web growth
Define reusable scaling sets that compensate for stretch at each of the
ink units on particular web presses. When printing jobs, you can select
and apply or edit a scaling set as needed.

The amount by which the paper stretches varies for each ink unit,
depending on the water and ink that the paper absorbs, and the tension
that is applied to the paper as it runs through each ink unit.

A print shop typically knows what percentage of stretch occurs at each
unit. If they don't know the exact percentages, they can easily run a test
job through the press and measure the stretch percentage for each unit.
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To define web-growth compensation scaling sets, you require an
advanced understanding of web press concepts and behaviors. To
manage the scaling sets, you can:

● Add, edit, and store reusable scaling sets as needed
● Edit an existing scaling set for a specific job
● Duplicate and edit an existing set to create a new set

You can optionally set up a central folder for compensation scaling
sets, and set the path on the Folders tab in the Preferences dialog box
at each installation that uses this folder.

Note: Changes that a user makes at one installation are not reflected at another
installation until the other installation’s Web Growth Compensation Sets window
is closed and reopened.

Applying a scaling set to job output

1. Select File > Print > General.

2. Select PDF Color Mapping.

3. Set up the Color Separations tab.

4. On the Web Growth tab, select Compensate for Web Growth..

5. The first time that you use this feature, a message asks you to locate
the scaling sets folder (and create if necessary).

6. On the Web Growth tab, select a scaling set from the
Compensation Set list.
The number of ink units for the selected set appear below your
selection.

7. If you do not want to use exact compensation, clear the Use exact
compensation check box.

8. Select a scaling set to use, or select a set that is somewhat but not
completely correct for the job.

● To create a new set from a copy of the selected set, click
Duplicate and Edit.

● To edit the selected set, click Edit This Set.

9. Click Print to generate the output.

Your changes are applied to this job’s output. Sets that you create are
stored for reuse.
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Web Growth Print options
Select File > Print > Web Growth.

Option Description

Compensate for Web Growth Select to activate the web-growth compensation options.

Compensation Set list
Select a set from the alphabetical list of sets that are
defined.

Set type, Ink units
When you select a set from the list, the type (Scaling)
and the number of ink units that are defined for the set
appear.

Use exact compensation

Scales the raster images. Each object on each
separated page is translated (moved a certain
distance) and scaled (made larger or smaller). This
scales the page position and the page itself, which in
effect scales the entire press sheet.

In most cases, these changes provide the best
compensation for the effects of web growth. Under
certain circumstances, you might want to translate
images but not scale them.

For copydot files with screened data, clear the Use
exact compensation check box.

Color to Ink Unit Mapping

Printing Colors
All job colors are listed, including any spot colors that
are printing separately.

Ink Unit

A default ink unit identifier is listed for each color,
where 1 is the first color that will be printed, 2 is the
second, and so on. If needed, you can edit these
numbers to remap the colors to the actual ink units in
the correct sequence.

Creating and managing the scaling sets
When you define a scaling set, you need to know the press orientation,
the sequence of the ink units, and the percentage by which the press
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will stretch the paper at each unit. You can define as many different
scaling sets as you need.

1. Select Setup > Web Growth Compensation Sets.

2. Locate and open the compensation sets file.

The first time that you use this feature, a message asks you to locate
the scaling sets folder (and create if necessary). The location
appears on the Folders tab in the Preferences dialog box after you
restart the software.

3. In the Web Growth Compensation Sets window, choose a task:

● To add a new set, click Scaling Set.

Map the ink colors to the press units and apply a scaling
percentage to each ink color, which resizes the images
appropriately for each color.

● To modify only the scaling percentages in a scaling set, select the
set and click Edit.

● To create and edit a copy of a scaling set, select the set and click
Copy.

● To delete a scaling set, select the set and click Delete.

4. If applicable, edit the options in the dialog box that appears:

● If adding a new set, type a name for the scaling set, and specify
the Number of ink units, the Sheet width, and the Reference ink
unit, and click Create.

● If editing a set, enter the scaling percentage to apply to each ink
unit, and click OK.

Web Growth Compensation Sets window
Select Setup > Web Growth Compensation Sets.

Option Description

Table of scaling sets

You can click a column header to
change the sort order. This does not
affect the alphabetical sort order of
scaling sets on the Web Growth tab in
the Print dialog box.

None is always the first item in the list.

Set type All types are Scaling.

Name Name of the scaling set
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Ink Units
Number of units that you defined when
creating this scaling set

Sheet Width
Press sheet width that you defined
when creating this scaling set

Scaling Set setup dialog boxes
Select Setup > Web Growth Compensation Sets, and if prompted,
locate and open your compensation sets folder.

New

Click Scaling Set to add a new set.

Option Description

Name
Maintain a clear, consistent approach
to naming the scaling sets.

Number of ink units
Type the number of ink units in the
target press.

Reference ink unit

Type the number of the ink unit that
prints the reference ink against which
all other units are scaled. In general,
the last ink unit on the press is the
reference unit.

Sheet width

Type the width of the web-press sheet.
This value appears beside the scaling
set name in the Web Growth
Compensation Sets dialog box, to make
it easier to select a suitable set. It is not
used elsewhere.

Copy

Select an existing set, and click Copy.

Option Description

Name
Accept or edit the name of the scaling
set copy.
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Reference ink unit

Type the number of the ink unit that
prints the reference ink. In general, the
last ink unit on the press is the
reference unit.

Number of ink units
Type the number of ink units in the
target press.

Sheet width

Type the width of the web-press sheet.
The value that you enter appears
beside the scaling set name in the Web
Growth Compensation Sets dialog box,
to make it easier to select a suitable
set. It is not used elsewhere.

Edit

Select an existing set, and click Edit.

Option Description

Name
Displays the name of the scaling set
that you selected in the Web Growth
Compensation Sets dialog box

Reference ink unit
Displays the ink unit number of the
reference ink unit.

Ink unit

Map the unit numbers (1 is the first
unit) to scaling percentages. At print
time, you can map the units to the
colors in the job. The percentages
remain mapped to the unit numbers.

Scaling

The reference ink unit is always scaled
at 100 percent, and you then define
scaling percentages for the other ink
units relative to the reference unit.
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7 Media and devices

Each press run targets a media resource that represents either a media
configuration for a specific output device or a virtual press-sheet-size
media that allows the selection to be made downstream.

Media configurations
A media configuration associates a media size and type with the device
PPD file that determines the supported sizes.

The supported media dimensions for a particular device are defined in
the device’s PostScript Printer Description (PPD) file. When setting up
the software, add the PPD files for each output device type that you will
use, and then create the media configurations for each media size that
you use at a particular device. If supported by the device PPD, you can
also add custom media sizes.

When you add a new device PPD or create a new media configuration,
the information is stored in the Printers folder. You can share a single
Printers folder between multiple installations by setting the same path
on the Folders tab in the Preferences dialog box at each installation.

Note: When printing to a file type, your computer does not need to be physically
connected to the target device.

Standard media resources

The software includes a few standard media resources that cannot be
deleted, with limited options for editing their properties.
● Use the default Generic PostScript Printer media resource to print

directly to a device that is connected to your computer’s operating
system, such as a laser printer in your local network.

● When the media choice will be made in a downstream system, you
can print to a virtual Press Sheet Size media that is equal to the
stock size. You can optionally add margins for marks that must print
off the sheet.

Creating a new media resource
To add a resource to the Media list, you prepare a media configuration
for a specific target device. You can set up a media configuration for any



valid size that is defined in the device-specific PostScript Printer
Description (PPD) files in the Printers folder.

The software DVD provides several PPD files, and you can get the most
current PPD files directly from the manufacturer of your imaging
device. If a device is already installed on your operating system, you
can use a copy of the system’s PPD file.

1. (Skip this step if the PPD file is already installed.) Copy the new
device PPD file and paste it to the \Printers\ppd\ folder.

The name of the PPD file must end in .ppd, and contain no special
characters.

2. Select Resources > New Media.

3. Select the Media Type.

The Media Type list displays all the media for which a device PPD
file exists in the \Printers\ppd\ folder.

Note: To create a virtual media configuration that is equal to or larger than the
stock size, select Press Sheet Size.

4. Provide a meaningful nickname for the new media configuration,
and click OK.

5. In the Media Configuration dialog box that appears, select the size,
and set any other options that you need.

Note: For Press Sheet Size media configurations, you cannot change the Size
(PressSheetSize). However, you can optionally increase the size of the output by
specifying top, bottom, and side margins. You cannot set margins for other media
types.

6. Close the dialog box.

The new media resource appears in the Media list in the Resources
pane. The software stores the details for each media in a MediaName
\printer.ppd file in the Printers folder.

Creating and using tile sets
Creating and storing a tile set for a specific media resource gives you
the choice of sending output to either the full media size or to tiles,
which can be stripped together after imaging.

Tiling breaks up the output so that it can be imaged onto a smaller
media size than the stock for which a layout is designed.
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1. Determine the media dimensions and any punch requirements of
the device that will image the tiles.

2. Plan how the tiles can be stripped to fit the final media and stock,
including the number of tiles needed, the grid arrangement, and any
overlap dimensions.

3. In the Media list, select the media for which you will create the tile
set.

4. Select Resources > New Tile Set.

5. Specify the following details for the tile set:

● The tile media and device information, including the punch co-
ordinates

● The tile grid’s horizontal and vertical page count
● The tile orientation and overlap
● The distance from the trim edge of the stripped tiles to the sheet

edge

The tile set appears in a sublist under the media resource in the
Media list.

6. Start a job and build the layout, including any marks that are
required for the final output.

7. In the Media list, select and add the media’s tile set to the layout.

8. Select Resources > Add Tile Mark to Sheet, and choose the Mark
Type that corresponds to the tile orientation.

9. Print the tiles:

Tip: To suppress a message that appears when printing to a media that is smaller
than the sheet, select the Skip device warning check box on the Output tab in the
Preferences dialog box.
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a. Select File > Print.
b. In the Media list, select the tile set.
c. Set up the other print options as needed, and click Print.

The printed tiles are imaged according to the tile set, and the tile
marks appear in the overlapping area of adjacent tiles:

10. Overlap the printed tile sheets using the tile alignment marks, based
on matching numbers.

For example, the tile marks on adjacent overlapping tiles might be
x1y1 and x1y2.

● X indicates a vertical column position.
● Y indicates a horizontal row.

The colors on the paired marks are reversed, which helps you to
determine whether adjacent tiles are positioned correctly.

Adjacent tiles before stripping: Tling marks correctly aligned:

The stripped tiles form a flat:
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Note: Tile sets are saved only as a media resource and are not saved with the job.

Next:

If you used tiling for proofing, you can print the job again, sending the
output to the media resource instead of the tile set.

Media Configuration settings
Edit or define a new media resource in the Media Configuration dialog
box. In the Press Runs workspace, you can select the layout’s media to
view its settings in the Properties pane.

Nickname The name that you specified in the Add Media
dialog box

Short name Derived from the PPD. If the PPD does not provide
a short name for the device, the media nickname is
displayed.

Media type The type that you selected in the Add Media dialog
box

Size List of supported media sizes. The selected size is
applied by the media resource.

Margin Optionally set top, bottom, and side margins to add
an allowance for marks that must print off the sheet.

Divided output
path

The folder location that collects any divided output
for this media resource

● To set or change the path, click Select.
● To use the default output path that is specified

on the Folders tab in the Preferences dialog box,
click Use default.
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Note: You cannot type or copy a path into this box. Also,
when printing divided output, you cannot override the
folder location. It can be changed only here.

Alignment,
Horizontal,
Vertical

If needed, specify offset amounts to keep the
image within the usable area of the media or to
compensate for a small mechanical misalignment
in the device.

Note: This setting is effective only if the Center Image in
Media check box is cleared on the Output tab in the
Preferences dialog box.

You can store different alignment information for
each size that is supported by a device.

Connection Displays the Connection dialog box

Error Log Available only if you received an error message
while printing output to this device; displays the
error information

Job Log Displays a Job Log of status messages that are
generated by the output device each time you print
a job to that device

Punch Displays the Punch Location dialog box

Custom Size Displays the Edit Page Size dialog box, from which
you can access the Custom Size dialog box

PPD Information Available only if you already edited the PPD
settings using the PPD Browser; displays the PPD
Information window, which lists only those settings
that are no longer at their default values.

To change any of these or other PPD settings, use
the PPD Browser tool.

Media list in the Resources pane
The Media list contains the software’s predefined standard media and
the media resources that you configure to target specific devices. You
can also store tile sets for specific media resources. Use this list to
specify the media size and its target device for a press run. You can also
use the context menus to manage the media resources.

Nickname The name that you specified in the Add Media dialog
box
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Dimensions Height and width of the media Size that is currently
selected in the Media Configuration dialog box

Punch Vertical offset of the punch, derived from the Punch
Location settings in the Media Configuration dialog
box. This offset appears in the workspace as a dark
gray area between the defined punch center and the
bottom edge of the media.

Note: Only devices that have a defined punch location can be
added to a press sheet.

The media punch edge and stock punch grip edge are
always displayed at the bottom of the workspace,
whether the punch orientation is set to A, B, C, or D.
For example, if the punch orientation is B (right edge),
then the media object in the workspace rotates 90° to
show the media punch at the bottom. The stock that
you add does not rotate.

Size Names the area on which the layout will print; derived
from the PageSize value in the device PPD file

Context menus

Right-click a resource item to access a context menu.

Add Displays the Add Media dialog box

Edit Displays the Media Configuration dialog box for the
selected media resource

Delete Deletes the media configuration from the Printers
folder

Connecting a printer for direct printing
To be able to print directly to a device such as a laser printer on your
network, you define the connection in its media configuration.

Requirements:

The printer must already be installed and selectable on your computer.

1. In the Media list, right-click Generic PostScript Printer, and select
Edit.

2. In the Media Configuration dialog box, click Connection.

3. In the Connection dialog box, select the printer.
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4. Click Test Print.

5. After the test page prints, click OK.

Tip: If a test page does not print, troubleshoot the printer and operating system setup.

Determining the punch location
To automatically position press sheets so that the image is accurately
centered on the center pin of a punch system, you calculate and define
the punch coordinates for the media configuration.

1. In the Media Configuration dialog box, select the Media Size.

2. Click Punch.

3. In the Punch Location dialog box, click Punch Test to generate a test
page.

4. Position the imaged test page so that it is oriented to match the
diagram in the dialog box.

5. In the Punch Orientation area, select the letter that represents the
punch side of the media.

By default, a punch mark appears centered on the bottom edge of
the press sheet (A).

6. Measure the X axis:

a. Click the X Axis box to display arrows in the diagram that show
which measurement from the test to use.

b. On the test media, measure from the center of the test image to
the center of the punch system.

c. Type this measurement in the X Axis box.

7. Measure the Y axis:

a. Click the Y Axis box to display arrows in the diagram that show
which measurement from the test to use.

b. Measure from the center of the punch center hole to where the
center measurement line would extend off the media.

c. Type this measurement in the Y Axis box.

8. Click OK.

9. Print a placeholder layout to check the placement of the punch mark.

The punch coordinates remain at these settings until you edit them.
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Turning off punch marks in the output
Specify a location for the punch mark that is beyond the edge of the
press sheet.

By default, a punch mark appears centered on the bottom edge of the
press sheet. Use this procedure if you do not want the punch mark to
appear on the press sheet, or to include an amount for setback or plate
bend.

1. In the Preferences dialog box, load the profile that you want to use
for printing without punch marks.

2. On the Output tab in the Preferences dialog box, clear the Display
punch mark check box.
The punch mark will not preview or print in job layouts while this
check box is cleared.

3. To permanently turn punch marks off in all press runs that you print
using this profile, save the currently loaded profile.

Using custom media sizes
When none of the standard media sizes in a device PPD file fit a job’s
needs, you can use a custom size, if supported by the PPD.

Note: In PPD files, the media size is referred to as the device PageSize.

1. In the Media list, right-click the media resource, and select Edit.

2. In the Media Configuration dialog box, click Custom Size.

This button is available only if the device PPD supports custom
media sizes.

3. Choose a task:

● To add a new media size: Click Add, give the new size a name,
and specify its dimensions and orientation.

● To change an existing custom media size: Select the size name,
click Edit, and edit the dimensions, name, and orientation, as
needed.

● To delete an existing custom page size, select the size name, and
click Delete. You cannot delete a standard size.

Note: Standard sizes that are defined in the PPD files cannot be edited or deleted.
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4. Click OK as needed to apply your changes and return to the Media
Configuration dialog box.
The Size list contains your changes.

5. Choose one of the following steps:

● Select the new size for this media resource, and close the dialog
box.

● Do not select the new size, and instead, close the dialog box, right-
click the same item in the Media list, and select Add. You can
then create a new media resource with a new nickname for your
new custom size.

You can now use the custom media for a press run. The grip edge
appears at the bottom of the workspace, according to the orientation
that you specified.

Custom Size dialog box
In the Media Configuration dialog box, click Custom Size.

Option Description

Name

Type a descriptive name for this page
size. The name can be up to 40
characters long and must not include
any special characters, spaces, slashes
(/ or \), colons (:), tabs, or new line
characters.

Width, Height
Specify the dimensions of the custom
media.

Orientation

The availability of orientations depends
on the capabilities of the device and
always includes 0, which is the default
device orientation as defined in the
PPD. The default can be 0, 90, 180, or
270 degrees, depending on what the
RIP uses as the load edge.

Custom page orientation settings 1, 2,
and 3, if available, rotate the
orientation in 90-degree increments.
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Moving the Printers folder
A software restart is required whenever you move the Printers folder.

You might want to set a single Printers folder to be shared by multiple
installations, or copy the device PPD files and media configurations
from a previous installation to a new installation of the software.

1. Create the new Printers folder, if it does not already exist.

2. Move your existing device files to the new folder.

Be sure to include the printers.psm file.

3. On the Folders tab in the Preferences dialog box, set the new location.

4. Restart the software to activate the new location.

Media-related files
To ensure that the software knows about the available media sizes and
device capabilities, you must add a PostScript Printer Description
(PPD) file for each device.

All files that are required to support media resources are stored in the
Printers folder. Information about a device’s media support can be
provided in any of the following files:

● PPX files: A PostScript printer extension (PPX) file can be used to
expand the PPD information to allow a device to take advantage of
capabilities such as custom media sizes, punch coordinates, and
page positioning. If there is conflict between a PPD and PPX, the
PPX is used. Not all devices need a PPX file.

● Device PPD files: When you add a media resource, a printer.ppd file
stores its information inside a new folder with the same name as the
nickname. If you change the configuration settings, the printer.ppd
file is automatically updated. If necessary, you can edit additional
settings using the PPD Browser tool that is installed with the software.

Note: Although you can edit the supported settings, PPD files are copyrighted and
should not be modified.
● Default PPD file: If the software cannot find required information in

a PPD or PPX file, it uses the configuration defaults that are stored in
the defaults.ppd file in the /Printers/PPD/ folder.

The software looks for information in this sequence: printer.ppd file >
PPX file (if available) > device PPD file > defaults.ppd file.
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Note: You can replace the pre-installed PPD files or add new PPD or PPX files. The
best source for an up-to-date PPD is the device manufacturer.

Editing a PPD file using PPD Browser
PPD Browser is stand-alone software that is automatically installed
with the software.

Depending on the device, the PPD settings that you can change in PPD
Browser generally include settings that you cannot change in the Media
Configuration dialog box.

1. Start PPD Browser by double-clicking its icon in the installation folder.

(On the Microsoft Windows operating system, select PPD Browser
from the Start menu.)

The Installed Devices list that appears contains all devices for
which you already added a PPD file.

Note: PPD Browser will be unable to find the printer.ppd file if a media
configuration nickname includes characters from the extended character set.

2. Select a device, and click OK.

If a message indicates that PPD Browser cannot read the file that
you selected, obtain an updated PPD file from the manufacturer.

Each device has one or two tabs of settings: one labelled with the
name of the device, and one, if available, for the installed options.
Icons indicate whether a default or edited value is currently applied
when you print to this device:

● A printer icon indicates a default value.
● A pointing hand icon indicates a nondefault value that you can edit.

3. On each available tab, edit the settings as needed.

Tip: To make a setting editable, click the icon to change it to a pointing hand.

Note: If an installed option is not set correctly for a particular device, related
settings on the other tab might be unable to accept your changes.

4. Select File > Save Settings.

After saving, you cannot choose Revert, but you can manually
restore the previous settings, if known, or you can delete the device
and add it back to restore the default settings.

5. To select another device to edit, select File > Open Device.

In the Media Configuration dialog box, the PPD Information button
becomes available only if the PPD file was edited. You can then view
the nondefault settings that were applied.
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Checking a media’s job log
Information about each job that is printed to a media configuration is
accumulated in its job log.

1. In the Media list, right-click the media that you want to check, and
select Edit.

2. In the Media Configuration dialog box, click Job Log.

3. Review the job log that appears.

The log is updated with the job name, print time and the number of
pages, separations, and copies. Unsuccessful or canceled jobs are also
noted.

When you close the software, the job log is saved so you can go back
and look at logs from the past, if necessary. The log.txt files are stored
in the Printers folder.
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8 Marks

All marks that you can create and add to press runs are based on the
Kodak SmartMarks software technology. Each mark is dynamically
placed and sized, based on the positioning rules that you configure and
store in its SMK file.  You can create collation, crop, custom, duplicating,
fold, rectangle, and text SmartMarks and groups, and you can also set
preferences for built-in side guide and center sheet marks.

Mark anchors
SmartMarks can be anchored to the points that you specify on press
sheets, pages, page bleeds, or media. You can set horizontal and vertical
offsets to allow space between the mark image and component anchor
points.

When adding most SmartMarks to a press-run layout, you choose the
layout component to which you are adding the mark, and then you
select two anchor points: on the rectangle that represents the mark
image and the rectangle that represents the component.

For example, selecting the upper-left anchor points: 

Results in this mark position: 

Anchor-to component Rectangle description

Press sheet Dimensions of the stock resource



Media Dimensions and position of the media resource

Note: To print marks that extend off the sheet when
the media is smaller than the sheet, use a Press
Sheet Size media resource that is configured with an
extra margin.

Page or page bleed Trim or bleed dimensions of a template page or
ganged page group

Note: A page-anchored mark is placed on all
instances of the page and shifts to match any page
orientation changes.

Imposition or Imposition
with bleeds

Farthest extents of the trim boxes or the bleed boxes
of all pages in an imposition

Gutter (horizontal,
vertical)

Set of horizontal or vertical rectangles between trim
boxes of the pages of an imposition and between the
opposing edges of the imposition-with-bleeds
rectangle

Margin (top, bottom, left,
right)

Rectangle between the corresponding edges of the
imposition and the press sheet, and between the
opposing edges of the imposition

Margin (top left, top
right, bottom left, bottom
right)

Rectangle between the corresponding corners and
edges of the imposition and press sheet
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“Bring to Front” for overlapped marks
To ensure that the correct mark is printed on top of the others, you
need to know the default layer sequence that the software applies.

If you overlap marks on a press-run layout, the Bring to Front option
gives you some control over which mark is to print on top. However, if
you place a mark group, you are adding several SmartMarks at once, all
of which might be set to Bring to Front.

When you add individual SmartMarks that overlap:

● The first mark that you add to a press sheet becomes the bottom-
most mark.

● Each subsequent mark that you add will be on top of the previous
mark.

When you create and import a SmartMarks group:

● Marks in a group are added in ascending order, sorted by file name.
● The highest mark on the press sheet has the lowest file name, and

the rest of the marks are added in top-down order.

The easiest way to control the layering is by adding numbers to the
mark file names, giving the lowest number to the mark that you want
on top.

For example, in this SmartMarks group, the 1_ssi_Custom mark is the
highest mark and 4_Bottom_Rectangle is the lowest:

● 1_ssi_Custom
● 2_Registration_Custom
● 3_Yellow_Rectangle
● 4_Bottom_Rectangle

Note: If any individual SmartMarks are added after this group is placed, then they
are placed on top of it.

Legacy static marks in older files
Limited support is provided for legacy static marks that might exist in
older jobs or templates that you open in this newer software.
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Depending on various factors, the static marks are retained,
autoconverted to SmartMarks, or deleted.

● Rectangle, line, and text marks can be retained as static marks in a
job, as long as you do not edit them. Otherwise, the mark will be
converted to a sheet-anchored SmartMark.

● All static crop marks on a sheet become page-anchored crop
SmartMarks.

● Static exposure marks are retained as static marks. They can be
edited and are included in the output. There is no corresponding
type of SmartMark for exposure bars.

● If you open a file that contains an unsupported type of static mark, a
message informs you that the mark will be deleted if you continue.

● Any converted or deleted static marks in a job are stored with the
job. The original template is not affected.

General mark tasks
You can add, edit, duplicate, copy, reposition, and delete SmartMarks,
set up mark groups, and add your own image files to use for custom or
duplicating marks.

Creating a new mark resource
To add a new resource to the Marks list, you define a mark that is
based on an existing SmartMarks (SMK) file. You can create, edit, and
duplicate individual marks or groups as needed.

1. On the Folders tab in the Preferences dialog box, set the default
Templates, Marks, and Resources path for this installation.

2. Choose a method to create or modify a mark:

● Select  Resources > New SmartMark, choose a mark type, and
edit its name and properties.

● In the Marks list, right-click a mark to use as the basis, select
Duplicate or Edit, edit its name and properties, and save the
mark or a copy of the mark under a new name.

3. Save the mark to a location in the /Marks/SmartMarks/ folder.
The mark’s positioning information is stored in its MarkName.smg
file.

Important: Only marks that are stored in this folder appear in the Marks list.
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4. Optionally, create a group of marks that can be added and
automatically positioned all at once:

a. Create a new subfolder within the SmartMarks folder, with a
name to identify this mark group.

b. Drag or copy the SMK files for this group into the new folder.

An info.smg file stores the information about the group in the same
folder as the individual SMK files.

The marks and groups that you create appear in the Marks list in the
Resources pane.

Adding marks to a press-run layout
When you add a mark to a press run, it is anchored and positioned
automatically according to its defined properties.

In the Marks list, select and double-click marks to add them to the
currently selected press-run layout.

You can add individual marks, mark groups, and selected marks
from within a group to a press-run layout.

The marks are also added to any linked press runs, and the name of
each placed mark remains highlighted in the Marks list until you
delete or edit it.

The job file references any mark files that it uses. However, if you edit
or move a placed mark so that its properties no longer match a stored
SMK file, the mark data is embedded and stored in the job file.

Deleting a mark from the Marks list

Note: This action cannot be undone. It does not delete any instances of this mark
that were modified or moved after they were placed on the sheet.

1. In the Marks list, right-click a mark.

2. Select Delete to permanently remove the mark file from both the
Marks folder and Marks list, including all placed instances of this
mark.
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Editing a placed mark

1. If the mark on the press run is an unedited instance of a mark
resource, locate and right-click the highlighted mark name in the
Marks list, and choose Select in Sheet.
This selects all placed instances of the mark and displays its settings
in the Properties pane.

2. If the placed mark does not exist in the Marks list, choose a method.

● Click a mark, or press and hold Shift while clicking multiple marks.
● If the mark is small, click the Zoom tool, and click or draw a

marquee around the area that contains the mark.

3. In the Properties pane, edit the properties as needed.

When you modify a placed mark, its name is no longer highlighted
in the Marks list, because it is no longer an exact instance of the
original mark file. The placed mark properties are stored with the job.

Note: Editing a mark file by right-clicking it in the Marks list does not affect
instances of this mark that were previously added to a press sheet.

Dragging a mark to a new position

1. In the placed mark’s properties, clear the Lock mark to this position
check box.

2. Drag the mark to a new position.

The offset values are immediately updated in the placed mark’s
properties. When you save the job, the mark is automatically locked in
its new position.

Copying marks between press sheets

1. Select the mark or marks on the current press run.

2. From the Edit menu, select Copy.

3. Select another press sheet.

4. From the Edit menu, select Paste.
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Creating a mark group
You can create a group of marks that can be both added and
automatically positioned at the same time.

Requirements: Create all the mark resources that you want to place
into a group. For example, a mark group might contain a flat identifier
text mark, fold mark, crop marks, color bar, and custom registration
marks for your press.

1. Create a new subfolder in the SmartMarks folder, with a name to
identify this mark group.

2. Drag or copy the SMK files for this group into the new folder.
An info.smg file stores the information about the group in the same
folder as the individual SMK files, and the new group appears in the
Marks list.

Managing placed crop and fold marks

Choose a task:

● To select a crop or fold mark: Press Option/Alt+click the mark.
● To select multiple crop or fold marks: Hold Shift+Option/Alt and

click the marks one at a time.
● To delete crop or fold marks: Select the marks (press Option/Alt

or Shift+Option/Alt), and press Delete.
● To restore a partial set of crop marks to a full set: In the crop

mark properties, click the Place crop marks on outside of
imposition check box until it is in either a cleared state or
selected state with a white background, depending on your
requirements.

● To delete an entire crop mark set: Select one or more crop marks,
and press Delete.

● Optionally configure default white knockout under marks on the
Marks tab in the Preferences dialog box.

Marks Preferences settings
You can store default mark settings in a profile, including mark
dimensions and text-mark fonts.

In Mac OS: Select Preps > Preferences > Marks.
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In Microsoft Windows: Select Edit > Preferences > Marks.

Defaults

Specify the following default measurements:

● Rectangle Mark Width
● Rectangle Mark Height
● Crop Mark Distance
● Crop Mark Length
● Line Width
● Fold Mark Length

Text Marks

View the currently installed and designated default font for each of the
following text-mark types:

● General Text Mark Font
● Roman Text Mark Font
● CJK Text Mark Font
● CJK Text Mark Font Preview
● CJK Text Mark Character Collection

Note: If multiple fonts are installed for any of these types, you can select from a list
to change the current default. To install a new text-mark font, use the Profile Editor
utility.

Sheet Marks

Use sheet marks: Clear this check box if side guides and center marks
are not required by default. Selecting this check box activates the
following options.

Place side guides:
[ ] From [ ]

On sheetfed presses, side guides are used to
position the sheet as it feeds into the press.
Specify the distance that is needed between the
center of the side guides and the edge that you
are measuring from (this is the gripper edge).

Length of center
marks

Specify the length of the center marks that
indicate the top and bottom centers of the press
sheet. The top center mark begins 3 mm (1/8 in.)
above the press sheet, and the bottom center
mark begins 3 mm (1/8 in.) below the press
sheet. If you do not want center marks, type 0.
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Other Marks

● Add white KO under crop marks: Select the check box to include
white knockout.

● Add white KO under fold marks: Select the check box to include
white knockout.

● Collation mark steps from head direction

Common settings for SmartMarks
Settings that you can edit for most SmartMark types include name,
anchor, and placement information, and options for saving, creating,
and duplicating marks.

Identifying marks

Mark Type (Properties pane only) Displays the SmartMark type
on which the selected mark is based.

Name The mark name can be edited only when creating a
new SmartMark or editing a selected mark in the
Properties pane, or you can use the Rename context-
menu item for marks in the Marks list.

The name that you specify for a new SmartMark
becomes the mark’s default SMG file name in the Save
As dialog box when you save the new or edited mark
file.

In the Properties pane, if you edit the name of a
selected placed mark, no corresponding SMG file is
created. The mark name and settings are stored only
in the JOB file and TPL file, if applicable.

Anchoring marks

Note: See also  Mark anchors on page 133 and the topics about specific mark types.

Anchor to Select the component to which the mark will be
anchored, and on the diagram, click a reference
point for the selected component.

Mark Anchor On the diagram, click a reference point for the
mark image.

Margins or offsets
(various labels)

Type the amounts of horizontal and vertical
space to allow between the mark and
component anchor points.
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Lock mark to this
position

Clear this check box to temporarily allow the
mark to be dragged to a new position. The
repositioned mark is automatically locked in its
new position and any offset values are updated.

Note: Any mark type that does not offer this option is
locked by default.

Placing marks on press runs

Front, Back, Both Specify the side or sides on which to place the mark.

Range: When anchoring custom or crop marks to a
page or page bleed, you can specify a page range.

Use a dash to indicate a range, and use a comma to
separate multiple values (1-4,9-12,21-24). Do not
insert spaces.

Bring to front Select this check box to print the mark on top of
any other content. See also  “Bring to Front” for
overlapped marks  on page 135.

Mirror on back Select this check box to print the mark in the same
relative position on the back of the press sheet. If
you flip the press sheet in the workspace, you can
see that the mark is in the same place. Mirrored
text in text marks is reversed. This option does not
apply to crop, collation, or fold marks.

Place on every... Specify the press runs on which the mark is to print.

For example, to place it on every second press run
starting with the second press run, type 2 in both
boxes. To print the mark on all press runs, accept
the default values (1, 1).

Restrict to
section

This option is available for custom, collation, and
text marks. To add this mark to only one section on
a multiple-section press run, select this check box
and select the section number on which to place
this mark.

Lock mark to this
position

Clear this check box to temporarily allow the mark
to be dragged to a new position. The repositioned
mark is automatically locked in its new position and
any offset values are updated.

Saving your mark edits

Mark resources can be edited and saved via the Resources menu and
the context menus in the Marks list. On press-run layouts, you can edit
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the properties of selected marks, and your edits are stored with the job
without affecting the mark resource files.

The available buttons depend on how you access the mark properties:

● Via the Properties pane: No buttons are provided, because this
pane applies only to the current press run.

● Via the Resources menu: The dialog box provides Cancel, Save, and
Apply & Save buttons.

Clicking Apply & Save places this mark on the current press run,
saves it as SMK file, and adds it to the Marks list. A reference to the
SMK file is saved in the JOB file, unless you edit or move the placed
mark.

● Via the Edit context menu item in the Marks list: The dialog box
provides Cancel, Save, and Save a Copy As buttons.

● Via the Duplicate context menu in the Marks list: The dialog box
provides Cancel and Save buttons. The file is saved with the same
name, with the addition of Copy, and you can then use the Rename
context menu item if desired.

Setting mark color

The Mark Color dialog box can be accessed when configuring the
following mark types:

● Collation
● Crop
● Fold
● Line
● Rectangle
● Text

Mark Color dialog box

The Mark Color button is available for the following mark types:

● Collation
● Crop
● Fold
● Line
● Rectangle
● Text

All Separations:
%Screen

Prints the mark on all separations. In the
%Screen box, specify the screening percentage.
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Spot Color:
%Screen,
SSiCustomColor

Prints the mark on the separations that are
mapped to the spot color that you specify. In the
%Screen box, specify the screening percentage.

In the SSiCustomColor box, type an SSi custom
color name and number, such as
SSiCustomColor101. The SSi custom color
number is a placeholder that can be mapped to
any spot color or process color equivalent when
you set up the Print Color Separations tab. You
can prevent a mark from printing by setting its
color build to all zeroes.

Process Color:
%Cyan,
%Magenta,
%Yellow, %Black

Prints the mark on process color separations.
Type the CMYK percentages to specify the
process color build for the mark.

Custom and duplicating marks
Custom marks can be created from existing marks or by adding your
own image files. When creating a duplicating mark, you set up an
image file to repeat automatically to fill a specified area.

Mark image files
Custom marks that you create require both an EPS and a PDF version of
the image. You select the .eps image file when creating a custom mark,
and the corresponding .pdf file is automatically included in the output.
EPS marks can optionally be included with PJTF or JDF output.

Image files for the following custom mark types are included with the
software:

● Registration marks
● Short- and long-side guides
● Bender mark for NELA plate-bending system, to help ensure

accurate positioning on the cylinder
● Color bar duplicating marks (located in the Dupmarks folder)
● In-RIP color ID marks in various rotations
● Digital exposure test mark
● Device resolution mark
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● Collation marks (available as PostScript only)
● Bar code marks for WST and Müller Martini equipment (available as

PostScript only)

In order to use PostScript-based marks such as the collation marks and
bar code marks, you must enable the Output PS marks flats for PJTF/
JDF option on the Output tab in the Preferences dialog box.

Bar codes in custom marks
JDF or PJTF output can include PostScript marks flats that contain
custom bar codes for preventing collation and folding errors in
postpress equipment. The finishing equipment scans the coded text-
mark variables in each mark to check that all the signatures belong to
the same job and are in the correct sequence.

Note: Before adding PostScript-coded marks such as bar codes to a job, you must
select the Output PS marks flats for PJTF/JDF check box on the Output tab in the
Preferences dialog box.

When deciding where to place a bar code mark, be sure to apply any
guidelines provided by the finishing equipment manufacturer. You
typically place the bar code in the spine or grip area, positioned so that
the bar code scanner will be able to read it.

The bar code that you select depends on the target equipment that the
mark was designed for, in accordance with the manufacturer
requirements. The software includes bar code images that can be read
by Müller Martini and Wafer Systems Technologies (WST) optical
scanners during job finishing:

● The MM-barcode128c.eps bar code for Müller Martini’s automatic
signature detection (Asir) or compliant equipment contains the job
ID (0-4999), signature ID (0-99), and total number of signatures in
the output.

● The WST-bar2of5.eps WST-compliant bar code contains the job ID
(0-99999) and signature ID (0-99), and the WST-bar2of5w-
text.eps mark also displays a human-readable version of the
numbers represented by the bar code symbols.

Each mark contains the job and signature ID text-mark variables, with a
defined number of numeric digits allocated for each variable. Leading
zeros automatically fill the bar code when fewer digits are required.
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Otherwise, the value is truncated from the front to the defined number
of digits:

● If a bar code allocates two digits for a signature ID, and the actual
job signature number is 5, 105, or 205, the bar code represents the
signature as number 05.

● If a job ID is allocated five digits, and the actual job ID is 123, the bar
code uses number 00123. If the actual job ID is 12345678, the
number 45678 is used.

Note: All ID numbers must contain numeric characters only. The job will fail to
print or preview if an applicable ID contains any characters that are not numeric. If
the job does not contain a job ID and the bar code requires the job ID, the job will
still print, but the job ID portion of the bar code will be set to all zeros.

Bar code marks are cross-platform compatible. However, they can be
previewed only on the same platform (Microsoft Windows or Mac OS)
on which the press-run layout was created.

If you have a solid understanding of the PostScript language and bar
code technology, you can edit the number of digits for the signature
and job ID.

Adding a new custom mark
A custom mark consists of an image file and the SMK file that stores its
positioning rules.

1. Skip this step if your workflow does not require a TIFF mark in the
output. If your workflow requires TIFF marks, you must wrap the
image in both an EPS file and a PDF file.

a. Prepare the TIFF image in your source software.
b. Use Adobe Illustrator® to create a new document with the exact

same dimensions as the TIFF image.
c. Place the TIFF image into the document.

2. Save the image document as a PDF file. See  Preparing suitable PDF
input files on page 15.

3. Save your image document as an EPS file.

Set the preview as recommended for your software version, and
enable the option for including linked files.

4. Place the PDF and EPS image files into the Marks folder.

5. Select Resources > New SmartMark > Custom Mark.

6. Edit the properties:

a. Give the new mark file a suitable name.
b. Locate and select the mark image file.
c. Edit the anchor and placement details as needed.
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7. Save the mark to the SmartMarks folder in the configured Preferen-
ces folder location for marks.

Mark image files can reside anywhere in the Marks folder or
subfolders.

Note: If you add a custom EPS mark image file with the same file name as an
existing mark image file, the original file is overwritten.

The new custom mark is added to the Marks list.

Next:

When you add the custom mark to a job, the SmartMark rules will
retrieve the correct image file for previewing and printing.

In order to use PostScript-based marks such as the collation marks and
bar code marks, you must enable the Output PS marks flats for PJTF/
JDF option on the Output tab in the Preferences dialog box.

Custom Mark settings
You can add a new custom mark for an existing mark or for an image
file that you create in your choice of software. Custom mark images are
also used to create duplicating marks.

Image file Select the image file to use in the mark.

Rotation Select the number of degrees to rotate the mark
image clockwise around the mark anchor point.

For information about the following settings, see Common settings for
SmartMarks on page 141.

● Anchor to, Mark Anchor
● Margins
● Lock mark to this position
● Front, Back, Both, Range
● Mirror on back
● Bring to Front
● Place on every...
● Restrict to section
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Creating a new duplicating mark (color bar)
Create a duplicating mark that repeats a mark image file to
automatically fill a specified area.

You can choose to repeat the image from one end of the mark length to
the other (clear the Centered check box), or to repeat it to either side
from the center of the mark area (select Centered).

1. In the Marks folder, select both the EPS and PDF version of an
existing custom mark image file.

2. Move (do not copy) the mark image file to the Dupmarks folder.

A mark image file that is in the Dupmarks folder must not also
reside in another location within the Marks folder.

3. Restart the software, so that it will recognize the mark file as a
duplicating mark.

4. Select Resources > New SmartMark > Duplicating.

5. Edit the properties:

a. Give the new mark a suitable name.
b. Locate and select the mark image file.
c. Specify the area that the mark is to fill.
d. Edit the remaining mark properties as needed.

6. Click Save to automatically add the new duplicating mark to the
Marks list.

The duplicating SMK file is stored in the SmartMarks folder and
references the custom mark image file in the Dupmarks folder. When
you add this mark to a press sheet, it will automatically repeat to fill the
area that you specify.

Duplicating Mark settings
Use duplicating marks to add color bars to press sheets. The mark
image duplicates automatically within a specified area on a press sheet,
typically across its width or within a fixed area that you specify.

Image file Select the image file to use in the mark.

Rotation Select the number of degrees to rotate the mark
image clockwise around the mark anchor point.

Size Type Select a fixed or variable size type, and specify the
fixed dimension of the area that is to be
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automatically filled with duplications of the color-
bar mark image:

● To create a fixed-size mark: Select Fixed, and
specify the Width and Height in the text boxes
that appear.

● To create a vertical mark that automatically
matches the height of the component: Select
Variable height, and specify the mark thickness
in the Width text box that appears.

● To create a horizontal mark that automatically
matches the width of the component: Select
Variable width, and specify the mark thickness in
the Height text box that appears.

Duplicate from
center

Select this check box to center the mark image in
the specified mark area and to automatically
duplicate the image to either side of the center until
the area is filled.

Clear this check box if the mark image is to be
automatically duplicated from one end to the other
end.

Apply workflow
calibration

Note: This option applies only to JDF or PJTF output; it is
ignored for all other output types.

Select this check box to generate a pair of marks
flats:, one containing the uncalibrated version of the
marks, the other with calibrated marks in case this is
needed downstream. Uncalibrated marks are not
affected by color profiles or curves applied to jobs.

Anchor to Select the component to which the mark will be
anchored.

On the diagram, click a reference point for the
selected component.

● Fixed-size mark: Choose any of the nine points.
● Vertical mark (variable height): Choose one of the

three vertical anchor points to anchor the mark to
the left edge, center, or right edge of the component.

● Horizontal mark (variable width): Choose one of
the three horizontal anchor points to anchor the
mark to the top edge, center, or bottom edge of the
component.

Offsets Type the amounts of horizontal and vertical space to
allow between the mark and component anchor points
and between the mark image and the component edge.
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● For a fixed-size mark: In the H Offset and V Offset
text boxes, specify the vertical and horizontal
distances between the mark and component
anchor points.

● For a vertical mark (variable height): In the H
Offset and V Margin text boxes, specify the
horizontal distance from the component anchor
point and a width for the vertical margin between
the mark and the component.

● For a horizontal mark (variable width): In the V
Offset and H Margin text boxes, specify a vertical
distance from the component anchor point and a
width for the horizontal margin between the mark
and the component.

For information about the following settings, see Common settings for
SmartMarks on page 141.

● Mark Anchor
● Lock mark to this position
● Front, Back, Both
● Mirror on back
● Bring to Front
● Place on every...

Text marks

Text-mark variables
When you add code words called variables to your text marks, their
values are derived from the job details and included in the output.

Note: Text-mark variable names are not case-sensitive. Before Asian or other
Unicode™ fonts can be rendered in text marks, the CJK text-mark profile options
must be correctly set.

This variable Prints this content:

$Comment Derived from the Comment that you type in the Print
dialog box

$Color The colors on the side of the sheet where the text mark
is placed
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$ColorNum The numeric identifier for the color

● Process colors: 00=multiple colors, 01=cyan,
02=magenta, 03=yellow, 04=black

● Spot colors: The numbers 05 to 98
● Composite: The number 99

$Date Indicates when the job was last printed to file

$Device Derived from the Nickname in the Media Configuration
dialog box

&JobDate, $JobTime Indicates when the job was last saved

$JobID The job ID number

$JobName The job file name (includes the .job extension)

$Job_Title The name that you give the saved job

&LocaleLongDate, $LocaleJobDate Same as DATE and JOBDATE, except that the
applicable format is applied based on the current
international settings at the operating system level

$PressRunNumber The sequential number as it appears in the job’s Press
Runs List

$PressSheetName The relative stock name. The stock can be specified by
an MIS JDF file, and the selected stock is included in
JDF output.

$SheetHeight, $SheetWidth The stock dimensions, in the default measurement unit

$Side The press sheet side (A = front, B = back). For multiple-
web press runs, the additional sides are labeled C, D,
and so on. If sides are printed together, this variable is
blank.

$Sig The press run ID number

$SigName The name of the current press run

$Template The relative path and name of the signature’s template
Note : The relative path starts at the default Templates
folder (as set in Preferences). A colon [ : ] is used to
delimit any subfolders in the path.
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$Time The time the job was output from Preps, using the 24-
hour clock

$Web The numeric identifier of the current press sheet

$XTile, $YTile The horizontal (X) and vertical (Y) tile identifiers. If all
tiles are printed together, this variable is blank.

Text Mark settings
When setting text mark properties, you can type plain text and
optionally include text-mark variables that derive their values from a
variety of sources. You can also set default font information on the
Marks tab in the Preferences dialog box.

Note: Set the default text-mark font properties on the Marks tab in the Preferences
dialog box.

Text Type the mark text, which can include text-mark
variables such as $Job_Title.

Text Size Type the text height in points.

Script Select Roman or CJK to set the corresponding text-
mark font that is defined on the Marks tab in the
Preferences dialog box.

Rotation Select the number of degrees to rotate the mark
image clockwise around the mark anchor point.

Vertical Text Select this check box if vertical characters are to be
used in the marks. The appearance of the vertical
characters depends on the mark rotation:

Rotation when Vertical is selected:

Rotation when Vertical is not selected:
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Flat Identifier
Mark

Select this check box to place the text mark in
exactly the same place on each press-sheet side. For
example, you might use this mark to identify the
color separation per plate, using the $Color or
$ColorNum text-mark variable.

Text Anchor Click a reference point on the diagram, which
represents the left edge of the first text-mark
character.

For information about the following settings, see Common settings for
SmartMarks on page 141.

● Mark color
● Anchor to
● Margins
● Lock mark to this position
● Front, Back, Both
● Mirror on back
● Bring to Front
● Place on every...
● Restrict to section

Creating a CJK text mark
Create text marks using a Roman-style or CJK (Chinese, Japanese,
Korean) font, rotated as needed.

1. In the text mark’s properties, select CJK from the Script list.

2. To create a vertical text mark, select the Vertical Text check box,
and specify the text orientation.

3. Edit the properties as needed for the new mark, and click Save.
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Crop Mark settings
Crop marks can be added and managed individually or as a set, and are
always anchored to pages. On the Output tab in the Preferences dialog
box, you can choose to shift the crop marks with page shingling and to
print additional crop marks for the bleed margins. On the Marks tab,
you can also set an optional white knockout.

Length Type a length for the crop marks.

Note: Set the default length on the Marks tab in the
Preferences dialog box.

Offset from page Type the distance from the page trim corners to
place the crop marks. This number can be
negative.

Note: Set the default distance on the Marks tab in the
Preferences dialog box.

Style Select the line type (solid, dotted, or dashed).

Place crop marks on
outside of
imposition

Select this check box to automatically prevent
placement of any crop marks that would be
inside the imposition, such as in the gutters
between the pages.

Bring to Front Prints the mark on top of any other content

● If Bring to Front is either selected or cleared in the
same way for both marks, then the crop mark will
print over a color bar.

● If only one of the two overlapping marks is
selected, then that mark will print on top.

Note: All output types except JDF or PJTF support printing
crop marks on top of duplicating marks.

For information about the following settings, see Common settings for
SmartMarks on page 141.

● Mark color
● Lock mark to this position
● Front, Back, Both, Range
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Collation Mark settings
Add collation marks to identify the planned sequence of the sections in
a product assembly, based on the binding style. If you change the page
count or renumber the pages, the collation marks adjust automatically.
You can place collation marks in the trim or content areas, anchored to
low, high, or mid folio pages of product sections. The marks can be
trimmed off after the collation is checked at the bindery.

Binding Select the binding style, which determines the
placement of the marks.

Note: A collation mark whose binding style does not match
that of the section will not image.

Type Select a mark type that provides the desired character
rotation and text-mark font.

Collation Mark A: Numeric collation indicator inside
the mark, rotated 90 degrees

Collation Mark B: Numeric collation indicator inside
the mark, no rotation

Collation Mark C: No collation indicator inside the mark

JA, ZH, ABC: Japanese, Simplified Chinese, Roman
characters. Your selection applies the corresponding
text-mark font that is defined on the Marks tab in the
Preferences dialog box.

Collation Mark A-JA
(rotated 90 degrees):

Collation Mark B-ZH (no
rotation):

Origin Select the edge from which to offset the collation
mark. The available options are determined by the
binding style.

Note: You can also set a Collation mark steps from head
direction option on the Marks tab in the Preferences dialog box.

Width Specify how wide each mark will be.
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Length Specify the distance from the start point that may be
used by the stepped collation marks, after which the
next mark is placed at the start point again.

Step distance Specify the distance between the optional text and
the collation mark, which can be positive or negative,
and not zero.

Optional Text Type any text that is to trail the mark and print in the
same color as the mark. You can use regular text and
text-mark variables.

Note: The font used in the optional text is not affected by the
type of collation mark.

Script Select Roman or CJK to set the corresponding text-
mark font that is defined on the Marks tab in the
Preferences dialog box.

Vertical Text Select this check box if vertical characters are to be
used in the marks. The appearance of the vertical
characters depends on the mark rotation:

Rotation when Vertical is selected:

Rotation when Vertical is not selected:

Step optional
text with mark

Select this check box if you want the trailing text to
step along with the mark. Clear this check box if you
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want the text to appear at the same position on all
job signatures, such as for multisection impositions.

For information about the following settings, see Common settings for
SmartMarks on page 141.

● Mark color
● Bring to Front
● Place on every...
● Restrict to section

Fold Mark settings
Edit the mark length, line style, color, and gutter offset. You can also set
a default fold length and optional white knockout on the Marks tab in
the Preferences dialog box. In the workspace, you can select and delete
individual marks when necessary.

Length Type a length for the fold mark.

Note: Set the default length on the Marks tab in the
Preferences dialog box.

Offset This number can be negative.

Style Select the line type (solid, dotted, or dashed).

For information about the following settings, see Common settings for
SmartMarks on page 141.

● Mark color
● Front, Back, Both
● Bring to Front
● Place on every...
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Line Mark settings
Edit the mark length, line style, color, and placement details. You can
also set the default line width on the Marks tab in the Preferences
dialog box.

Note: Set the default line width on the Marks tab in the Preferences dialog box.

Size ● If you select Fixed Length, specify the Length of
the line mark and the Angle (number of degrees)
by which it is to be rotated.

● Select either Vertically centered or Horizontally
centered if you require a straight, centered line
mark of variable length that is automatically sized
to fit the Anchor to selection.

Style Select the line type (solid, dotted, or dashed).

Anchor

For fixed-length line marks, you can select any of the nine points in the
Anchor to diagram, and then specify any vertical and horizontal offsets
to be applied to the selected anchor point.

For variable-length marks, the anchor points are selectable vertical or
horizontal lines, corresponding to the selected Size centered option.

● For vertically centered marks, you can apply a horizontal offset, and
specify how much vertical margin to allow. (Applying a vertical
margin shortens the line mark.)

● For horizontally centered marks, the reverse applies.

Horizontal, Vertical Type the amounts of horizontal and vertical
space to allow between the mark and component
anchor points.

For information about the following settings, see Common settings for
SmartMarks on page 141.

● Mark color
● Anchor to
● Lock mark to this position
● Front, Back, Both
● Mirror on back
● Bring to Front
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● Place on every...
● Restrict to section

Rectangle Mark settings
Edit the mark dimensions, line style, color, and placement details. You
can also set the default dimensions on the Marks tab in the
Preferences dialog box.

Size Select a size type and specify the mark’s fixed or
variable dimensions.

● If you select Fixed, specify the mark’s Width and
Height.

● If you select Height is variable, specify the fixed
Width for a vertical rectangle.

● If you select Width is variable, specify the fixed
Height for a horizontal rectangle.

Note: Set the default dimensions on the Marks tab in the
Preferences dialog box.

Style Select the line type (solid, dotted, or dashed).

Anchor

For fixed-size marks, you can choose any of the nine points in the
Anchor to diagram, and then specify any vertical and horizontal offsets
to be applied to the selected anchor point.

For variable-sized marks, the anchor points are selectable vertical or
horizontal lines, corresponding to the selected Size centered option.

● For variable height marks, you can apply a horizontal offset and
specify how much vertical margin to allow. (Applying a vertical
margin shortens the mark’s height.)

● For variable width marks, the reverse applies.

Horizontal, Vertical Type the amounts of horizontal and vertical
space to allow between the mark and component
anchor points.

For information about the following settings, see Common settings for
SmartMarks on page 141.

● Mark color
● Anchor to, Mark Anchor
● Lock mark to this position
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● Front, Back, Both
● Mirror on back
● Bring to Front
● Place on every...
● Restrict to section
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9 Administration

Profiles and preferences
Configure preference settings that suit your most typical requirements,
and store them in reusable custom profiles.

Profiles for storing default settings
Many default settings are stored in the software’s default profile. You
can store customized settings in additional profiles to reuse for your
most common job types.

You might switch between custom profiles for:

● Jobs that have similar custom requirements
● Jobs that you run regularly
● Settings for printing proofs
● Settings for final output
● Settings for individual prepress operators

The settings in profiles are stored in corresponding text files that have a
CFG file name extension. The Profiles/default folder contains the
default profile (default.cfg), and a new subfolder is automatically
created to store each new profile that you create.

Configuration subfolders and files are portable and can be copied into
any other installation’s Profiles folder. Each CFG file must be in its own
subfolder with the same name.

In a configuration file, each line represents one option that can be either
turned on or off or set to a specific value. Most of these options are
controlled by a dialog box. However, if necessary, advanced users can
edit technical options that are not exposed in a dialog box.

Note: You must start and close the software at least once after it is installed before
you can see the default profile contents in a text editor.The Profiles folder, which
contains the configuration files for both the default profile and your custom
profiles, cannot be shared. Each installation uses only its own Profiles folder.



Setting your preferences
You can set default values for various settings throughout the software.
Define your preferences for the current session, and optionally store
the settings in a profile.

1. Open the Preferences dialog box:

● In Mac OS: Select Preps > Preferences.
● In Microsoft Windows: Select Edit > Preferences.

2. Set preferred values on each tab as needed.

The default values appear in various other areas of the software, where
they are typically editable for a specific purpose, without changing the
stored default values. The default values can be changed only in the
Preferences dialog box.

Next:  You can optionally store various combinations of settings in
custom profiles.

Using custom profiles
Store collections of preference settings in custom profiles, and edit or
switch profiles for specific purposes in a job or between jobs.

You can follow these steps as part of a job or without a job open. If you
want to include print settings, a job must be open.

1. Open the Preferences dialog box:

● In Mac OS: Select Preps > Preferences.
● In Microsoft Windows: Select Edit > Preferences.

2. In the Profile Name list, select a profile, and close the dialog box.

Chose a profile that you want to edit and save, or a profile on which
you want to base a new profile.

The settings in the Preferences dialog box change to match the
stored settings.

3. Edit the settings as needed.

4. In the common area on the Preferences dialog box, click Save
Profile.
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5. Choose a task:

● To save your edits to the currently loaded profile, accept the
displayed name and click OK.

● To save the settings to a new profile, type a name for the profile,
and click OK.

If you saved a new profile, it is added to the Profile Name list, and
its CFG file is placed into a new folder with the same name, within
the Profiles folder.

6. Repeat as needed to edit or create additional profiles.

A profile’s settings remain in effect until the next time that you change
them in the Preferences dialog box.

General Preferences
Specify your preferred values for commonly used settings.

In Mac OS: Select Preps > Preferences > General.

In Microsoft Windows: Select Edit > Preferences > General.

Units The unit type that you select is immediately applied to
all displayed measurement values.

Notes:

● The default measurement unit for all non-English
installations is Millimeter.

● Other selectable units are Centimeter, Inch (English
default), Point, and Pica.

● Picas and points are based on the PostScript standard of
72 points to the inch, not the traditional 72.31 points to the
inch.

● Whenever you type a measurement without including a
unit type, the next time that you view this property, the
default unit will also be displayed.

● If you type a measurement number and follow it with a
unit that is different from the default unit, then the next
time that you view this property, you will see that it was
converted to the default unit. For example, if you type
215.9 mm when the default is inches, it is converted to
8.5 in.

Defaults

Specify the values that will be presented as defaults for these items:

● Default Work Style for press runs
● Default Binding Style for sections
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● Default Stock for press sheets
● Page Width, Page Height for template pages
● Default Bleed Limit for maximum size of bleed margins

Notes:

❐ When an input file specifies bleed margins that are wider than this limit, the
margins are automatically reduced to the limit that you specify here.

❐ If no bleed is specified, the default bleed limit is applied to the placed pages.
(The input file is not affected.)

❐ The bleeds of adjacent pages are automatically adjusted so that they meet in
the middle between the pages, up to the maximum that you specify here.

● Press Sheet Edge to Punch Center for press runs

Input Options

Report modified
input files

Select this check box to see a message when an
input file has changed since the last time that
you saved the job, so that you can update the
run list, if necessary.

Autocenter run list
pages

Select this check box to automatically center all
run-list pages. You can override this on a per-
page basis.

Show dimensions

Select how you prefer to see distance measurements in the workspace
when the Show Dimensions view option is turned on.

● Center to center
● Trim edge to trim edge

Snap

Choose the type of snapping to apply for draggging and dropping pages:

● Trim to trim (default): The trim edges touch, and any inner bleed
margins are automatically removed.

● Bleed to bleed: The inner bleed margins are automatically adjusted
to half their original width.

● Gutters: When you specify the horizontal and vertical distances,
any overlapping bleed margins are automatically adjusted to split
the width equally.

Display

Show Units Select this check box if you want to see the units
in all measurement boxes in the workspace. Clear
this check box if you want only the numeric values.
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Antialias Lines Select this check box to diminish the appearance
of jagged edges in the display. This does not affect
the output.

High Resolution
Preview

● Select this check box for more accurate
previews (144 dpi).

● Clear this check box if you prefer faster
previews (72 dpi).

Default Bleed
Limit

Specify the maximum size of bleed margins. When
an input file specifies bleed margins that are wider
than this limit, the margins are automatically
reduced to the limit that you specify here.

Common Preferences
You can load or save a profile from any tab in the Preferences dialog box.

In Mac OS: Select Preps > Preferences.

In Microsoft Windows: Select Edit > Preferences.

Profile Name Lists the profiles that currently exist in a folder in
the Profiles folder

Save Profile Saves your current settings to a profile. In the
dialog box that appears, you can select a profile
from the Profile Name list, or type a name for the
new profile that is then automatically added to the
Profiles folder.

Language
(Windows only)

Displays all the user interface options in the
selected language

Note: This setting does not change the measurement
unit, which you can set separately.

Files and folders
You work with various job and setup file types, and you must configure
certain folder paths for the software to use.
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File types and folder locations
As a job is processed, a variety of files are used, referenced, created,
and stored, output, or destroyed. Other software-support files store the
configurations and resources that you define.

Tip: For ease of retrieval, be sure to establish and maintain a clear, consistent
approach to file naming and storing.

Job files

● New job files (.job) that you create and save.
● Input files that provide the customer content (.pdf)
● Customer source-document files that you might be required to

convert to Adobe Acrobat PDF input files
● Existing job files (.job) that you might reopen, edit, and save.
● Job files (.job) that are generated by Kodak UpFront® software.
● JDF files (.jdf) that are generated by an MIS or other system
● Job output files (.jdf, .pjtf, .ps, .ppf, .pdf)

Software-support file types

● SmartMark files (individual .smk files and group info.smg files)
● Mark image files (.eps, .tif, or .pdf)
● Template files (.tpl)
● Profile configuration files (.cfg)
● Media configuration and device files (.ppd or .ppx)
● Resource list files (.xml)
● Other file types that are accessed only by the software

Standard file locations

● Whenever the software is unable to find a folder or file that is
needed, a message prompts you to locate it.

● Customer input files, job files, and output files can be stored in any
accessible folder. Network servers can be a Mac OS, Microsoft
Windows, or UNIX-based.

● You can use the Job File Collector utility to collect and store all the
files associated with a job.

● The files that store templates, marks, media, stock, common color,
folios, fold patterns, and web-growth compensation sets must be
stored in the locations that you define on the Folders tab in the
Preferences dialog box.
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● The Migration utility can be used to move software configuration
and resource files from one installation to another.

● The software installation folder structure includes files that are
needed for processing. Do not move or alter these folders unless
instructed to do so.

The difference between a job file and a template file

Each job contains and stores its own layout information in its JOB file,
and you can optionally can save a frequently-repeated job as a
template in a separate TPL file, for quick reuse.

● Template information that is stored in TPL files:

A template can be used to set up predefined press-run layouts for a
job, but it has no permanent association with a JOB file or any
content files. The exception is jobs that were created using legacy
versions of the software, which derive their layouts from specific
referenced TPL files. If you open and edit a legacy job, the
referenced template is updated only if you select Save As Template.

● Template information that is stored in JOB files:

When you save a job, its press-run layout details and content
references are all stored in the JOB file. The job can be reopened and
reprinted with the assurance that nothing has changed since you
last saved it.

Note: When you apply a template resource to a job, the layouts are added to the
JOB file, and the original template is no longer referenced. If you separately edit
and resave the template that you used for this job, the changes are not
automatically applied when you reopen the job. To apply the changes, you must
reapply the template.

Folders and files that can be moved or shared
Instead of storing resource configurations on each computer in a
networked environment, you can keep just one set of shared files where
multiple users can access them.

The same paths can be set on the Folders tab in the Preferences dialog
box of each installation that is to share folders.

The following folders can be shared as a single group:
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Important: These folders must be named as shown, and must all be within the
same parent folder.

● Templates folder: Contains your templates subfolders and files
(TPL). Do not change the name of this folder.

● Marks folder: Contains your mark image files (PDF, EPS). Do not
change the name of this folder.

● Resources folder: Contains the XML files that store your common
colors, folios, and fold patterns. Do not change the name of this folder.

The Marks folder has additional structural requirements:

● Marks\Dupmarks: Contains your duplicating mark image files. Do
not change this folder's name or path.

● Marks\SmartMarks: Contains your SmartMark files (SMK),
including any subfolders that you add. Do not change this folder's
name or path.

● Marks\SmartMarks\MarkGroupName folders: Contain your group
member SMK files and the group info.smg file. These subfolders,
which you can define as needed to create mark groups, must be in
the Marks\SmartMarks folder.

Each of the following folders can be shared from any accessible
location in your network:

● Printers folder: Contains the configuration files and list that define
your media, stock, tile sets, and devices. Do not change the name of
this folder.

Note: If you move this folder, you must restart the software.

● Your compensation sets folder: Contains your web growth scaling
sets. You can give this folder a name of your own choosing.

Notes:

● These files are protected against more than one user applying edits
simultaneously, although multiple copies of a shared file can be open for
viewing. However, this does not protect against someone deleting or moving a
shared file at the operating system level while the file is being edited.

● You can create additional subfolders and move files around inside the standard
folder structure without closing the software.

● Shared items are available immediately from their new locations.
● You can edit, add, or delete files in these folders from any installation of the

software.
● Instead of sharing folders, you can copy the contents of folders between

installations.
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Moving and sharing folders
Set up central folders and configure multiple installations to share the
files.

Using a central Mac OS, Microsoft Windows, or UNIX-based server
ensures that everyone is using the latest revision of a particular file.
Depending on your requirements, you can choose which of the
following steps to implement.

1. Set up shared Templates, Marks, and Resources folders:

Note: These folders are interdependent and cannot be shared individually. The
software must be able to find these folders when it starts.

a. Choose the software installation folder that is to share its
templates, marks, and other resources (common colors, folios,
fold patterns).

b. Prepare the central resource lists by adding any items that need
to be shared, deleting any items that are not needed, and moving
any desired files from other installations to their respective
folders at the central installation.

Note: The correct folder names and structure are important.

c. On the Folders tab in the Preferences dialog box at each
installation that will use these folders, set the new Templates,
Marks, and Resources folders path.

2. Set up a shared Printers folder, and/or move the files from one
installation to another:

a. Create the new Printers folder at any accessible location in your
network, or choose an existing software installation’s Printers
folder.

b. At one of the installations, add any required media, stock, tile
sets, and device PPD files that you want to share or move.

c. Use the Migration tool or manually move the contents of the Print-
ers folder that contains the prepared media resources to the new
folder.

Note: If you manually move the files, be sure to include all the subfolders and
all the files that are at the root of the Printers folder, including the output
resource list files: printers.psm (media), tileset.psm (tile sets), and sheet.xml
(stock).

d. On the Folders tab in the Preferences dialog box at each
installation that will use this folder, set the new Printers folder
path.

e. Restart the software to activate the new location.

Note: The software must be able to find this folder when it starts.

Moving and sharing folders 169



3. Set up a shared compensation sets folder:

a. At one of the installations, prepare the scaling sets that you want
to share.

b. Move the folder that contains the sets to any accessible location
in your network, or share the folder that you prepared.

c. On the Folders tab in the Preferences dialog box at each
installation that will use this folder, set the new Compensation
Sets folder path.

4. Optionally manage the Templates, Marks, Resources, Printers, and
compensation sets folders by deleting any files that will not be used
by the installations.

You can edit, add, or delete files in these folders from any installation of
the software.

Folders Preferences
In Mac OS: Select Preps > Preferences > Folders.

In Microsoft Windows: Select Edit > Preferences > Folders.

Option Description

Temporary Folder Displays the folder that the software uses while processing
files

Templates, Marks,
and Resources
Folder

Specify the parent folder that contains the Templates,
Marks, and Resources folders. You can specify a central
folder for multiple installations.

Printers Folder Specify the folder that stores all the media configuration
and PPD files. You can specify a central folder for multiple
installations.

Output Path Select the default location for output files. This path is
presented by default when you print to a file type.

To retain the last-used output folder as the default for the
next time you print, select the Use last location check box.
The Output Path displays Use last location instead of an
actual path. To cancel, click Select, and set the path to a
fixed location.

Compensation
Sets Path

Specify the folder that stores the web-growth compensation
sets for this installation.
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Managing job notes
Set up the job notes to provide the content for text-mark variables. The
default note types are defined in the media PPD files, and the content
can be manually provided or derived from JDF data. You can also define
new text-mark variables and content for a specific job.

Note: If a job uses multiple media, then the job notes contain the default notes for
each media.

1. Select Job > Job Notes.

2. To add a custom note to the list:

● In Mac OS: Click New Note, and provide the new Type and
Content.

● In Microsoft Windows: Provide the new values in the Type and
Content boxes, and click Add/Modify Note.

You can use literal text and text-mark variables to build a job note.

To define a new variable to use in text marks for this job, when
specifying the type, use the format $VariableName.

Note: Do not insert spaces.

3. To delete a custom job note, select the note, and click Delete Note.

Note: Default note types cannot be deleted. Only their content can be edited.

4. To edit a note, select the note, and edit the Content.

In Windows, click Add/Modify Note.

Any custom note types and content that you create are stored with
that job only.

Checking the current session’s status messages
Review status information about your job activities.

You might need this for JDF import diagnostics or to review software
messages about such details as missing marks.

1. Select Windows > Show/Hide Status Window.

2. Optionally copy the contents to a text file.
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10 Automation support

Automation features are license dependent.

Mark rules for JDF automation and AutoGang
Mark rules define the criteria that determine which SmartMarks are
added when press-run layouts are generated by AutoGang and JDF
automation. Use the Mark Rules Editor to configure the criteria for each
rule that you create, and select the marks and mark groups that are
added by that rule.

Creating a mark rule
Use the Mark Rules Editor to create the rules for adding marks to
autocreated and autoganged layouts.

1. In the Preps\Extras\ folder double-click the  PrepsMarkRulesEditor
file to start the software.

2. In the Mark Rules Editor, locate the software installation folder:

● In Mac OS: Select PrepsMarkRulesEditor > Preferences.
● In Microsoft Windows: Select Tools > Options.

3. On the General tab in the Preferences  dialog box, load the profile to
be used and set the Unit for specifying dimensions in the criteria
settings.

4. In the Preps Mark Rules Editor window, click [+] to add a new rule.

5. Configure the criteria in the rule settings.

It is not necessary to provide a value for each of the settings. For
example, a generic rule to apply crop marks to all autocreated
signatures might contain only the rule name.

6. In the SmartMarks list, choose the marks to be applied by this rule,
and drag them to the Marks to be added list.

7. Click Save Rules.

8. Repeat as needed to set up additional rules.



9. To activate the rules for JDF auto signature creation, enable the Add
SmartMarks based on mark rules option on the JDF tab of the
Preferences dialog box.

● The mark rules are added to an XML file inside the Printers folder.
● For JDF auto signature creation, rules are applied based on the JDF

data’s work style, binding type, front and back colors, and sheet size
(or size range).

● For AutoGang, rules are applied based on the flat work binding style
and specified sheet size in the AutoGang Preset.

● When more than one rule matches a press run, all matching rules
are applied.

Criteria for mark rules
Not all of the possible criteria apply to both the AutoGang and JDF
Auto Signature Creation features.

General criteria

The following settings can be used as criteria by both AutoGang and
JDF automation.

Rule Name Give the rule a descriptive name.

Work Style ● Not specified (Any binding style qualifies
as a match.)

● SheetWise
● Perfector
● Work & Turn
● Work & Tumble
● Single Sided

Binding Type ● Not specified
● Saddle Stitch
● Perfect Bound
● Flatwork (This is the only binding type that

the AutoGang feature uses.)

Sheet Size (Min) W
and H

The dimensions of the smallest press sheet to
which this rule applies

Sheet Size (Max) W
and H

The dimensions of the largest press sheet to
which this rule applies
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Criteria for auto signature creation

The following settings are specific to the auto signature creation (ASC)
feature.

Press Name For your reference only, describe the press that is
represented in the MIS software by the Device ID. The
software doesn’t use this information.

Device ID Device ID that the MIS software assigns to this device.
If no device is specified, then all devices are considered.

Device ID

Front Colors

Number of colors on the front side of the job that are
described in the JDF file

Back Colors Number of colors on the back side of the job that are
described in the JDF file

JDF automation
The open-standard job definition format (JDF) is used by JDF-
compliant systems to communicate data and automatically trigger
specific job tasks. Experienced users with JDF training can set up
profiles for varying degrees of job automation, and they can manually
intervene in automation jobs when needed.

JDF jobs
In a JDF workflow, the management information system (MIS) sends
you a JDF file that represents the job ticket and specifies the imposition
requirements in its stripping data. Incoming JDF files can contain
enough product intent to autogenerate the Press Runs List via template-
signature matching or creation, and you can add or edit details as
needed.

The currently loaded profile determines the type of automation that is
applied when a JDF file is opened, based on the JDF tab settings in the
Preferences dialog box.

When you open an MIS JDF file, the software immediately examines
the JDF data (stripping parameters) and attempts to resolve the
requirements using a specific sequence, depending on the profile.

Manually matching the source JDF values

You can manually edit the product intent to match the JDF values when:
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● The profile is configured for matching only, and no suitable template
is found.

● The profile is configured for signature matching or creation, and the
JDF data is not complete.

● The original intent needs to be updated with late change requests.

When the product intent is fully defined, you can generate the Press
Runs List.

When structural changes are needed

When necessary, you can make structural changes, such as to
accommodate an increased page count. Before proceeding, determine
whether the customer service representive will send you new or
updated JDF data to replace this job, or whether you will change the job
manually.

You can manually specify the new product intent in the Assembly view,
and create the additional press-run layout in the Press Runs view.
Although the printed result might be correct, the new press run will
have no association with the original JDF stripping parameters, and the
JDF output will contain an apparently unrequested press run.

Tips for optimal results

The JDF data that you receive can vary in structure and content
between MIS systems and jobs. Even when the data is very
comprehensive, mismatched properties can result if the profile requires
several mandatory criteria, with a low tolerance for differences.

And even if the JDF data and the profile both have minimal
requirements and the press-run layouts are easily autogenerated, the
impositions might not be suitable. In that case, you might need to
compare the JDF values of nonmandatory settings with the
autoselected values, and then manually edit the settings to match more
of the JDF values.

Here are some suggestions for achieving better results:

● Store suitable JDF settings in custom profiles, so that the generated
impositions will be compliant with downstream systems.

● Configure additional profiles, and switch between them as needed.
● For auto signature matching, maintain a well-organized collection of

layout resources (templates).
● For more accurate matching, create a profile that uses all or most of

the Matching Criteria and a fairly strict Match Tolerance.
● For easier matching (with the risk of unsuitable results), use fewer

Matching Criteria and a more lenient Match Tolerance.
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Completing a JDF job
After opening a JDF file, you can check the autogenerated layouts,
compare the current settings alongside the source JDF values, and
make any necessary adjustments before you print the output.

Note: For auto signature creation, define the mark rules that will add the correct
marks to the autogenerated layouts.

Implement any of these steps that apply to your situation, based on
your awareness of the type of JDF data that you receive from your MIS.

For example, if the JDF data is consistently well defined, you might
proceed to print the generated press-run layouts, with or without first
checking the results.

1. In the Preferences dialog box, load a suitable profile or set options
as needed on the JDF tab.

a. Choose the automation type:

● For auto signature creation (ASC) only, select Create Only.
● For auto signature matching (ASM) only, select Match only.
● For the most flexible automation, select Match then create

(ASM/C).
b. Select the matching criteria that are mandatory, and set the

Match Tolerance level.

2. Select File > Open, and locate and open the JDF file.

The job notes are updated with the JDF file name, descriptive name,
and MIS job ID, if provided. The run list is populated with PDF pages
if the JDF includes a reference to the input files; otherwise, blank
pages fill the specified page count.

The results and your next actions depend on the JDF data contents
and the profile settings.

Depending on the configured auto generation type, the software
tries to resolve the requirements in the following sequence:
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If the JDF data contains: For: The software: Typical next steps

A reference to a valid
template that is in the
Templates folder

ASM, ASC,
ASM/C

Ignores the profile settings, and
generates the assembly and press runs
based on the referenced template

Check the generated
press runs in the Press
Runs view, and make any
necessary adjustments
before printing.

Sufficient stripping data,
no template reference

ASM Based on the Matching Criteria, tries
to match the mandatory JDF values to
the values in an existing template
(within the profile’s Match Tolerance
limit) and if successful, generates the
assembly and press runs based on the
template

Check the generated
press runs in the Press
Runs view, compare the
JDF values and settings in
the Properties pane, and
make any necessary
adjustments before
printing.

If ASM was unsuccessful,
you can manually
complete the job.

ASM/C Based on the Matching Criteria, tries
to match the mandatory JDF values to
the values in an existing template
(within the profile’s Match Tolerance
limit) and if unsuccessful, generates the
assembly and press runs based on the
template

ASC Applies the JDF values to the intent
properties, and generates the assembly
and press runs

Insufficient stripping data ASM, ASC,
ASM/C

Highlights the missing properties and
generates a minimal assembly or no
assembly

Obtain the missing
customer requirements
for the product intent,
update the properties,
and generate and check
the press runs before
printing.

3. In the Assembly view, check the generated product assembly and
intent settings:

a. In the workspace, review the product structure that was derived
from the JDF data.

b. In the Properties pane, expand the Source JDF Values column.
c. For each product, part, and section one at a time, compare the

current property settings with the source JDF values, and edit or
complete the settings as needed.

The Properties pane highlights any mandatory settings that are
not within the profile's defined JDF Match Tolerance level for its
Matching Criteria selections. You can edit or specify values for
mandatory and non-mandatory settings.
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Note: Skip the next step if the press runs were already autogenerated and no
edits are required.

4. Click Generate Press Runs.
If the press-run layouts are successfully generated, the view
switches to the Press Runs view. If they fail to be generated, you can
edit the settings and try again, or switch to Press Runs view and
manually complete the job.

5. In the Press Runs view, check the autogenerated press-run layouts
and make any changes needed for production, such as to change the
stock selection.

Any autogenerated, duplicated, or copy-and-pasted press runs with
the same layout and stock are automatically linked.

6. Print the output.

JDF Preferences
Use the JDF tab in the Preferences dialog box to define how the
software automates JDF-based jobs, and optionally save the settings in
a custom profile.

In Mac OS: Select Preps > Preferences > JDF.

In Microsoft Windows: Select Edit > Preferences > JDF.

Signature Creation

Choose the automation method used to build the Press Runs List:

Match only Always attempt to build the Press Runs List by
matching the requirements to existing template
signatures, and never automatically create press-
run layouts. This is also known as auto signature
matching (ASM).

Create only Always build the Press Runs List by autocreating
the layouts; ignore any templates that are in the
Templates folder. This is also known as auto
signature creation (ASC).

Match then
create

Always build the Press Runs List by first mtaching
the requirements to existing template signatures
(ASC), and create a press-run layout only when
unable to find a match (ASC).

Matching Criteria

Choose the characteristics that will be used as criteria for matching:
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● Check sheet size
● Check work style
● Check head and foot trim
● Check fold pattern: When autogenerating signatures, matches the

specified fold pattern number, as defined in the CIP4 JDF Fold Catalog.
● Check fold orientation: When autogenerating signatures, matches

the specified JDF rotate and flip coordinates. The bindery uses this
information to transform the production signature as it comes off
the press to its final product orientation.

Match Tolerance Decrease this tolerance to a stricter level for more
precise matching, or increase it to a more lenient
level to increase the likelihood of successful
matching.

Signature Creation Marks

Add SmartMarks
based on mark rules

Select this check box when you are ready to
activate your mark rules.

Add JDF error marks Clear this check box to suppress error
messages in text marks, which can appear
when the JDF geometry specifications include
incomplete or inconsistent information. If this
check box is selected, you can manually delete
the error marks.

Error Mark Tolerance If Add JDF error marks is selected, set the
tolerance level to allow before adding the error
mark.

JDF Output

Format the output
based on this
specification

● JDF version 1.2 (software default)
● JDF version 1.3
● JDF version 1.4

Use relative paths for
marks

If selected, formats the URL for the location
of the marks as a path that is relative to the
location of the JDF output file.

Use relative paths for
input files

If selected, formats the URL for the location
of the content input files as a path that is
relative to the current location of the JDF file.
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JDF output
You can print JDF output from any job, including jobs that were not
based on MIS JDF data. You can save a JDF-based job as a regular JOB
file, and you can also print it to any of the supported output types.

JDF output files contain all the information needed to re-open and
automatically reconstruct the job, for example, if a job needs to be re-
plated. This is referred to as JDF roundtripping.

JDF output can be generated from any job, including jobs that were not
started from JDF data. Other features of JDF output include:

● Color mapping and web-growth compensation are supported and
can be configured in the Print dialog box.

● In the Print dialog box, you can export CIP3 cutting data by either
embedding it inside the JDF output file or by printing the job twice:
once to JDF, and once to PPF. Your method depends on the
postpress system capabilities.

● If the MIS JDF includes CIP4 folding data for setting up CIP4-
compliant folding equipment, it is passed through in the JDF output.

AutoGang
The AutoGang feature makes intelligent decisions to determine which
PDF pages constitute a complete flat-work product. It chooses the best
positions for pages on the press sheets, based on the settings and
priorities that you assign. You can review and adjust the results as
needed.

Creating an AutoGang preset
AutoGang presets apply specific settings and optimization priorities.

Note: The default profile and any custom profiles all share the same AutoGang
presets, which are stored in a special configuration file called Autoganging.cfg.

1. Select Resources > AutoGang Presets.

2. To add a new AutoGang preset, click [+], or select a preset and click
[+] to add a duplicate.

3. Specify a name, and choose the media and stock that this preset will
apply .
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4. Specify the margins that will determine the dimensions of the
imageable area on the sheet.

5. Choose the work style.

If you select a two-sided work style, products will be autoganged in
front-and-back content page pairs.

6. Set the default gap limit between pages.

Any bleed margins that are wider than this limit will be adjusted to
fit this space.

7. Choose whether AutoGang should optimize for digital printing (zero
makeready), offset printing (default makeready), or print cost
(actual calculated make ready).

If you choose to optimize for cost, you must enter the total costs for
press runs for quantities of 500 sheets and 1000 sheets (including
all costs that you want considered in the calculations).

Note: The default offset printing option adds 200 sheets to the run length quantity
as an approximation of makeready time and materials, or waste per press run.

8. Specify the step direction for the autoganged layout of multiple-up
products on a press run.

Note: This can depend on whether an automatic or manual cutter is used.

● Choose a specific direction if the items must be adjacent, to form
blocks with either horizontal or vertical cut lines.

● If a specific direction is not required, allow the software to
calculate the layouts based on cut efficiency.

This can result in horizontal or vertical cut lines on a layout, or both.

9. If you choose cut efficiency, use the slider to indicate whether the
autocalculation should make a quick decision or take more time to
create a more efficient layout.

10. If products or cut blocks may be rotated for the best fit, select the
Allow Rotation check box, or clear it to prevent rotation.

11. (Skip this step if you are not using AutoGang hot folders in a
Prinergy workflow.) Choose whether files are to be autoganged on a
first in, first out basis.

If selected, the file that was in the hot folder for the longest time is
included in the autoganged layout. Oher files might also be included,
depending on your optimization and step direction choices.

12. To create a new preset based on these settings, click Save as Preset.

Generating the AutoGang press runs

1. Set up the AutoGang tab in the Preferences dialog box.
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2. Use the Mark Rules Editor to configure rules for automatically
adding marks to the generated press runs.

3. Set up the Files list.

4. Click the AutoGang tool to generate the job’s AutoGang list.
All Files list pages are automatically added to the job’s AutoGang
list. Each single-sided page or two-sided page pair is considered to
be one flat-work product, and each row displays information about
one flat-work product.

5. Review and adjust the list as needed:
What you can do Description

Select the
AutoGang
preset

Accept, change, or edit the AutoGang Preset selection
as needed for this job.

Check front and
back page pairs

When the selected preset uses a two-sided work style,
the pages are autopaired in front and back page
positions. Each even-numbered page is assigned to the
back of its preceding odd-numbered page.

Tip: You can change the way a product is paired by dragging a
product row to anywhere else in the list to create two new
products with content on the front only. Dragging one of
these rows onto another blank-backed product replaces its
blank back with the dragged content.

Select products
for ganging

Select the check boxes to include the products in this
ganging session. Products with cleared check boxes will
be ignored.

Set the
quantities

Use one of these methods:

Note: It does not matter if the check box is selected or cleared.

● Double-click in the Quantity column, type a new
value, and tab to the next row.

● Select multiple products that require the same
quantity by clicking on the front page names, (not
the check boxes), click Set Quantity, and type the
value.

6. To generate the layouts for the selected products, click Gang.

7. Review and adjust the results as needed.

The number of generated press runs depends on the job size and
the settings in the Preferences dialog box. The generated press run
names are appended with the press run lengths.

8. Save the job and print the output.
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AutoGang Preferences

In Mac OS: Select Preps  > Preferences > AutoGang.

In Microsoft Windows: Select Edit > Preferences > AutoGang.

Replace current
sheet(s)

Select or clear the check box, depending on
whether existing press-run layouts are to be
replaced or retained.

Note: If this check box is cleared, the default press run
that is available in every new job must be manually
deleted.

Press Sheet
Generation

Use the check boxes to specify whether to
generate all the layouts for the entire AutoGang
list.

Tip: Clear the Replace current sheet(s) check box,
generate first best sheets for different combinations of
settings, and compare the results before generating all
the layouts with the Create multiple sheets option.

Create multiple
sheets (for selected
products)

Generates press runs to lay out all the
AutoGang products

Create first best
sheet

Autoselects products and generates only the
best possible ganged layout, based on the
current settings. Any products that do not fit are
not placed.

AutoGang hot folders for Prinergy systems
The AutoGang feature includes a hot folder capability to fully automate
job ganging for a Kodak Prinergy workflow system. You can set up as
many AutoGang presets as needed to associate with the hot folders
that you create.

Setting the root hot folder
After you specify a root hot folder location locally or on a server, Preps
watches the hot folders for input files, generates layouts based on a hot
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folder’s associated AutoGang presets, and places the output files in the
specified folder locations.

All AutoGang hot folders must reside within the same root folder
location, which is used by all profiles.

On the AutoGang tab in the Preferences dialog box, click Select,
and locate the root hot folder that will contain all the individual hot
folders that you create on either your computer or on a server in
your network.

Click New Folder as needed if the folder does not yet exist.

Tip: For network locations, use the SMB protocol to connect to the server.

Setting up an AutoGang hot folder
You can set up as many AutoGang hot folders as needed for your
operations, with one or more quantity-based folders per hot folder.

Adding PDF input files to a quantity-based folder automatically sets the
number of copies to be printed. Each hot folder scans and prints the
contents of its quantity folders according to the schedule that you set
up. You also specify the AutoGang preset to be used by each hot folder,
as well as the output file type and the folders where the job, product,
and output files are automatically placed when the job is finished.

New hot folders that you set up following this procedure are
automatically created inside the Root Hot Folder path that you define
in the Preferences dialog box.

1. From within the Kodak Prinergy Workshop software, open the Preps
software.

2. Expand the AutoGang resource pane to display the categorized hot
folders that are currently defined in the AutoGang resource list.

This list initially contains no hot folders. As you configure and add
hot folders to the AutoGang resource list, they are automatically
listed under either the Manual print or Automatic print category,
depending on your hot folder settings.

3. To create and configure a new hot folder, click [+].

4. At the top of the settings dialog box that appears, give your new hot
folder a descriptive name.

Tip: Keep in mind that Mac OS file names are limited to a total of 32 characters.
The date and time of printing are automatically added to AutoGang output file
names, which leaves only up to 13 characters for the hot folder name portion,
depending on the file name extension.
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5. Choose the AutoGang Preset that this hot folder uses.

6. In the Scan every box, specify how frequently (number of minutes)
the software should scan the hot folder for new files.

7. In the Quantity Folders area, type a value for each quantity-based
subfolder that this hot folder requires.

Optionally click [+] to add more quantity folders, if needed.

8. In the Print Options area, select the Output Type that this hot
folder generates: JDF, PJTF, or PDF.

9. Specify where this hot folder places each type of generated file
when it completes a job.
This folder location: Collects these files types:

Output ganged layout
to

The generated JDF, PJTF, or PDF output files

Move product files to The PDF input files that have been ganged

Output Preps .job files
to

The automatically saved Preps job files

Check box Output PPF
to

Select this check box if Print Production Format
(PPF) output files are also to be generated.

You can then locate the folder where PPF files
are to be placed.

You can add new folders to collect these files in any accessible
location or various locations in the network. Give the folders names
that are meaningful for your purposes.

10. Choose a print option, depending on whether you want to preview
the layouts:
Choose this
option:

To do this:

Manual Print Preview each generated layout, and make any
adjustments needed. When you are satisfied with the
layouts, manually print the output.

For manual printing, there are no further settings to
specify.

Automatic Print Save the job and generate the autoganged layouts
automatically, with no manual intervention. Selecting
this option activates additional options.

Your choice determines the category under which this hot folder
appears in the AutoGang resource list.

Note: Jobs created via hot folder cannot be manually saved, to be consistent with
the automated hot-folder file management.
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11. For automatic printing only, set the schedule for automatically
generating the output when sheet utilization is above the minimum
percentage that you specify.

You can choose to print the output immediately, every specified
number of hours, at a specific time each weekday (Monday to
Friday), or at a specific time every day (Monday to Sunday).

Printing takes place when your specified sheet utilization percentage
is reached, and the files are then placed in the folders that you defined.

12. Click OK, and verify that the new hot folder appears in the
AutoGang resource list.

13. To refresh the hot folder AutoGang list, click Rescan.

Tip: Double-clicking a hot folder in the AutoGang list will pause the hot folder and
change the appearance of the icon, until you double-click it again to make it active.

Autoganging a job for Prinergy

1. Place the PDF input files into a suitable quantity-based folder within
an AutoGang hot folder.

Note: Input files must be either single-page PDF files (for single-sided work style)
or two-page PDF files (two-sided work style). Files with more than two pages (or
more than one in a single-sided hot folder) are moved to the error folder, because
parts of a file cannot be ganged independently.

2. If this is a manual print job, open the Preps software from within the
Prinergy Workshop software, and check the generated layouts
before saving and printing the job.

3. For the first few autogang jobs that you run, you might want to
verify that the output files were generated and placed in the
configured folder locations.

The output file names automatically include date, time, and hot
folder name, in this format:

YYMMDDHHmm_nn_<HotFolderName>, where nn represents the
incremented file ID number.

Note: You cannot currently change the way that output files are named.

4. For information about processing the final output in Prinergy, see
the Prinergy documentation.
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11 Shortcuts

User interface viewing tools
Click the arrows and stretch the dividers to fit the window panes to your
needs.

1 Click a triangle to expand or collapse a list tree .

2 Drag a divider to stretch or shrink a pane.

3 Expand a pane to hide the adjacent panes.

4 Click a tab to switch views.

5 Click the triangle to reverse a column's sort order.

6 Drag the column edges to adjust their widths.

7 Drag the column headers to rearrange the columns.

8 Stretch or shrink a column.



Menu shortcuts (Windows)

To do this: First: Then press these keys:

* Select all objects Select an object Ctrl A

* Select all same-type
objects

Select nothing Ctrl A

Locate and add files Open or start a job Alt+Ctrl A

Duplicate or step and
repeat

Select an object Ctrl D

* Flip the sheet Set up a press sheet Ctrl F

* Group Select pages Ctrl G

* Ungroup Select a page group Shift +Ctrl G

* Lock Select an object Ctrl L

* Unlock Select a locked object Shift +Ctrl L

Create imposition dialog
box

Ctrl M

Start a new job Save current job Ctrl N

Locate and open a job Ctrl O

Open the Print dialog box Ctrl P

Close the software Ctrl Q

Save this job Ctrl S

Save this job as... Shift +Ctrl S

* Add a new press run Ctrl T

* Duplicate this press run Select a press run Shift +Ctrl T
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To do this: First: Then press these keys:

Paste Select an object Ctrl V

Close this job Save current job Ctrl W

Cut Select an object Ctrl X

Undo (if undoable) Ctrl Z

Redo Shift +Ctrl Z

Expand a resource pane:

* Media list Ctrl 1

* Stock list Ctrl 2

* Marks list Ctrl 3

* Layouts pane Ctrl 4

* AutoGang pane Ctrl 5

Zoom:

*Zoom in/out Select an object Ctrl plus (+) / minus (-)

Fit in window Ctrl 0

* View at actual
dimensions

Select an object Alt+Ctrl 0

Align objects:

Align left Select an object Shift

Align top Select an object Shift

Align right Select an object Shift

Align bottom Select an object Shift

* Indicates a specialized command key sequence for this software. All
other commands are standard to the operating system.
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Menu shortcuts (Mac OS)
Keyboard symbols:

● Command 
● Shift 
● Option 

● Control 

To do this: First: Then press these keys:

* Select all same-type
objects

Select an object A

* Select all objects A

Locate and add files Open or start a job ^+ A

Duplicate or step and
repeat

Select an object D

* Flip the sheet Display a press sheet or
web

F

* Group Select pages G

* Ungroup Select a page group + G

* Lock Select an object L

* Unlock Select a locked object + L

Minimize M

Start a new job Save current job N

Locate and open a job O

Open the Print dialog box P

Close the software Q
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To do this: First: Then press these keys:

Save this job S

Save this job as... + S

* Add a new press run T

* Duplicate this press run Select a press run + T

Paste V

Close this job Save current job W

Cut Select an object X

Undo (if undoable) Z

Redo + Z

Expand a resource pane:

* Media list 1

* Stock list 2

* Marks list 3

* Layouts pane 4

* AutoGang pane 5

Zoom:

*Zoom in/out Select an object plus (+) / minus (-)

Fit in window 0

* View at actual
dimensions Select an object + 0
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Align objects:

Align left Select an object

Align top Select an object

Align right Select an object

Align bottom Select an object

Changing the order of overlapping objects

Bring to front Select an object + ]

Bring forward Select an object ]

Send backward Select an object + [

Send to back Select an object [

Other keyboard shortcuts

Preferences dialog box , (comma)

Help (user guide and other information) ?

* Display next sheet + >

* Display previous sheet + <

* Indicates a specialized command key sequence for this software. All
other commands are standard to the operating system.

Other shortcuts
This table summarizes various other shortcuts that use the keyboard,
the mouse, or both.

Note: In these shortcuts a plus sign is used to mean the word and—it does not
mean to press the plus (+) key.
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To achieve this: Use this shortcut: Description

Viewing and selecting items

Select an imposition page within a
page grtid

Use the Page Select tool, and click
the page

Select multiple pages or marks Shift + click the items, or drag a
marquee around them

Allows you to click multiple pages
or marks, or drag a marquee around
them to select them all

Select a fold mark Mac OS: Option + Shift + click

Windows: Alt + click

Allows you to view and edit the fold
mark properties

Zoom in and out Roll the mouse wheel Increases or decreases the zoom as
you roll the mouse wheel

Pan your current view Spacebar + drag an object in the
workspace

Moves the press sheet in the same
way as the Pan tool

Editing

Edit a layout’s page properties Select a page in the workspace Activates the editable text boxes in
the workspace, depending on the
current View menu selections, and
displays the Content Page and
Template Page settings in the
Properties pane

Edit a layout’s mark Double-click a mark in the workspace Displays the selected mark’s
settings in the Properties pane

Edit a reusable media, stock, or
mark resource

Right-click the item in the
corresponding list in the Resources
pane

Displays a context menu from which
you can choose Edit

Edit a press-run section’s trims In the workspace, select the section Activates the editable text boxes in
the workspace, depending on the
current View menu selections, and
displays its settings in the
Properties pane

Edit a product section From any view, select the section in
the Products list.

Displays its settings in the
Properties pane

Edit an imposition on a layout Double-click the imposition Displays the Edit Imposition dialog
box
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Editing

Edit a product or product part From any view, select the product or
part in the Products list.

Displays its settings in the
Properties pane. Structural edits of
multipart products can be made
only in the Assembly view, such as
changing the page count

Edit content trim boxes Select the page in the Pages List Displays the page and trim boxes in
the Preview pane (depending on
View menu settings) and its run-list
page settings in the Properties pane

Edit a press run’s settings Select the press run in the Press
Runs List

Displays its settings in the
Properties pane. You can also edit
certain settings directly in the list
row.

Edit gutters in a layout In the workspace, select the press-
run section

Displays its editable gutter or trim
text boxes in the workspace and
Properties pane

Edit a media’s punch location In the Media list, right-click the
media, select Edit, and in the Media
Configuration dialog box, click
Punch Location.

Displays the Punch Location dialog
box

Edit a layout’s distance beween the
sheet edge and the media punch

In the workspace, select the stock. Displays its settings in the
Properties pane, including the
editable Punch Distance

Moving items

Move a page along its axis Shift + drag a page Moves a page to a position that is
on either the X or Y axis of its
original position. If you move the
page diagonally, it snaps to its
nearest original axis.

Nudge an item Select the item and use the arrow
keys

Moves the selected, unlocked page
or mark in the direction of the arrow

Override the snap behavior Mac OS: Command + drag

Windows: Ctrl +drag

Drags the selected page without
regard to snap settings. When you
release the mouse, the page
remains exactly where it is instead
of snapping to the nearest available
grid line.
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Replacing items

Replace a content page in a layout Drag new page over old page until
recycle symbol appears, then drop.

Replaces that page and any other
page on the press sheet that has the
same template number. Retains the
original template page properties
for each replaced page.

Replace content on only one of
multiple same-numbered template
pages

Mac OS: Option + drag

Windows: Alt + drag

Replaces only the page with a
recycling symbol on it, even if it is in
a group. Does not affect any other
pages with the same template page
number. Assigns the next available
template page number to the new
page. Works only for pages dragged
from the file list.

Replace a stock or media in a layout Double-click the new item in the
Stock or Media list

Replaces without removing any
placed pages

Replace a press-run layout Double-click the new template
signature in the Templates list

Removes any placed pages and
replaces the existing layout
resources in the workspace

Replace selected file list placeholder
with content

Job  > Replace File Placeholder Replaces the file placeholder with
content. If the new file is larger or
smaller than the placeholder, a
message asks you what to do with
the extra pages in the larger file.

Creating duplicates

Duplicate a selected page once Mac OS: Option + drag

Windows: Alt + drag

Places a copy of the original page,
with content, where you release the
mouse

Duplicate a selected page via step
and repeat

Mac OS: Command + D

Windows: Ctrl + D

Displays a dialog box with the step-
and-repeat options

Duplicate a selected press run Mac OS: Command + D

Windows: Ctrl + D

Adds and selects the duplicated
press-run layout, without content

Copy a selected press run or ganged
page

Mac OS: Command + C, Command
+ V

Windows: Ctrl + C, Ctrl + V

Inserts a copy of the press run or
places a copy of the page where you
release the mouse, with content
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Deleting pages

Delete the entire selected page from
a layout

Press Delete. Deletes the selected template page
and its content. This does not affect
the Files list.

Remove only the content from a
selected page on a layout

Mac OS: Option + Delete

Windows: Alt + Delete

Removes only the selected content
page and not its template page. If
used on a page group, removes all
the content pages and retains the
template pages.
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12 For more information
and software updates

Several sources of additional information and software downloads are
available.

The documentation that is installed with a new software release is
written in advance to allow time for translation. Updated information is
posted online as it becomes available.

● Troubleshooting information: Search for knowledgebase articles on
the Kodak eCentral® Internet portal at https://ecentral.kodak.com/.

● Software updates, utilities, and release notes: For up-to-date
software and release-specific documentation, go to http://
graphics.kodak.com/ and select Products > Unified Workflow >
Production > Production Planning > PREPS Software.

Note: The knowledgebase and some software downloads require an eCentral user
account, which is free.
● Related documentation: Additional guides and technical bulletins are

available on the software DVD or http://graphics.kodak.com/.
● Online forums: To find or share information and ideas, see the Kodak

Graphic User Association forums at http://www.mygua.org/forums/.

http://ecentral.graphics.kodak.com/
http://graphics.kodak.com/
http://graphics.kodak.com/
http://graphics.kodak.com/
http://www.mygua.org/forums/
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Index
A

Acrobat software settings 15
actual colors 23
adding

device PPDs 52, 120
files to the Files list 14
mark resources 53, 136
media 52, 120
pages 92
pages to a layout 30
pages to a run list 18
parts 92
products 91
stock resources 53

alignment 124
anchors 133
ASC 175
Asian text marks 153
ASM 175
assembly 68, 89–92, 96, 100
Assembly 97
Assembly view 95
Auto Select 65, 73
auto signature creation 175, 177
AutoGang 9, 173, 181, 182, 184, 185
automation 9, 175, 177

JDF 9

B

bar codes 145
basic steps 8
binding styles 67, 92
blank pages 18, 23
bleed margins 21
bleeds 35, 79

for bottled pages 79
bottling 35, 79

with bleed margins 79

C

center marks 133
center sheet marks 139
central folders 129, 167, 169
CFG files 161
CIP3 104
CIP3 cutting data 109, 181
CIP4 folding data 181
CJK

text marks 153
collation marks 155
color bars 148

color mapping 109, 111
color separations 110–112
colors 23, 37, 110, 143
combining sections 92
come and go 67
comment text mark 107
common colors 37
common folios 37
common resources 37
compensation sets 116, 117
Compensation Sets folder 169
configuration files 161
Connection dialog box 125
content pages 14, 18, 32, 85

replacing 85
context menus 7
conversion percentages 38
converting to a multiweb press run 55
Create Imposition dialog box 73
creating

jobs 9
jobs with product intent 91
mark groups 53, 136
mark resources 53, 136
run lists 18

creep 35, 80
crop marks 139, 154

restoring 139
selecting 139

custom marks 144, 146, 147
custom media sizes 127, 128
Custom Size dialog box 128
customer content 14
cut and stack 67
cutting data 109

D
default.cfg file 161
deleting

crop marks 139
fold marks 139
marks 137
versus removing 7

device configurations
. See media

device size
. See media size

devices 43, 52, 119, 120, 124, 126, 129, 130
See also media

dimensions 63
direct template reference 175
displaying properties 7
distances 63



divided output 104, 109
documentation 199
double dash 7
double-clicking 7
dragging 7, 95
Duplicate dialog box 85
duplicating 148
duplicating marks 144, 148

E

emulsion side down 109
external imposition template 175

F

features 1
files 20, 133, 144, 166

categories 166
SmartMarks 133

Files list 14, 15
flat identifier 152
flat work 82
fold marks 139, 157

selecting 139
fold patterns 45–47, 49, 70, 71
folders 129, 161, 166, 167, 169

Printers 129
profiles 161

folios 23, 37
fonts 139
forums 199

G

ganged layouts 83
ganged pages 88
ganging 9, 82, 85, 181

manual 9
gaps 63
Generate Press Runs button 96
Generic PostScript Printer 119
grouping 85
gutters 63, 85

H

hot folder 185
hot folders 184, 185
HTML files 104

I

impositions
gutter-based 73

Increment tool 23
independent pages 82

input files 14, 15
intent 91

J

JDF 104, 171, 173, 175, 177, 179
JDF output 181
job files 79, 137
JOB files 11, 166
job logs 131
job notes 171
job signature

. See press run
jobs 8, 9, 177

K

keyboard commands 190
knockout 139
KO

. See knockout

L

Layout pane 61
layouts 28, 43, 45, 51, 70, 79, 104, 137
Layouts search 71
license types 1
licensing 1
line marks 158
linking 55, 73
loading profiles 162
locking 63, 85, 138

marks 138
log files 131
low-folio page position 46

M

manual
ganging 9

JDF
automation 9

margins 63
Mark Color dialog box 143
mark groups 53, 136, 139
mark image files 146
mark rules 173, 174
marks 53, 79, 127, 133, 135–139, 141, 144–148, 152–155,

157–159
adding 53, 136
CJK text 153
collation 155
copying 138
custom 146, 147
duplicating 148



duplicating marks 148
editing 138
fold 157
groups 139
line 158
locking 138
overlapping 135
static 136

Marks folder 169
Marks list 53, 136
media 45, 52, 78, 107, 119, 120, 123, 124, 126–130

tiling 120
Media Configuration dialog box 124
Media list 52, 120, 124
moving 7
multiple media 107
multiple sections 75

O

orientation
template pages 33

output 10, 103, 104, 110, 181
output types 107
overlapping

marks 135

P

page groups 85
page size

. See media size
pages 13, 17, 20, 21, 26, 28–31, 37, 38, 54, 73, 83, 85, 181

adding to a layout 30
ganged 83, 85

Pages List 18, 23
partial output 109
parts 18, 89, 92, 96, 99
PDF 104
PDF files 14
PDF input files

creating in source software 15
perfect bound 67
perfector work style 57
placeholders 14, 18, 20, 23
planned colors 23, 37
plate bend 127
PostScript marks 104
PostScript Printer Description (PPD) file 129
PPD Browser 130
PPD files 52, 119, 120, 129, 130
PPF 104
PPF output 181
PPX files 129
preferences 165
Preferences 104, 139, 161–163, 179, 184

General 163

Output 104
presets 181
press runs 22, 30, 31, 43, 45, 54, 55, 65, 73, 75–77, 96,

182
multiple sections 75

press sheet edge to punch center
. See punch distance

Press Sheet Size media 52, 119, 120
press sheets

stock size 53
press-run layouts 29
press-run sections 44, 68, 89
Preview pane 21
previewing 17
Prinergy 184, 185
Print dialog box 107, 112
Printers folder 119, 129, 169
printing 10, 103, 104, 107, 110, 112, 114, 115, 125, 161

web growth 115
process build 111
product intent 89
Product Intent dialog box 89, 91
product sections 44, 89, 92, 100
products 89, 91, 98
Products pane 89, 96
profiles 104, 161, 162, 165, 179
properties 7, 26, 32, 33, 35, 65, 68, 96, 98–100

content page 32
displaying 7
parts 99
press runs 65
product 98
product section 68, 100
template pages 33, 35

Properties pane 89, 91
PS output 104
punch 124
punch distance 65
punch marks 104
punches 126, 127
pushout

. See creep

R

rearranging
sections 92

rectangle marks 159
reference 199
reference points 133
Repeat tool 23
replacing 85

content pages 85
reports 104
resources 37, 45, 47, 51–53, 119, 120, 124, 136

common folios 37
fold pattern 47



marks 53, 136
media 52, 119, 120, 124
stock 53

Resources folder 169
rotating 85
rotation 21
run length 55
run list 23, 26, 30
run lists 17, 18, 21

S

saddle stitched 67
saving 11
scaling 38, 80, 104

for creep 80
scaling sets 113, 114, 116, 117
script 152
searching 70, 71
sections 44, 55, 68, 75, 92, 96, 100

multiple 75
sections terminology 89
Select a Fold Pattern dialog box 49
selecting 7, 139

crop marks 139
fold marks 139

setback 127
shared folders 167, 169
sheet marks 139
sheetfed press runs 77
sheets 77
sheetwise work style 57
shingling 35, 80, 104
shortcuts 190
side guides 133, 139
single-sided work style 57
SmartMarks 133, 136, 139, 141

See also marks
SMK files 133
software 1, 199

updates 199
source files 14
source software for PDF files 15
split files 109

See also divided output
splitting sections 92
spot colors 111
spreads 80
SSiCustomColor 143
static marks 136
Status window 171
step and repeat 84, 85
stock 45, 53, 78, 124

adding 53
alignment 124

Stock list 53
stripping parameters 175

summary
creating different job types 9
of tips 7

T

template pages 33, 35
templates 11, 45, 51, 73, 166
Templates folder 169
terminology 13, 63, 89

sections 89
text marks 139, 150, 152, 171
text-mark variables 107
tile sets 120
tiling 120
tools 3, 61, 189
TPL files 166
trim boxes 21
trims 63
troubleshooting 171, 199

U

Unlink tool 73
user interface 3

V

variables 150, 171
vertical text 152
View menu 22, 31, 54
views 3, 21, 54, 189

W

web growth 113–117
web press runs 77
webs 55, 77
window 3
work and turn or tumble work style 57
work styles 57
Workspace pane 97
WST 104
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