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Introduction to Preps 6 for Preps 5 Users 
If you have used earlier versions of the Kodak® Preps® software for any length of time, this document 

summarizes the most significant changes. It maps the old to the new, to help you quickly learn and appreciate 

the enhancements introduced in Preps 6.  

Streamlined user interface 

The biggest difference is a more streamlined and efficient user interface. For example, instead of switching 

between several windows and dialog boxes, you use a single window in the Press Runs view to 

simultaneously build, preview, and edit a job’s layouts: 

 Use the panes at the left to drag resources such as stock, media, marks, and layouts to the 
interactive workspace. 

 Choose which details to display in the workspace, including distances, content, trim and bleed boxes, 
page boxes, marks, file names, and page numbers. 

 Use drag and drop to manipulate the objects in the layouts and dynamically update the properties, or 
click and type inside the dimension text boxes. 

 Click items in the layout to display and edit their settings in the Properties pane at the right. 

 Click a press run in the list at the bottom of the window to display it in the workspace. 

 Use the list’s toolbar to duplicate or insert press runs or webs, or rearrange the list. 

 Click a tab to instantly switch to a similarly arranged Pages view for managing the run-list pages. 

For more information about using the new features, such as the Assembly view, see the release notes, quick 

start guide, and user guide. These documents are all available from the Preps 6 Help menu. 

Conceptual changes 

Review this list to update your understanding of previously familiar Preps concepts and terminology. 

Preps 5 concept Preps 6 notes 

Jobs and products In Preps 5, a job represented a single product (or part of a product). 

A job can represent multiple products, and global adjustments such as shingling can be applied to 
specific products within a job. You can also organize each product into parts and set properties for 
all or some parts, part sections, and part pages. 
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Preps 5 concept Preps 6 notes 

Native PDF jobs In Preps Pro 6, all jobs are PDF-based, so there is no option to select a workflow type when 
starting a new job. Only PDF input file types are accepted.  

Some capabilities that were previously available only to PostScript-type jobs are now available for 
PDF jobs. For example, you can output PS marks flats for PostScript-based marks as bar codes. 

The same output types are still available. 

Signatures and 
sections 

In Preps 5, a signature represented a single imposition on one sheetfed or multiweb press run. 
Although you could organize an imposition into multiple sections (Preps Pro only), you could not 
lay out more than one imposition per press run, and all the sections had to use the same binding 
style and template page size. 

In the Preps 6 user interface, each imposition section on a layout is now referred to as a press-run 
section. The term signature is now used only to refer to the data that describes one press-run 
layout in either a template file or an output file, such as JDF. 

One press-run layout can now contain multiple imposition sections (any license) with different 
page sizes and different binding styles (Preps Pro). A job can consist of any number of press runs. 

After printing one press run, its sections can be cut apart and individually folded and trimmed, to 
create physical signatures (unique or identical) that will be assembled and bound into one or more 
products. 

Each section on a press-run layout represents one instance of a product section, depending on 
how you plan your press runs. 

A “Preps Plus 5” type of imposition in Preps 6 can be described as a press run that contains a 
single section on a single sheet. 

Marks All marks now use the Kodak SmartMarks® software technology, and static marks are no longer 
supported. When you open an older job or template, any existing legacy static marks will be either 
autoconverted to SmartMarks, retained, or deleted, depending on various factors. 

In Preps 6 documentation, the term marks is used interchangeably with SmartMarks, unless static 
marks specifically are being discussed. 

Templates Templates are now just an optional resource for creating layouts. When you save a job, its press-
run layout details and content references are all stored in the JOB file. The job can be reopened 
and reprinted with the assurance that nothing has changed since you last saved it.  

There is no longer a separate Template Editor, because each job contains and stores its own 
layout information in its JOB file, and you can optionally can save a frequently-repeated job as a 
template in a separate TPL file, for quick reuse. 

A template can be used to set up predefined press-run layouts for a job, but it has no permanent 
association with a JOB file or any content files. The exception is jobs that were created using older 
versions of the software, which derive their layouts from specific referenced TPL files. If you open 
and edit a legacy job, the referenced template is updated only if you select File > Save As 
Template.  

Tiled templates Instead of creating tiled templates that are specific a certain page size, work style, binding style, 
and so on, you can now create tile sets that are associated with a specific media. You can then 
choose to print any layout to either a media tile set or to the media itself. 

Device 
configurations 

These are now referred to as media configurations and media resources. 

 The term media refers to the material on which the generated output will be imaged, which 
can include plate, film, or paper. 

 The term device refers to the system or equipment that will process the generated output, 
such as a printer, press, platemaker, proofer, or imagesetter. 

 The term resource refers to a reusable configuration that you have defined. Other types of 
resources in Preps 6 include stock (sheet size), marks, and templates. 

You can set up a media configuration for any valid size that is defined in the device-specific 
PostScript Printer Description (PPD) files in the Printers folder. 
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Preps 5 concept Preps 6 notes 

Independent and 
ganged pages 

Ganged pages are a type of independent page, except that they are not associated with a 
multipage imposition section. (If you previously used the Preps Ganging 5.3.x software, then you 
are already familiar with this change.) 

Note: You cannot currently add an independent page to an imposition. For example, to create a 
spread, you would add the double-sized PDF page to the run list so that it occupies one side of the 
opposing pages in a spread, and just use an empty placeholder page for the opposing template 
page. 

Where is the <name> dialog box now? 

Use this table to determine where to find the Preps 6 functionality that corresponds to several Preps 5 user 

interface components.  

Note: This table does not mention new Preps Pro features that are available via the new Assembly view, 

which can be used to autogenerate press runs without using many of the tools that you must use with non-Pro 

license types. For details about license types and all features, see the Preps User Guide. 

Preps 5 user interface Preps 6 notes 

Add Crop Marks dialog box Static crop marks are no longer supported. You can now select and delete individual 
crop SmartMarks. 

To add to a layout: Resources pane > Marks list > select the mark > double-click 

Add Device dialog box Now called Add Media dialog box. To access, choose a method: 

 Resources > New Media  

 Resources pane > select the media > right-click > Add 

Add Independent Page dialog box  Not yet available for non-flat imposition work. For ganged work, you can drag pages 
from the Files list to a press run. 

Add Job Signature/Job Signature 
Info dialog box 

To renumber a section, edit the Section box in its Section Properties, or drag the 
section in the Assembly workspace. This automatically updates the first page number, 
which cannot be manually edited in Preps 6.  

A part’s section pages are automatically numbered in sequence. If you need to print a 
specific page range, use the Print dialog box to specify the print range. 

Add Placeholder/Placeholder 
Information dialog box 

This can still be accessed via Job > Add File Placeholder. 

Now, you can also simultaneously create a file placeholder and add its pages to a run 
list, complete with with page position adjustment details: In the Pages view: Double-
click the Add Pages icon in the Pages List.  

Add Signature/Signature Info 
dialog box 

Instead of adding a signature, you now add a press run. There are multiple ways of 
adding press runs, with or without layouts. For example, you can: 

 Insert a new press run with a blank sheet or multiple webs, ready for you to build a ganged 
layout, add a fold pattern, or create an imposition. 

 Duplicate a press run, with or without a layout. 

 Set up a run list, and then autoselect a template to autogenerate the press runs with the 
layouts. 
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Preps 5 user interface Preps 6 notes 

Add Tile/Tile Information dialog 
box 

See the user guide for more information about the following paths: 

 Resources > New Tile Set 

 In the Media list, locate the media that has a tile set > expand the media item to 
display its tile sets > double-click a set to add it to the press run 

 In a layout in the Press Runs view, click the tile set to display its settings in the 
Properties pane 

 Print > Media > select the tile set to print tiled output 

Add/Edit Static Mark dialog box 

 

Static marks are no longer supported. Use SmartMarks only. 

To add to a layout: Resources pane > Marks list > select the mark > double-click 

Add SmartMarks Instead of adding marks to a template, you now add them directly to a layout. 

To add to a layout: Resources pane > Marks list > select the mark > double-click 

To edit a placed mark: Select the mark in the layout > edit the Properties pane. 

To edit the SMK file of a mark resource: Marks list > select and right-click the mark > 
Edit. 

Additional Settings dialog box Content Bleed Margin, Shingling (Creep), Rotation (Bottling) settings are now on 
the Template Page tab on the Properties pane. 

Choose Device dialog box You now apply a media to a press run by double-clicking it in the Media list in the 
Resources pane. You can also select the press run in the Press Runs List and 
change the Media setting in the Properties pane. 

Connection dialog box Now in Media Configuration dialog box > Connection 

Create/Modify Imposition dialog 
box 

To create and add to current press run: Job > Create Imposition 

To edit: Double-click an imposition to display its Modify Imposition dialog box. 

Or select the section in the workspace and use the Properties pane. 

Custom Page Size dialog box Now in Media Configuration dialog box > Custom Size 

Device Configuration dialog box  Now called Media Configuration: Media list > select and right-click a media > Edit 

Device Setup dialog box  View all configured media resources in the Media list in the Resources pane. When 
you add a new media resource, the Media Types list in the Add Media dialog box 
displays all devices for which a PPD file is installed. 

Edit [SmartMark type] dialog box To create a new SMK file: Resources > New SmartMark 

File Information dialog box  View basic file information in the Files list and for individual pages in the Properties 
pane after you add and select the page in the Pages List. 

File List window Replaced by the Files list pane. You can no longer preview pages before they are 
added to a run list. (To preview, simply use your own Acrobat software.) 

Fitting Setup dialog box Fitting support is discontinued. In Preferences > Output, you can override an error 
message that informs you when the media size is smaller than the sheet.  

Get Info The Properties pane at the right side of the window displays information and editable 
settings for the currently selected item. 
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Preps 5 user interface Preps 6 notes 

Import SmartMarks dialog box Mark groups that you create by dragging SMK files into a subfolder in the SmartMarks 
folder immediately appear in the Marks list in the Resources pane 

Double-click a mark group to add the entire group to the current press-run layout, or 
expand the mark group list and select individual marks. 

Job Log window To access: Media list > select and right-click a media > Edit > Job Log 

Layout Details dialog box  To access: Job > Layout Details > Select a product and edit the settings. 

Load or Save Profile dialog box Moved to the Preferences dialog box 

Modify Bleed Margins dialog box Edit in Template Page properties. You can also set a global default in Preferences and 
a product default in Job > Layout Details. 

Modify Gutters/Gutter Information 
dialog box 

Click and edit the text boxes directly in the Press Runs workspace. Or edit in Section 
properties or Modify Imposition dialog box. 

Modify Page Bottling dialog box Edit in Template Page properties. 

Modify Page Shingling dialog box Edit in Template Page properties. 

Modify Run List Page dialog box Select page in Pages List or Pages workspace > Properties pane 

New Template\Template 
Information dialog box 

Create a job and press-run layouts, and select File > Save as Template. 

Preferences dialog box tabs Now includes General, Folders, Marks, Output, JDF, AutoGang tabs, with several 
options for defaults that were previously available only in a CFG file. 

The PDF, Font Processing, Brisque tabs have been removed. 

Preview window The functionality of the Template Editor and Preview windows is now combined in the 
interactive (job-based) workspace in the Press Runs and Pages views. 

Print Mock-Up dialog box Layout mock-ups and press run details can now be printed: Select File > Print Job 
Layout Report. 

Punch Location dialog box Now in Media Configuration dialog box > Punch 

Resolve Signature Placeholder 
dialog box 

Now in Properties pane. Click the arrow at top right corner to display Source JDF 
Values alongside current settings. 

Run List window Replaced by the Pages List in the Pages view; includes many more options for 
describing and managing the pages. 

Scaling Set dialog box To add, edit, or delete: Resources > Web Growth Compensation Sets 

Signature List window Replaced by the Press Runs List in the Press Runs view.  
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Preps 5 user interface Preps 6 notes 

Signature Selection dialog box Completely changed. You now create imposition press runs by adding one or more 
sections based on selected fold pattern or template layouts. 

To find a suitable layout resource, use the Search tool in the Layouts pane.  

To select and apply it to a press run: Select it in either the Templates list or Fold 
Patterns list, and double-click and drag it to the workspace, or right-click it and select 
AutoSelect.  

To manage the list of press runs, use the Press Runs List. 

To change the work style, stock, or other aspects of a press run, use the Properties 
pane for the selected press run. 

To change the book signature number of a section, select the section in the workspace 
and edit the Section number in the Properties pane. This updates the First Page 
Number. (You cannot force page numbers to skip.) 

Step and Repeat dialog box Select the page and Edit > Duplicate. 

Template Editor The functionality of the Template Editor and Preview windows is now combined in the 
interactive (job-based) workspace in the Press Runs and Pages views. 

Template Page Information dialog 
box 

Select a page in Press Runs workspace (for imposition pages, use the hollow-arrow 
Page Select tool), and click Template Page on the Properties pane.  

Template tool palette Press Runs workspace > Toolbar 

Web Growth Compensation Sets 
window 

Resources > Web Growth Compensation Sets 

Discontinued features and user interface components 

Preps 5 feature Discontinued user interface components 

AppleScripts AppleScript support, Scripts menu (Mac OS only) 

Brisque job workflows  Preferences Brisque tab and General tab > Default Workflow > Brisque 

 File > New Job > Brisque  

 File > Print > ICF  

 File List > Add Files and Jobs button 

PostScript job workflows  File > New Job > Mixed Files  

 File > Send Postscript File  

 File > Print > Host Based Color Mapping, Sort-by Color/Page 

 Xerox DocuTech system tickets 

 Xerox DigiPath system documents 

 Font Processing tab 

 OPI processing; APR, OPI, and DCS passthrough 

Other  Windows > Save/restore window positions  

 General tab > Compatability Settings -> Cross Platform 

 Template Menu > Static Marks  
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About Kodak Graphic Communications Group (GCG) 

The leading provider of graphic communications solutions worldwide, Kodak’s Graphic Communications Group (GCG) offers image 

capture systems; professional color, copydot, and high-speed document scanning systems; inkjet printing and proofing systems; 

workflow and color management software; thermal imaging devices for film, plates, and proofs; high-quality proofing media, printing 

plates, and recording film; on-demand color and black-and-white printing systems; data storage products; and professional 

services. With corporate headquarters located in Rochester, N.Y., Kodak (NYSE: EK) has the largest global sales force and is 

committed to a digitally oriented growth strategy.  

© Kodak, 2009. All rights reserved. Kodak, Creo, eCentral, Preps, and SmartMarks are trademarks of Kodak. Acrobat, Adobe, 

Distiller, Illustrator, Photoshop, and PostScript are trademarks of Adobe Systems Incorporated. Apple, AppleShare, AppleTalk, 

iMac, ImageWriter, LaserWriter, Mac OS, Power Macintosh, and TrueType are registered trademarks of Apple Inc. Macintosh is a 

trademark of Apple Inc., registered in the U.S.A. and other countries. Hexachrome, PANTONE, PANTONE Goe, PANTONE 

Hexachrome, and PANTONE MATCHING SYSTEM are the property of Pantone, Inc. PEARL, PEARLdry, PEARLgold, 

PEARLhdp, and PEARLsetter are registered trademarks of Presstek, Inc. XEROX is a trademark of XEROX CORPORATION. 

Technical data subject to change without notice. 
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