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Глава 1: Введение

Э та глава знакомит вас с основной информа-
цией о проверке ваших системных требова-
ний, установке плагина PitStop Professional и

запуске программы Enfocus PitStop Professional из-
нутри интерфейса приложения Adobe Acrobat. 

Относительно данного 
Руководства пользователя

Данное Руководство пользователя PitStop Professio-
nal описывает пошаговые инструкции для проверки,
редактирования и исправления PDF документов с
помощью Enfocus PitStop Professional. Оно состоит
из следующих разделов:

ГГллаавваа  11::  ВВввееддееннииее.. Содержит инструкции по уста-
новке и запуску Enfocus PitStop Professional. Эта гла-
ва также кратко перечисляет новые особенности
программы.

ГГллаавваа  22::  ООббззоорр  ррааббооччеейй  ооббллаассттии  EEnnffooccuuss  PPiittSSttoopp  PPrroo--
ffeessssiioonnaall.. Указывает, где вы можете найти определен-
ные инструментальные средства Enfocus PitStop Pro-
fessional, интегрированные в интерфейс Adobe Ac-
robat. Эта глава также описывает различные спосо-
бы просмотра PDF документа и объясняет переклю-
чение между режимами просмотра.

ГГллаавваа  33::  РРааббооттаа  сс  PPDDFF  ддооккууммееннттааммии.. Обеспечивает
основные рекомендации по настройке PDF докумен-
тов относительно определенной рабочей среды и
технических требований.

ГГллаавваа  44::  РРааббооттаа  сс  CCeerrttiiffiieedd  PPDDFF  ддооккууммееннттааммии..  
Эта глава представляет концепцию Certified PDF и
описывает, как вы можете выполнять ряд действий c
Certified PDF документами, исходящими из среды
Enfocus Certified PDF.

ГГллаавваа  55::  ГГллооббааллььнныыее  ииззммееннеенниияя  вв  PPDDFF  ддооккууммееннттаахх..
Позволяет вам сделать глобальные изменения с объ-
ектами или страницами в вашем PDF документе.
Для этого используется окно диалога Global Change. 

ГГллаавваа  66::  ППррееддппееччааттннааяя  ппррооввееррккаа  PPDDFF  ддооккууммееннттоовв..
Рассказывает, как использовать одну из ключевых
особенностей PitStop: предпечатную проверку (pre-
flighting). Здесь вы найдете детальное объяснение
того, как вы можете создавать PDF профиль и про-
верять ваш PDF документ согласно этому профилю.
Эта глава также объясняет, как вы можете управлять
множеством профилей. 

ГГллаавваа  77::  ААввттооммааттииззаацциияя  ззааддаачч.. Объясняет цель спис-
ков действий (Action List) и объясняет процесс уста-
новки списка действий.

ГГллаавваа  88::  РРееддааккттииррооввааннииее  ттееккссттаа..  Описывает способы
редактирования текста, включая его правку и фор-
матирование, а также описывает, как изменить цвет
текста и как получить лучшие результаты при печа-
ти PDF документа.

ГГллаавваа  99::  РРееддааккттииррооввааннииее  ооббъъееккттоовв.. Объясняет раз-
личия между графическими и пиксельными изобра-
жениями и описывает соответствующие изменения,
которые вы можете делать с этими объектами.

ГГллаавваа  1100::  УУппррааввллееннииее  шшррииффттааммии.. Обеспечивает тео-
ретическое понимание типов шрифтов и их исполь-
зования. Вы также изучите, как изменить шрифты
или их свойства в PDF.

ГГллаавваа  1111::  УУппррааввллееннииее  ццввееттоомм..  Предоставляет базо-
вую информацию для тех, кто собирается изменять
цвет в PDF документах для печати их на специфи-
ческом устройстве вывода. Эта глава представляет
базовые теории цветовых моделей и показывает, как
эффективно работать с цветом в PDF документах.
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Системные требования

Enfocus PitStop Professional требует:

• Adobe® Acrobat® 4.05 или Adobe® Acrobat® 5 (неко-
торые кнопки Enfocus PitStop Professional могут
быть недоступны в Acrobat 4.x)

• Microsoft® Windows® 98 или более позднюю вер-
сию ОС, Windows NT ® 4.0 с Service Pack 5 или более
позднюю версию ОС, или Windows ® 2000.

или

• Системное программное обеспечение компании
Apple Inc версии 8.6 или более поздней на компью-
тере Power Macintosh.

Чтобы иметь возможность управления цветом, вы
должны иметь операционную систему допускаю-
щую управление цветом, типа Windows 98 или более
позднюю, Windows 2000 или Mac OS с Apple Color-
Sync 2.5 или более поздней версии.

Требования к памяти

Enfocus PitStop Professional требует оперативной па-
мяти как минимум 64 Mb. На Mac OS увеличьте рас-
пределение памяти для Adobe Acrobat до 64 Mb или
более.
В зависимости от типа документов, с которыми вы
работаете и типов изменений, которые вы делаете,
может быть необходимо большее количество памяти. 

Установка 
Enfocus PitStop Professional

Вы можете установить Enfocus PitStop Professional на
вашем компьютере при активном Adobe Acrobat.
Однако в Windows вы не сможете использовать En-
focus PitStop Professional до тех пор, пока не переза-
грузите свой компьютер. На Macintosh вам нужно
только перезагрузить Adobe Acrobat.

Если вы устанавливаете Enfocus PitStop Professional,
в то время как Adobe Acrobat не активен, перезагруз-
ка компьютера не потребуется.

Чтобы установить Enfocus PitStop Professional:

1. Вставьте CD диск с программным обеспечением
Enfocus в CD-ROM своего компьютера.

Появится окно, показывающее содержимое CD
диска.

В Microsoft Windows программа инсталляции
запустится автоматически.

2. Также вы можете загрузить программу установки
Enfocus PitStop Professional с официального web-
сайта Enfocus (www.enfocus.com).

3. Выберите соответствующий файл инсталляции в
папке файлов инсталляции.

4. Следуйте за инструкциями инсталляции, появля-
ющимися на экране.

Если инсталляция не запускается автомати-
чески, найдите файл инсталляции, и вручную
запустите соответствующее приложение.

Запуск Enfocus PitStop Professional

Enfocus PitStop Professional является плагином для
Adobe Acrobat, так что вы можете запускать програм-
му только изнутри интерфейса Adobe Acrobat.

Чтобы запустить Enfocus PitStop Professional:

1. Сначала запустите Adobe Acrobat.

Удостоверьтесь в том, что вы не удерживае-
те клавишу Shift во время запуска программы
Adobe Acrobat, иначе программа будет стар-
товать без загрузки плагинов и Enfocus PitStop
Professional будет недоступен.

Enfocus PitStop Professional
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2. Выберите File > Open.

3. Определите местоположение PDF документа, ко-
торый вы хотите открыть и нажмите Open.

4. Нажмите любую кнопку на одной из инструмен-
тальных панелей Enfocus PitStop Professional.

Появится заставка Enfocus PitStop Professional и про-
держится на экране пару секунд.

Заставка Enfocus PitStop Professional

Как только вы зарегистрировали Enfocus PitStop Pro-
fessional или нажали кнопку Run Trial, вы можете ис-
пользовать Enfocus PitStop Professional для редакти-
рования, проверки или автоматического исправле-
ния PDF документов. См. также “Покупка и регист-
рация Enfocus PitStop Professional” ниже.

Покупка и регистрация 
Enfocus PitStop Professional

Относительно покупки и регистрации

После истечения срока испытательной версии Enfo-
cus PitStop Professional, вы можете купить полнос-
тью функциональную версию на сайте www.enfo-
cus.com или у любого из наших уполномоченных
дилеров. Кроме того, необходимо зарегистрировать

вашу версию Enfocus PitStop Professional. Это даст
вам право обращаться за технической поддержкой и
закачивать обновления программы.

Покупка Enfocus PitStop Professional

Вы можете купить Enfocus PitStop Professional на
сайте www.enfocus.com или у любого из наших упол-
номоченных дилеров. Список доступен на сайте.

Чтобы купить Enfocus PitStop Professional:

1. Запустите Adobe Acrobat .

2. Выберите Help > Plug-in Help > Enfocus PitStop
Professional > Buy Now!

3. Следуйте инструкциям на web-сайте. 

Регистрация Enfocus PitStop Professional

Когда вы запускаете Enfocus PitStop Professional в
первый раз после установки, появляется следующее
окно диалога:

Вам предлагаются две возможности:

• Вы может использовать испытательную версию En-
focus PitStop Professional для работы и оценки в те-
чение 30-дневного срока.

Enfocus PitStop Professional
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• Вы можете использовать лицензионную и полнос-
тью зарегистрированную версию Enfocus PitStop
Professional.

Чтобы зарегистрировать Enfocus PitStop Professional,
вам нужен ключ регистрации. Вы получаете этот
ключ при покупке Enfocus PitStop Professional. При-
обретение лицензионной программы дает вам право
обращаться за технической поддержкой и закачи-
вать обновления программы. Вы можете зарегист-
рироваться на сайте компании, послав форму реги-
страции по интернету:

• Чтобы зарегистрироваться автономно, заполните,
и отправьте форму регистрации, которая прилага-
ется с комплектом при покупке программы.

• Чтобы зарегистрироваться по интернету, следуйте
инструкциям, изложенным ниже.

Чтобы зарегистрировать Enfocus PitStop Professional:

1. Запустите Adobe Acrobat.

2. Выберите Help > Plug-In Help > Enfocus PitStop Pro-
fessional > Register Online.

3. Заполните форму регистрации в интернете.

4. Нажмите Submit (Подтвердить).

Получение технической поддержки

Если вы работаете с зарегистрированными програм-
мами Enfocus, вы имеете право на техническую поддер-
жку. При контакте с Отделом технической поддержки
Enfocus, важно обеспечить наших инженеров необ-
ходимой информацией относительно конфигура-
ции вашего компьютера и программ Enfocus, кото-
рые вы используете. Поэтому мы включили эту ин-
формацию в окне диалога About Enfocus PitStop Pro-
fessional, который находится в меню Help. Вы може-
те легко копировать эту информацию, вставить ее в
текстовый файл и отослать по электронной почте в
наш Отдел технической поддержки.

Кроме того, вы можете также обратиться к элект-
ронной базе данных по изучению Enfocus или испо-
льзовать web-сайт технической поддержки Enfocus,
чтобы сообщить о проблеме.

Чтобы обратиться к базе данных Enfocus:

1. Выберите Help > Plug-In Help > Enfocus PitStop
Professional > Knowledge Base.

Чтобы сообщить о проблеме:

1. Выберите Help > About 3rd Party Plug-Ins > Enfocus
PitStop Professional.

Появится окно диалога About Enfocus PitStop Profes-
sional.

2. Нажмите закладку Support Info.

Теперь вы можете просмотреть всю детальную ин-
формацию относительно версии Enfocus PitStop Pro-
fessional, установленной в вашей системе, и вашей
системной конфигурации.

3. Нажмите Copy to Clipboard.

4. Сделайте одно из следующего:

• Вставьте скопированную информацию в тексто-
вый файл и отправьте его по электронной почте по
адресу: support@enfocus.com. 

• Выберите Help > Plug-In Help > Enfocus PitStop Pro-
fessional > Report a Problem и вставьте информа-
цию для технической поддержки в текстовом поле
Support Information в электронной форме. Запол-
ните остальные поля формы и нажмите Submit.

Enfocus PitStop Professional
Руководство пользователя

10



Настройка предпочтений 
Enfocus  PitStop Professional

Enfocus PitStop Professional позволяет вам опреде-
лять следующие категории предпочтений:

Чтобы установить основные предпочтения Enfocus
PitStop Professional:

1. Сделайте одно из следующего: 

• В Adobe Acrobat 4 выберите File > Preferences > Enfo-
cus PitStop Professional.

• В Adobe Acrobat 5 выберите Edit > Preferences > Enfo-
cus PitStop Professional.

Появится окно диалога Enfocus PitStop Preferences с
активной закладкой General (Основные).

2. В области Editing behavior вы можете определить:

• Число отмен (но помните, что большое число от-
мен требует большего количества памяти).

• Отображение серединных маркеров выделения при
редактировании объектов.

• Изменение курсора на черную стрелку при поме-
щении курсора поверх объекта.

• Использование выбора, сделанного инструментом
Select Objects ( ) при нажатой клавише Alt, — для
выбора объектов с полным перекрытием выделяю-
щей области или с наложением данной области.

• Отображение текста greeked — то есть как серых
полос — при режиме просмотра в виде фреймов.

3. В области Warn when укажите, когда следует появ-
ляться предупреждающим сообщениям.

4. В области Language выберите язык интерфейса En-
focus PitStop Professional.

Если вы изменяете язык интерфейса PitStop
Professional, вам необходимо перезагрузить
Adobe Acrobat.

5. Нажмите OK когда всё сделано.

Чтобы установить предпочтения Colors, отвечаю-
щие за цвета рамок, которые появляются при редак-
тировании текста, объектов и блока страницы.

1. Сделайте одно из следующего: 

• В Adobe Acrobat 4 выберите File > Preferences > Enfo-
cus PitStop Professional.

• В Adobe Acrobat 5 выберите Edit > Preferences > Enfo-
cus PitStop Professional.

Enfocus PitStop Professional
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ККааттееггоорриияя ООппииссааннииее

Основные
(General)

Редактирование поведения прог-
раммы и предупреждений.

Цвета
(Colors)

Цвета рамок, которые появляют-
ся при редактировании текста,
объектов и боксов страницы.

Инструменты
(Tools)

Инструментальные средства окна
Inspector PitStop, которое будет
появляться автоматически при
выборе инструментов; также
здесь вы можете определить еди-
ницы измерения.

Новые объекты
(New Objects)

Свойства по умолчанию, кото-
рые будут использоваться при со-
здании новых объектов (текста и
графики). Вы можете выбрать
текст или графику и сделать ее
свойства свойствами по умолча-
нию для новых объектов, кото-
рые будете создавать.

Управление цветом
(Color Management)

Включает и выключает управле-
ние цветом и предоставляет цве-
товые модели, которыми вы мо-
жете управлять.



2. Нажмите закладку Colors.

3. Определите в соответствующих областях цвета,
связанные с редактированием текста и объектов, и
специальные цвета для блока страницы.

Если вы хотите изменить цвета по умолча-
нию, дважды щелкните на одном из цветов,
появится палитра Color Picker, в которой вы
можете легко определить новый цвет.

4. Нажмите OK, когда всё сделано.

Чтобы установить предпочтения инструментов En-
focus PitStop Professional:

1. Сделайте одно из следующего: 

• В Adobe Acrobat 4 выберите File > Preferences > Enfo-
cus PitStop Professional.

• В Adobe Acrobat 5 выберите Edit > Preferences > Enfo-
cus PitStop Professional.

2. Нажмите закладку Tools.

3. Определите инструментальные средства, с кото-
рыми вы хотите запускать Inspector Enfocus Pit-
Stop, устанавливая или снимая галочки в соответ-
ствующих опциях.

4. Нажмите OK когда всё сделано.

Для более детального объяснения инструменталь-
ных средств, доступных в  PitStop, см. раздел “Инст-
рументальные панели Enfocus PitStop Professional”
на странице 18.
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Предпочтения, которые связаны с определен-
ными инструментальными средствами, ин-
тегрированы в панель Inspector. Вы можете

устанавливать эти предпочтения, поскольку вы ис-
пользуете соответствующий инструмент. Напри-
мер, если вы используете инструмент поворота объ-
екта, Inspector отобразит следующие предпочтения:

В этом примере, ограничивающий угол (Constrain Angle),
цвет крестовины (Crosshair Color) и единицы измере-
ния (Measurement Units) могут быть изменены.

Чтобы установить предпочтения Enfocus PitStop Pro-
fessional для новых объектов:

1. Выберите инструмент Select Objects ( ).

2. Выберите любой существующий текст или графи-
ку в вашем PDF документе.

Например, если вам нужно добавить новый текст, и
вы хотите, чтобы этот текст был набран шрифтом
Times-Roman 11 пунктов, вы сначала выбираете
текст с соответствующими свойствами, как показа-
но ниже.

Также, если нужно добавить новые графические
объекты с определенной обводкой и заполнением,
вы выбираете объект с соответствующими свой-
ствами, как показано ниже.

3. Сделайте одно из следующего: 

• В Adobe Acrobat выберите Edit > Preferences > Enfo-
cus PitStop Professional.

4. Выберите закладку New Objects.

Enfocus PitStop Professional
Руководство пользователя

13



5. Нажмите кнопку Grab в поле Line Art (Графика)
или поле Text (Текст), в зависимости от объекта,
который предварительно был выбран.

6. Нажмите OK.

Следующий раз, когда вы добавляете новый текст
или создаете новый графический объект, Enfocus,
PitStop Professional применит выбранные вами свой-
ства объекта по умолчанию.

См. также разделы “Добавление нового текс-
та” на странице 98 и “Создание новых форм”
на странице 120.

Чтобы установить предпочтения Enfocus PitStop
Professional для управления цветом:

1. Сделайте одно из следующего: 

• В Adobe Acrobat выберите Edit > Preferences > Enfo-
cus PitStop Professional.

2. Нажмите закладку Color Management.

3. После включения опции Enable Color Management,
вы можете выбирать различные профили цвета
по умолчанию для черно-белых, RGB, CMYK или
Lab изображений.

Для получения дополнительной информации
об управлении цветом, см. также раздел “Уп-
равление цветом” на странице 134.

4. Нажмите OK, когда всё сделано.

Чтобы установить единицы измерения, используе-
мые в Enfocus PitStop Professional:

1. Сделайте одно из следующего: 

• В Adobe Acrobat выберите File > Preferences > Enfo-
cus PitStop Professional.

2. Выберите закладку Tools.

3. Определите нужные вам единицы измерения, вы-
брав их в списке в области Measurements Units.
Доступны следующие единицы измерения:

• Пункты
• Пики
• Дюймы
• Сантиметры
• Миллиметры

4. Нажмите OK.

Настройка предпочтений 
Enfocus Certified PDF

Предпочтения Enfocus Certified PDF позволяют вы-
брать:

• Значок состояния: Enfocus PitStop Professional до-
бавляет кнопку состояния ( ) Certified PDF в па-
нель инструментов Adobe Acrobat. Эта кнопка из-
меняется в зависимости от состояния текущего
PDF документа.
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• Вы можете выбрать цвета подсветки, которые бу-
дут использоваться, когда вы рассматриваете изме-
нения, которые были сделаны в протоколе редак-
тирования или когда вы сравниваете два “снимка”
(snapshots).

Чтобы установить предпочтения Enfocus Certified
PDF:

1. Сделайте одно из следующего:

• В Acrobat выберите Edit > Preferences > Enfocus Cer-
tified PDF.

Появится окно диалога Enfocus Certified PDF Prefe-
rences.

2. В области Status Icon (Значок состояния) опреде-
лите, действительно ли кнопка состояния на инст-
рументальной панели Adobe Acrobat должна ука-
зывать соответствие между PDF профилем, вклю-
ченным в Certified PDF документ, и одним из про-
филей в вашей системе.

3. В случае необходимости вы можете изменить цве-
та подсветки, нажав любой из двух цветных пря-
моугольников в окне диалога, показанного выше.

Появится палитра цвета, в которой вы можете выб-
рать новый цвет подсветки, щелкнув в круге и пере-
мещая точку, чтобы изменить цвет или яркость.

4. В случае необходимости вы можете изменить
язык интерфейса, просто выбрав нужный язык в
списке доступных языков Current Language.
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Enfocus PitStop Professional имеет ряд специали-
зированных кнопок, добавленных по умолча-
нию в меню Acrobat. Кроме того, специализи-

рованные команды PitStop Professional в меню обес-
печивают инструментальные средства, которые поз-
воляют работать с PDF документами. Точное распо-
ложение этих инструментальных средств отличается
для пользователей Adobe Acrobat 4 и Adobe Acrobat
5, как показано ниже.

Обзор рабочей области Enfocus Pit*
Stop Professional в Adobe Acrobat 4

Инструментальные средства Enfocus PitStop Profes-
sional могут быть найдены в пунктах меню Edit, Ser-
tified PDF и Window, а также в области команд Enfo-
cus PitStop Professional в панели инструментов, как
обозначено ниже.

Enfocus PitStop Professional
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Глава 2: Обзор рабочей области 
Enfocus PitStop Professional 

AA. Строка меню. BB. Панель инструментов со специализированными кнопками PitStop Professional. CC. Специализиро-
ванные команды PitStop Professional. DD. Навигационная область окна. EE. Строка состояния. FF. Область окна докумен-
та. GG. Область команд со специализированными кнопками PitStop Professional. 



В Adobe Acrobat 5 к инструментальным средствам
Enfocus PitStop Professional можно обращаться через
кнопки на одной из инструментальных панелей En-

focus PitStop Professional, или через пункты меню
Edit, Sertified PDF и Window, как показано ниже.
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AA. Строка меню. BB. Инструментальная панель File в Acrobat. CC. Enfocus инструментальная панель Undo и Redo Pit-
Enfocus Stop. DD. Инструментальная панель View Enfocus PitStop. EE. Инструментальная панель Tools PitStop Enfocus.
FF. Инструментальная панель Window Enfocus PitStop. GG. Инструментальная панель PDF Profile Enfocus PitStop.
HH. Инструментальная панель Action List Enfocus PitStop. II. Специализированные команды Enfocus PitStop.FF. Специа-
лизированные команды вызова панелей Enfocus PitStop. JJ. Область окна документа. KK. Строка состояния. LL. Навига-
ционная область окна. 

Обзор рабочей области Enfocus PitStop Professional в Adobe Acrobat 5



Все специализированные кнопки Enfocus PitStop
Professional находятся на панелях инструментов Pit-
Stop Professional в Adobe Acrobat 5. Однако пользова-
тели Adobe Acrobat 4 видят только инструменталь-
ную панель View Enfocus PitStop и инструменталь-
ную панель Tools Enfocus PitStop.

В Adobe Acrobat 4 вы можете использовать оп-
ции недоступных инструментальных панелей,
выбирая соответствующую команду меню.
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Инструментальные панели Enfocus PitStop Professional

ППааннеелльь  UUnnddoo

Отмена

Повтор

ППааннеелльь  VViieeww

ППааннеелльь  WWiinnddooww

ППааннеелльь  PPDDFF  PPrrooffiillee

ППааннеелльь  AAccttiioonn  LLiisstt

ППааннеелльь  TToooollss

Показать аннотации

Показать боксы на странице

Показать фреймы

Показать проблемы

Выбор объектов

Выбор прямоугольной области

Перемещение

Редактирование
траектории

Добавить
точку

Удалить
точку

Новая
траектория

Измерение

Направляющие

Пипетка

Копирование и
вставка атрибутов

Редактирование
текстовой строки

Редактирование
параграфа

Масштаб
Прямоугольник

Редактирование
вертикальной строки

Овал

Поворот Искажение

Выбор полигональной области

Выбор схожих объектов
Вызов палитры инспектора

Вызов палитры глобальных
изменений

Вызов палитры управления
PDF профилями 

PDF профиль выбор 1 

PDF профиль выбор 2 

PDF профиль выбор 3 

PDF профиль выбор 4 

PDF профиль выбор 5 

Лист действий выбор 1 

Лист действий выбор 2 

Лист действий выбор 3 

Лист действий выбор 4 

Лист действий выбор 5 

Добавить выбор PDF профиля 

Добавить выбор Листа действий

Вызов палитры управления
листом действий



Инструментальная панель Tools

Вы можете выбрать основной инструмент из ин-
струментальной панели Tools, нажав соответствую-
щую кнопку. Все инструменты на этой панели име-
ют черную стрелку в правом нижнем углу, это озна-
чает, что они скрывают дополнительные инструмен-
ты, как обозначено ниже.

Чтобы выбрать один из скрытых инструментов ре-
дактирования, нажмите текущий инструмент на
инструментальной панели и удерживайте кнопку
мыши в течение некоторого времени. Все связанные
инструментальные средства станут видимыми, и
затем вы можете выбрать нужный инструмент.

Инструментальная панель View

Кнопки инструментальной панели View позволяют
вам переключаются между различными доступными
видами. Нажатие любого из инструментов отобра-
зит PDF документ в одном виде; при повторном щел-
чке на инструменте дисплей вернется к первонача-
льному виду. Enfocus PitStop Professional предлагает
вам следующие кнопки на инструментальной пане-
ли View:

Кнопки и их соответствующие функции обозначены
ниже:

Инструментальная панель Window 

Вы можете нажать любую из кнопок в инструмента-
льной панели Windows Enfocus PitStop, чтобы пока-
зать или скрыть главные окна диалога Enfocus PitStop
Professional:

AA. Вызов панели инспектор (Inspector). BB. Вызов пане-
ли глобальных изменений (Global Change). 
CC. Вызов панели управления PDF профилями (PDF
Profile Control). DD. Вызов панели управления списком
действий (Action List Control).
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Показать
аннотации

Показать боксы
на странице 

Показать
фреймы

Показать
проблемы

Кнопки Функции 

Нажмите, чтобы показать или скрыть все
аннотации в PDF документе. См. также
раздел “Показать /скрыть аннотации” на
странице 24.

Нажмите, чтобы увидеть обрезные края и
выход за обрез в PDF документе. 
См. раздел “Просмотр рамок страницы: 
дообрезной и обрезной форматы PDF
документа” на странице 21.

Нажмите, чтобы просмотреть PDF доку-
мент в предварительном просмотре или в
режиме вида фреймов. См. раздел “Про-
смотр PDF документа” на странице 21.

Нажмите, чтобы просмотреть проблемы в
PDF документе. См. раздел “Проверка
PDF документа с помощью панели Navi-
gator” на странице 77.



Инструментальные панели
PDF Profile и Action List

Инструментальные панели PDF Profile и Action List
содержат кнопки быстрого доступа к пяти пользова-
тельским PDF профилям и пяти листам действий со-
ответственно. Вы можете связать эти кнопки с PDF
профилями или листами действий, которые вы ис-
пользуете наиболее часто и затем выполнить эти
PDF профили или списки действия, просто нажав на
соответствующую кнопку.

AA. Инструментальная панель Action List. BB. Инстру-
ментальная панель Profile PDF. 

Чтобы назначить PDF профили или списки дейст-
вий для кнопок быстрого доступа:

1. Нажмите кнопку Select PDF Profiles ( ) или кноп-
ку Select Action List ( ) на соответствующей ин-
струментальной панели.

2. В соответствующем окне диалога установок ин-
струментальной панели, выберите Action List или
PDF Profile в списке, и нажмите Set.

3. Повторите действия, описанные в пункте 2, чтобы
назначить для кнопок быстрого доступа все ваши
списки действий или PDF профили.

4. Нажмите OK.

Определение языка интерфейса 
Enfocus PitStop Professional

Подобно версиям с многоязычным Adobe Acrobat,
вы можете определить язык интерфейса пользовате-
ля PitStop, так чтобы все меню и окна диалога Enfo-
cus PitStop Professional отображались на вашем род-
ном языке.

Чтобы определить язык интерфейса пользователя
PitStop Professional:

1. Сделайте одно из следующего:

• В Adobe Acrobat 5 выберите Edit > Preferences > En-
focus PitStop Professional.

Выбор языка интерфейса пользователя PitStop.
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2. Выберите язык, в котором вы хотите отображать
меню и окна диалога Enfocus PitStop Professional.

3. Перезагрузите Adobe Acrobat.

Интерфейс Enfocus PitStop Professional будет теперь
появляться на выбранном языке.

Просмотр PDF документа

Вы можете просматривать PDF документ в любом из
следующих режимов:

• Режим предварительного просмотра.

• Режим отображения фреймов. 

Вы можете использовать кнопку переключения меж-
ду этими двумя режимами.

Если вы смотрите на PDF документ в режиме пред-
варительного просмотра, вы видите страницы доку-
мента в том виде, в котором они будут печататься.

Если вы смотрите на PDF документ в режиме отоб-
ражения фреймов, документ будет представлен сле-
дующим образом:

• Объекты отображаются в форме схематичных кон-
туров.

• Текст может быть затенен (greeked), то есть на экра-
не текст отображается как серые полосы без инди-
видуальных знаков. Вы можете выбрать эту опцию
в окне диалога Enfocus PitStop Preferences.

Вы можете просматривать PDF документ в режиме
отображения фреймов для того, чтобы:

• Увидеть и выбрать объекты, которые полностью
или частично перекрыты другими объектами. См.
также раздел “Изменение порядка объектов” на
странице 112.

• Видеть и редактировать маски. См. также раздел
“Маскированные объекты” на странице 124.

Вид PDF документа в режиме фреймов (wireframe): все
объекты отображаются в виде схематичных кон-
туров (AA), текст отображается в виде серых полос (BB).

• Быстрее отображать страницы, если они содержат
много картинок или большие пиксельные изобра-
жения. 

Чтобы включить режим предварительного
просмотра или режим отображения фрейB
мов PDF документа

Нажмите кнопку  переключения между режимом
предварительного просмотра и режимом  отображе-
ния фреймов (       ).

Просмотр рамок страницы: 
дообрезной и обрезной форматы
PDF документа

Рамки страницы (боксы)

Когда вы создаете PDF документ, он содержит не-
сколько рамок страницы. Рамки страницы — это
условные прямоугольники, выведенные вокруг раз-
личных объектов на странице и непосредственно
вокруг самой страницы. Вы не можете увидеть эти
рамки страницы, если вы смотрите на PDF документ
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без PitStop Professional или другого инструмента
просмотра PDF. Они — своего рода скрытое описа-
ние раскладки вашего PDF документа.

Типы рамок страницы (боксов)

Иллюстрация ниже показывает различные типы ра-
мок страницы.

AA.. Бокс устройства (Media box). BB.. Дообрезной бокс
(Bleed box). CC.. Обрезной бокс (Trim box). 
DD.. Бокс художественных объектов (Art box). 

MMeeddiiaa  bbooxx.. Бокс устройства — самая большая из ра-
мок страницы. Бокс устройства соответствует фор-
мату полосы (например, A4, A5, US Letter и т. д.),
которую вы выбрали, когда печатали документ в
файл PostScript или PDF. Другими словами, бокс уст-
ройства определяет физический размер устройства,
в котором PDF документ будет отображен или напе-
чатан.

BBlleeeedd  bbooxx..  Если вы используете выход за обрез в ва-
шем документе, PDF документ также будет иметь
бокс выхода за обрез. Выход за обрез — это область
цветных плашек или пиксельных иллюстраций, ко-
торые выходят за края страницы. Выход за обрез ис-

пользуется, чтобы краска печаталась в самый край
страницы, и при обрезке не оставалось белых зазо-
ров на краях страницы. 

TTrriimm  bbooxx.. Обрезной бокс показывает заключитель-
ный размер документа после печати и обрезки.

AArrtt  bbooxx..  Художественный бокс — бокс, выведенный
вокруг фактического содержимого страниц в ваших
документах. Этот бокс иногда используется при им-
портировании PDF документов в другие приклад-
ные программы.

CCrroopp  bbooxx.. Кроп бокс является размером страницы,
который ваш PDF документ показывает в Adobe Ac-
robat. В нормальном виде в Adobe Acrobat отобра-
жается только содержимое кроп бокса. 

Использование рамок страницы

Использование рамок страницы особенно полезны
при изменении размеров объектов или же самих
страниц в вашем PDF документе. Enfocus PitStop
Professional предлагает вам инструментальные сред-
ства, могущие совершать подобные действия посред-
ством глобальных изменений или с использованием
PDF профилей. Таким образом, вы можете легко из-
менить размер вашего документа, например, с A4 на
US Letter или на заказной формат полосы,  без необ-
ходимости делать трудные и, как правило, отнимаю-
щие много времени, модификации в вашем исход-
ном документе или приложении.

Пример рамки страницы 

Предположим, что вы создаете обложку для журнала
со следующими шагами:

• Вы решаете, что размер обложки после печати и
обрезки будет A5 (148 × 210 mm). Это будет размер
обрезного бокса.

• Вы используете фоновую краску, которая прости-
рается влево, вправо и на нижнее поле страницы.
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Вы используете 5 мм выхода за обрез со всех сто-
рон. Следовательно, размер дообрезного бокса бу-
дет равен 158 × 220 mm.

• Вы размещаете свои художественные работы на
чистой странице в какой-либо программе настоль-
ной издательской системы. Размер чистой страни-
цы — 180 × 260 mm. Это станет кроп боксом в Ado-
be Acrobat.

• Наконец, вы печатаете этот документ в файл Post-
Script (и создаете PDF документ позже). При выбо-
ре драйвера принтера, вы определяете, что формат
полосы должен быть A4 (210 × 297 mm), потому
что метки реза и приводные кресты должны уме-
щаться на странице. Это будет размер бокса уст-
ройства.

Просмотр информации вне кроп бокса

Новая особенность PDF 1.3 — способность опреде-
лить документ, который имеет информацию вне ее
заключительной ширины полосы после обрезки.
В полиграфии эта информация обычно включает
выход за обрез, приводные кресты метки реза и
шкалы для контроля цветопередачи. Используя
кнопку View Page Boxes (Вид рамок страницы) (       ),
вы можете легко увидеть информацию вне заключи-
тельного формата полосы даже после обрезки ваше-
го PDF документа.
Эта информация определена в приложении, которое
использовалось, чтобы создать первоначальный
файл PDF, например, в Adobe FrameMaker или в
Adobe PageMaker. Как только они сделаны видимы-
ми с использованием Enfocus PitStop Professional,
эти элементы могут быть отредактированы, добав-
лены или удалены, точно так же как любой другой
графический объект. 
Некоторые PDF документы сгенерированы без вы-
ходов за обрез, приводных крестов или шкал. Когда
вы выбираете кнопку View Page Boxes для этих доку-
ментов, страница будет показана как она была сгене-
рирована (за исключением тонкой линии реза по
краям страницы).

Чтобы увидеть дообрезной и обрезной
боксы PDF документа:

1. Откройте PDF документ. Acrobat отображает PDF
документ в его полном размере.

2. Нажмите кнопку View Page Boxes (Вид рамок стра-
ницы) (       ) .

Acrobat отобразит страницу в конечном размере уст-
ройства (Media box) и покажет:

• Рамку страницы после обрезки (Trim box).
• Метки реза страницы, если они есть.
• Маркеры принтера, если они есть. 
• Выход за обрез страницы (Bleed box),  если есть.
• Шкалы для контроля цветопередачи, если они есть.

AA. Метки реза. BB.. Послеобрезной формат (Trim box). 
CC.. Приводные кресты. DD.. Выход за обрез (Bleed). 
EE.. Формат бокса устройства (Media box). 
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Показать/скрыть аннотации

Вы можете просматривать PDF документ с види-
мыми или скрытыми аннотациями. Enfocus PitStop
Professional дает вам возможность показать или
скрыть все аннотации, используя кнопку View Anno-
tations ( ) .

PDF документ с показанными и скрытыми аннота-
циями.

Чтобы показать или скрыть все аннотации
в документе:

Нажмите кнопку переключения  между этими двумя
режимами View Annotations ( ). Аннотации мо-
гут быть созданы как средствами программы Adobe
Acrobat, или же с использованием плагинов сторон-
них производителей.
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Эта глава знакомит с некоторыми базовыми
средствами редактирования, предлагаемые
Enfocus PitStop Professional. Здесь вы найдете

всю информацию, в которой вы нуждаетесь при ко-
пировании и вставке атрибутов, измерении расстоя-
ний между точками в документе, добавлении и уда-
лении направляющих, и конечно, использовании
кнопок отмены и повтора.

Копирование и вставка 
атрибутов объекта 

Вы можете легко копировать атрибуты объекта и
применять все или некоторых из этих атрибутов к
другому объекту в вашем PDF документе, как иллю-
стрировано на примере ниже.

Чтобы копировать 
и вставить атрибуты объекта:

1. Нажмите на кнопку инструмента Copy and Paste
Attributes ( ). 

Появляется панель Inspector PitStop, если вы предоп-
ределили это в предпочтениях. См. раздел “Наст-
ройка предпочтений Enfocus PitStop Professional” на
странице 11.

Значок курсора изменится на и окно диалога
Inspector Enfocus  PitStop изме- нится соответ-
ственно.

2. Удерживая клавишу Ctrl (значок курсора изме-
нится на ), щелкните на объекте, чтобы ско-
пировать его атрибуты.

Скопированные атрибуты окажутся выбранными в
панели Inspector PitStop.

3. В случае необходимости, снимите выделение ат-
рибутов, которые вы не желаете вставлять в целе-
вой объект.

4. Вновь изменившимся курсором щелкните
на объекте, в который вы желаете вставить выб-
ранные атрибуты.
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Отмена и повтор действий

Вы можете отменить любые изменения (если не сох-
раняли файл), которые вы сделали с помощью лю-
бого из инструментальных средств PitStop Professio-
nal. После отмены одного или нескольких действий,
вы можете повторить их снова.

Если вы работаете с Sertified PDF документа-
ми, вы можете даже отменить действия после
того, как вы сохранили файл. См. также раз-
дел “Сохранение снимков” на странице 43.

Предположим, что вы сделали следующие измене-
ния с текстовым сегментом:

• Вы переместили текстовый сегмент в другую пози-
цию на странице.

• Вы повернули его на 45° против часовой стрелки.

Чтобы отменить и восстановить ваше последнее
действие:

1. Выберите Edit > Undo Rotate или в Acrobat наж-
мите кнопку ( ).

Название вашего последнего действия появляется в
команде меню. Если вы переместили объект,  в стро-
ке меню будет прописано Undo Move.

2. Чтобы повторить действие, которое вы отменили,
выберите Edit > Redo или в Acrobat нажмите кноп-
ку ( ).

Измерение расстояния между 
двумя точками

Вы можете измерять расстояние между двумя точка-
ми в области работы вашего PDF документа. Вы мо-
жете делать это, для того, чтобы, например, вырав-
нивать объекты или проверять позиционирование

или размер объектов. Для этого вам надо использо-
вать инструмент Measure ( ) в комбинации с Ins-
pector PitStop, чтобы измерить данное расстояние.

Чтобы измерить расстояние между двумя точками в
области работы:

1. Выберите инструмент Zoom In ( ) и приблизь-
те область, в которой вы хотите измерить расстоя-
ние между двумя точками.

2. Нажмите инструмент Measure ( ).

Появится панель Inspector PitStop, если вы предоп-
ределили это в соответствующих Preferences. См.
раздел “Настройка предпочтений Enfocus PitStop Pro-
fessional” на странице 11.

3. Нажмите эти две точки, чтобы измерить расстоя-
ние между ними.

В тех позициях, где вы нажали, появятся два крести-
ка разного цвета (точка 1 и точка 2).

Inspector PitStop отобразит расстояния в данном мо-
дуле измерения, например:
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Если требуется, вы можете изменить цвет
крестиков. Для этого нажмите соответству-
ющие поля в панели Enfocus PitStop Inspector и
выберите другой цвет, как показано ниже.

Просмотр свойств объекта 
инструментом “пипетка”

С инструментом пипетка вы можете просматривать
следующие свойства любого объекта:
• Тип объекта.
• Цветовое пространство объекта.
• Установки цвета.
• Установки оверпринта.

Чтобы просмотреть свойства объекта
инструментом пипетка:

1. Нажмите кнопку инструмента EyeDropper ( ).

Появится панель Enfocus PitStop Inspector, если вы
предопределили это в Preferences.

2. Щелкните на любом тексте или объекте в PDF до-
кументе.

На панели Enfocus PitStop Inspector отобразятся свой-
ства выбранного текста или объекта.
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Вставка направляющих 
в PDF документ

С помощью Enfocus PitStop Inspector вы можете до-
бавлять PDF документ направляющие. Вы можете
также корректировать установки направляющих.

Понимание позиции направляющих

При определении позиции направляющих в области
Feedback Inspector PitStop, вы должны иметь в виду,
что позиция направляющих отчитывается, начиная
с точки 0.0 координат, расположенной в левом ниж-
нем углу страницы.

Позиция направляющей рассчитана, начиная с
нижнего левого угла страницы.

Чтобы вставлять 
и корректировать направляющие:

1. Выберите инструмент Guides ( ).

Появится панель Inspector PitStop, если вы предоп-
ределили это в соответствующих Preferences. См. раз-
дел “Настройка предпочтений Enfocus PitStop Pro-
fessional” на странице 11. Inspector PitStop изменится
соответственно.

2. Чтобы создать новую горизонтальную или верти-
кальную направляющую, нажмите соответствую-
щую кнопку в области New Guides (Новая направ-
ляющая).

Новая направляющая окажется центрированной на
экране.

3. Нажмите на направляющей, чтобы выбрать ее и
переместите ее в желательную позицию. Если у вас
есть и горизонтальная и вертикальная направляю-
щие, вы можете переместить обе, нажав в центре
их пересечения.
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Для точного позиционирования — перетащи-
те направляющую, глядя на значения в облас-
ти Feedback на панели Inspector PitStop. См.
раздел “Понимание позиции направляющих”
на странице 28 для получения дополнительной
информации.

4. В случае необходимости, корректируйте предпоч-
тения направляющих в области Preferences.

Вы можете:

• Выбрать цвет для горизонтальных или вертикаль-
ных направляющих, нажав пробник цвета и выб-
рав новый цвет (вы можете также изменять яр-
кость для выбранного цвета, используя сдвиг в
хроматическом круге), как показано ниже. 

• Отобразить или скрыть направляющие, выделив
или сняв выделение соответствующей “галочки”.

• Сделают направляющие магнитными — так, чтобы
объекты, которые вы перемещаете, привязывались
к ним, — и определить величину магнитной облас-
ти вокруг направляющих.

• Установить единицы измерения.

Удаление направляющих 
в PDF документе

Если вы хотите удалить одну или несколько направ-
ляющих, вы можете сделать это, используя инстру-
мент Guides ( ).

Чтобы удалить направляющие 
из PDF документа

1. Выберите инструмент Guides ( ).

2. Поместите курсор поверх направляющей, кото-
рую вы хотите удалить.

Когда курсор установлен точно над направляющей,
он примет следующий вид .

3. Чтобы удалить направляющую перетащите ее за
пределы страницы.

Удаление направляющей перемещением ее за страницу.

Возможно, вам придется перетащить направ-
ляющую далеко в сторону от края страницы,
прежде чем она исчезнет. Причина этого —
то, что направляющие удаляются, только
когда перемещены за границу самых больших
из рамок страницы (обычно это бокс устрой-
ства, который не всегда видим в Adobe Acro-
bat). См. раздел “Просмотр рамок страницы: 
дообрезной и обрезной форматы PDF докумен-
та” на странице 21 для получения дополните-
льной информации.
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Enfocus Sertified PDF TM — концепция рабочего
потока PDF с программным обеспечением En-
focus. Вы можете использовать ее для безопас-

ного обмена и редактирования PDF документов с
полной конфиденциальностью.

Относительно Sertified PDF

Sertified (Сертифицированный) PDF — концепция
рабочего потока с использованием PDF файлов, раз-
работанная Enfocus, основываясь на запросах заказ-
чика и требованиях промышленных экспертов. Кон-
цепция Sertified PDF предназначена для решения
трех основных проблем, перед которыми стоит
большинство пользователей, применяющих рабо-
чий поток с использованием PDF файлов:

• Как гарантировать, что PDF документ был успешно
проверен с определенным PDF профилем.

• Как поддерживать последовательность между ис-
ходным и целевым PDF документом, когда незна-
чительные изменения могут применяться к PDF
документу на каждом этапе рабочего процесса.

• Как минимизировать риск и ответственность при
изменении PDF документа заказчика перед заклю-
чительным выводом.

Гарантируемая проверка

Проблемы проверки

Preflying — процесс проверки PDF документа по раз-
личным критериям, чтобы гарантировать, что PDF
документ удовлетворяет всем требованиям вывода
или публикации. Как правило, критерии изменяют-
ся в зависимости от особенностей издательского
процесса. Набор критериев, соответствующих тре-

бованиям отдельного издательского процесса назы-
вается “PDF профиль”.

Enfocus PitStop Professional позволяет вам создать
PDF профиль, который проверяет ваш PDF доку-
мент на наличие различных критериев, например,
использования шрифта и цвета. Кроме того, вы мо-
жете использовать Enfocus PitStop Professional, что-
бы обнаружить фактические проблемы в своих или
чужих PDF документах.

В идеале, PDF документ должен быть проверен на
ранней стадии рабочего процесса, то есть, как толь-
ко он был создан. Это особенно актуально, если PDF
документ передается от создателя PDF документа его
получателю, например, в издательство или типогра-
фию. Создатель PDF документа сэкономит время и
деньги, если обнаружит проблемы в PDF документе
раньше, чем отправит файл его получателю.

Вы также можете создавать Sertified PDF доку-
менты с помощью Enfocus PDF Instant. Для полу-
чения дополнительной информации, посетите
наш web-сайт по адресу: www.enfocus.com.

Проверка при рабочем потоке 
с Sertified PDF

Рабочий поток с Sertified PDF поддерживает следую-
щие виды проверки:

• Простой и верный способ проверки PDF докумен-
та — проверять файл с помощью PDF профиля,
предоставленного получателем PDF документа.

• Включение PDF профиля и рапорта проверки в
предоставляемый PDF документ. Этот способ га-
рантирует проверенное состояние PDF документа.

Enfocus PitStop Professional
Руководство пользователя

30

Глава 4: Работа с Sertified PDF документами 



• Предоставление прямого интерфейса пользовате-
ля, который дает возможность получателю PDF до-
кумента удостовериться, что документ был успеш-
но проверен предоставленным профилем.

Вышеупомянутые особенности помогают:

• Мотивировать создателя PDF документа для его
фактической проверки.

• Уменьшить число проблем в файлах, полученных
от создателя PDF документа.

Последовательность документа

Отредактированные версии PDF 

Инструменты редактирования PDF, типа Enfocus
PitStop Professional, очень удобны для создания про-
межуточных или последних исправлений в PDF
документах. Они экономят время и деньги, посколь-
ку вам не нужно возвращаться к первоначальному
приложению, чтобы переделать PDF документ.
Иногда, даже более эффективно сделать изменения
непосредственно в PDF документе. Enfocus PitStop
Professional, например, позволяет вам делать гло-
бальные изменения цвета внутри всего PDF докумен-
та. См. также главу “Автоматизация задач” на стра-
нице 79.

Однако редактирование PDF также имеет и оборот-
ную сторону: как только вы редактируете и сохра-
няете PDF документ, вы создаете версию документа,
которая отличается от оригинала, как правило,
сгенерированного с использованием текстового
редактора или другого программного обеспечения
настольной издательской системы. Эти изменения
трудно зарегистрировать и, таким образом, этот
аспект может представлять проблемы для архивиро-
вания PDF документа или его последующего переиз-
дания.

Редактирование PDF в рабочем потоке с
Sertified PDF документами

Чтобы уменьшить проблемы в рабочем потоке с Ser-
tified PDF документами, существует следующий ме-
ханизм:

• Все изменения, которые сделаны в Sertified PDF до-
кументе, вносятся в протокол.

• Последовательность этих изменений сохраняется
внутри Sertified PDF документа.

Основываясь на этой информации, генерируется
читаемое сообщение — протокол редактирования.

Если очень важно сопоставление между целевым
PDF документом и исходным оригиналом, вы може-
те использовать протокол редактирования, чтобы
соответственно изменить исходный файл. Чтобы
помочь в этом процессе, Sertified PDF документ мо-
жет также сохранить ссылку на исходный файл, из
которого PDF документ был создан. Вы можете ис-
пользовать эту ссылку, чтобы удостовериться, что
исходный файл не был отредактирован со времени
создания PDF документа.

Ответственность

Проблемы ответственности

Изменения, сделанные получателем PDF документа,
который был создан кем-то другим, могут создать
неоднозначную ситуацию относительно того, кто
является в конечном счете ответственным за фина-
льный результат.

Множество сервисных бюро, системных служб и т. д.
категорически отказываются делать любые измене-
ния в документах заказчика из страха принять на
себя ответственность, если что-нибудь пойдет не так
как надо. Это включает проблемы, которые могут
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быть полностью связаны даже с незначительными
исправлениями.

Ответственность в рабочем потоке 
с Sertified PDF документами

Рабочий поток с Sertified PDF документами отчасти
улаживает проблему ответственности, он предостав-
ляет:

• Обеспечение детального рапорта всех изменений,
сделанных в PDF документе.

• Слежение за процессом редактирования PDF, — то
есть, кто редактировал, какие изменения сделал и
когда.

• Осуществление механизма “обратной перемотки”,
который позволяет вам легко вернуться к предва-
рительно сохраненному состоянию — “снимок” —
вашего PDF документа.

• Возможность сравнивать любые два снимка визу-
ально, чтобы найти и проанализировать отличия.
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Обзор рабочего потока 
с Sertified PDF документами

Процесс сертифицирования Sertified PDF основан на
следующих принципах:

• Принцип сохранения изменений с приращением. 
• Механизм “обратной перемотки”.

Обычный рабочий поток с PDF

В обычном рабочем потоке PDF, документ проходит
через руки различных сторон, которые могут редак-
тировать его, в случае необходимости. Оригинал
PDF документа заменяется отредактированной вер-
сией, как показано на рисунке ниже:

Рабочий поток с Sertified PDF: 
сохранение изменений с приращением

В процессе сертифицирования с Sertified PDF, все
изменения, сделанные в PDF документе, зарегистри-

рованы в сессиях и сохранены в протоколе редакти-
рования. Также, отредактированные PDF документы
сохранены с приращением. Это означает, что изме-
нения, сделанные в PDF версии 3, например, сохра-
нены “на вершине” изменений, сделанных в PDF
версии 2, и т. д. но физически вы сохраняете только
один файл PDF. 
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Принцип сохранения изменений с приращением не
обязательно намного увеличивает размер файла PDF
документа, поскольку Adobe Acrobat сохраняет толь-
ко изменения, сделанные в течение различных сес-
сий. Однако различие в размере файла может стать
очевидным, если вы удаляете большое количество
объектов, потому что эти объекты поддерживаются
в одной или нескольких версиях.

Механизм обратной перемотки

Процесс сертифицирования Sertified PDF также пред-
лагает вам механизм обратной перемотки. Каждый
раз, когда вы сохраняете ваш документ, в PDF файл
включается “снимок” сохранения. Снимок можно
сравнить с отображением состояния PDF документа
во время сохранения. Это позволяет вам вернуться к
любой предыдущей стадии в рабочем потоке с Serti-
fied PDF и сравнить различные версии вашего PDF
документа, притом, что физически вы имеете один и
тот же файл. См. также раздел “Сохранение сним-
ков” на странице 43.

Что такое Sertified PDF документ?

Любой обычный PDF документ содержит metadata
(метаданные), то есть информацию относительно
непосредственно самого документа. Окно диалога
Document Summary (Резюме документа) Adobe Acro-
bat, например, содержит следующие метаданные.
(См. рис.)

Enfocus Sertified PDF документ может быть снабжен
следующими метаданными:

• Ссылка на один или более исходных документов,
на которых PDF документ был основан.

• PDF профиль. 
• Рапорт проверки (Preflight report).
• Пользовательская и системная идентификация.
• Протокол редактирования (Edit Log), перечисляю-

щий все изменения, сделанные в PDF документе в
течение сессии редактирования (время, в течение

которого PDF документ был открыт, отредактиро-
ван и сохранен).

• Комментарии сессии (Session comments).

Установка  идентификации 
пользователя Sertified PDF

Sertified PDF документ может содержать два типа
идентификации пользователя: персональная ин-
формация и системная информация. Каждый тип
служит своим целям:

• Персональная информация — информация о ва-
шем имени и контактах вашей компании, вместе с
сообщением. Вы можете заполнить форму так,
чтобы люди знали, как связаться с вами, если у них
возникнут вопросы относительно редактирования
или проверки, сделанных в PDF документе.

• Системная информация состоит из информации
об имени пользователя, на которого зарегистриро-
ван Enfocus PitStop Professional и информации о ва-
шей операционной системе, сети и компьютере.
Эта информация не может быть изменена и поэто-
му является надежным источником, чтобы точно
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определить ответственность. Если люди могут от-
казаться от ответственности за какое-либо измене-
ние, сделанное в PDF документе, системная инфор-
мация обеспечит бесспорное доказательство. Эта
информация будет использоваться в протоколе ре-
дактирования (Edit Log), чтобы показать, кем сде-
ланы изменения в данной сессии.

Чтобы установить пользовательскую идентификацию:

1. Выберите Sertified PDF > Show Personal Info.

2. Заполните форму вашей персональной информа-
цией.

Введите столько информации сколько возможно.
Заполнять всё необязательно.

3. Нажмите OK.

Чтобы просмотреть системную информацию:

1. Выберите Sertified PDF > Show Personal Info.

2. Нажмите закладку System.

3. Если у вас установлено больше чем одна програм-
ма Enfocus, выберите Enfocus PitStop Professional в
списке Application (Приложения).

4. Нажмите OK.

Добавление комментариев сессии

Механизм  Sertified PDF в PitStop дает вам возмож-
ность расширить качество вашего рабочего потока
PDF, добавляя комментарии в протокол редактиро-
вания (Edit Log). Например, при отправке вашего
PDF документа издателю, возможно, вы захотите
объяснить, почему данные изменения были сделаны.
Вы можете добавить комментарии в сессии редакти-
рования. Сессия — время, в котором вы редактируе-
те и сохраняете PDF документ.

Чтобы добавить комментарии сессии:

1. Выберите Sertified PDF > Edit Properties (Редакти-
ровать свойства).

2. Добавьте комментарий новой сессии или измени-
те комментарий текущей сессии.

3. Нажмите OK.

Кнопка состояния Sertified PDF документа

Enfocus PitStop Professional добавляет специализиро-
ванную кнопку состояния Sertified PDF ( ) в инст-
рументальную панель File Adobe Acrobat. Вид этой
кнопки изменяется в зависимости от состояния PDF
документа, с которым вы работаете:
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Вид кнопки Значение

• Текущий PDF документ — не Sertified PDF
документ. Нажмите эту кнопку, чтобы запу-
стить процесс сертифицирования PDF.

• Текущий PDF документ — Sertified PDF до-
кумент, который был успешно проверен.
Нажмите эту кнопку, чтобы увидеть состо-
яние документа.

• Текущий PDF документ — Sertified PDF до-
кумент, который не был успешно проверен.

• Профиль Sertified PDF не соответствует ни
одному из PDF профилей в списке, кото-
рый вы видите в Profile Editor (Редакторе
PDF профиля). Нажмите эту кнопку, чтобы
увидеть состояние документа.



Запуск процесса сертифицирования 
PDF документа

Запуск процесса сертифицирования PDF документа
означает, что вы обеспечиваете документ информа-
цией, необходимой для рабочего потока с Sertified
PDF. Как только вы запустили процесс сертифи-
цирования PDF для документа, любое изменение,
сделанное в документе, будет зарегистрировано в
сессии редактирования и может быть отслежено в
протоколе редактирования. См. также раздел “Про-
смотр протокола редактирования” на странице 42.

Запуск процесса сертифицирования PDF документа

Процесс сертифицирования PDF дает возможность:

• Определить один или более исходных документов,
на основе которых ваш PDF документ был создан,
и сохранить ссылку на эти документы в вашем PDF
документе.

• Выбрать PDF профиль, который вы хотите прикре-
пить к вашему PDF документу. Профиль сохра-
няется внутри Sertified PDF документа для дальней-
шего использования.

• Ввести комментарий сессии. Эти комментарии бу-
дут сохранены внутри Sertified PDF документа.

Чтобы запустить процесс сертифицирования PDF:

1. Откройте PDF документ, для которого вы хотите
запустить процесс сертифицирования.

2. Выберите Sertified PDF > Start или нажмите кноп-
ку ( ).

Если вы внесли любые изменения в ваш PDF
документ, вы должны сохранить его прежде,
чем вы запустите процесс сертифицирова-
ния. Если вы не сделаете этого, появится сле-
дующее предупреждение.

Затем появится следующее окно диалога.

3. Нажмите Add, чтобы добавить ссылку на один или
более исходных файлов, на основании которых
ваш PDF документ был создан.

Рекомендуется добавить ссылку на исходный
файл(ы) на этой стадии. Эта информация не
может быть добавлена позже в процессе сер-
тифицирования  PDF.
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4. В случае необходимости, определите PDF про-
филь, который будет использован для проверки
вашего PDF документа:

• Выберите PDF профиль из списка PDF профилей.
Список PDF профилей содержит те же самые PDF
профили, что и панель управления PDF профиля-
ми Enfocus PitStop.

или

• Нажмите Browse. Выберите файл PDF профиля в
данной папке и затем нажмите Open, как показано
на примере ниже.

5. В случае необходимости, введите комментарий
для данной сессии. Чтобы начать новый параграф,
сделайте одно из следующего:

• В Windows нажмите Ctrl+Enter.
• На Macintosh нажмите Enter.

6. Нажмите OK.

Начнется процесс сертифицирования для данного
PDF документа. Появится следующее сообщение:

7. Сделайте одно из следующего:

• Нажмите Now для проверки вашего PDF документа
немедленно. В случае необходимости, введите ком-
ментарий для сессии в окне диалога Preflight and
Save и нажмите OK. После проверки документа по-
явится рапорт проверки.

• Нажмите Later (Позже), если вы не хотите в дан-
ный момент проверять ваш PDF документ. 

Для получения дополнительной информации отно-
сительно проверки (preflying), см. главу “Предпечат-
ная проверка  PDF документов” на странице 65.

Обеспечение Sertified PDF 
документа рабочей информацией

Относительно рабочей информации 

Sertified PDF документы можно обеспечивать рабо-
чей информацией (Job Info). Рабочей информацией
может быть любой вид информации относительно
PDF документа, который вы хотели бы совместно
использовать с получателем PDF документа. Эта ин-
формация может включать, например:

• Имя, компания, адрес и контакт отправителя до-
кумента — для того, кому PDF документ (в конеч-
ном счете) предназначен.

• Любые дополнительные замечания, которые полу-
чатель PDF документа должен знать. Это может
быть, например, детали относительно того, как
PDF документ должен быть напечатан или что дол-
жно случиться затем с PDF документом.

Чтобы обеспечить Sertified PDF документ рабочей
информацией:

1. Выберите Sertified PDF > Show Job Info.

2. Заполните поля имени, адреса компании и других
контактов для получателя PDF документа.
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3. В текстовом поле Message введите дополнитель-
ные комментарии или замечания для получателя
PDF документа. 

4. Нажмите OK.

Проверка оригинального 
документа

Вы можете добавить ссылки в своем Sertified PDF до-
кументе на один или несколько исходных базовых
файлов, на которых был основан ваш PDF. Эта воз-
можность предоставляет вам или получателю PDF
удобный способ найти соответствующие исходные
файлы; а также — проверить, изменились ли эти ис-
ходные файлы, начиная с момента, когда был запу-
щен процесс сертифицирования для данного PDF
документа. Если вы хотите “синхронизировать” ис-
ходный файл с отредактированным PDF докумен-
том, вам стоит использовать сообщения протокола
редактирования (Edit Log), чтобы применить изме-
нения отредактированного PDF документа к исход-
ному документу. В этом случае вы будете точно
знать, что работаете в правильной версии исходного
файла.

Чтобы проверить исходный документ:

1. Выберите Sertified PDF > Verify Original Document
(Проверить оригинальный документ). Появится
следующее окно диалога:

2. Проверьте статус исходного документа.

Вы найдете детальную информацию относительно
даты создания, модификации и исходного приложе-
ния PDF документа в области Document Info (Ин-
формация о документе).

3. Сделайте одно из следующего:

• Если статус исходного документа “Identical” (Иден-
тичен), это означает, что исходный документ не из-
менялся со времени запуска процесса сертифици-
рования Sertified PDF. Вы можете применять изме-
нения, перечисленные в файле протокола редакти-
рования (Edit Log), к исходному документу.

• Если статус исходного документа “Different” (Отли-
чающийся), это означает, что исходный документ
изменился с момента запуска процесса сертифици-
рования для PDF документа. Если возможно, снача-
ла проверьте различные версии исходного докумен-
та прежде, чем вы синхронизируете любой из этих
исходных документов со своим PDF документом.

• Если статус исходного документа “Missing” (Отсут-
ствует), это означает, что исходный документ был
либо перемещен, либо переименован либо удален.
Выберите строку соответствующего документа, и
нажмите кнопку Browse (Обзор). Найдите местопо-
ложение соответствующего исходного документа
или выберите его с новым именем и нажмите Open.
Исходный документ вновь появится в списке с со-
стоянием “Identical” или “Different”.

4. Нажмите OK.

Замена PDF профиля 
Sertified PDF документа

Как только PDF документ сертифицирован, к нему
можно прикрепить PDF профиль. Вы можете заме-
нить этот PDF профиль другим в любой стадии
процесса сертифицирования. Предположим, что
ваш PDF документ предназначен и для печати и для
просмотра. В соответствии с этим, вы можете при-
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крепить соответствующий PDF профиль — в зави-
симости от целевого формата.

Чтобы заменить PDF профиль в Sertified PDF доку-
менте:

1. Выберите Sertified PDF > Edit Properties (Редакти-
ровать свойства).

2. Сделайте одно из следующего:

• Выберите PDF профиль из списка PDF профилей.

• Нажмите Browse. Выберите файл PDF профиля в
данной папке и затем нажмите Open, как показано
рисунке ниже.

3. Нажмите OK.

Если вы заменяете PDF профиль и затем на-
жимаете OK чтобы сохранить изменения,
появляется предупреждение, которое запра-
шивает проверку PDF документа тотчас же
или позже. Рекомендуется  нажать Now. Ваш
PDF документ будет немедленно проверен и
сохранен с недавно выбранным PDF профилем.

Проверка и сохранение 
Sertified PDF документа

Если PDF документ сертифицирован и содержит PDF
профиль, вы можете проверить и сохранить его за
один раз. Даже те люди, у которых нет Enfocus PitStop
Professional, но есть другой Sertified PDF-совмести-
мый инструмент, типа Enfocus Instant PDF, могут сде-
лать это, если получат подобный PDF документ. 

Чтобы проверить и сохранить ваш Sertified PDF до-
кумент:

1. Выберите Sertified PDF > Preflight and Save.
Появится следующее окно диалога:

• Если PDF документ уже имеет внедренный PDF
профиль:

• Если в PDF документе нет внедренного PDF про-
филя. (Вы можете выбрать PDF профиль из ниспа-
дающего списка, или нажать Browse, чтобы вы-
брать PDF профиль на диске).
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2. В случае необходимости измените или закончите
комментарий сессии.

3. Нажмите OK для проверки и сохранения вашего
PDF документа с PDF профилем.

Как только проверка закончится, будет отображен
рапорт проверки.

Просмотр рапорта проверки

Когда вы получаете Sertified PDF документ, который
был проверен с внедренным PDF профилем, вы
можете просматривать рапорт проверки без необхо-
димости повторно делать проверку.

Чтобы просмотреть рапорт проверки:

Выберите PDF Certified > Show Preflight Report.

Сообщение проверки будет сгенерировано из сохра-
ненной базы данных и отображено, как показано на
примере ниже.

Более подробно о символах и информации в рапорте
проверки, описано в разделе “Интерпретация сооб-
щений проверки“ на странице 77.

Проверка состояния Sertified PDF

Enfocus PitStop Professional дает вам возможность
проверить состояние Sertified PDF документа и  PDF

профиля. Окно диалога Status Sertified PDF предос-
тавляет следующую информацию:

• Имя, автор и дата профиля Sertified PDF.

• Состояние профиля Sertified PDF.

• Состояние Sertified PDF документа.

Состояния профиля Sertified PDF

Enfocus PitStop Professional определяет состояние
PDF профиля, внедренного в PDF документ, сравни-
вая его с PDF профилем в вашей базе данных про-
филей. Внедренный в Sertified PDF профиль может
либо соответствовать одному из профилей в базе
данных либо не соответствовать. Соответствие PDF
профилей определяется при следующих условиях:

• Имена PDF профилей должны быть идентичны.
Имя PDF профиля — это название, сохраненное в
PDF профиле, под которым он будет идентифици-
рован. Не путайте его с именем файла профиля.
См. рисунок ниже.
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AA.. Имя PDF профиля.  BB. Имя файла PDF профиля.

• PDF профили, созданные в ранних версиях Enfocus
PitStop Server, — также известные как “профили
проверки” (“preflight profiles”) — должны иметь те
же самые установки, за исключением различии меж-
ду Do и Do & Log.

На рисунке показан пример двух соответствующих
профилей в предыдущей версии Enfocus PitStop Profes-
sional: то же самое имя профиля (AA) и те же самые
установки профиля (BB) за исключением различий
между Do и Do& Log (CC).

• PDF профили, созданные в текущей версии Enfocus
PitStop Professional должны иметь те же самые уста-
новки для пунктов “Problems to detect” (Определять
проблемы) and “Report as” (Сообщать как). Различ-
ные установки для пункта Fix this problem (Фикса-
ция этой проблемы), не принимаются во внимание.

Пример двух соответствующих профилей PDF в те-
кущей версии Profile Editor: то же самое имя профиля,
та же установка на определение проблемы и та же
самая установка сообщения об ошибке (AA). Установ-
ки на исправление проблемы могут различаться (BB).

Профиль Sertified PDF не обязательно должен
соответствовать одному из профилей в базе
данных PitStop. Вы можете отменить этот
выбор в Preferences Sertified PDF. См. раздел
“Настройка предпочтений Enfocus Sertified
PDF” на странице 11.

Чтобы проверить состояние профиля Sertified PDF:

Выберите Certified PDF > Show Status.
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Профиль Sertified PDF может иметь любое из сле-
дующих состояний:

• Он соответствует PDF профилю в базе данных En-
focus PitStop.

• Он не соответствует ни одному из PDF профилей в
базе данных Enfocus PitStop. Причина может быть,
например, в том, что имя профиля документа не
совпадает с именем профиля в базе данных PDF
профилей или установки профиля являются раз-
личными.

Состояние вашего Sertified PDF документа может
быть одним из следующих:

• Ваш PDF документ не может быть проверен, пото-
му что не был выбран профиль для проверки. Наж-
мите Select PDF Profile, и прикрепите PDF профиль.
Запустить проверку PDF документа можно позже.

• Ваш PDF документ имеет прикрепленный PDF про-
филь, но не был проверен, или же документ был
изменен со времени последней проверки. Нажмите
Preflight & Save Now.

• Ваш PDF документ был проверен, но рапорт про-
верки содержит ошибки. Нажмите Show Report, и
проверьте ошибки. В случае необходимости, изме-
ните PDF профиль, чтобы устранить обнаружен-
ные ошибки. См. главу “Предпечатная проверка
PDF документов” на странице 65.

• Ваш PDF документ был успешно проверен. Нажми-
те OK или Show Report, чтобы просмотреть резуль-
таты проверки.

Просмотр 
протокола редактирования

Механизм Sertified PDF в Enfocus PitStop Professional
сохраняет отчет каждой сессии редактирования Ser-
tified PDF документа. Таким образом, все изменения,

сделанные в PDF документе хронологически зареги-
стрированы в нем самом. Изменения можно ввести
двумя различными способами, в зависимости от
инструмента, которым они были сделаны:

• Если вы редактируете ваш PDF документ любыми
Enfocus Sertified PDF-совместимыми плагинами,
типа Enfocus PitStop Professional или Enfocus Pow-
erUp PDF, изменения немедленно сохраняются в
протоколе редактирования. Протокол редактиро-
вания будет содержать детальное описание каждо-
го изменения.

• Если вы редактируете ваш PDF документ плагина-
ми и инструментальными средствами других про-
изводителей, протокол редактирования не будет
содержать никакой информации — ни относитель-
но изменений, ни относительно программы, с по-
мощью которой эти изменения были сделаны.

Чтобы просмотреть протокол редактирования: 

Выберите PDF Certified > Show Edit Log.

Появится сообщение протокола редактирования.

Пример одной из страниц сообщений протокола 
редактирования.
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Просмотр 
хронологии документа

Механизм Sertified PDF в Enfocus PitStop Professional
позволяет вам просматривать хронологию вашего
PDF документа. Это означает, что вы можете про-
сматривать хронологический список всех сессий ре-
дактирования, через которые прошел ваш Sertified
PDF документ.

Хронологический список сессий содержит следую-
щую информацию:

• Программа Sertified PDF, в которой прошла данная
сессия редактирования.

• Человек или компания, ответственная за сессию.

• Дата и время сессии.

Чтобы просмотреть хронологию документа:

1. Выберите Sertified PDF > Show History.

Появится следующее окно диалога.

2. Выполните двойной щелчок на строке любой из
сессий, чтобы увидеть всю доступную информа-
цию относительно выбранной сессии.

Появится следующее окно диалога:

3. Нажмите закладку User или System, чтобы рассмо-
треть соответствующую информацию этой специ-
фической сессии.

4. Нажмите Close.

Сохранение снимков

Объяснение понятий снимка и механизма
обратной перемотки

В рабочем потоке Sertified PDF документ может
пройти различные сессии редактирования, сделан-
ные различными пользователями. Sertified PDF
документ “помнит” все изменения, которые были
сделаны в течение сессии, и сохраняет информацию
относительно этих изменений в сессиях (с так назы-
ваемым “приращением”) как только вы сохраняете
ваш PDF документ.
Подобный способ сохранения изменений имеет
большое преимущество: вы точно знаете, какие
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изменения были сделаны в каких сессиях и кем.
Кроме того, эти изменения могут быть представле-
ны в форме “снимка”. Снимок это “вид” состояния
PDF документа во время сохранения в конце сессии.
С помощью “снимка” вы можете не только просма-
тривать состояние PDF документа в предыдущей сес-
сии редактирования, но также сохранить этот сни-
мок как отдельный PDF документ. Это называется
механизм обратной перемотки. 
При редактировании PDF документов может сло-
житься ситуация, в которой изменение прошло уже
несколько стадий и в сумме всех изменений получа-
ется только нежелательный результат. Но этот ре-
зультат вынужден  сохраняться в PDF документе. Та-
кая ситуация не представляет проблемы в рабочем
потоке с Sertified PDF: вы можете вернуться к любо-
му предварительно сохраненному состоянию PDF
документа.

Просмотр снимка

Вы можете пользоваться снимками Sertified PDF до-
кумента следующими способами:

• Сохранить снимок под другим именем и открыть
его как обычный PDF документ.

• Сравнивать два различных снимка.

Для получения дополнительной информации при
сравнении снимков, см. раздел “Сравнение сессий”
на странице 45.

Сохранение снимка

Снимок — это визуальное представление состояния
PDF документа во время сохранения после сессии
редактирования. Вы сохраняете снимок, чтобы вер-
нуться к предыдущей версии вашего PDF документа.
Однако вы не обязательно должны сохранять этот
снимок в конце каждой сессии. Вы можете просто
выбрать любую сессию из списка и сохранить ее
снимок на любой стадии рабочего процесса.

Рассмотрим следующий пример. Вы создали Sertified
PDF документ, в котором используете только чер-
ный текст и одну дополнительную (spot) краску.
Документ был предназначен для вывода на машине
офсетной печати. В некотором пункте рабочего
процесса вам также нужно напечатать этот PDF до-
кумент на четырехкрасочной печатной машине, и
поэтому вам необходимо изменить дополнительную
краску в ее CMYK эквивалент. Для этого вы можете
использовать Enfocus PitStop Professional. Это озна-
чает, что самая последняя версия вашего PDF доку-
мента будет содержать только CMYK цвета, а проме-
жуточная версия — черный цвет и одну дополни-
тельную краску. Вы можете просто выбрать версию,
которая предназначена для печати одной дополни-
тельной краской, и сохранить ее снимок как сепари-
рованный PDF документ. После чего — послать этот
PDF файл на машину офсетной печати.

Чтобы сохранить снимок:

1. Выберите Sertified PDF > Show History. Появится
следующее окно диалога.

2. Выберите сессию, в списке которой вы хотите со-
хранить снимок.

3. Нажмите Save Snapshot for End of Session (Сохра-
нить снимок в конце сессии), чтобы соответствен-
но, сохранить снимок вашего PDF документа в кон-
це выбранной сессии.
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Появится следующее окно диалога.

4. Введите подробное название для вашего снимка и
нажмите Save. 

5. В случае необходимости, повторите шаги со 2 по 4,
чтобы сохранить дополнительные снимки.

6. Нажмите Close.

Сравнение сессий 

Возможно, на некотором этапе вашего рабочего про-
цесса,  вы захотите сравнить две версии Sertified PDF
документа, — например, если вы обнаружили незна-
чительные изменения. Вы можете сделать это двумя
способами:

• Сравнить снимки этих версий визуально, сопоста-
вив их рядом, как показано ниже.

• Сравнить их сообщения с описанием примененно-
го редактирования, как показано ниже.

Визуальное сравнение сессий 

Визуальное сравнение двух версий вашего PDF доку-
мента полезно, чтобы сразу просмотреть видимые
изменения. Идея состоит в том, что вы выбираете
две сессии и нажимаете кнопку Compare Visually.
В этом случае Enfocus PitStop Professional генерирует
два снимка, показывающих состояние PDF докумен-
та в конце соответствующих сессии и размещает оба
этих снимка рядом на экране. 

Чтобы сравнить сессии визуально:

1. Выберите Sertified PDF > Show History. 

2. Выберите одну сессию из списка сессий.

Кнопка Visually (side-by-side) сделается доступной.

AA. Выбранная сессия. 
BB. Кнопка Visually (side-by-side) сделалась доступной. 
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3. Нажмите кнопку Visually (side-by-side).

Появляется второй список сессий. Этот список сес-
сий идентичен списку в предыдущем окне диалога.

4. Выберите вторую сессию из списка сессий.

Эта сессия будет использоваться для сравнения с
первой сессией.

Кнопка Select Session отключена до тех пор,
пока вы не выберите вторую сессию из списка,
или если вы выбираете ту же самую сессию как
в предыдущем окне диалога.

5. Нажмите Select Session, чтобы сравнить две сессии,
которые вы уже выбрали.

Enfocus PitStop Professional сравнивает эти две вер-
сии и отображает их рядом на экране, показывая
различия, как показано в примере ниже.

Сравнение сессий с использованием 
протокола редактирования (Edit Log)

Вы можете также использовать протокол редактиро-
вания, чтобы сравнить две версии вашего Sertified
PDF документа. Это рекомендуются, если вы знаете,
что изменения были сделаны, но не видны на экра-
не, например, изменены установки треппинга или
изменены “скрытые” объекты в слоях.

Чтобы сравнить сессии, используя протокол редак-
тирования:

1. Выберите Sertified PDF > Show History.

2. Выберите одну сессию из списка сессий.

Кнопка Using the Edit Log сделается доступной.

AA. Выбранная сессия.
BB. Кнопка Using the Edit Log сделалась доступной. 

3. Нажмите кнопку Using the Edit Log.

Появится второй список сессий. Этот список сессий
идентичен списку в предыдущем окне диалога.

4. Выберите вторую сессию из списка сессий.

Этот сессия будет использоваться для сравнения с
первой сессией.
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Кнопка Select Session отключена до тех пор,
пока вы не выберите вторую сессию из списка,
или ту же самую сессию как в предыдущем окне
диалога.

5. Нажмите Select Session, чтобы сравнить обе сес-
сии, которые вы выбрали.

Первый снимок открыт, и появляется окно диалога
Edit Log Navigator, как показано ниже:

6. Выберите одно из изменений в списке.

В окне документа будут показаны изменения — до-
бавится прозрачный цветной тон поверх объекта на
странице как показано ниже.

Вы можете изменить цвет прозрачного тона
в Preferences. Выберите Edit > Preferences > En-
focus Sertified PDF и щелкните на цветном
прямоугольнике первичного цвета подсветки
(primary highlight color).

7. Используйте кнопку Toggle, чтобы переключаться
между первым и вторым снимками.

Навигатор протокола редактирования (Edit Log Na-
vigator) отображает только изменения на текущей
странице документа. Если вы переходите к другой
странице PDF документа, навигатор протокола ре-
дактирования обновляет список изменений, соответ-
ствующих новой странице.
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Enfocus PitStop Professional позволяет вам делать
глобальные изменения в вашем PDF докумен-
те, связанные с объектами или страницами.

Для этого используйте панель Enfocus PitStop Global
Change. Внутри PDF документа вы можете изменять
следующее:

• Цвет.

• Шрифт.

• Установки оверпринта (Overprint).

• Минимальную толщину линий объектов.

• Разрешение изображений.

• Размер, позицию или ориентацию содержимого
страницы.

• Рамки страницы.

• Нумерацию страниц.

• Есть возможность удаления объектов внутри или
вне выбранной области.

Глобальное изменение цвета

Вы можете изменить любой цвет внутри вашего
PDF документа. Например, это может быть цвет вы-
бранного текста или цвет из вашей библиотеки цве-
тов. См. раздел “Работа с библиотекой цветов” на
странице 141.

Чтобы сделать глобальное изменение цвета:

1. Выберите Edit > PitStop Global Change, чтобы на
экране появилась панель глобальных изменения.

Закладка Object и закладка Color — отображены по
умолчанию.

2. В левой  области окна “From” сделайте одно из сле-
дующего:

• Чтобы изменить цвет из набора, нажмите кнопку
Load в области Repository Color (Библиотека цве-
тов). Затем выберите цвет из библиотеки, который
вы желаете изменить в PDF документе. Удостоверь-
тесь, что этот цвет используется в текущем PDF до-
кументе.

• Чтобы изменить цвет определенного текстового
сегмента или объекта, выберите текстовый сегмент
или объект, используя инструмент выбора объек-
тов ( ), и нажмите Grab Fill (Захват заполнения)
или Grab Stroke (Захват обводки), чтобы скопиро-
вать цвет заполнения или обводки, соответственно,
в панель глобальных изменений.
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• Чтобы изменить цвета в пределах определенного
диапазона RGB или CMYK, нажмите соответствую-
щую опцию и определите диапазон в текстовых
полях в градациях 0–255 для RGB и в процентах для
CMYK.

3. В правой области окна “To” сделайте одно из сле-
дующего:

• Чтобы изменить цвет на цвет из набора, нажмите
кнопку Load в области Repository Color (Библиоте-
ка цветов) и выберите соответствующий цвет.

• Чтобы изменить цвет на цвет определенного тек-
стового сегмента или объекта, выберите текстовый
сегмент, или объект, используя инструмент выбора
объектов ( ) и нажмите Grab Fill (Захват запол-
нения) или Grab Stroke (Захват обводки), чтобы ско-
пировать цвет заполнения или обводки, соответст-
венно.

• Чтобы изменить цвета в пределах определенного
диапазона RGB или CMYK, нажмите соответствую-
щую опцию и определите диапазон в текстовых
полях в градациях 0–255 для RGB и в процентах для
CMYK.

4. В области “Apply to” выберите часть PDF докумен-
та, к которому вы хотите применить изменения:

• выбранный объект(ы);

• текущая страница;

• одна или несколько страниц, диапазон которых
может быть обозначен дефисом (-) или разделен
запятой;

• целый документ.

5. Нажмите кнопку Apply (Применить) или Save as
Action List (Сохранить как список действий), если
вы желаете создать макрос с этими изменениями.
См. также раздел “Создание списка действий” на
странице 82.

Глобальное изменение шрифта

Enfocus PitStop Professional позволяет вам изменять
один или большее количество шрифтов в выборке,
на странице, на нескольких страницах или в целом
документе. Вы можете изменить любое из следую-
щих свойств:

• Шрифт.

• Кегль шрифта в пунктах.

• Интервал между символами.

• Интервал между словами.

Чтобы сделать глобальное изменение шрифта:

Быстрый доступ: Выберите Edit > Show
PitStop Global > Change > Object > Font.

1. Выберите Edit > Show PitStop Global Change, чтобы
изобразить окно диалога глобальных изменений.

2. Выберите закладку Object, затем перейдите на за-
кладку Font окна диалога глобальных изменений.
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3. В области “From” сделайте одно из следующего:

• Чтобы изменить шрифт, который присутствует на
отображенной странице или в PDF документе, на-
жмите кнопку Picker, выберите шрифт из списка на
закладке Page или Document и нажмите OK.

• Чтобы изменить шрифт, названия которого вы не
знаете, откройте страницу, содержащую этот
шрифт, и выберите текстовый сегмент, используя
инструмент выбора объектов ( ). Затем нажми-
те кнопку Grab. Имя шрифта появится в текстовом
поле.

• Чтобы изменить любой шрифт в PDF документе,
нажмите Any Font.

4. В случае необходимости, ограничьте изменение до
определенного диапазона кеглей.

Допустим, у вас есть документ, в котором весь текст
набран шрифтом Times. Основные заголовки разме-
ром 16 пунктов должны быть оставлены без изме-
нений, принимая во внимание, что весь основной
текст должен быть заменен на Helvetica. В этом слу-
чае, вы можете определить, что только шрифт Times
в пределах от 0 до 15 пунктов должен быть изменен
на Helvetica.

5. В области “To” определите те свойства шрифта, на
которые вы хотите изменить шрифт документа.
Вы можете желать делать один или большее коли-
чество следующего:

• Выберите шрифт с помощью picker или grab, точно
так же как вы сделали это в области “From”.

• Выберите кегль в пунктах (Point Size) и введите со-
ответствующее значение в текстовом поле.

• Выберите значения для межбуквенного интервала
(Character) и межсловного интервала (Word) с оп-
ределением значения для кегельной шпации (em) в
соответствующем поле ввода. Пробел кегельной
шпации — той же самой ширины, что и кегль в

пунктах шрифта, который вы используете. Напри-
мер, если вы используете Times 10 пунктов, пробел
кегельной шпации также составит 10 пунктов.

6. В области “Apply to” выберите часть PDF докумен-
та, к которому вы хотите применить изменения:

• выбранный объект(ы);

• текущая страница;

• одна или несколько страниц, диапазон которых
может быть обозначен дефисом (-) или разделен
запятой;

• целый документ.

7. Нажмите кнопку Apply (Применить) или Save as
Action List (Сохранить как список действий), если
вы желаете создать макрос с этими изменениями.
См. также раздел “Создание списка действий” на
странице 82.

Изменение установок оверпринта и
нокаута для черного и белого текста
на цветных плашках

Оверпринт для черного текста 

Черный текст — особенно малого кегля — трудно
печатать на цветном фоне без наложения. В этом
случае даже небольшое несовмещение оттисков пе-
чатной машиной может стать значимым, поскольку
могут появиться промежутки между текстом и ос-
новным цветным фоном. 

Чтобы избежать этой проблемы, вы можете опреде-
лить, чтобы весь черный текст печатался поверх
любого цветного фона. Эта методика известна как
оверпринт. Печать черного текста с оверпринтом
сохраняет четкость текста и, соответственно, его чи-
табельность.
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Печатаясь поверх фона, черный текст устраняет
проблему возможного несовмещения оттисков.

Вы можете определить оверпринт только для 100 %
черного текста, поскольку печать текста некоторых
других цветов по цветному фону, мог бы за счет на-
ложения смешать краски и произвести нежелатель-
ные цвета.

Создание нокаута для белого текста 

Когда печатается белый текст, цвета позади текста не
должны печататься. Другими словами, белый текст
должен выбить (knockout) цвета на других сепара-
циях.

Чтобы изменить установки оверпринта для черного
или белого текста:

Быстрый доступ: Выберите Edit > Show Pit-
Stop Global Change > закладка Object > заклад-
ка Prepress.

1. Откройте PDF документ, в котором вы хотите из-
менить установки оверпринта.

2. В случае необходимости, выберите черный или бе-
лый текст на цветном фоне, используя инструмент
выбора объектов ( ).

3. Выберите Edit > Show PitStop Global Change, чтобы
отобразить окно диалога Enfocus PitStop Global
Change.

4. Выберите закладку Object > закладку Prepress окна
диалога Enfocus PitStop Global Change.

5. Активируйте одну или обе из опции области Over-
print для черного или белого текста.

6. В области Apply to выберите часть PDF документа,
к которому вы хотите применить изменение:

• выбранный объект(ы);

• текущая страница;

• одна или несколько страниц, диапазон которых
может быть обозначен дефисом (-) или разделен
запятой;

• целый документ.
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7. Нажмите кнопку Apply (Применить) или Save as
Action List (Сохранить как список действий), если
вы желаете создать макрос с этими изменениями.
См. также раздел “Создание списка действий” на
странице 82.

Изменение минимальной толщины
линий объектов

При создании PDF документа, содержащего очень
тонкие линии, например, линии 0,03 pt, имеется
очень большая вероятность, что эти линии исчезнут,
когда документ будет выводиться с высоким разре-
шением, например, на фотонаборном аппарате.
Чтобы избежать этой проблемы, вы можете опреде-
лить минимальную толщину линии для всех объек-
тов в PDF документе равной, например, 0,25 pt.

Чтобы изменить минимальную толщину линий
объектов:

Быстрый доступ: выберите Edit > Show Pit-
Stop Global Change > закладку Object > закладку
Prepress.

1. Откройте PDF документ, в котором вы хотите оп-
ределить минимальную толщину линий объектов.

2. Выберите Edit > Show PitStop Global Change, по-
явится окно диалога Enfocus PitStop Global Change.

3. Выберите Object > закладку Prepress окна диалога
Enfocus PitStop Global Change.

4. В случае необходимости, выберите другие едини-
цы измерения из списка. Толщина линии обычно
измеряется в пунктах.

5. Выберите опцию Line Weight и определите мини-
мальное значение толщины линий в текстовом
поле.

6. В области Apply to выберите часть PDF документа,
к которому вы хотите применить изменение:

• выбранный объект(ы);

• текущая страница;

• одна или несколько страниц, диапазон которых
может быть обозначен дефисом (-) или разделен
запятой; 

• целый документ.

7. Нажмите кнопку Apply (Применить) или Save as
Action List (Сохранить как список действий), если
вы желаете создать макрос с этими изменениями.
См. также раздел “Создание списка действий” на
странице 82.

Пересчет пиксельных изображений 

Пересчет изображений означает уменьшение их раз-
решения (числа пикселов) и, следовательно, сокра-
щение размера PDF файла. Вы можете делать это по
следующим причинам:

• Чтобы ускорить обработку при редактировании
или печати PDF документов, содержащих пиксель-
ные изображения.

• Чтобы скорректировать разрешение изображений
(dpi) до их заключительной линиатуры растра вы-
водного устройства, выраженной на линиях в дюйм
(lpi).
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• Чтобы подготовить PDF документ для интернета.

Хорошее правило для определения оптимального
разрешения — следующее:

Линиатура растра (например, 150 lpi) × 2 = разреше-
ние изображения (300 dpi).

Используя Enfocus PitStop Professional, вы можете пе-
ресчитать изображения любым из следующих спосо-
бов:

• Среднее уменьшение (Average).

• Центрическое уменьшение (Subsampling).

• Бикубическое уменьшение (Bicubic).

Более подробно эти методы пересчета объясняются
ниже.

Среднее уменьшение (Average)

Один способ сокращения разрешения ваших изо-
бражений и размера файла — среднее уменьшение.
Enfocus PitStop Professional вычисляет среднее число
пикселов в области сэмпла. Это среднее число заме-
няет целую область со средним цветом пиксела в
указанном разрешении.

Центрическое уменьшение (Subsampling)

Центрическое уменьшение означает, что пиксел в
центре типовой области становится контрольной
точкой. Окружающие пикселы берут свои значения
от среднего пиксела. Фактически, средний пиксел
заменяет целую область в указанном разрешении. 

Бикубическое уменьшение (Bicubic)

Бикубическое уменьшение означает, что каждому
пикселу в типовой области дается различное значе-
ние или “вес” (weight). Enfocus PitStop Professional
вычисляет среднее число “веса” различных пиксе-
лов, чтобы определить цвет конечного пиксела. 

Чтобы пересчитать изображение:

Быстрый доступ: Выберите Window > Show
PitStop Inspector > закладка Image > закладка
Resample.

1. Нажмите инструмент выбора объектов ( ).

2. Выберите пиксельное изображение.

3. Сделайте одно из следующего:

• Чтобы уменьшить только выбранное изображение,
выберите Window > Show PitStop Inspector > за-
кладка Image > закладка Resample.
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• Чтобы уменьшить разрешения нескольких или
всех изображений внутри PDF документа, выбери-
те Window > Show PitStop Global Change > закладка
Object > закладка Image.

4. Выберите из списка метод пересчета:

• Среднее уменьшение (Average).

• Центрическое уменьшение (Subsampling).

• Бикубическое уменьшение (Bicubic).

5. Определите требуемое разрешение (dpi), к кото-
рому изображение должно быть пересчитано.

6. Активируйте опцию Resample above и измените
значения dpi, в случае необходимости.

Опция Resample above — пороговое значение: изо-
бражения с разрешением ниже этого значения не
будут пересчитаны. Например, если значение Re-
sample above — 100 dpi, а выбранное изображение
имеет разрешение 96 dpi, оно не будет пересчитано. 

7. Если вы используете окно диалога Enfocus PitStop
Global Change, чтобы пересчитать разрешение не-
скольких изображений вашего PDF документа,
определите страницы, на которых пересчет дол-
жен применяться.

8. Нажмите Apply.

Изображения будут пересчитаны до указанного раз-
решения.

Изменение размера, позиции и
ориентации содержимого страницы

Enfocus PitStop Professional позволяет вам управлять
содержимым страницы следующими способами:

• Перемещать содержимое.

• Масштабировать содержимое.

• Зеркально отражать содержимое.

• Поворачивать содержимое.

ППееррееммеещщееннииее  ссооддеерржжииммооггоо  ссттррааннииццыы.. Предполо-
жим, что вы хотите переделать документ с размером
25,4 × 40,7 см, под формат A4 без того, чтобы изме-
нять фактическую установку страниц вашего доку-
мента. Enfocus PitStop Professional позволяет вам
изменить позицию содержимого нечетных и четных
страниц всего вашего PDF документа, вводя новые
значения для X и Y осей. 

Перемещение объема полосы по X и Y осям.
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ММаассшшттааббииррооввааннииее  ссооддеерржжииммооггоо  ссттррааннииццыы.. Предпо-
ложим, что у вас PDF документ A4 (210 × 297 мм).
Однако вам нужен более узкий формат. Следова-
тельно, вы должны пропорционально уменьшить
содержимое страницы. Для этой цели Enfocus Pit-
Stop Professional предлагает вам специальную опцию
(Shrink to Fit). С ней вы можете приспособить содер-
жимое страницы PDF документа под любой размер
устройства. Например, если вам нужно публикацию
размером A5 вывести на формате A4, вы можете
выбрать Shrink to Fit , чтобы соответственно масш-
табировать вашу публикацию. Вы можете также ис-
пользовать коэффициент масштабирования, выра-
женный в процентах относительно текущего разме-
ра содержимого страницы.

Пропорциональное масштабирование содержимого
страницы 

ЗЗееррккааллььннооее  ооттрраажжееннииее  ссооддеерржжииммооггоо.. Enfocus PitStop
Professional предлагает вам возможность зеркально
отразить содержимое вашей страницы относитель-
но горизонтальной и вертикальной оси. Эти две воз-
можности иллюстрированы ниже.

AA.. Зеркальное отражение содержимого страницы, го-
ризонтально (слева направо): по вертикальной оси.
BB.. Зеркальное отражение содержимого страницы вер-
тикально (сверху вниз): по горизонтальной оси. 

ППооввоорроотт  ссооддеерржжииммооггоо  ссттррааннииццыы.. Вы можете ис-
пользовать стандартные функциональные возмож-
ности Adobe Acrobat, чтобы повернуть одну или нес-
колько страниц в вашем PDF документе. Однако и
страница и содержимое страницы в этом случае бу-
дут повернуты вместе. Если же вы хотите повернуть
только содержимое страницы, вы можете использо-
вать особенность поворота содержимого Enfocus
PitStop Professional. Например, вы можете сначала
изменить обрезной размер (crop box) или размер
устройства (media box), а затем повернуть содержи-
мое страницы, чтобы оно снова соответствовало уже
новой странице.

Чтобы изменить размер, позицию или ориентацию
содержимого страницы:

Быстрый доступ: Выберите Edit > Show
PitStop Global Change > закладка Page > за-
кладка Position.

1. Выберите Edit > Show PitStop Global Change, поя-
вится окно диалога Enfocus PitStop Global Change.

2. Нажмите Page > закладка Position.

3. В случае необходимости, выберите другие еди-
ницы измерения, а не пункты, которые являются
единицами измерения, отображенными по умол-
чанию.
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4. Сделайте одно из следующего:

5. В области Apply to выберите часть PDF документа,
к которому вы хотите применить изменение:

• выбранный объект(ы);

• текущая страница;

• одна или несколько страниц, диапазон которых
может быть обозначен дефисом (-) или разделен
запятой; 

• целый документ.

6. Нажмите кнопку Apply (Применить) или Save as
Action List (Сохранить как список действий), если
вы желаете создать макрос с этими изменениями.
См. также раздел “Создание списка действий” на
странице 82.

Изменение рамок страницы

Основная “физическая” структура PDF документа
состоит из рамок страницы. Рамки страницы это
своего рода скрытые фреймы в вашем PDF докумен-
те, у которых есть свои функции. Они определяют,
например, как ваш PDF документ будет отображен в
Adobe Acrobat или как он будет напечатан на устрой-
стве фотонабора или CTP.

Есть пять типов рамок страницы:

• Бокс устройства (Media box), который является фи-
зическим размером устройства, на котором PDF
документ будет отображен или напечатан. Бокс
устройства соответствует самому большому фор-
мату страницы, когда вы печатаете ваш документ в
файл PostScript или PDF. Например, если вы печа-
таете буклет A5 на странице A4, бокс устройства
будет, соответственно, иметь размер страницы A4,
то есть 210 × 297 мм.

• Кроп бокс (Crop box), который является размером
“страницы” в том формате, в котором ваш PDF до-
кумент будет отображен в Adobe Acrobat. Напри-
мер, вы можете переключиться между видом кроп
бокса и видом бокса устройства, нажав кнопку View
Page Boxes ( ).
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Переместить 
содержимое страницы

1. Выберите Move Contents. 
2. Введите значения сдвига для

четных и нечетных страниц

Масштабировать
содержимое страницы

1. Выберите Scale Contents.
2. Выберите точку привязки

(Anchor Point) и одну из опций
масштабирования

Зеркально отразить
содержимое страницы

1. Выберите Flip Contents.
2. Выберите Horizontal или

Vertical

Повернуть
содержимое страницы

1. Выберите Rotate Contents.
2. Выберите угол (Angle) на кото-

рый вы хотите повернуть со-
держимое, и точку привязки



• Бокс выхода за обрез (Bleed box), который является
условной рамкой, выведенной вокруг объектов, ко-
торые простираются за обрезными метками на
странице. 

• Обрезной бокс (Trim box), который является заклю-
чительным размером документа после печати и об-
резки.

• Художественный бокс (Art box), который является
условной рамкой, выведенной вокруг фактическо-
го содержимого страниц в ваших документах.

См. также раздел “Просмотр рамок страницы: до-
обрезной и обрезной форматы PDF документа” на
странице 21.

Чтобы изменить рамки страницы:

Быстрый доступ: Выберите Edit > Show Pit-
Stop Global Change > закладка Page > закладка
Page boxes.

1. Выберите Edit > Show PitStop Global Change, по-
явится соответствующее окно диалога.

2. Нажмите Page > закладка Page boxes  в окне диалога
Enfocus PitStop Global Change, как показано ниже.

AA.. Изменяемый бокс страницы. 
BB.. Бокс страницы, используемый в качестве кальки. 

3. Выберите бокс, который вы хотите изменить из
ниспадающего списка.

4. В случае необходимости, определите координаты
бокса.

5. Если вы выбрали бокс устройства (Media box), оп-
ределите, что должно произойти с содержимым
страницы:

• Содержимое сдвигается в заданном направлении.

• Содержимое пропорционально сжимается. 

6. Чтобы определить размер, к которому должен
быть приведен выбранный бокс страницы, сде-
лайте одно из следующего:

• Чтобы привести размер выбранного страничного
бокса к размерам другого бокса, выберите соответ-
ствующий бокс из раскрывающегося списка и наж-
мите Grab (Захват) (AA), как показано ниже.

• Чтобы привести размер выбранного бокса к раз-
мерам любого объекта на странице, выберите сна-
чала соответствующий объект, используя инстру-
мент выбора ( ). Затем выберите соответству-
ющую строку из списка (BB), и нажмите Grab. 
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7. Выберите абсолютные координаты или координа-
ты сдвига.

Пример ниже показывает различие между этими
двумя видами координат.

Координаты сдвига: Абсолютные координаты:
• X = 10 mm • Left = 10 mm
• Y = 30 mm • Right = 190 mm
•Width = 180 mm • Bottom = 30 mm
• Height = 230 mm • Top = 260 mm

8. В области Apply to выберите часть PDF документа,
к которому вы хотите применить изменение:

• выбранный объект(ы);

• текущая страница;

• одна или несколько страниц, диапазон которых
может быть обозначен дефисом (-) или разделен
запятой; 

• целый документ.

9. Нажмите кнопку Apply (Применить) или Save as
Action List (Сохранить как список действий), если
вы желаете создать макрос с этими изменениями.
См. также раздел “Создание списка действий” на
странице 82.

Установка обрезного бокса,
основанного на выбранном объекте 

Вы можете выбрать любой объект в вашем PDF до-
кументе и установить обрезной бокс, основанный на
этом выбранном объекте или нескольких объектах.

Чтобы установить обрезной бокс, основанный на
выбранном объекте:

1. Выберите инструмент выбора объектов ( ).

2. Выберите один или несколько объектов.

Для получения дополнительной информации,
см.  раздел “Выбор объектов” на странице 109.

3. Выберите Edit > Show PitStop Global Change, по-
явится окно диалога Enfocus PitStop Global Change.

4. Выберите закладку Page > закладку Page Boxes.

5. В случае необходимости, определите горизонталь-
ное и вертикальное поля для обрезного бокса:
X поле — горизонтальное расстояние от выбран-
ного объекта; Y поле — вертикальное.

6. Выберите Edit > PitStop Set Trimbox.

Обрезной бокс будет установлен на основании вы-
бранных объектов, включая поля, если таковые име-
ются, и отображен в данном цвете. Чтобы изменить
цвет обрезного бокса, см. “Настройка предпочтений
Enfocus PitStop Professional” на странице 11.
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Удаление объектов внутри 
или вне выбранной области

Эта особенность дает вам возможность удалять, и
текст и объекты  из вашего PDF документа на осно-
вании выбранной области. 

Чтобы удалить объекты внутри или вне выбранной
области:

Быстрый доступ: Выберите Show PitStop Glo-
bal Change > закладка Page > закладка Remove.

1. Откройте PDF документ, в котором вы хотите уда-
лить объекты.

2. Выберите Edit > Show PitStop Global Change, поя-
вится окно диалога Enfocus PitStop Global Change.

3. Нажмите Page > закладка Remove.

4. Нажмите инструмент Select Rectangular Area (Вы-
бор прямоугольной области) ( ).

5. Очертите курсором мыши прямоугольную об-
ласть на странице.

6. Нажмите кнопку Grab selected area (Захват выб-
ранной области).

7. Выберите опцию Inside area (Внутри выбранной
области) или Outside area (Вне выбранной области).
Вы можете также выбрать опцию Overlapping the area
(С наложением на область), если вы хотите включить
сегменты текста или объектов, которые накладыва-
ются на выбранную область.

8. Выберите объекты, которые вы хотите удалить:

• Только текст 

• Все типы объектов (включая текст)

9. В области Apply to выберите часть PDF документа,
к которому вы хотите применить изменение:

• выбранный объект(ы);

• текущая страница;

• одна или несколько страниц, диапазон которых
может быть обозначен дефисом (-) или разделен
запятой; 

• целый документ.

10. Нажмите кнопку Apply (Применить) или Save as
Action List (Сохранить как список действий), если
вы желаете создать макрос с этими изменениями.
См. также раздел “Создание списка действий” на
странице 82.
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Изменение нумерации страниц

Enfocus PitStop Professional позволяет вам корректи-
ровать нумерацию страниц PDF документа. Это оз-
начает, что вы можете сделать одно из следующего:

• Перенумеровать существующие номера страниц,
например, после того, как вы вставили или удалили
страницы в вашем PDF документе.

• Добавить новую нумерацию страниц в свой PDF
документ.

Закладка Page Numbers в окне диалога Enfocus Pit-
Stop Global Change, дает вам доступ и контроль над
рядом свойств нумерации страниц в вашем PDF до-
кументе.

Возможности нумерации страниц следующие:

• Выравнивание нумерации.

• Переменная последовательность номера.

• Первый номер.

• Предотвращение для новых номеров страниц от
перекрывания существующего текста.

• Нумерация только тех страниц, которые уже име-
ют номер страницы.

• Добавление белого фона.
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AA.. Выравнивание нумерации. BB.. Номер страницы в переменной последовательности. CC.. Первый номер, с которого
нумерация страниц должна начаться. DD.. Предотвращение нумерации от перекрывания существующего текста,
например, колонтитулов внизу страницы. EE.. Пропускать страницы  без нумерации. FF.. Размещение номеров стра-
ниц на белом фоне. 



Выравнивание

Выравнивание номера страницы определяет пози-
цию сегмента текста номера страницы, который ус-
танавливается как префикс номера страницы. Эта
позиция обозначена маленьким красным треуголь-
ником (    ).

Вы увидите, что небольшой красный треугольник
сдвигается, в зависимости от того, которая из трех
опций (Left, Center, Right) будет активна. 

Выравнивание не относится к физической
позиции сегмента текста номера на страни-
це, как показано на иллюстрации ниже.

AA.. Выровненный влево номер страницы. BB.. Центри-
рованный номер страницы. CC.. Выровненный вправо
номер страницы.

Первый номер

Первый номер дает возможность вам определить
первый номер страницы вашего PDF документа. На-
пример, некоторые PDF документы должны начи-
наться не с первого номера. Возможно, вы создали
отдельные PDF документы для каждой главы в кни-
ге, и хотите, чтобы нумерация шла по отдельным
главам.

Предположим, что ваш документ будет состоять из
следующих глав:

• Глава 1: Страница 1 из 25 (PDF документ 1)

• Глава 2: Страница 10 из 25 (PDF документ 2)

• Глава 3: Страница 20 из 25 (PDF документ 3)

Следовательно, второй PDF документ будет должен
начаться на странице 10 и третий PDF документ нач-
нется на странице 20.

Вы можете обозначить первый номер вашего PDF
документа в поле ввода, как показано ниже.

Переменная последовательность номера

Переменная последовательность номера может при-
меняться, если вы используете последовательность
чисел, например, “Глава 4: Страница 1 из 25”. Вы мо-
жете определить, какой номер должен быть пере-
менным, а какой постоянным. Например, “1” — пе-
ременный, принимая во внимание, что “4” и “25”
постоянны. Это означает, что номера “4” и “25” не
будут изменяться (см. рисунок ниже). 
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Переменная последовательность номера 
(Variable nomber sequence)

Эта нумерация страницы состоит из трех чисел. Ло-
гически, только второе число должно быть перемен-
ным. Поэтому, вы помещаете “2” в блок переменной
последовательности номера. Это означает, что толь-
ко второе число в последовательности будет изме-
нятся. Первое и третье числа не будут изменяться.

Опции номера страницы

Окно диалога Enfocus PitStop Global Change также по-
зволяет вам определять некоторые опции нумера-
ции страниц, которые объясняются в таблице ниже.
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Опция Объяснение Пример 

Remove any overlapping text
from under new page number 

(Удалить любой перекрывающий
текст из-под номера страниц)

PitStop удалит любой текст, перекры-
вающий номера страниц. Это могут
быть колонтитулы внизу страницы,
которые уже содержат нумерацию. 

Only number pages that
already have a page number

(Нумеровать только те страницы,
которые содержат нумерацию)

Если ваш документ содержит стра-
ницы без нумерации, PitStop перену-
мерует страницы, но не добавит ко-
лонцифры на страницы без нуме-
рации. 

Add white background

(Добавить белый фон)

Эта опция может быть полезна для
PDF документов, которые состоят из
сканированных страниц. Вы можете
поместить белый фон позади новой
нумерации.



Корректировка нумерации страниц

Корректировка нумерации страниц может также по-
дразумевать, что вы добавляете новые номера стра-
ниц в PDF документ, который еще не имеет нумера-
ции. 

Чтобы откорректировать нумерацию страниц:

Быстрый доступ: Выберите Edit > PitStop Glo-
bal Change > закладка Page Numbers > Apply.

1. Сделайте одно из следующего:

• Если ваш PDF документ не имеет нумерации стра-
ниц, все же, выбирает инструмент Edit Text Line
(Редактирование текстовой строки  ( ). Щелкни-
те в том месте документа, где должны появиться
колонцифры нумерации страницы и введите нуме-
рацию в соответствующем порядке (например,
“Глава 4: Страница 1 из 25”)

• Если ваш PDF документ уже имеет нумерацию,
страниц, продолжите действия, описанные в пунк-
те 2.

2. Выберите инструмент Select Objects ( ) и выпол-
ните двойной щелчок на законченном текстовом
сегменте номера страницы.

3. Выберите Edit > Show PitStop Global Change и пе-
рейдите на  закладку page Numbers, окна диалога
PitStop Global Change.

4. Нажмите кнопку Grab Sample from Selection, что-
бы скопировать выбранную нумерацию страницы
(например, “Глава 4: Страница 1 из 25”) из вашего
PDF документа в область Sample PitStop Global
Change.

5. В случае необходимости, определите следующее:

• Выравнивание
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• Переменная последовательность номера

• Первый номер

• Опции номера страницы

См. также “Опции номера страницы” на странице 62.

6. В области Apply to выберите часть PDF документа,
к которому вы хотите применить изменение:

• выбранный объект(ы);

• текущая страница;

• одна или несколько страниц, диапазон которых
может быть обозначен дефисом (-) или разделен
запятой; 

• целый документ.

7. Нажмите кнопку Apply (Применить) или Save as
Action List (Сохранить как список действий), если
вы желаете создать макрос с этими изменениями.
См. также раздел “Создание списка действий” на
странице 82.
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E nfocus PitStop Professional дает вам удобную
возможность проверить PDF документы преж-
де, чем вы пошлете их на печать. Вы можете

легко создавать и управлять PDF профилями, и
смотреть, соответствуют ли свойства ваших PDF до-
кументов свойствам, определенным в соответствую-
щем профиле. Результат этой проверки представлен
в рапорте  проверки (preflight report).

Что такое предпечатная проверка
(preflighting)?

Определение предпечатной проверки

Проверка (preflighting) — термин, заимствованный
из гражданской авиации. Пилот гражданской авиа-
ции должен определить надежность самолета перед
полетом. Это означает, что он должен выполнить
ряд проверок перед каждым рейсом.

Проверка PDF документов, в основном, означает то
же самое: “пилот в команде”, то есть человек, кото-
рый создает или обрабатывает PDF документ, дол-
жен удостовериться, что документ “к полету готов”,
или скорее, “к выводу готов”, перед отправкой доку-
мента, например, в типографию. 

“К выводу готов” означает, что PDF документ “при-
годен для использования”, например:

• Что PDF документ, который будет напечатан на ма-
шине четырехкрасочной печати, содержит только
CMYK изображения и что все необходимые шриф-
ты внедрены в файл.

• Что PDF документ, предназначенный для просмот-
ра на экране, содержит только RGB изображения.

Кроме того, свойства PDF документа, которые не со-
ответствуют требования проверки, могут быть отме-
чены как “ошибка” (error) и устранены в том же са-
мом процессе проверки.

PDF профили

Для проверки PDF документов вы используете PDF
профили. PDF профиль — совокупность критериев,
которые PDF документ должен пройти, чтобы быть
“готовым к выводу”. Для каждого критерия, вы мо-
жете определить:

• Проверять его или нет.

• Как он будет обозначаться в сообщении проверки,
то есть как “информация” или “ошибка”, если в
PDF документе обнаружено несоответствие.

Кроме того, некоторые критерии позволяют вам ус-
тановить, какие обнаруженные проблемы, если та-
ковые имеются, должны быть устранены (fix).

Как пример критерия — RGB цвета. Если вы не хо-
тите использовать RGB цвета в ваших PDF докумен-
тах, вы можете проверять их наличие и сразу, в про-
цессе проверки, конвертировать RGB цвета в CMYK.

Механизм проверки

Как же работает проверка в Enfocus PitStop Professio-
nal? Типичные стадии проверки следующие:

1. Открыть PDF документ, который должен быть
проверен.

2. Создать новый PDF профиль или определить уже
существующий. 

Enfocus PitStop Professional
Руководство пользователя

65

Глава 6: 
Предпечатная проверка PDF документов



3. Запустить процесс проверки. Enfocus PitStop Pro-
fessional проверит ваш PDF документ на соответ-
ствие нужному PDF профилю и автоматически ус-
транит обнаруженные ошибки.

4. По завершении процесса, Enfocus PitStop Professio-
nal сгенерирует рапорт проверки (preflight report).

5. В случае необходимости в интерактивном режиме
решите обнаруженные проблемы, которые не
были автоматически устранены в PDF документе.

6. В случае необходимости используйте списки дей-
ствий (Action List).

7. Передайте PDF документ в вашу сервисную службу.

8. Сервисная служба получает готовый к выводу PDF
документ и применяет его в заключительной ста-
дии вывода, например, для печати или для экран-
ного просмотра.

Свойства PDF документов

Группы свойств

Редактор PDF профиля Enfocus PitStop (Profile Edi-
tor) дает вам контроль над большим количеством
свойств PDF документов. Эти свойства подразделя-
ются на ряд категорий.

Предпечатная проверка проверяет и решает пробле-
мы (если они обнаружены) с этими свойствами PDF
документов. Они касаются следующих категорий:

• Цифровой формат документа

• Защита

• Страницы

• Шрифты

• Цвет

• Изображения

• OPI

• Текст

• Графика

• Прозрачности

• Аннотации

• Meta-данные

• Стандарты  PDF/X
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Рапорт о проблемах

Уровни серьезности проблемы

Если любое из свойств в PDF документе не соответ-
ствует установкам, определенным в PDF профиле,
оно будет упомянуто в рапорте проверки. Вы може-
те выбрать, как должны быть отмечены эти откло-
нения:

• Как “Информация” (Information).

• Как “Ошибка” (Error).

Эти две метки указывают уровни серьезности обна-
руженной проблемы. Если свойство не соответству-
ет PDF профилю, вы можете определить, насколько
серьезна обнаруженная проблема:

• Вы можете отметить несоответствие свойствам как
“Информация”, если это несоответствие не реаль-
ная проблема в строгом смысле этого слова, а толь-
ко нечто, о чем вы хотите знать.

• Вы можете отметить несоответствие свойствам как
“Ошибка”, если вы хотите, чтобы свойства реально
были такими, как определено в PDF профиле преж-
де, чем вы передадите файл на вывод.

Пример уровней серьезности проблем

Предположим, что некоторые из PDF документов, с
которыми вы работаете, содержат RGB цвета. Сна-

чала, вы хотите распечатать их на черно-белом уст-
ройстве, типа лазерного принтера, для визуальной
проверки. В том случае наличие в документе RGB цве-
тов не является проблемой. Однако при этом вы хо-
тите знать, какие именно PDF документы содержат
объекты в RGB цвете, так как на более поздней ста-
дии, вам надо будет подготовить эти документы для
вывода на четырехкрасочной печатной машине.
В этом случае вы можете использовать два различных
PDF профиля для проверки этих PDF документов:

• PDF профиль для лазерного принтера, который
отмечает наличие RGB цветов как “Информацию”.

• PDF профиль для четырехкрасочной печатной ма-
шины, которая отмечает наличие RGB цветов  как
“Ошибку”.

См. также раздел “Интерпретация сообщений про-
верки” на странице 77.

Результаты процесса и отметка свойств в
предыдущих версиях

Предыдущие версии Enfocus PitStop Professional, а
также предыдущие версии списков действий или
PDF профилей могут использовать различную тер-
минологию для отметки несоответствия свойств.
Терминология этих меток была сделана более удоб-
ной в текущей версии Enfocus PitStop Professional.
Таблица ниже дает краткий обзор того, как метки
были изменены.
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Создание PDF профиля

Предопределенные PDF профили

Enfocus PitStop Professional обеспечивает ряд пред-
определенных профилей. Вы можете создавать ваши
собственные PDF профили, основанные на этих пред-
определенных профилях. Предопределенные про-
фили, показанные ниже, служат как базовые профи-
ли. Они могут изменяться при обновлении програм-
мы Enfocus PitStop Professional.

Предопределенные профили Enfocus PitStop Professional

См. также “Редактирование PDF профиля и
создания нового PDF профиля” на странице 71.

Установка свойств PDF профиля

PDF профиль имеет два типа свойств:

• Свойства профиля.

• Свойства обработки.

Свойства профиля — имя профиля, автор профиля
и его компания, вместе с кратким описанием.

Свойства обработки имеют отношение к исправле-
ниям (fix), которые должны или не должны быть
сделаны, и к информации, которую вы хотели бы
видеть в рапорте проверки. Например, вы можете
выбрать регистрацию исправлений и включение
следующих информационных страниц в рапорт
проверки:

• Шрифты

• Изображения

• Цвет

• OPI

Кроме того, вы можете включать или отключать все
исправления (fixes) в PDF профиле. Действительно,
PDF профиль Enfocus PitStop может делать больше,
чем просто проверка PDF документов: он может так-
же устранять обнаруженные проблемы. Также вы
можете создать PDF профиль, в котором вы опреде-
ляете некоторое количество исправлений (fixes) и
можете отключать эти исправления, если надо, —
допустим, если вы хотите только проверить PDF до-
кументы, но не изменять их.

Чтобы установить свойства обработки PDF профиля:

1. Выберите Window > PDF Profile Control Panel.

2. Выберите PDF профиль из списка.

3. Нажмите закладку Managing.

4. Нажмите Edit.

Появится редактор PDF профиля.

5. Выберите требуемые опции в области панели Pro-
cessing Properties.

6. Нажмите OK.
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Использование редактора PDF профиля

Создание PDF профиля подразумевает, что вы
определяете свойства PDF документа, которые дол-
жны быть проверены, отражены в рапорте проверки
и, в случае необходимости, исправлены. Чтобы
сделать это, вы используете редактор PDF профиля.

Чтобы отобразить окно редактора PDF профиля:

1. Выберите Window > Show PDF Profile Control Panel.

2. Выберите PDF профиль из списка.

3. Нажмите закладку Managing.

4. Нажмите Edit. Появится окно диалога редактора
PDF профиля.

Чтобы использовать редактор PDF профиля:

1. Выберите прикладную категорию в списке.

2. Активируйте опцию Enable (Включить) данной ка-
тегории.

3. Выберите проверку необходимых свойств или
потенциальных проблем.

Интегрированная справка в нижней области
редактора PDF профиля обеспечивает инфор-
мацию относительно выбранных свойств.

4. Определите, как устранить проблему, в случае
необходимости.

5. Выберите, как обнаруженная проблема должна
быть отражена в рапорте проверки: как “Инфор-
мация” или “Ошибка”.

6. Повторите действия, описанные в пунктах 1–5 для
каждой потенциальной проблемы, которую вы
желаете проверить и устранить.

7. Нажмите OK.
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Управление PDF профилями

Использование панели управления 
PDF профилями 

Чтобы управлять PDF профилями, используйте
панель управления PDF профилями Enfocus. Эта па-
нель управления позволяет:

• Создать новый PDF профиль.

• Редактировать существующий PDF профиль.

• Удалять PDF профиль.

• Дублировать PDF профиль.

• Импортировать PDF профиль.

• Экспортировать PDF профиль.

• Переименовать PDF профиль.

• Блокировать PDF профиль паролем.

Чтобы отобразить панель управления PDF профи-
лями:

Выберите Window > Show PDF Profile Control Panel.
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Редактирование PDF профиля и
создание нового PDF профиля

При создании нового PDF профиля или при редак-
тировании уже существующего, выполняются в ос-
новном те же самые задачи. Даже если вы создаете
новый PDF профиль “на пустом месте”, вы пользуе-
тесь предопределенными шаблонами профилей, ко-
торые включаются с инсталляцией PitStop. Эти шаб-
лоны PDF профилей охватывают наиболее общие
потребности. Вы можете сначала создать свой PDF
профиль, основанный на шаблоне, и позже настро-
ить пользовательские установки этого профиля.

Когда вы редактируете PDF профиль, вы изменяете
некоторых из свойств того профиля. 

См. также раздел “Создание PDF профиля” на
странице 68.

Чтобы создать или отредактировать PDF профиль:

1. Выберите Window > Show PitStop PDF Profile Cont-
rol Panel.

2. Выберите закладку Managing.

3. Сделайте одно из следующего:

• Чтобы создать новый профиль, нажмите New. Вы-
берите шаблон профиля из списка и нажмите OK.

• Чтобы отредактировать существующий PDF про-
филь, выберите профиль из списка и нажмите Edit.

Появится редактор PDF профиля.

4. Выберите соответствующую категорию, чтобы
отобразить свойства для редактирования.

5. Удостоверьтесь, что вся категория Enable.

6. Сделайте нужные изменения для проверки и уст-
ранения проблем выбранных свойств.

Название профиля, который вы в настоящее время
редактируете, отображается в области заголовка ре-
дактора PDF профиля.

AA.. Список категорий. BB.. Название PDF профиля, ко-
торый вы в настоящее время редактируете.

7. Повторите действия, описанные в пунктах 4–6 для
каждой потенциальной проблемы, которую вы
хотите проверить и устранить.

8. Нажмите OK.

Изменение общей информации 
PDF профиля

Общая информация PDF профиля включает:

• Название PDF профиля, которое должно быть опи-
сательным именем профиля. Если вам позже пона-
добится экспортировать этот профиль, данное наз-
вание будет предложено для сохранения как имя
файла PDF профиля.

• Автор, — соответственно имя пользователя, соз-
давшего профиль.

• Компания,  — соответственно название компании,
в которой работает пользователь.
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Чтобы изменить общую информацию PDF профиля:

1. Выберите > Window > Show PDF Profile Control Panel.

2. Нажмите закладку Managing.

3. В списке PDF профилей в левой области окна па-
нели управления PDF профилями выберите PDF
профиль, в котором вы хотите изменить общую
информацию.

4. Поместите курсор в соответствующем текстовом
поле и измените название профиля, имя автора,
название компании.

Название будет изменено, как только вы перемести-
те курсор ввода текста из текстового поля или на-
жмете Enter.

Удаление PDF профиля

Когда вы удаляете PDF профиль, он больше не  по-
является в списке профилей в левой области окна
панели управления PDF профилями.

Чтобы удалить PDF профиль:

1. Выберите > Window > Show PDF Profile Control Pa-
nel.

2. Нажмите закладку Managing.

3. В списке PDF профилей в левой области окна па-
нели управления PDF профилями выберите про-
филь, который вы хотите удалить.

Удаляя профиль из списка, вы также физичес-
ки удаляете его с вашего жесткого диска. Перед
удалением удостоверьтесь, что вы точно не
нуждаетесь больше в этом профиле, поскольку
удаление профиля не может быть отменено.

4. Нажмите Remove.

Выбранный PDF профиль будет немедленно удален
из списка и с жесткого диска вашего компьютера.

Дублирование PDF профиля

Дублирование PDF профиля означает, что вы созда-
ете копию профиля. Возможно, вы хотите создать
новый профиль, основанный на уже существую-
щем. Например, если у вас есть PDF профиль для че-
тырехкрасочной печатной машины, и вам нужен но-
вой профиль с некоторыми отличающимися уста-
новками, вы можете дублировать профиль четырех-
красочной печатной машины, переименовывать его
и затем изменить требуемые свойства.

Чтобы дублировать PDF профиль:

1. Выберите > Window > Show PDF Profile Control Panel.

2. Нажмите закладку Managing.

3. В панели управления PDF профиля выберите PDF
профиль, который вы хотите дублировать.

4. Нажмите Dublicate.

Enfocus PitStop Professional создает копию выбран-
ного PDF профиля с тем же самым именем, что и
оригинальный, с префиксом “Copy of ”. Эта копия
появится в списке  PDF профилей в левой области
окна панели управления PDF профилями. Затем вы
можете переименовать копию PDF профиля.
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Импорт PDF профиля

Вы можете импортировать существующие PDF про-
фили, чтобы позже добавлять их в список профилей
в панели управления PDF профилями. PDF профили
предыдущих версий Enfocus PitStop также могут
быть импортированы и отредактированы. Однако
как только эти профили будут отредактированы,
они не могут использоваться предыдущими версия-
ми Enfocus PitStop Professional или другими про-
граммами Enfocus.

См. также раздел “Редактирование PDF профиля и
создание нового PDF профиля” на странице 71.

Чтобы импортировать PDF профиль:

1. Выберите Window > Show PDF Profile Control Panel.

2. Нажмите закладку Managing.

3. Нажмите Import.

4. Выберите профиль, который вы хотите импорти-
ровать.

5. Нажмите Open.

Импортированный профиль будет добавлен в спи-
сок профилей в левой области окна панели управле-
ния PDF профилями.

Экспорт PDF профиля

Экспорт PDF профиля означает, что вы сохраняете
его как отдельный файл. Вы можете делать это по
ряду различных причин, например:

• Для повторного использования этого PDF профи-
ля позднее.

• Чтобы создать резервную копию PDF профиля.

• Чтобы совместно с другими пользователями исполь-
зовать PDF профиль.

• Чтобы послать PDF профиль сервисной службе или
любому другому получателю PDF документов. См.
также главу “Работа с Sertified PDF документами”
на странице 30.

Если вы экспортируете PDF профиль, который нуж-
но использовать другим людям, мы рекомендуем ус-
тановку профиля с паролем. Для получения допол-
нительной информации, см. “Блокировка PDF про-
филя паролем” на странице 74.

Чтобы экспортировать PDF профиль:

1. Выберите Window > Show PDF Profile Control Panel.

2. Нажмите закладку Managing.

3. В панели управления PDF профилями выберите
PDF профиль, который вы хотите экспортиро-
вать.

4. Нажмите Export.

Если PDF профиль не защищен паролем, 
появится следующее сообщение:

См. “Блокировка PDF профиля паролем” ниже.

5. Определите название и местоположение файла
профиля .

6. Нажмите Save.
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Блокировка PDF профиля паролем

Вы можете защитить ваш PDF профиль паролем,
чтобы предотвратить изменения его установок. Это
может быть удобно, если профиль используется
множеством пользователей. Вы можете блокировать
PDF профиль паролем, при создании профиля или
добавить пароль впоследствии.

Пароль может включать:

• Символы верхнего и нижнего регистра.

• Любой знак на клавиатуре.

• Пробелы.

Чтобы блокировать PDF профиль паролем:

1. Выберите Window > Show PDF Profile Control Panel.

2. Нажмите закладку Managing.

3. В панели управления PDF профилями выберите
PDF профиль, который вы желаете заблокировать
паролем.

4. Нажмите Lock with Password.

Появится окно диалога Password.

5. Введите ваш пароль в текстовом поле.

6. Нажмите OK.

Общая информация блокированного профиля
(имя, автор и компания) и кнопка Edit потускнеют в

панели управления PDF профилями. Кнопка Lock
with Password” поменяется на “Unlock with password”. 

Вид панели управления PDF профилями с заблокиро-
ванным паролем профилем: AA.. Общая информация
блокированного профиля потускнела. BB.. Кнопка “Lock
with Password” поменялась на “Unlock with Password“
CC.. Кнопка Edit потускнела.

Другие пользователи могут экспортировать, удалять
или дублировать PDF профиль, защищенный паро-
лем, но не могут редактировать его:

• Если они нажимают Remove, профиль будет немед-
ленно удален из списка PDF профилей в левой об-
ласти окна панели управления PDF профилями.
Даже при том, что профиль защищен паролем, En-
focus PitStop Professional при удалении не будет за-
прашивать подтверждение пароля.

См. также “Удаление PDF профиля” на странице 72.

• Если они дублируют защищенный паролем PDF
профиль, копия будет блокирована тем же самым
паролем что и первоначальный профиль.

См. также “Импорт PDF профиля” на странице 73.

• Мы рекомендуем блокировать PDF профиль паро-
лем перед его экспортом, это гарантирует, что уста-
новки профиля останутся неизменными.

См. также “Экспорт PDF профиля” на странице 73.
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Создание рапорта 
предпечатной проверки

Если вы уверены, что выбранный PDF профиль  со-
держит необходимые установки проверки, вы може-
те создать рапорт предпечатной проверки. Вы може-
те сами определить возможности охвата предпечат-
ной проверки, т. е. — применить PDF профиль толь-
ко к текущей странице, к диапазону страниц, или ко
всему PDF документу. Вы можете выполнить обыч-
ную предпечатную проверку или сертифицирован-
ную предпечатную  проверку. Эти опции доступны
на закладке Checking панели управления PDF про-
филями.

AA.. Индикатор выбранного профиля. BB..  Информация о
состоянии  PDF профиля. CC.. Опция охвата проверки.

Обычная предпечатная проверка

Если вы выбираете опцию Regular Preflight (Обыч-
ная проверка), PDF профиль, который вы выбрали в
списке, применится без каких-либо изменений в со-
стоянии с Sertified PDF документом. 

При обычной проверке PDF профиль, вне-
дренный в Sertified PDF документы, не уда-
ляется — даже если вы проверяете документ
другим профилем на панели управления PDF
профилями. См. также “Замена PDF профиля
Sertified PDF документа” на странице 38.

Чтобы выполнить обычную проверку:

1. Выберите Window > Show PDF Profile Control Panel.

2. Выберите PDF профиль, с которым вы хотите
проверить документ, из списка профилей.

3. Выберите опцию Regular Preflight.

4. Нажмите Create Report.

Документ будет проверен с использованием выбран-
ного PDF профиля, который также показан индика-
тором состояния на панели управления PDF профи-
лями и в строке состояния программы Acrobat.

Сертифицированная проверка

Если вы выбираете опцию Certified Preflight (Серти-
фицированная проверка), состояние Sertified PDF
документа будет проверено и отображено на панели
управления PDF профилями. В зависимости от со-
стояния файла, рапорт проверки будет выглядеть
по-разному. Следующие параграфы показывают
возможные результаты выполнения сертифициро-
ванной проверки.

AA.. Опция проверки Sertified PDF документа. BB.. Здесь
отображается состояние Sertified PDF.

Для получения дополнительной информации о
состоянии Sertified PDF файла см. “Проверка и
сертифицированное состояние PDF” на стра-
нице 76.
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Проверка и сертифицированное 
состояние PDF

NNoott  CCeerrttiiffiieedd  (Не сертифицирован). Если документ,
который вы хотите проверить — не Sertified PDF до-
кумент, запустите процесс сертифицирования. Вам
будет предложено ввести информацию о сессии, как
описано в разделе “Запуск процесса сертифициро-
вания PDF документа” на странице 36.

После ввода этой информации, вы можете запустить
проверку документа сразу или позже. Если вы выбра-
ли выполнение проверки немедленно, состояние
изменится на Preflight OK  или Preflighted with Errors.
Иначе оно изменится на Not Preflighted.

DDiiffffeerreenntt  PPDDFF  PPrrooffiilleess (Разные PDF профили), если
PDF профиль, который вы выбрали в списке, не со-
ответствует профилю, внедренному в Sertified PDF
документ, и вы всё равно запускаете процесс серти-
фицированной проверки, свойства Sertified PDF до-
кумента будут изменены. Для получения дополните-
льной информации о соответствии PDF профилей,
см. раздел “Проверка состояния Sertified PDF” на
странице 40. PDF профиль, который вы использова-
ли при новой проверке, заменяет первоначально
внедренный PDF профиль. После того, как вы введе-
те новую информацию в окне диалога Edit Enfocus

Certified PDF Properties, проверка будет выполнена с
новым PDF профилем.

PPrreefflliigghhtt  OOKK (Проверен OK). PDF документ уже был
проверен PDF профилем, который вы выбрали. В
этом случае, создание нового рапорта проверки про-
сто повторит предыдущий процесс.

NNoott  PPrreefflliigghhtteedd  (Не проверен). Если документ еще не
был проверен, или если он был изменен, начиная с
того момента, как был создан последний рапорт про-
верки, его состояние отображается как Not Preflight-
ed. Создание рапорта установит состояние докумен-
та в Preflight OK или в Preflighted with Errors, в зави-
симости от результата проверки.

PPrreefflliigghhtteedd  wwiitthh  EErrrroorrss (Обнаружены ошибки). Это
состояние дается документам, которые были прове-
ренны выбранным PDF профилем, и в рапорте про-
верки содержатся сообщения об ошибках. Если вы
исправляете причину ошибок и создаете новый ра-
порт проверки, состояние Sertified PDF документа
изменится на Preflight OK.

Выполнение сертифицированной
проверки

Чтобы выполнить сертифицированную проверку
Sertified PDF документа:

1. Выберите Window > Show PDF Profile Control Panel.

2.  Из списка выберите PDF профиль, с которым вы
хотите проверить документ.

3. Выберите опцию Certified Preflight.

4. Нажмите Create Report.

В зависимости от сертифицированного сос-
тояния вашего документа, вы можете ввести
информацию в одном из окон диалога Enfocus
Sertified PDF и выбрать, продолжить проверку
или нет. 
См. раздел “Проверка состояния Sertified PDF”
на странице 40.
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Интерпретация сообщений проверки

Рапорт, созданный Enfocus PitStop Professional, явля-
ется PDF документом который состоит из следую-
щих глав:

Первая глава — наиболее важная, потому что она
предупреждает вас, если ваш PDF документ не соот-
ветствует установкам, которые вы определили в PDF
профиле (и, следовательно, документ не отвечает ва-
шим потребностям).

Типичный рапорт проверки Enfocus PitStop Profes-
sional содержит два вида гиперссылок:

• Знак зачеркивания ( ) переносит вас к проблем-
ному(ным) объекту(ам) оригинального PDF доку-
мента, указанным в соответствующей строке ра-
порта проверки и запускает панель Enfocus PitStop
Navigator.

• Щелчок на звездочке ( ) переносит вас к объекту-
(ам) оригинального PDF документа, указанному в
соответствующей строке рапорта проверки, на ко-
торый(ые) стоит обратить внимание.

Пример типичного рапорта проверки Enfocus PitStop
Professional: список ошибок и предупреждений, в каж-
дой строке которого сообщениям предшествует два
вида гиперссылок.

Проверка PDF документа с 
использованием панели Navigator

В дополнение к использованию панели Enfocus Pit-
Stop Preflight Control Panel, вы можете также исполь-
зовать инструмент View Problems ( ), чтобы про-
верить PDF документы. Если вы проверяете PDF до-
кументы этим способом, у вас не будет рапорта про-
верки, но вы сможете перемещаться к каждой обна-
руженной проблеме. PDF документ будет проверен
“активным” профилем, который в настоящее время
выбран в панели управления проверкой (Enfocus Pit-
Stop Preflight Control Panel). Предположим, у вас есть
профиль “4-color press” и вы выбрали этот профиль
в панели управления проверкой, как показано на ил-
люстрации ниже.

Выбранный профиль проверки “4-color press”
в  панели управления проверкой Enfocus PitStop
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ГГллааввыы ССооддеерржжааннииее

Errors &
Warnings 

Ошибки и предупреждения (потенци-
альные проблемы) согласно выбранно-
му PDF профилю

General File 
Information

Информация относительно текущего
PDF документа, его заголовка, автора,
используемого профиля, формата дан-
ных, и т. д.

Font
Information

Все шрифты, используемые в PDF до-
кументе, наряду с их атрибутами (тип
шрифта, внедрен или использована
подстановка, и т. д.)

Color
Information

Все цветовые пространства (RGB,
CMYK, и т. д.) используемые в PDF до-
кументе, с возможной дополнительной
информацией

Image
Information

Все изображения в PDF документе, на-
ряду с дополнительной информацией
(например, физическое и используемое
разрешение, страница, угол поворота,
заказные функции цвета, и т. д.)

OPI Information Использование OPI в PDF документе



Одна из установок этого профиля — то, что прове-
ряемый PDF документ не должен иметь RGB цвета,
как показано на иллюстрации ниже.

Одна из установок цвета в профиле “4-color press”

Если вы проверяете PDF документ на содержание
RGB изображений, и если RGB изображение будет
обнаружено, появится панель PitStop Navigator:

RGB изображение в PDF документе запрещено ак-
тивным профилем проверки.

Чтобы проверить (исправить) PDF документ, с ис-
пользованием панели Enfocus PitStop Navigator:

1. Откройте PDF документ, который вы хотите про-
верить или исправить.

2. Нажмите кнопку ( ).

Появится панель Enfocus PitStop Navigator, которая
покажет обнаруженные проблемы.

Автоматизация проверки

Если у вас большое количество PDF документов, ко-
торые вы должны проверить (или исправить) с по-
мощью определенного PDF профиля, вы можете ав-
томатизировать этот процесс.

Enfocus PitStop Server предлагает автоматизирован-
ную проверку PDF документов. Вы можете создавать
“горячие папки”, в которые вы включаете данный
PDF профиль и, в случае необходимости, списки дей-
ствий (.eal) (см. также главу “Автоматизация задач”
на странице 79). Enfocus Сервер PitStop будет тогда
контролировать определяемую пользователем папку
ввода и автоматически проверять (исправлять) каж-
дый PDF документ, который помещается в эту пап-
ку. Правильные и неправильные PDF документы бу-
дут автоматически перемещаться в соответствую-
щую папку, вместе с рапортом проверки, если по-
требуется.

Более подробная информация относительно Enfocus
PitStop Server доступна на нашем сайте по адресу:
www.enfocus.com.
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О дной главных причин для использования
Enfocus PitStop Professional является воз-
можность редактирования PDF докумен-

тов. Например, вы можете выполнять задачи по из-
менению текста (или его форматированию) или по
изменению объектов. Могут иметься последователь-
ности задач, которые вам нужно сделать неодно-
кратно в одном или нескольких PDF документах.
Чтобы автоматизировать монотонную работу, вы
можете сгруппировать ряд задач в список действий.
Как только вы создали список действий, вы всегда
можете повторно использовать его. Например,
предположим, что в нескольких PDF документах
есть графический объект. Вы хотите изменить сле-
дующие свойства этого объекта во всех  документах:

• Изменить цвет нескольких областей в объекте.

• Сделать линии в объекте толще, чем исходная тол-
щина линии.

Изменение многократных свойств объекта в несколь-
ких PDF документах.

Эта работа может состоять из ряда последователь-
ных задач, как показано на иллюстрации. Эти инди-
видуальные задачи могут быть сгруппированы в
один список действий (Action List), который может
применяться к одной странице, диапазону страниц,
к целому документу (в одном или нескольких PDF
документах).
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Глава 7: Автоматизация задач



Типы действий (Actions)

Относительно типов действий

Списки действий могут быть созданы с помощью
Enfocus PitStop Professional, плагина для Adobe Acro-
bat. В основном, когда вы создаете список действий,
вы выбираете свойство или объект в PDF документе,
и изменяете его на другое свойство или объект. На-
пример, вы выбираете плашечную краску “Company
Green” и изменяете ее в “Company Gray”.

Однако список действий может делать и больше. Он
может состоять из следующих типов действий:

••  SSeelleeccttiioonnss (Выборы).

••  CChhaannggeess (Изменения).

••  CChheecckkss (Проверки).

••  IInnffoorrmmss (Информация).

Иллюстрация ниже показывает, как эти категории
типов действий, представлены в Enfocus PitStop Pro-
fessional.

Категории типов действий в Enfocus PitStop Server.

Selections (Выборы)

Прежде, чем вы сможете что-то изменить в PDF до-
кументе, вы должны это выбрать. То, что может
быть выбрано в PDF документе, перечислено в кате-
гории “Selections”, вместе с логическими оператора-
ми “AND”, “NOT”, “OR”.

Changes (Изменения)

Список изменений включает то, что программа Enfo-
cus PitStop Professional может делать с помощью ин-
струментальных средств редактирования, которые
включают:

• Добавление объектов или номеров страниц.
• Изменение широкого разнообразия свойств, вклю-

чая рамки страницы (page boxes).
• Преобразования цветов.
• Удаление объектов.
• Поворот и масштабирование содержимого страницы.
• Шрифт и связанные изменения цветов.

Checks (Проверки)

Списки действий не обязательно должны изменять
PDF документы. Они могут быть созданы для про-
верки различных свойств PDF документов или для
обнаружения определенных объектов или элемен-
тов. Например, список действий может проверять
связанные со шрифтом свойства или обнаруживать
пустые страницы в PDF документе.

Каждая действие проверки” или поиска может быть
зарегистрировано в рапорте проверки как “Warning”
(Предупреждение) или “Error”(Ошибка).

Informs (Информация)

Списки действия могут также собрать информацию
о PDF документах. Это может быть информация от-
носительно использованных шрифтов, красок, OPI,
и т. д. Соответствующие главы будут включены в
сообщение проверки.
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Использование панели управления 
списками действий

Вы используете панель управления списками дей-
ствий Enfocus PitStop, чтобы создавать, управлять и
выполнять списки действий. Эта панель управления
состоит из следующих частей:

• Левая область окна, показывающая списки дейст-
вий по их именам.

• Закладка Executing (Выполнение).

• Закладка Managing (Управление).

• Закладка Description (Описание).

Вы используете закладку Executing, чтобы приме-
нить выбранный список действий к странице, диа-
пазону страниц или целому PDF документу.

Закладка Managing позволяет вам:

• Создавать список действий.

• Редактировать список действий.

• Удалять список действий.

• Дублировать список действий.

• Импортировать список действий.

• Экспортировать список действий.

• Переименовывать список действий.

• Блокировать список действий пользовательским
паролем или разблокировать защищенные паро-
лем списки действий.
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AA..  Выбрать список действий из списка в левой облас-
ти окна панель управления списками действий Enfocus
PitStop. BB.. Нажмите закладку Managing. CC.. Нажмите
New, чтобы создать новый список действий. DD.. Наж-
мите Edit, чтобы изменить свойства выбранного
списка действий. EE.. Нажмите Remove, чтобы удалить
выбранный список действий. FF.. Нажмите Dublicate,
чтобы сделать копию выбранного списка действий. 

GG.. Нажмите Import, чтобы добавить список дейст-
вий в панель. HH.. Нажмите Export, чтобы сохранить
выбранный список действий как файл. II.. Нажмите
Lock with Password, чтобы защитить выбранный спи-
сок действий паролем. JJ.. В текстовых полях, вы може-
те изменить имя списка действий, автора и компа-
нии. Имена изменятся немедленно, как только вы уда-
лите курсор из текстового поля. 



Чтобы отобразить закладку Managing панели управ-
ления списками действий:

1. Выберите Window > Show PitStop Action List Panel.

2. Нажмите закладку Managing.

Создание списка действий

В основном, имеются три способа, которыми вы
можете создавать списки действий:

• “На пустом месте”, используя редактор списков
действий. Это означает, что вы начинаете с “чистой
страницы” и добавляете выборы, изменения и опе-
раторы в свой пользовательский список действий. 

• Используя кнопки Grab Undo в редакторе списков
действий. Каждый раз, когда вы нажимаете эту
кнопку, последнее действие, которое вы сделали в
PDF документе (и которое появляется в меню
Edit > Undo) будет перечислено в левой области
окна. Это интуитивный способ создания списка
действий: вы открываете PDF документ, выполня-
ете ряд задач и включаете их одну за другой в ваш
список действий, нажимая кнопку Grab Undo.

Кнопка Grab Undo в редакторе списков действий,
чтобы легко включить самые последние действия в
список действий.

• Вы можете также делать глобальные изменения в
полном PDF документе и сохранять эти изменения
как списки действий. Окно диалога Enfocus PitStop
Global Change содержит специальную кнопку для
этой цели. Для получения дополнительной инфор-
мации относительно глобальных изменений, см.
главу “Глобальные изменения в PDF документах” на
странице 48.

• Вы можете загрузить пример из библиотеки спис-
ков действий Enfocus на нашем web-сайте и при-
способить их для своих потребностей: www.enfo-
cus.com/support/actionlistlib/actionlist-index.htm 

Кнопка Save as Action List в окне диалога. Enfocus Pit-
Stop Global Change 

Использование редактора 
списков действий

Чтобы создавать список действий, вы используете
редактор списков действий Enfocus PitStop.

Чтобы отобразить редактор списков действий.

1. Выберите Window > Show PitStop Action List Panel.

2. В панели управления списками действий Enfocus
PitStop, нажмите кнопку New.

Редактор списков действий: основной инструмент
PitStop Professional для создания списков действий.
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Рекомендации по созданию 
списков действий

В основном, вы создаете список действий, используя
следующие шаги:

1. Делаете один или несколько выборов.

2. Определяете операторы (AND, NOT, OR) для ва-
ших выборов.

3. Определяете требуемые изменения для выборов.

При создании списков действий соблюдайте следую-
щие рекомендации:

• Изменения обращаются только к выборам. Поэто-
му сначала удостоверьтесь, что в своем списке дей-
ствий вы сделали правильные выборы. Если вы не
сделали никаких выборов, некоторые изменения
будут применяться ко всем элементам в вашем PDF
документе (например, ко всем шрифтам) или из-
менения не будут применяться вообще.

• Операторы (AND, NOT, OR) не должны вводиться
между двумя или большим количеством выборов,
но только после выборов. Эти операторы обраща-
ются только к предшествующим выборам.

• Операторы (AND, NOT, OR) — логические операто-
ры, что означает, что они должны использоваться
строго логическим способом. Например, если вы
хотите выбрать шрифты Times-Roman (Type 1) и
Times New Roman (TrueType), вы должны исполь-
зовать не оператор AND, а оператор OR (поскольку
шрифт не может быть одновременно и Times-Ro-
man и Times New Roman). Вы можете использовать
оператор AND, например, для выбора всего синего
текста с гарнитурой Times-Roman. Список дейст-
вий выглядел бы тогда следующим образом:

• Операторы OR и AND обращаются только к двум
предшествующим выборам. Поэтому, если вы
хотите делать больше чем два выбора, вы должны
расставить множество этих операторов в соответ-
ствующих местах в “стеке” выборов. Например,
если вы хотите выбрать шрифты, Times-Roman
(Adobe Type 1), Times New Roman (TrueType) и их
полужирные начертания, ваш список действий
должен выглядеть следующим образом:

• Оператор NOT обращается только к предшествую-
щему выбору и может использоваться, чтобы
исключить кое-что из выбора. В отличие от опера-
торов OR и AND, оператор NOT требует только
одного выбора. Например, если вы хотите изме-
нить все шрифты в PDF документе кроме Times-
Roman на Times-Bold, ваш список действий выгля-
дел бы следующим образом:

В вышеупомянутом примере, список действий изме-
нит все шрифты в PDF документе на Times-Bold, но
оставит Times-Roman без изменения.

Чтобы создать список действий.

1. Выберите Window > Show PitStop Action List Panel.

2. В панели управления списками действий Enfocus
PitStop нажмите закладку Managing.

3. Нажмите New.
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Появится редактор списков действий Enfocus PitStop.

4. Нажмите Add.

Появляется окно диалога New Action Type, в кото-
ром отображаются все доступные выборы, измене-
ния и операторы (AND, NOT, OR) в алфавитном по-
рядке.

5. Нажмите закладку Selections.

6. В списке Selections нажмите нужный вам выбор, и
нажмите OK.

7. В случае необходимости, откорректируйте атрибу-
ты вашего выбора в правой области окна диалога
Enfocus PitStop Action List Editor.

Панель атрибутов в окне диалога Action List Editor.

8. Повторите действия, описанные в пунктах с 4 по
7, чтобы добавить все необходимые выборы и
операторы в свой список действий.

Если вы добавляете операторы в свой список
действий, удостоверьтесь, что вы ввели эти операто-
ры после выборов, к которым они должны приме-
няться. См. также раздел “Рекомендации по созда-
нию списков действий” на странице 83.

9. Нажмите Add.

10. Выберите закладку Changes.

11. В списке Changes, выберите нужные вам измене-
ния и нажмите OK.
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12. В случае необходимости, откорректируйте атри-
буты своих изменений в правой области окна
диалога Enfocus PitStop Action List Editor.

13. Нажмите Add.

14. Повторите действия, описанные в пунктах с 9 по
12, чтобы добавить все необходимые изменения
в свой пользовательский список действий.

15. В случае необходимости, выберите выбор, изме-
нение или оператор, и нажмите кнопку Up (вы-
ше) или Down (ниже), чтобы изменить порядок
действий.

16. Сделайте одно из следующего:

• Если вы включить выполнения проверок в свой
список действий, выберите закладку Checks и выбе-
рите в ней соответствующие проверки.

• Если вы хотите собрать информацию относитель-
но, например, шрифтов, красок и иллюстраций в
PDF документе, нажмите закладку Informs и выбе-
рите из списка соответствующие сообщения.

17. Нажмите Add, чтобы добавить соответствующий
Inform, и Close, когда вы закончите добавление.

18. Нажмите OK, чтобы сохранить только что создан-
ный список действий.

Окно диалога редактора списков действий — Enfo-
cus PitStop Action List Editor — закроется и вы верне-
тесь в окно диалога Enfocus PitStop Action List Cont-
rol Panel. 

Здесь список действия, который вы только что соз-
дали, будет отображен в левой области окна.

19. В окне диалога управления списками действий —
Enfocus PitStop Action List Control Panel — запол-
ните текстовые поля с названием нового списка
действий, автора и компании.

Название списка действий будет изменено соответ-
ственно, как только вы удалите курсор из текстового
поля.
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Создание рапорта 
со списками действий

Когда вы выполняете список действий, возможно,
вам будет удобно знать точно, что именно измени-
лось в вашем PDF документе, и сколько раз было из-
менено. В одном и том же процессе вы можете про-
верить нужные свойства PDF документа и собрать
информацию относительно данных свойств. Вы мо-
жете сгенерировать всю вышеупомянутую инфор-
мацию в рапорте списка действий. Рапорт списка
действий может включать:

• Изменения, то есть, что было изменено списком
действий и сколько раз.

• Проверки, например, PDF документ, содержит вне-
дренные шрифты или вращаемые объекты

• Информацию, например, о шрифтах, изображени-
ях, красках и фильтрах.

Следующая процедура дает пример того, как вы мо-
жете выполнить список действий с рапортом.

Чтобы создать сообщение со списком действий:

1. Создайте новый список действий или отредакти-
руйте существующий.

2. В редакторе списков действий Enfocus PitStop на-
жмите кнопку Add.

3. Определите выборы на закладках Changes, Checks
и Informs. 

4. Сделайте одно из следующего:

• Чтобы регистрировать изменения в вашем рапорте
списка действий, добавьте изменение, и выберите
Log (Протокол) внизу области окна атрибутов.

• Чтобы включить проверки и сообщения в ваш
рапорт, выберите соответствующую закладку и
затем выберите соответствующие Checks или In-
forms. По окончании нажмите Add > Close. Про-
верка или сообщение будет включено в список дей-
ствий, как показано ниже.

5. В редакторе списков действий Enfocus PitStop, на-
жмите OK, когда вы добавили все требуемые из-
менения, проверки и сообщения.

6. В панели управления списками действий Enfocus
PitStop нажмите закладку Execute.

7. Выберите опцию Create Report (Создать рапорт)
как показано на рисунке ниже.
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8. Нажмите кнопку Execute.

Рапорт будет отображен, как только список дейст-
вий будет полностью выполнен. Выбранные измене-
ния, проверки и сообщения будут включены в ра-
порт, как показано в примере ниже.

Управление списками действий

Редактирование списка действий

Вы можете отредактировать список действий, чтобы
изменить любое из следующего:

• Добавляют выборы, изменения и операторов в
список действий

• Определить порядок действий в самом списке.

• Выбрать или изменить атрибуты.

См. также раздел “Создание списка действий”
на странице 82.

Чтобы отредактировать список действий:

1. Выберите Window > Show PitStop Action List Panel.

2. В панели управления списками действий Enfocus
PitStop выберите список действий, который вы
хотите отредактировать.

3. Нажмите закладку Managing.

4. Нажмите  Edit.

5. Сделайте одно из следующего:

• Чтобы добавить выборы или изменения, проверки
или сообщения, нажмите Add. Выберите требуемое
изменение или выбор из соответствующего списка,
и нажмите OK. Добавленное действие появится
внизу списка.

• Чтобы изменить порядок действий в списке, выбе-
рите соответствующее действие, и нажмите Up или
Down. 

• Чтобы изменить атрибуты действия, выберите дей-
ствие, и измените его атрибуты в правой области
окна.

Если вы хотите изменить атрибуты много-
кратных действий, не нажимайте OK после
того, как вы сделали изменение в действии.
Если вы изменили атрибуты действия,
просто выберите другое действие, для изме-
нения. Изменения, которые вы сделали, будут
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применяться, как только вы выбираете другое дей-
ствие. Если вы нажимаете OK, редактор списка дей-
ствий Enfocus PitStop закроется, и вы вернетесь в па-
нель управления списками действий Enfocus PitStop.

6. Нажмите OK.

Удаление списка действий

Если вы удаляете список действий, он исчезает из ле-
вой области окна панели управления списками дей-
ствий Enfocus PitStop, и стирается с вашего жесткого
диска.

Чтобы удалить список действий:

1. Выберите Window > Show PitStop Action List Panel.

2. В левой области окна панель управления списками
действий Enfocus PitStop, выберите список дейст-
вий, который вы хотите удалить.

3. Нажмите закладку Managing.

Теперь вы собираетесь удалить список действий. Он
будет физически стерт с вашего жесткого диска.
Удостоверьтесь, что вы больше не нуждаетесь в этом
списке действий, поскольку удаление списка дей-
ствий не может быть отменено.

4. Нажмите Remove.

Выбранный список действий будет немедленно уда-
лен из панели и стерт с вашего жесткого диска.

Изменение общей информации списка
действий

“Основная информация” списка действий включает:

• Название списка действий, которое является под-
робным именем списка действий. Если вы позже
экспортируете этот список действий, данное назва-
ние будет предложено как имя файла.

• Автор, т. е. имя человека, который создал данный
список действий.

• Компания, т. е. название компании, связанной со
списком действий.

• Краткое описание списка действий.

Чтобы изменить общую информацию списка дей-
ствий:

1. Выберите Window > Show PitStop Action List Panel.

2. В левой области окна панели управления списка-
ми действий Enfocus PitStop, выберите список дей-
ствий, который вы хотите изменить.

3. Поместите курсор в соответствующее текстовое
поле и измените автора, компанию или название
списка действий.

Имя будет изменено, как только вы переместите кур-
сор за пределы текстового поля.

Дублирование списка действий

Дублирование списка действий означает, что вы соз-
даете копию этого списка действий. Возможно, вам
понадобится это, чтобы создать новый список дей-
ствий, основанный на существующем. Например,
если у вас есть список действий, который меняет
TrueType шрифт в PDF документе на эквивалентный
Type 1 шрифт, и вам нужен новый, подобный спи-
сок действий, чтобы изменить Type 3 шрифт на его
Type 1 эквивалент. Вы можете дублировать список
действий Change Font, переименовать список дейст-
вий и изменить его соответствующие атрибуты.

Чтобы дублировать список действий:

1. Выберите Window >Show PitStop Action List Panel.

2. В панели управления списками действий Enfocus
PitStop, выберите список действий, который вы
хотите дублировать.

3. Нажмите закладку Managing.

4. Нажмите Dublicate.
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Enfocus PitStop Professional создаст копию выбран-
ного списка действий с тем же самым именем, что и
у оригинального с префиксом “Copy of”. Эта копия
также появится в левой области окна Enfocus PitStop. 

Панель управления списками действий. Вы можете
переименовать этот список действий.

Чтобы изменить атрибуты действий, см.
раздел “Редактирование списка действий” на
странице 87.

Импорт и экспорт списков действий

Вы можете импортировать и экспортировать списки
действий, и обращаться с ними, как с обычными фай-
лами:

• Экспорт списка действий означает, что вы сохра-
няете его как файл на диске.

• Импорт списка действий означает, что вы загружа-
ете его как файл в панель управления списками
действий Enfocus  PitStop.

Вы может понадобиться экспортировать список
действий по ряду различных причин, например:

• Для повторного использования этого списка дейст-
вий позже.

• Чтобы создать резервную копию этого списка дей-
ствий.

• Чтобы использовать список действий совместно с
другими пользователями.

• Чтобы послать список действий сервисной службе
или любому другому получателю PDF документа.

Например, сервисные службы, использующие Enfo-
cus PitStop Professional, могут включить один или
большее количество списков действий в свои “горя-
чие папки” PitStop Server, чтобы выполнить автома-
тические действия с множеством PDF документов.
См. также раздел “Дальнейшая автоматизация” на
странице 96.

Если вы экспортируете список действий, который
нужно использовать другим пользователям, мы
рекомендуем, чтобы вы защитили установки списка
действий  паролем. Для получения дополнительной
информации, см. раздел “Блокировка списка дейст-
вий паролем” на странице 90.

Чтобы импортировать список действий:

1. Выберите Window > Show PitStop Action List Panel.

2. Нажмите закладку Managing.

3. Нажмите Import.

4. Выберите список действий для импорта.

5. Нажмите Open.

Импортированный список действий появится внизу
левой области окна панели управления списками
действий Enfocus PitStop.

Чтобы экспортировать список действий:
1. Выберите Window > Show PitStop Action List Panel.
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2. В панель управления списка действий Enfocus Pit-
Stop выберите список действий, который вы хоти-
те экспортировать.

3. Нажмите закладку Managing.

4. Нажмите Export.

Если список действий не защищен паролем, появится
следующее сообщение:

5. Определите имя и местоположение файла списка
действий.

6. Нажмите Save.

Блокировка списка действий паролем

Вы можете заблокировать ваш список действий
паролем, чтобы предохранить от изменения его
установок. Это может быть удобно, если список дей-
ствий используется несколькими пользователями.
Вы можете блокировать список действий паролем
сразу при создании списка действий или вы можете
добавить пароль впоследствии.

Пароль может включать:

• Символы верхнего и нижнего регистра.

• Любой знак на клавиатуре.

• Пробелы.

Чтобы заблокировать список действий паролем:

1. Выберите Window > Show PitStop Action List Panel.

2. В панели управления списками действий Enfocus
PitStop выберите список действий, который вы
желаете заблокировать паролем.

3. Нажмите закладку Managing.

4. Нажмите кнопку Lock with Password.

Появится окно диалога Password.

5. Введите ваш пароль в текстовом поле.

6. Нажмите OK.

Общая информация относительно заблокированно-
го списка действий (имя, автор и компания) и кноп-
ка Edit потускнеют в панели управления списками
действий Enfocus PitStop. Кнопка Password изменит-
ся на “Unlock with Password”.
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Вид списка действий, который заблокирован паролем:
AA.. Общая информация потускнела. 
BB.. Кнопка Password изменилась на Unlock with Pass-
word. CC..  Кнопка Edit потускнела.

Защищенный паролем список действий вы можете
экспортировать, удалять или дублировать, но не мо-
жете редактировать:

• Если вы нажимаете Remove, список действий будет
немедленно удален из области окна панель упра-
вления списками действий Enfocus PitStop. Даже
если этот список защищен паролем, Enfocus PitStop
Professional не будет запрашивать подтверждение
на его удаление.

См. также раздел “Удаление списка действий”
на странице 88.

• Если вы дублируете, защищенный паролем список
действий, копия будет блокирована с тем же самым
паролем как первоначальный список действий. См.
также “Дублирование списка действий” на страни-
це 88.

Мы рекомендуем, чтобы вы заблокировали
список действий паролем перед его экспортом,
это гарантирует, что установки списка дей-
ствий остаются неизмененными.
См. также раздел “Импорт и экспорт списков
действий” на странице 89.

Выполнение списка действий

Когда вы выполняете список действий, действия
будут применяться к вашему PDF документу в  том
порядке, в котором они перечислены в списке. Вы
можете применять список действий по отношению к:

• Текущей странице.

• Диапазону страниц.

• Ко всему PDF документу.

Вы можете также сгенерировать рапорт выполнения
списка действий. Этот рапорт перечислит проверки
и сообщения, которые Вы, возможно, определили,
когда создавали список действий.

Чтобы применить один или большее количество
списков действий автоматически к множеству PDF
документов, вы можете использовать программу
Enfocus PitStop Server. См. также раздел “Дальней-
шая автоматизация” ниже.

Чтобы выполнить список действий.

1. В Adobe Acrobat откройте PDF документ, который
вы хотите отредактировать.

2. Выберите Window > Show PitStop Action List Panel.

Появляется панель управления списками действий.

Панель управления списками действий Enfocus Pit-
Stop, показывающая имя PDF документа (AA) и список
действий, который будет выполнен (BB).
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Для получения дополнительной информации
относительно создания и управления списками
действий, см. “Создание списка действий” на
странице 82 и “Управление списками дейст-
вий” на странице 87.

3. Выберите список действий, который вы желаете
выполнить.

4. Выберите диапазон страниц, к которым вы хотите
применить данный список действий.

Примените список действий к текущей странице,
определенному диапазону страниц или целому PDF
документу.

5. Удостоверьтесь, что в панели управления списками
действий Enfocus PitStop отображены правильный
PDF документ и правильный список действий.

6. Нажмите Execute (Выполнить), чтобы применить
изменения к PDF документу.

Enfocus PitStop Professional изменяет PDF документ и
отображает продвижение изменения на панели уп-
равления списками действий Enfocus PitStop.

Состояние списка действий в процессе, — как оно по-
казано в панели управления списками действий Enfo-
cus PitStop.

Если результат выполнения списка действий
оказался не тем, что вы ожидали, вы можете
отменить действия. Чтобы отменить дей-
ствия, выберите Edit > Undo Execute PitStop
Action List.

Список действий на практике

Давайте посмотрим на пару примеров того, как
списки действий работают на практике. Цель этих
примеров состоит в том, чтобы проиллюстрировать,
как делать выборы, как использовать операторов и
какие изменения применять. Примеры следующие:

• Создание списка действий, который изменяет
свойства шрифта PDF документа.

• Создание списка действий, который изменяет рас-
кладку страниц PDF документа (см. страницу 94)

Примеры стремятся показать PDF документ
до и после того, как списки действий применя-
лись и какие нужны выборы и изменения, что-
бы получить требуемый результат. Чтобы
быть способным создать эти типовые списки
действий, вы должны знать, как добавить
необходимые выборы, изменения и операторы.
Для постепенного описания того, как создать
список действий, см. раздел “Создание списка
действий” на странице 82.
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Создание списка действий, изменяющего
свойства шрифта PDF документа

Предположим, что у вас есть ряд PDF документов, и
основное заглавие в каждом из них имеет следую-
щие свойства шрифта:

Вы знаете, что шрифт Verdana используется только
для основного заголовка. Больше в документе он ни-
где не встречается.

Вы можете проверять эти свойства, исполь-
зуя Inspector Enfocus PitStop. Для получения до-
полнительной информации, см. “Изменение
свойств шрифта” на странице 99.

Для всего этого PDF документа, вы хотите создать
список действий, который изменит свойства шриф-
та этого основного заголовка следующим образом:

Визуальное представление изменений показано на
иллюстрации ниже.

Изменение свойств шрифта основного заголовка 
(А — А’) в целом PDF документе.

Чтобы создать список действий, который изменяет
свойства шрифта PDF документа.

1. В панели управления списками действий Enfocus
PitStop создайте список действий, который выгля-
дит следующим образом:
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2. В панели управления списками действий Enfocus
PitStop выберите соответствующий список дейст-
вий и нажмите Execute.

Enfocus PitStop Professional применит список дей-
ствий в следующих шагах:

Создание списка действий, изменяющего
раскладку страниц PDF документа

Предположим, что у вас есть PDF документ буклета,
который почти готов к печати. Страницы должны
быть напечатаны с двух сторон, сложены и обре-
заны. Вы надо удостовериться, что номера страниц,
которые находятся близко к краю страницы, не об-
режутся. Действительно, когда страницы сфальцо-
ваны для шитья внакидку, напечатанная область
слегка перемещается по направлению к наружной
стороне. В издательском деле это известно как спол-
зание (greep). Чем больше страниц в буклете, тем
больше будет сползание внутренних страниц.

Сползание перемещает напечатанную область вну-
тренних страниц за пределы, которые могут обре-
заться вместе с колонцифрами, расположенными
около внешних краев страниц.

Чтобы компенсировать это сползание, вы можете
создать список действий, который делает следующее:

• Сдвигает напечатанную область левых (четных)
страниц на 5 мм вправо.

• Сдвигает напечатанную область правых (нечет-
ных) страниц на 5 мм влево (ближе к переплету).
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• Оставляет первую страницу без изменений (потому
что эта страница, как правило, не нумеруется).

Визуальное представление изменений показано на
иллюстрации ниже.

Изменение раскладки страницы: переместите напе-
чатанную область внутренних страниц (BB и CC) к
переплету, чтобы компенсировать сползание, но
оставьте первую страницу (AA) без изменений.

Чтобы создать список действий, который изменяет
свойства шрифта PDF документа.

1. В панели управления списками действий создайте
список действий, который выглядит следующим
образом:

2. Нажмите кнопку ( ), чтобы просмотреть стра-
ницы в конечном размере устройства и увидеть:

• Ширину полосы после обрезки.

• Порядковые маркеры страниц, если они есть.

• Приводные кресты страницы, если они есть. 

• Выходы за обрез страницы, если они есть.

• Шкалы для контроля цветопередачи, если они есть.

3. В панель управления списками действий Enfocus
PitStop выберите соответствующий список дейст-
вий и нажмите Execute.

Enfocus PitStop Professional применит список дейст-
вий в следующих шагах:
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Дальнейшая автоматизация

Как объяснено во введении в эту главу, вы можете
использовать списки действий, чтобы автоматизи-
ровать выполнение скучных задач. Вы можете груп-
пировать эти задачи в список действий и применять
этот список действий к одному или множеству PDF
документов.

Но, если у вас есть большое количество PDF доку-
ментов, к которым вы хотите применить один и тот
же список(ски) действий, вы можете почувствовать
потребность в дальнейшей автоматизации. Действи-
тельно, без дальнейшей автоматизации вы должны:

• Открыть каждый отдельный PDF документ.

• Выполнить один или несколько списков действий.

• Закрыть и сохранить PDF документ.

Эти задачи сами по себе могут стать скучными и,
таким образом, получить право на автоматизацию.

Enfocus PitStop Server предлагает дальнейшую авто-
матизацию обработки задач PDF. Enfocus PitStop
Server — автономное приложение, которое вы
можете использовать, чтобы создать так называ-
емые “горячие папки” (hot folders). В этих горячих
папках, вы можете включать один или несколько

списков действий, и, в случае необходимости, даже
PDF профиль. Эти списки действий и профили бу-
дут выполняться автоматически, как только PDF
документ появится в определяемой пользователем
папке.

Более подробная информация относительно прило-
жения Enfocus PitStop Server доступна на нашем web-
сайте: www.enfocus.com.
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Р едактирование текста в Enfocus PitStop Profes-
sional позволяет вам изменять разметку набора
текста, а также изменять текстовое содержание

ваших PDF документов, например, добавлять или
изменять текст. Вы можете редактировать текст на
одиночной текстовой строке или в целом параграфе.

Редактирование одиночной 
текстовой строки

Enfocus PitStop Professional позволяет вам редакти-
ровать отдельные текстовые строки. Это особенно
удобно для незначительной коррекции, вроде ис-
правления орфографических ошибок.

Чтобы отредактировать одиночную текстовую строку:
1. Выберите инструмент Edit Text Line ( ).

Курсор изменится на        .

2. Щелкните на текстовой строке, в том месте, где вы
хотите отредактировать и сделайте необходимые
изменения.

Вы можете выбрать текст только на теку-
щей строке. Если вы должны отредактиро-
вать больше чем одну текстовую строку, ис-
пользуйте инструмент редактирования пара-
графа, как описано ниже.

Редактирование параграфа

Если вам надо сделать изменения, которые охваты-
вают несколько текстовых строк, вы должны ис-
пользовать инструмент редактирования параграфа.
Этот инструмент позволяет вам выбирать “логиче-
ский текстовый объект”. Логический текстовый
объект — это кусок текста между двумя знаками
препинания или пробелами, или кусок текста с раз-
личными свойствами шрифта.

Чтобы отредактировать параграф:

1. Нажмите инструмент Edit Paragraph ( ).

Курсор изменится на      .

2. Щелкните на параграфе, который вы хотите отре-
дактировать. Выбранный параграф обрисуется
красным прямоугольником с точкой привязки в
левом нижнем углу.

3. Измените текст выбранного параграфа.
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4. В случае необходимости, переместите или измени-
те размер красного блока, для изменения позиции
выбранного параграфа.

AA.. Используйте точку привязки для перемещения бло-
ка параграфа в другую позицию. BB..  Изменение разме-
ра блока параграфа. 

Редактирование вертикального текста

Вы можете использовать инструмент Edit Vertical
Text Line для редактирования вертикального текста.

Линия вертикального текста.

Чтобы отредактировать вертикальную текстовую
линию:

1. Выберите инструмент Edit Vertical Text Line ( ).

Курсор изменится на       .

2. Щелкните на вертикальной текстовой линии в
том месте, где вы хотите отредактировать текст и
сделайте любые необходимые изменения.

Добавление нового текста

Помимо редактирования текста, вы можете также
добавлять новый текст к вашему PDF документу.
Используя инструментальные средства редактирова-
ния текста, вы можете добавлять:

• Новая горизонтальная текстовая линия.

• Красная строка.

• Новая вертикальная текстовая линия.

Для нового текста вы можете установить
свойства шрифта по умолчанию. См. раздел
“Настройка предпочтений Enfocus PitStop Pro-
fessional” на странице 11.

Чтобы добавить новый текст:

1. Выберите любое из следующих инструментальных
средств:

• Инструмент Edit Text Line ( ), — чтобы добавить
новую текстовую строку.

• Инструмент Edit Paragraph ( ), — чтобы доба-
вить новый параграф текста.
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• Инструмент Edit Vertical Text Line ( ), — чтобы
добавить новый вертикальный текст.

Курсор изменится на       .

2. Переместите курсор в область, которая не содер-
жит текст.

Курсор изменится на        .

3. Нажмите в том месте PDF документа, где вы хоти-
те добавить новый текст.

В зависимости от инструмента, который вы выбра-
ли, произойдет следующее:

• Если вы выбрали добавление новой текстовой
строки, появится  только мигающий курсор.

• Если вы выбрали добавление нового параграфа,
появится красный блок, указывающий ширину
вашего параграфа.

Чтобы откорректировать ширину блока параграфа,
поместите курсор поверх правой вертикальной
линии блока, и перетащите его в нужную позицию.

• Если вы выбрали добавление новой вертикальной
текстовой линии, появится только мигающий кур-
сор.

4. Введите новый текст.

Изменение свойств шрифта

Свойствами шрифта являются:

• Имя семейства шрифта, например, Times-Roman.

• Размер шрифта, например, 10 пунктов.

• Стиль шрифта, например, Times-Bold.

Чтобы изменить свойства шрифта выбранного тек-
ста используйте Font Picker (Сортировщик шрифта).
Вы можете выбрать текст двумя способами:

• Используя инструмент Select Objects и Select Similar
Objects ( ) или инструмент (       ).

• Используя один из инструментов редактирования
текста ( ) или ( )

Доступные семейства шрифта зависят от того, какие
шрифты установлены в вашей системе. Вы можете
также использовать Font Picker, чтобы получить
список всех шрифтов, установленных в вашей сис-
теме.

Чтобы изменить свойства шрифта выбранного тек-
ста:

1. Выберите инструмент Select Objects ( ) или од-
но из инструментальных средств редактирования
текста ( ) или ( ).

2. Выберите один или несколько текстовых сегмен-
тов в PDF документе, который вы хотите изме-
нить.

3. Выберите Window > Show PitStop Inspector, чтобы
отобразить окно диалога Enfocus PitStop Inspector.

Появится окно диалога Enfocus PitStop Inspector, ко-
торое по умолчанию отображает текущие установки
цвета выбранного текста на закладке Color, как по-
казано ниже.
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4. В Enfocus PitStop Inspector нажмите закладку Text.

Enfocus Инспектор PitStop отобразит свойства вы-
бранного настоящий момент текста.

5. Нажмите Font Picker (Сортировщик шрифта).

Появится окно диалога Font Picker и покажет все
шрифты, которые:

• Используются на текущей странице открытого PDF
документа.

• Используются во всем PDF документе.

• Доступны в  системе.

6. Вы можете отсортировать список, нажимая кноп-
ки поверх списка: Font Name, Type или Status.

7. Выберите шрифт из списка в окне диалога Font
Picker (Сортировщик шрифта).

Выбранный шрифт в вашем PDF документе будет
заменен в интерактивном режиме.
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8. В случае необходимости, выберите опцию Embed
Font (Внедрить шрифт).

Для получения дополнительной информации
относительно внедрения шрифтов, см. раздел
“Внедрение шрифтов” на странице 132.

9. Нажмите OK.

10. Если требуется, выберите другой размер шрифта.

11. Вы можете также сделать одно из следующего:

• В области Spacing откорректировать интервалы
между словами или между символами.

• Если вы выбрали текст, используя кнопку ( ) ,  вы
можете разбить выбранный текстовый сегмент на
слова или символы, нажимая соответствующие
кнопки: (Split in Words), (Split in Characters).

• Если вы выбрали текст, используя инструменты
редактирования текста ( ) или ( ), вы можете
установить выравнивание выбранного текстового
сегмента.

Вы можете установить свойства шрифта по
умолчанию для нового текста. См. “Настрой-
ка предпочтений Enfocus PitStop Professional”
на странице 11.

Изменение цвета текста

Вы можете изменить не только цвет текста, но также
и цветовую модель: сделать цвет текста в цветовой
модели Gray или CMYK или RGB или назначить для
текста дополнительную (spot) краску.

Чтобы изменить цвет текста:

1. Выберите инструмент ( ).

2. Щелкните на базовой линии текста, цвет которого
вы хотите изменить. Если вы хотите выбрать це-
лую текстовую строку, дважды щелкните на базо-
вой линии текста.

3. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель инспектора Enfocus PitStop.

Появится панель Inspector Enfocus PitStop, на кото-
рой будет показаны текущие установки цвета вы-
бранного текста, как на рисунке ниже.

4. Сделайте одно из следующего:
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• Чтобы изменить цвет текста в пределах одной и
той же цветовой модели (например, CMYK), пере-
местите движок соответствующего цвета влево или
вправо или введите процент красок в текстовом
поле. Перемещаете движок, вы будете видеть пос-
тепенные изменения цвета текста.

• Чтобы изменить цвет текста на другую цветовую
модель (например, Gray, RGB или CMYK), нажмите
соответствующую кнопку и, в случае необходимос-
ти, переместите соответствующий движок или вве-
дите процент в текстовом поле.

• Если ваш PDF документ содержит дополнительные
(spot) краски и вы желаете изменить цвет выбран-
ного текста на одну из этих дополнительных кра-
сок, нажмите кнопку Spot Color. Выберите одну из
доступных дополнительных красок в Spot Color
Picker (Сортировщике дополнительных красок), и
нажмите OK.
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Эта глава определяет главные различия между
графикой и пиксельными изображениями  и
показывает вам, как использовать Enfocus Pit-

Stop Professional для редактирования этих объектов.
Вы можете легко изменять форму графических объ-
ектов в PDF документах или даже создавать новую
графику. 

Относительно векторной графики 
и пиксельных изображений

Имеются два основных вида компьютерного изо-
бражения:

• Графика.

• Пиксельные иллюстрации.

Эти два вида по-разному представлены в PDF доку-
ментах, и вы можете управлять каждым из этих ви-
дов по-своему. Понимание характеристик этих ви-
дов поможет вам понять их различное поведение
при работе с PDF документами.

Графика

Графика составлена из математически определен-
ных кривых и сегментов линий, называемых векто-
рами. Эти векторы описывают графику согласно их
геометрическим характеристикам как ряд линий в
системе координат X и Y, начал линии и окончаний
линии.

Например, наклонная линия может быть математи-
чески описана как линия, выведенная от координа-
ты h0 к координате a8 с определенной толщиной ли-
нии и определенным углом наклона.

Векторное представление наклонной линии.

Вы можете редактировать графику, перемещая и
изменяя размер целого графического символа или
линий и сегментов, которые составляют графиче-
ский символ. Графика не зависит от разрешения
(resolution): вы можете масштабировать графиче-
ский символ до любого размер и печатать его на лю-
бом устройстве вывода в любом разрешении без
потери качества, детализации и четкости. 
Графика также известна как объектно-ориентиро-
ванная (object-oriented graphics) или векторная (vector
graphics) графика.

Векторная графика описывает форму по ее геоме-
трическим характеристикам и независима от разре-
шения.
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Пиксельные изображения 

Пиксельные изображения сформированы прямоу-
гольной сеткой (также известной как точечный ри-
сунок — bitmap — или растр) маленьких квадра-
тов — пикселов. Каждый пиксел в изображении
имеет определенное расположение и содержит дан-
ные, которые описывают, является ли он черным
или белым или задают определенные координаты
цвета.

Например, наклонная линия в пиксельном изобра-
жении составлена из совокупности пикселов в опре-
деленном расположении, в котором пикселы A7 и
A8 являются черными, B6 и B7 так же черные, и т. д. 

Растровое представление наклонной линии. 

Вы можете редактировать пиксельные изображения,
изменяя или управляя пикселами или группами
пикселов. Для этого вам нужно программное обес-
печение — редактор пиксельных изображений, типа
Adobe Photoshop.

Пиксельные изображения зависят от разрешения
(resolution), поскольку число пикселов, которые
описывают графический символ, всегда устанавли-
вается. Масштабирование пиксельного изображе-
ния не изменит абсолютное число пикселов, но из-
менит число пикселов на квадратную единицу изме-
рения. Следовательно, пиксельные изображения, ес-
ли они увеличены или напечатаны в более высоком
разрешении, чем следует, могут оказаться “зубчаты-
ми” и потерять качество.  Пиксельные изображения
также называются растровыми изображениями.

Пиксельное изображение описывает формы в виде
квадратиков-пикселов, оно зависит от разрешения.

Относительно траекторий,
якорных и направляющих точек

В следующих разделах, вы узнаете, как создавать и
редактировать векторную графику. Графика состоит
из ряда типовых элементов, и важно иметь хорошее
понимание того, что эти элементы собой представ-
ляют, прежде чем вы начнете редактировать или со-
здавать векторную графику. Эти элементы:

• Траектории (Path).

• Якорные точки (Anchor points).

• Направляющие точки (Direction points).

Вы найдете краткое объяснение каждого из этих эле-
ментов ниже.

Траектории

Траектория  (Path) — любая линия или форма в гра-
фическом объекте. Траектория может иметь любую
форму, включая:

• круг
• прямоугольник
• прямую линию
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Отдельные элементы, которые составляют траекто-
рии, называются сегментами. Иногда в траектории
может быть только один сегмент, иногда она может
состоять из множества сегментов.

Траектория (AA), составленная из двух сегментов (BB и CC)

Якорные точки

Если вы выводите линию — или ее сегмент — на
листе бумаге, вы начинаете в той точке, где прикла-
дываетесь карандашом к бумаге, и останавливаетесь
в другой точке, где отрываете карандаш от бумаги.
В графике, эти точки называются якорными точка-
ми (Anchor points). Логически, если вы переместите
эти якорные точки, вы измените сегмент пути и,
возможно, форму пути.

Якорные точки (AA, BB и CC) определяют начало и конец
каждого сегмента.

Направляющие точки

Изогнутые сегменты имеют, около своих якорных
точек, два дополнительных вида управления, назы-
ваемого направляющими точками  (Direction points).
Эти направляющие точки соединяются с якорными
точками изогнутого сегмента посредством направ-
ляющих линий. Если вы перемещаете любую из этих
направляющих точек, вы изменяете форму кривой.

Направляющие точки контролируют форму изогну-
тых сегментов.

Изменение цвета 
графического объекта 

Вы можете изменять цвет заполнения (fill) или об-
водки (stroke) графических объектов, а также цвет
линий траекторий. Вы можете также определять для
них другую цветовую модель. Для этого вам надо ис-
пользовать панель Enfocus PitStop Inspector.

Чтобы изменить цвет графического объекта:

1. Нажмите кнопку инструмента Select Objects ( ).

Enfocus PitStop Professional
User Guide

105



2. Щелкните на объекте, который вы хотите изме-
нить.

3. Выберите Window > Show PitStop Inspector, по-
явится панель Enfocus PitStop Inspector.

Инспектор Enfocus PitStop отображает текущие уста-
новки цвета выбранного объекта, как показано на
рисунке ниже.

4. Чтобы изменить цвет заполнения, делайте одно из
следующего:

• Чтобы изменить цвет заполнения объекта в преде-
лах той же самой цветовой модели (например,
CMYK), переместите движок соответствующего
цвета влево или вправо или введите процент в тек-
стовом поле.

• Чтобы изменить цвет объекта в другой модели
цвета (Gray, RGB или CMYK), нажмите соответ-
ствующую кнопку и, в случае необходимости, пере-
местите соответствующий движок влево или впра-
во или введите процент в текстовом поле.

• Если ваш PDF документ содержит дополнительные
(spot) краски и вы желаете изменить цвет выбран-
ного текста на одну из этих дополнительных кра-
сок, нажмите кнопку Spot Color. Выберите одну из
доступных дополнительных красок в Spot Color

Picker (Сортировщике дополнительных красок), и
нажмите OK.

В случае необходимости, вы можете изменить
метод заполнения графического объекта на
закладке Fill/Stroke. Вы можете выбрать меж-
ду Fill ( ) и Eofill ( ). Для получения бо-
лее подробной информации см. раздел “Запол-
нение графических объектов, содержащих вну-
тренние формы” на странице 107.

5. Чтобы изменить цвет обводки выбранной траек-
тории, делайте одно из следующего:

• Если объект не содержит обводки, нажмите заклад-
ку Fill/Stroke, выберите Stroke On и определите ус-
тановки обводки.

• Если объект содержит обводку, и вы хотите изме-
нить ее цвет, нажмите закладку Color и повторите
действия, описанные в пункте 4.
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Заполнение графических объектов,
содержащих внутренние формы

Объекты с внутренними формами могут отличаться
от других графических объектов. Внутренние фор-
мы являются составными путями с пересекающими-
ся линиями внутри самих объектов. Чтобы опреде-
лять, является ли заполнение частью внутренней
формы или нет, могут применяться различные пра-
вила заполнения: стандартное правило или правило
четный–нечетный (even–odd (EO)). Эти правила оп-
ределяют метод заполнения форм, как демонстриру-
ет иллюстрация ниже:

AA. Многоугольник с четным–нечетным заполнением. 
BB.. Многоугольник со стандартным заполнением. 

Правило заполнения четный–нечетный предпола-
гает, что вы выводите линию между точкой внутри
контура объекта (xx) и точкой вне его контура (yy). Ес-
ли эта линия пересекает контур объекта нечетное
число раз, область внутренней формы, в которой на-
ходится точка (xx), будет заполнена. Если число пере-
сечений четное, область не будет заполнена, как это
показано на предыдущей иллюстрации.

Просмотр печатных установок
объекта и изменение установок
оверпринта

Панель Enfocus PitStop Inspector также позволяет
вам просматривать печатные установки объектов в
PDF документе.

Чтобы просмотреть печатные установки объекта:

Быстрый доступ: Выберите Window > Show
PitStop Inspector > закладка Prepress.

1. Выберите Window > Show PitStop Inspector.

2. Выберите закладку Prepress.

3. Чтобы просмотреть печатные установки выбран-
ного объекта, нажмите любую из четырех закладок:

• Summary (Резюме)
• Overprint (Печать с наложением)
• Halftone (Полутона)
• OPI (OPI-информация)

4. В случае необходимости, измените установки
оверпринта цвета заполнения или обводки объек-
та ( = вкл.; = выкл.).
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Изменение или удаление 
OPI*информации объектов

Если ваш PDF документ содержит объекты с OPI-
информацией, вы можете изменить или удалить эту
информацию, используя Enfocus PitStop Inspector.

Чтобы изменить OPI-информацию для выбранного
объекта:

1. Выберите инструмент Select Objects ( ).

2. Выберите Window > Show PitStop Inspector, чтобы
отобразить Enfocus PitStop Inspector.

3. Выберите объект в вашем PDF документе, для
которого вы хотите изменить OPI-информацию.

4. Выберите на закладке Prepress > закладку OPI, что-
бы отобразить OPI-информацию выбранного
изображения.

5. Поместите курсор в текстовом поле Filename и
сделайте необходимые изменения. Например, вы
можете изменить имя файла изображения или
прописать к нему другой путь на жестком диске.

6. Нажмите кнопку Change (Изменить). 

Изменение прозрачности объектов

Вы можете делать объекты прозрачными или изме-
нять установки их прозрачности. Кроме того, вы
можете удалить прозрачность выбранного объекта
или объектов на целой странице.

Чтобы изменить прозрачность объектов:

1. Выберите Window > Show PitStop Inspector.

2. Выберите Prepress > закладка Transparency.

3. Выберите объект, для которого вы хотите изме-
нить прозрачность.

4. Вы можете сделать следующее:

• Чтобы изменить прозрачность для заполнения объ-
екта, переместите движок Alpha Fill. Чтобы изме-
нить прозрачность для обводки — Alpha Stroke.
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• Чтобы изменить способ, при котором цвета про-
зрачного объекта смешиваются с цветами фоно-
вых объектов, выберите закладку Blending, и затем
выберите нужные вам режимы смешивания.

Для получения дополнительной информации
относительно режимов смешивания, посети-
те web-сайт корпорации Adobe по адресу:
www.adobe.com.

• Чтобы удалить прозрачность для выбранного объ-
екта или объектов на странице, нажмите закладку
Remove и соответствующую кнопку Remove.

Выбор объектов 

Чтобы выбрать объект в вашем PDF документе, вы
можете использовать одно из двух инструменталь-
ных средств выбора:

• Инструмент Select Objects  ( ).

• Выбор Select Similar Objects ( ).

Выбор одного определенного объекта

Инструмент Select Objects ( ) работает почти пол-
ностью также как в режиме предварительного прос-
мотра и в режиме просмотра фреймов. Единствен-
ное отличие — то, что в режиме просмотра фреймов
вы можете выбрать графику и векторные изображе-
ния только щелчком на их контурах. См. также раз-
дел “Просмотр PDF документа” на странице 21.

AA. Выбор объекта в режиме предварительного про-
смотра может быть сделан щелчком в любом месте
на объекте. BB.. Выбор объекта в режиме просмотра
фреймов возможен только щелчком на контурах объ-
екта. 

Чтобы выбрать объект:

1. Выберите инструмент Select Objects ( ).
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2. Щелкните на объекте или очертите вокруг объек-
та рамку для выделения, называемую marquee.

Обрисовка рамки вокруг объекта для выделения пол-
ного графического символа.

• Если вы выберите графический объект или пик-
сельное изображение, вы увидите, что контуры
выделения будут выведены вместе с якорными точ-
ками (для графики). Если вы активировали опцию
центрального маркера для выделенных объектов в
Preferences Enfocus PitStop Professional, в центре
ограничивающей рамки объекта появится цен-
тральный маркер.

• Если вы выберите текст, вы увидите, что контур
выделения выведен по его базовой линии с
якорной точкой привязки слева на краю текстовой
линии. Эта якорная точки не активна; она не может
использоваться, чтобы изменить размер объекта.
Если вы дважды щелкаете на текстовом сегменте,
будет выбрана полная логическая текстовая линия.

• Щелчок на составной траектории выбирает только
сегмент траектории, на котором был закликан.
Двойной щелчок на такой составной траектории
выбирает целый объект.

AA.. Одиночный щелчок на составной траектории. 
BB..  Двойной щелчок на составной траектории выби-

рает целый объект. 

• Вы можете выбрать объект, который замаскиро-
ван, щелкнув на невидимой части объекта вне мас-
ки. При этом иерархическое представление объек-
тов сохраняется. Это означает, что при нажатии бу-
дет выбран перекрывающийся невидимый, замас-
кированный, прямоугольник вместо основного ви-
димого объекта. Маска может быть выбрана щелч-
ком непосредственно на ее (невидимом) контуре.
Если вы помещаете курсор поверх невидимой мас-
ки, указатель курсора будет инвертирован. Двойное
нажатие на маске выбирает целую группу масок.
Если вы дважды щелкаете на маскированном изоб-
ражении, будет выбрана первая маска, принадле-
жащая изображению.

Выбор подобных объектов

Инструмент Select Similar Objects (Выбор подобных
объектов) ( ) позволяет вам выбирать множество
объектов на одной странице, которые имеют те же
самые атрибуты. Этот инструмент может быть поле-
зен, если вы хотите изменить подобные объекты в
PDF документе.
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Чтобы выбрать подобные объекты:

1. Нажмите инструмент Select Similar Objects ( ).

Если определено в Preferences Enfocus PitStop появит-
ся панель Inspector. См. также “Настройка предпоч-
тений Enfocus PitStop Professional” на странице 11.

2. Выберите объект в вашем PDF документе. Это мо-
жет быть или графический символ (или его часть)
или текстовый сегмент.

3. Панель Inspector PitStop соответственно изменит-
ся и покажет атрибуты выбранного объекта.

4. В случае необходимости, снимите выделение од-
ного или нескольких свойств, чтобы развернуть
ваш выбор.

5. Чтобы выбрать подобные объекты сделайте одно
из следующего:

• Нажмите кнопку Select Similar Objects.

• Дважды щелкните на выбранном объекте.

Все подобные объекты, то есть объекты с теми же
самыми атрибутами, будут выбраны.

Показать/скрыть 
выбранные объекты

Как только вы выбрали один или несколько объек-
тов — текст или графику или пиксельные изображе-
ния, — вы можете скрыть выбранные объекты. Это
может понадобиться, например, если вы хотите ре-
дактировать объекты, которые трудно выбрать, по-
скольку они частично или полностью перекрывают-
ся другими объектами. Скрытые объекты не будут
видимы в режиме просмотра фреймов. Для получе-
ния дополнительной информации о режиме про-
смотра фреймов, см. раздел “Просмотр PDF докуме-
нта” на странице 21.

Вы можете одновременно скрывать один объект и
делать другие скрытые объекты видимыми.

Чтобы скрыть выбранные объекты:

1. Нажмите инструмент Select Objects ( ).

2. Выберите один или несколько объектов.

3. Выберите Window > PitStop Hide Selection.

Enfocus PitStop Professional
User Guide

111



Выбранный объект(ы) будет скрыт.

Чтобы сделать все скрытые объекты видимыми:

Выберите Edit > PitStop Show All.

Изменение порядка объектов

Иногда ваш PDF документ может содержать объек-
ты, которые положены друг на друга. Если вы хотите
отредактировать один из нижних объектов, вам,
вероятно, сначала придется перенести этот объект
наверх. В таких случаях Enfocus PitStop Professional
дает возможность изменить порядок, в котором
объекты расположены по слоям.

Изменение порядка наложения объектов: красный
фон страницы вынесен наверх.

Чтобы изменить порядок объектов:

1. Выберите объект, который вы хотите вынести по-
верх других или послать вниз.

2. Выберите Edit > PitStop Layer и выберите одну из
опций:

• Bring Forward или Send Backward — соответственно
объект двигается вверх или вниз на одну позицию.

• Bring to Front или Send to Back — соответственно
выбранный объект перемещается поверх всех оста-
льных или ниже всех.

Замена объекта

Enfocus PitStop Professional дает возможность заме-
нить один объект другим объектом с помощью ко-
пирования и вставки. Новый объект автоматически
примет точно такой же размер, что и заменяемый.
Если вставляемый объект не пропорционален по
размеру заменяемому, в результате вставки
получится “искаженный” прямоугольный объект. 

AA.. Скопируйте объект. BB.. Выберите объект, кото-
рый должен быть заменен. CC..  Вставьте “новый” объ-
ект в “старый” и размер объекта изменится  авто-
матически.

Чтобы заменить объект:

1. Выберите инструмент Select Objects ( ).

2. Выберите “новый” объект, то есть объект, кото-
рый вы хотите использовать, чтобы заменить дру-
гой.

3. Выберите Edit > Copy.

4. Выберите “старый” объект, то есть объект, кото-
рый должен быть заменен.

5. Выберите Edit > Paste.

Скопированный объект заменит “старый” объект и
примет его точный размер и позицию.
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Поворот объекта

Если вы поворачиваете объект, необходимо задать
позицию оси, вокруг которой этот объект будет по-
вернут. Эта ось обозначена красным крестиком.

Вы можете повернуть объект двумя способами:

• Перемещая его (см. ниже).

• Определяя значения в градусах угла поворота, ис-
пользуя панель Enfocus PitStop Inspector.

См. “Преобразование объекта по точным зна-
чениям” на странице 119.

Чтобы повернуть объект перемещением:

1. Выберите инструмент Select Objects ( ).

2. Выберите Window > > Show PitStop Inspector, что-
бы отобразить панель PitStop Inspector.

3. Выберите объект, который вы хотите повернуть.
См. также “Выбор объектов” на странице 109.

4. Нажмите инструмент Rotate Selection ( ).

Панель Enfocus PitStop Inspector изменится соответ-
ственно.

5. В случае необходимости измените углы ограниче-
ния (для поворота с нажатой клавишей Shift), цвет
знака перекрестья (для оси вращения) или едини-
цы измерения в области Preferences.

В области Numeric Feedback вы можете найти точ-
ную информацию относительно действия, которое
вы собираетесь выполнять.

6. Щелкните на выбранном объекте.

Появится красный знак перекрестья, который обоз-
начает местонахождение оси, вокруг которой объект
будет повернут.
По умолчанию знак перекрестья находится в центре
выбранного объекта.
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7. Сделайте одно из следующего:

• Чтобы повернуть объект вокруг его середины, пе-
ретащите курсор в произвольном круговом напра-
влении.

Поворот объекта вокруг его центра.

• Двойной щелчок в другой позиции переместит
знак перекрестья. Переместите указатель подальше
от оси вращения объекта и выполните круговое
движение, чтобы повернуть объект вокруг его но-
вой оси.

Поворот объекта вокруг оси вращения, помещенной
вне объекта.

• Удерживайте клавишу Shift при перемещении кур-
сора, чтобы повернуть объект по определенному
углу. Вы можете установить этот угол в области
Preferences окна диалога Enfocus PitStop Inspector. 

• Удерживайте клавишу  Alt  (в Windows) или Option
(в Macintosh) при перемещении, чтобы создать
повернутую копию выбранного объекта.

Масштабирование объекта

Вы можете масштабировать объект, чтобы увели-
чить или уменьшить его горизонтально или верти-
кально или в обоих направлениях одновременно. Вы
можете также использовать инструмент выбора мас-
штаба, чтобы изменить форму объекта или создать
масштабируемую копию выбранного объекта. 

Масштабировать объект можно двумя способами:

• Перемещая его (см. ниже).

• Определяя коэффициент масштабирования, ис-
пользуя панель Enfocus PitStop Inspector. См. “Пре-
образование объекта по точным значениям” на
странице 119.

Чтобы масштабировать объект с перемещением:

1. Выберите инструмент Select Objects ( ).

2. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

3. Выберите объект, который вы хотите масштаби-
ровать. Щелкните на объекте, или очертите кур-
сором прямоугольник вокруг объекта.

Переместите курсор вокруг объекта, чтобы выбрать
целый графический символ.
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4. Нажмите инструмент Scale Selection ( ).

Панель Enfocus PitStop Inspector изменится соответ-
ственно.

5. В случае необходимости измените цвет значка пе-
рекрестья или единицы измерения в области Pre-
ferences.

В области Numeric Feedback вы можете найти
точную информацию относительно действия
масштабирования, которое вы собираетесь
выполнять.

6. Щелкните на выбранном объекте.

Появится знак перекрестья, который обозначает
точку привязки, относительно которой объект будет
масштабироваться.

По умолчанию тоска привязки находится в центре
выбранного объекта.

7. Сделайте одно из следующего:

• Чтобы масштабировать объект непропорциональ-
но, перетащите курсор в нужном направлении.

Масштабирование объекта непропорционально из-
меняет соотношение высоты к ширине объекта.

• Двойной щелчок в другой позиции перемещает то-
чку привязки. Затем перетащите курсор, чтобы
масштабировать объект, используя новую точку
привязки. Например, вы можете поместить точку
привязки на одном из углов прямоугольного объ-
екта, чтобы сохранить две стороны объекта в уста-
новленной позиции при масштабировании.

Масштабирование объекта с точкой привязки вне
центра объекта.

• Удерживайте клавишу Shift при перемещении, что-
бы масштабировать объект пропорционально, то -
есть сохранить соотношение высоты к ширине мас-
штабируемого объекта, идентично оригиналу.
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• При перемещении удерживайте клавишу Alt (в Win-
dows) или Option (в Macintosh), чтобы создать мас-
штабированную копию выбранного объекта.

Перемещение объекта

Вы можете выбрать и переместить любой объект в
PDF документе в новое месторасположение.

Объект может перемещаться двумя способами:

• Перемещение вручную (см. ниже).

• Определением данного расстояния и направления,
используя Enfocus PitStop Inspector. См. “Преобра-
зование объекта по точным значениям” на страни-
це 119.

Чтобы переместить объект или копию объекта:

Чтобы облегчить выравнивание объектов, ко-
торые вы передвигаете, вы можете использо-
вать магнитные направляющие. См. “Встав-
ка направляющих в PDF документе” на стра-
нице 28.

1. Выберите инструмент Select Objects ( ).

2. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

3. Выберите объект, который вы хотите перемес-
тить.

Для выбора нескольких объектов вы можете щел-
кать по ним мышью при нажатой клавише Shift.

4. Выберите инструмент Move Selection ( ) или на-
жмите клавишу Ctrl.

Указатель изменится со значка ( ) на значок ( ).

Панель Enfocus PitStop Inspector изменится соответ-
ственно.

5. В случае необходимости, измените единицы изме-
рения в области Preferences.

В области Numeric Feedback вы можете найти
точную информацию относительно переме-
щения, которое вы собираетесь выполнить.

6. Сделайте одно из следующего:

• Перетащите выбранный объект в новое местопо-
ложение.
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Перемещение выбранного объекта в новое местополо-
жение.

• Для соблюдения горизонтального или вертикаль-
ного направления при перетаскивании объекта
нажмите и удерживайте клавишу Shift.

Удерживайте клавишу Shift при перемещении объ-
екта в строго вертикальном или горизонтальном на-
правлении.

• Чтобы создать копию объекта в новом расположе-
нии, при перетаскивании объекта удерживайте
клавишу Alt (в Windows) или Option (в Macintosh).

Удерживайте клавишу Alt (в Windows) или Option
(в Macintosh) при перемещении объекта — для созда-
ния копии объекта в новом местоположении.

Наклон объекта

Наклон искажает объект, — это очень похоже, как
если бы прямоугольник видоизменился в параллело-
грамм, как показано на рисунке ниже.

Чтобы наклонить объект:

1. Выберите инструмент Select Objects ( ).

2. Выберите объект, который вы хотите наклонить.
Щелкните на объекте, или обведите прямоуголь-
ную область выделения вокруг объекта.
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Перемещение точечного прямоугольника области вы-
деления вокруг объекта, чтобы выбрать целый гра-
фический символ.

3. Выберите инструмент Shear Selection ( ).

Панель Enfocus PitStop Inspector изменится  соответ-
ственно.

4. В случае необходимости, измените ограничения
для углов сдвига (чтобы сдвигать под определен-
ным углом при нажатой клавише Shift), цвет знака
перекрестья или единицы измерения в области
Preferences.

В области Numeric Feedback вы можете найти
точную информацию относительно действия
наклона, которое вы собираетесь выполнить.

5. Щелкните на выбранном объекте.

Появится знак перекрестья, который обозначает
точку привязки, относительно которой объект будет
наклонен.

Точка привязки по умолчанию находится в центре
выбранного объекта.

6. Сделайте одно из следующего:

• Чтобы наклонить выбранный объект, перетащите
курсор мыши в любом направлении при сохране-
нии центральной точки привязки.

• Для того чтобы переместить точку привязки, вы-
полните двойной щелчок мышью в другой пози-
ции внутри или вне объекта. Значок перекрестья,
означающий точку привязки, переместится в соот-
ветствующее место. Например, чтобы создать па-
раллелограмм из прямоугольного объекта методом
наклона, поместите точку привязки на любом из
углов объекта.
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Размещение точки привязки на углу объекта, чтобы
создать параллелограмм из прямоугольного объекта.

• Удерживайте клавишу Shift при перемещении, что-
бы ограничить угол наклона до установленного
значения, например, 15 градусов. Вы можете уста-
новить это значение в области Preferences панели
Enfocus PitStop Inspector.

Наклон объекта по установленным значениям, как
определено в Preferences.

• Удерживайте клавишу Alt (в Windows) или Option
(в Macintosh) при перемещении, чтобы создать на-
клоненную копию выбранного объекта.

Преобразование объекта 
по точным значениям

Если вы хотите преобразовать объект по точным
значениям, используя одно из инструментальных
средств преобразования ( ), вы должны
использовать панель Enfocus PitStop Inspector. Enfo-
cus PitStop Inspector позволяет вам преобразовывать

любой объект в вашем PDF документе, посредством
ввода точных значений.

Преобразование объекта может включать одно или
большее количество следующих действий:

• Перемещение.

• Масштабирование.

• Наклон.

• Зеркальное отражение.

• Вращение.

Чтобы преобразовать объект с помощью определе-
ния точных значений:

Быстрый доступ: Window > Show PitStop In-
spector > закладка Position.

1. Выберите инструмент Select Objects ( ).

2. Выберите объект, который вы хотите преобразо-
вать.

3. Выберите Window > Show PitStop Inspector , чтобы
отобразить панель Enfocus PitStop Inspector.

4. Выберите закладку Position.

5. Переместите или масштабируйте выбранный объ-
ект, изменяя значения в области Position & Size.
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6. Наклоните или поверните выбранный объект, из-
меняя значения в области Aspect Ratio & Angle:

7. Масштабируйте, поверните или зеркально отрази-
те выбранный объект, изменяя значения, и нажи-
мая кнопки в области Numeric Transforms:

Создание новых форм

При использовании Enfocus PitStop Professional вы
не можете только редактировать существующие
объекты, но также и рисовать новые простые фор-
мы, например, эллипсы и прямоугольники. Напри-
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ООббллаассттьь ЧЧттоо  ооззннааччааеетт

Lower Left
Расстояние между нижней левой
точкой объекта и нижним левым
углом страницы.

Size
Значения ширины и высоты
объекта.

Upper Right
Расстояние между верхней правой
точкой объекта и нижним левым
углом страницы.

ЗЗннааччееннииее РРееззууллььттаатт

> 1
Объект вытянут вертикально
(h > w).

< 1
Объект вытянут горизонталь-
но (h < w).

positive
Объект повернут по часовой
стрелке.

negative
Объект повернут против
часовой стрелки.

ООббллаассттьь

Aspect 
Ratio

Angle

ЧЧттооббыы...... ССддееллааййттее  ссллееддууюющщееее

Масштабиро-
вать объект

Сделайте одно из следующего:

• Введите значения в процентах и
нажмите кнопку         .

• Нажмите кнопку        чтобы увели-
чить объект в 2 раза или кнопку
чтобы уменьшить объект в 2 раза.

Повернуть
объект

Сделайте одно из следующего:

• Введите значения в градусах и на-
жмите кнопку        .

• Нажмите кнопку        или        ,
чтобы повернуть объект на 90°.

Зеркально
отразить
объект

Сделайте одно из следующего:

• Нажмите кнопку       , чтобы
зеркально отразить объект влево
или вправо.

• Нажмите кнопку       , чтобы
зеркально отразить объект вверх
или вниз.



мер, вы можете вывести прямоугольник или эллипс
вокруг фрагмента текста, чтобы  таким образом вы-
делить текст в отдельную рамку.

Если вам надо создать несколько новых форм с
одинаковыми заливкой и обводкой, вы можете
сначала установить эти свойства по умолча-
нию. См. “Настройка предпочтений Enfocus
PitStop Professional” на странице 11.

Чтобы создать новую форму:

1. Нажмите кнопку соответствующего инструмента,
чтобы создать новый прямоугольник ( ) или
эллипс ( ).

2. Установите курсор на странице PDF документа и
сделайте одно из следующего:

• Чтобы вывести новый прямоугольник или эллипс,
нажмите кнопку мыши и переместите курсор по
диагонали.

• Чтобы вывести квадрат или круг, при перемеще-
нии удерживайте клавишу Shift.

• Чтобы вывести прямоугольник или эллипс, начи-
ная от его центра, при перемещении удерживайте
клавишу Alt (в Windows) или Option (в Macintosh).

AA.. Начало со стороны сохраняет стороны формы в
установленной позиции по X и Y осям. 

BB.. Начало нового объекта от центра сохраняет
центральную точку в установленной позиции. 

• Чтобы вывести квадрат или круг, начиная с его
центра, удерживайте и клавишу Shift и клавишу Alt
(Windows) или Option (Macintosh) при перемеще-
нии курсора.

Создание новой траектории

Вы можете создавать новые траектории “на пустом
месте” в вашем PDF документе, просто выбирая ин-
струмент ( ) и щелкая мышью в документе. Но-
вые якорные точки и сегменты будут добавлены при
каждом щелчке. Вы можете создавать открытые или
закрытые траектории.

Чтобы создать новую траекторию:

1. Выберите инструмент Create New Path ( ).
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2. Установите курсор ( ) в том месте PDF доку-
мента, где вы хотите создать первую якорную
точку траектории и щелкните мышью.

3. Переместите курсор туда, где вы хотите закончить
первый сегмент траектории, и щелкните снова.

Таким образом, вы вывели сегмент между двумя
якорными точками.

AA.. Первая якорная точка. BB.. Сегмент. CC.. Средняя
точка. DD.. Вторая якорная точка и указатель. 

4. Щелкните в других местах, чтобы добавить новые
якорные точки и таким образом создать дополни-
тельные сегменты траектории.

Чтобы создать изогнутый сегмент, щелкните в нуж-
ном месте и, удерживая кнопку мыши, и перемести-
те курсор.

5. Чтобы завершить траекторию, нажмите кнопку
любого другого инструмента кроме ( ).

Редактирование траектории

Enfocus PitStop Professional дает вам возможность
изменить форму траектории графического объекта.
Вы можете делать это, выбрав одну или несколько
якорных точек траектории и перемещая эти якор-
ные точки или их направляющие точки. См. также
раздел “Относительно траекторий, якорных и на-
правляющих точек” на странице 104.

Чтобы отредактировать траекторию:

1. Выберите инструмент Edit Path ( ).

2. Выберите графический объект, траекторию кото-
рого вы хотите отредактировать.

Якорные точки траектории станут видимыми, но
еще не выбранными.

Якорные точки видимы, но еще не выбраны.

3. Сделайте одно из следующего:

• Щелкните по нужной якорной точке второй раз.

• Удерживая клавишу Shift, щелкните на нескольких
якорных точках второй раз.

• Обрисуйте курсором рамку выделения вокруг од-
ной или нескольких якорных точек.

Якорные точки будут выбраны, если только вы щел-
кните их второй раз или если вы обрисуете курсором
рамку выделения вокруг них. Выбранные якорные
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точки станут более заметны, и их направляющие то-
чки станут видимыми.

AA.. Видимые якорные точки, которые не выбраны. 
BB.. Выбранные якорные точки с их видимыми напра-

вляющими точками и линиями. 

4. Перетащите якорную точку или ее направляющую
точку в нужную позицию, чтобы изменить форму
сегмента.

Перемещение направляющей точки изменяет форму
сегмента.

Добавление и удаление 
якорных точек

Вы можете добавлять якорные точки или удалять их
из любой траектории графического объекта:

• Если вы добавляете якорные точки, у вас появится
больше возможностей контроля над формой тра-
ектории.

• Если вы удаляете якорные точки, вы упрощаете
форму объекта и автоматически изменяете форму
траектории.

Чтобы добавить якорную точку:

1. Выберите инструмент Add Anchor Point ( ).

2. Выберите графический объект, в который вы
хотите добавить якорную точку.

3. Щелкните в том месте на сегменте траектории, где
вы хотите добавить якорную точку.

Новые якорные точки будут добавлены в сегмент
при каждом щелчке.

Добавление новых якорных точек (AA) в сегмент тра-
ектории.

Чтобы удалить якорную точку:

1. Выберите инструмент Remove Anchor Point (Уда-
ление якорной точки) ( ).
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2. Выберите графический объект, из которого вы
хотите удалить якорную точку.

3. Щелкните на якорной точке, которую вы хотите
удалить.

Выбранная якорная точка на короткое время станет
выглядеть крупнее (и отобразятся ее направляющие
точки, если они есть), затем якорная точка исчезнет.

Форма траектории при этом изменится.
Удаление якорные точки из сегмента траектории
изменяет форму траектории.

Маскированные объекты 

Вы можете создать маску по одному или нескольким
объектам в вашем PDF документе или редактиро-
вать любую существующую маску.

Чтобы создать маску с объектами:

Быстрый доступ: Edit > PitStop Mask > Make.

1. Чтобы создать маску, выберите по крайней мере
один объект в вашем PDF документе и еще один
графический или текстовый объект.

Выберите два объекта для создания маски.

2. Выберите Edit > PitStop Mask > Make.

Контур верхнего объекта используется, чтобы за-
маскировать нижние объекты.

Создание маски с верхним объектом.
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Просмотр свойств 
пиксельных изображений

Enfocus Инспектор PitStop предоставляет вам обзор
свойств пиксельных изображений, включая:

• Размер изображения

• Разрешение

• ICC профиль, если он есть.

Чтобы просмотреть свойства пиксельного изобра-
жения:

Быстрый доступ: Выберите Window > Show
PitStop Inspector > закладка Image > закладка
Properties.

1. Выберите инструмент Select Objects ( ).

2. Выберите изображение.

3. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

4. Нажмите закладку Image, чтобы просмотреть свой-
ства выбранного пиксельного изображения. За-
кладка Properties отображается по умолчанию.

Свойства OPI-объектов не показаны в Image >
закладка Properties. Чтобы просмотреть свой-
ства OPI-объектов, нажмите Prepress > за-
кладка OPI.

Просмотр статистики 
выбранных объектов

Вы можете просматривать статистическую инфор-
мацию относительно выбранных объектов на пане-
ли Enfocus PitStop Inspector. Enfocus PitStop Inspector
также позволяет вам изменять ваш выбор.

Чтобы просмотреть статистику выбранных объек-
тов:

Быстрый доступ: Выберите Window > Show
PitStop Inspector >  закладка Statistics.

1. Выберите инструмент Select Objects ( ).

2. Выберите объект(ы).

3. Выберите Window > Show PitStop Inspector.

4. Отобразите закладку Statistics, чтобы просмотреть
статистику выбранной траектории, текстового
сегмента и/или пиксельного изображения.
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5. В случае необходимости, измените ваш выбор в
области Selection.

Нажатие кнопки Expand Selection имеет тот
же самый результат, что и двойной щелчок
на объекте. См. раздел “Выбор объектов” на
странице 109.

Редактирование 
PDF2GoTM документов 
от CreoScitex Brisque DFE

PDF документы, сгенерированные CreoScitex Brisque
DFE через модуль Brisque PDF2GoTM состоят из
слоев line-work (LW) и continuous-tone (CT) .

Enfocus PitStop Professional позволяет вам изменять
цвета в слое line-work (LW) этих PDF документов.
Например, вы можете делать цвет из выбранной
области в слое line-work (LW), который будет соот-
ветствовать определенному цвету в слое continuous-
tone (CT).

Вы можете использовать любое из двух специализи-
рованных инструментальных средств: Select Restan-
gular Area и Select Polygonal Area.

Специализированные инструментальные средства
Enfocus PitStop Professional, которые могут редакти-
ровать PDF2GoTM документы.

Также вы можете редактировать слой continuous-
tone (CT) PDF2GoTM документа через обычную оп-
цию Edit Image в Adobe Acrobat.

Чтобы отредактировать PDF2GoTM документы от
CreoScitex Brisque DFE.

1. Откройте PDF2GoTM документ.

2. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

3. Выберите инструмент Select Objects ( ).

Курсор изменится на изображение пипетки ( ).

4. Щелкните на любой позиции в PDF документе:

• Если вы нажали на LW слое, окно диалога Enfocus
PitStop Inspector отобразит и исходный цвет и цвет
замены, как показано на иллюстрации ниже.

Вид панели Enfocus PitStop Inspector, когда вы нажима-
ете на LW слое: отображен исходный цвет (AA) и
цвет замены(BB).
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• Если вы нажали на CT слое, окно диалога Enfocus
PitStop Inspector отобразит только цвет текущего
выбора, означая, что вы можете отредактировать
цвет, только ретушируя его в LW слое PDF2GoTM

документа.

Вид панели Enfocus PitStop Inspector когда вы нажимае-
те на CT слое: отображен только цвет текущего
выбора.

5. Нажмите на цвете, который вы хотите изменить в
LW слое.

Выбранный (исходный) цвет появится в области
Selection на панели Enfocus PitStop Inspector.

6. Удерживая клавишу Alt (в Windows) или Option
(в Macintosh), нажмите на целевом цвете, то есть
на цвете, которым вы хотите заменить выбран-
ный цвет.

Вы можете щелкать на цвете CT или LW слоев.
Выбранный целевой цвет появится в области Repla-
ce with на панели Enfocus PitStop Inspector.

7. В случае необходимости, измените целевой цвет,
перемещая движки или введя процентные значе-
ния цвета.

8. Сделайте одно из следующего:

• Чтобы заменить исходный цвет целевым во всем
документе, нажмите Replace in Document.

• Чтобы заменить исходный цвет целевым только на
текущей странице, нажмите Replace in Page.

• Чтобы заменить исходный цвет целевым в опреде-
ленной области, обрисуйте область, используя ин-
струменты ( ) или ( ). Затем нажмите Replace
in Area.
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К акое значение имеет использования шрифта
Times-Roman вместо Times New Roman в  PDF
документе? Могу ли я использовать эти

шрифты попеременно в документе, если нет, когда
мне надо использовать который шрифт? Как раз-
личные типы шрифтов влияют на вывод моего PDF
документа в экранном и в печатном вариантах? Эта
глава обеспечивает ответы на подобные вопросы, а
также предоставляет теоретическую информацию о
шрифтах.

Типы шрифтов и их использование

Стандартные 14 шрифтов

При работе в средах PostScript и PDF вы можете
натолкнуться на понятие “стандартные 14 шриф-
тов” или “базовые 14 шрифтов”. Что же такое “стан-
дартные 14 шрифтов”? Фактически, термин получен
из стандартного набора шрифтов PostScript, кото-
рые являются резидентными на всех устройствах
вывода данных PostScript. Эти шрифты перечисле-
ны в таблице ниже.

Для среды PDF к этому стандартному набору шриф-
тов добавлен шрифт ZapfDingbats (❑✽✒✔ ✎) .

PostScript Type 1 шрифт

PostScript Type 1 шрифты, были первоначально раз-
работаны Adobe Inc. для использования в принтерах
PostScript.

PostScript Type 1 шрифты — контурные шрифты.
Они используют линии и кубические кривые Безье,
чтобы определить форму символа или “глиф” (см.
также раздел “Относительно векторной графики и
пиксельных изображений” на стр. 103). “Глиф” —
это форма, которая используется, чтобы предста-
вить код буквы на экране или на бумаге. Примеры
глифов — символы алфавита или символы  подоб-
ные шрифту ITC ZapfDingbats (т. е. ❑✽✒✔ ✎). 

Type 1 шрифты имеют следующие характеристики:

• Их файлы меньше по размеру, чем шрифты True-
Type, что означает, что они занимают меньше про-
странства на жестком диске вашей системы.

• Являясь контурными шрифтами, Type 1 шрифты
могут масштабироваться до любого размера. Они
остаются четкими в напечатанном виде, даже когда
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Глава 10: Управление шрифтами

ШШррииффтт

Times-Roman

Times-Italic

Times-Bold

Times-BoldItalic

Helvetica

Helvetica�Oblique

HHeellvveettiiccaa��BBoolldd

HHeellvveettiiccaa��BBoollddOObblliiqquuee

ССееммееййссттввоо  шшррииффттаа

Times

Helvetica

ШШррииффтт

Courier

Courier�Oblique

Courier�Bold

Courier�BoldOblique

Symbol (∞≠∆Σϒς ΩΘΞ)

ССееммееййссттввоо  шшррииффттаа

Courier

Symbol



печатаются маленьким кеглем на лазерных принте-
рах с низкой разрешающей способностью.

• PostScript Type 1 шрифты, обычно используются в
профессиональной издательской среде и поддер-
живаются всеми высококачественными устрой-
ствами вывода, потому что большинство этих уст-
ройств использует программный язык PostScript в
качестве языка описания страниц.

• PostScript Type 1 шрифт содержится в двух отдель-
ных файлах: в одном описаны контуры символов, а
в другом содержатся метрические данные шрифта.
На платформе Windows, вы можете узнать эти
файлы по их расширениям:  .pfb (Printer Font Bina-
ry file) для контуров символов и  .pfm (Printer Font
Metrics file) для  содержащего метрические данные.
Первый файл (.pfb) обычно называется шрифтом
принтера, второй (.pfm) также известен как
шрифт видеотерминала. Общий размер обоих
файлов, однако, меньше чем размер одного файла
его TrueType дубликата. Иногда размер файла Post-
Script шрифта может быть даже вдвое меньшим,
чем размер соответствующего шрифта TrueType.

• В операционной системе Macintosh вы можете узнать
PostScript Type 1 шрифт по значку  ( ), в системе
Windows по значку  ( ).

PostScript Type 3 шрифт

PostScript Type 3 шрифты — это прежде всего деко-
ративные шрифты с большим количеством украше-
ний, они характерны наличием сглаженных объек-
тов, разновидностями заливок и обводок в каждом
символе. Действительно, Type 3 шрифт может иметь
черно-белые заливки и контуры и другие “специаль-
ные эффекты”, в то время символы Type 1 и True-
Type шрифтов полностью черные. Type 3 шрифты
имеют следующие характеристики:

• Их файлы по размеру больше чем файлы Type 1 и
TrueType шрифтов.

• Они могут потребовать больше времени для печа-
ти.

• Type 3 шрифты смотрятся хуже, чем Type 1 или
TrueType шрифты, особенно в маленьком кегле и
когда печатаются с низким разрешением.

TrueType шрифт

Формат TrueType font (.ttf) был разработан корпора-
цией Apple Computer как альтернатива стандарту
Type 1 от Adobe Systems Inc. Он применяется на ком-
пьютерах в системах Windows и Macintosh. 

Так же как и PostScript Type 1 шрифты, TrueType
шрифты тоже используют контуры, чтобы описать
формы символов.

TrueType шрифты имеют следующие характеристи-
ки:

• Они широко используются, и интегрированы прак-
тически в каждой настольной офисной программе
для систем Macintosh или Windows.

• Шрифты TrueType могут хорошо печататься на
PostScript и не-PostScript устройствах вывода. Од-
нако чтобы хорошо напечататься на PostScript уст-
ройстве, TrueType шрифт должен быть сконверти-
рован в PostScript, что может затронуть визуальное
качество конечного шрифта. Это основная причи-
на из-за чего множество сервисных служб допечат-
ной подготовки отказываются работать с TrueType
шрифтами.

• На системах Windows, TrueType шрифт физически
содержится в одном файле, имя которого имеет
расширение .ttf. На Macintosh он хранится как оди-
ночный Suitcase.

• Файл TrueType шрифта визуально представлен в
операционной  системе Windows значком ( ), в
системе Macintosh значком ( ) .
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• Использование TrueType шрифтов, или же сов-
местное использование и TrueType и PostScript
шрифтов в одном документе, может быть непри-
емлемо в высококачественных устройствах вывода
PostScript, особенно фотонаборных аппаратах.
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AA..  Times  как PostScript Type 1 Single Master шрифт на экране.
BB.. Times New Roman как TrueType шрифт на экране.

CC.. Times как напечатанный PostScript Type 1 Single Master шрифт.
DD.. Times New Roman как напечатанный TrueType шрифт.



Multiple Master шрифт

Формат Multiple Master font это расширенный фор-
мат шрифта PostScript Type 1. Multiple Master шриф-
ты являются шрифтами, предлагающими разновид-
ности дизайна символа на так называемой “оси ди-
зайна”. Эта ось дизайна представляет переменные
свойства шрифта, а именно:

• Weight (вес) — (светлый или полужирный).

• Width (ширина) — (сжатый или расширенный).

• Оптический размер.

Механизм Multiple Master шрифтов основан на том,
что два “мастера” на оси дизайна имеют установлен-
ный дизайн символа, но вы можете создать любую
разновидность этого дизайна в промежутке между
ними. Как правило, Multiple Master шрифты имеют
две оси дизайна и четыре мастера. Таким образом,
мастеры представляют собой “краеугольные камни”
данной матрицы.

AA. Мастеры. BB.. Свойства шрифта. CC.. Ось дизайна.
DD.. Одно из определяемых пользователем начертаний. 

Чтобы создавать промежуточные варианты Multiple
Master шрифта, вам нужна программа Adobe Type
Manager.

DoubleBbyte шрифт 

Double-byte шрифты (или шрифты с двумя байта-
ми, т. е. 16-ти битные) необходимы, если вы работа-
ете с азиатскими языкам, например, японским, ки-
тайским или корейским. Эти языки имеют намного
больше символов, чем языки, основанные на алфа-
вите. Соответственно, работа с такими языками тре-
бует программное обеспечение, которое поддержи-
вает формат кодирования с двумя байтами.

Double-byte шрифт использует знаки с 16-ю битами
(т. е. единицами информации), иначе говоря, он ис-
пользует в два раза больше единиц информации,
чем шрифты с 8-ю битами (однобайтные). 

Подстановка шрифта в PDF

Если вы передаете PDF документы на другой ком-
пьютер или на другую компьютерную платформу,
шрифты в документе находиться в любом из трех
состояний. Они могут быть:

• Доступны, то есть шрифты в PDF документе также
установлены в системе компьютера, где открыт PDF
документ.

• Доступны как внедренные шрифты, что означает,
что шрифты встроены в PDF документ.

• Не доступны, т. е. шрифты отсутствуют в докумен-
те или в системе.

Если шрифт не доступен, он должен быть заменен
шрифтом, доступным на компьютере получателя.
Этот процесс называется “подстановкой  шрифта в
PDF”(substitution).
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Обнаружение точных имен 
PostScript шрифта 

Если вы должны ввести имя шрифта вручную в En-
focus PDF Profile Editor, вы можете использовать
файл PDF, чтобы найти точную орфографию имени
PostScript шрифта.

Чтобы найти точное имя PostScript шрифта. 

1. Используйте любое приложение, чтобы создать
одностраничный документ со шрифтом PostScript.

2. Создайте из этого документа файл PDF.

3. Откройте PDF файл в Acrobat и выберите File >
Document Info > Fonts. (Если файл содержит боль-
ше одной страницы, а шрифт, который вам ну-
жен, находится не на первой странице, нажмите
List All Fonts.)

4. Запишите имя шрифта по буквам, используя точ-
ную орфографию (прописные и строчные буквы,
дефисы и т. п.), точно так же, как шрифт указан в
окне диалога Font Info.

5. Нажмите OK, чтобы закрыть окно диалога.

Внедрение и  подмножества 

Внедрение шрифтов

Используя Enfocus PDF Profile Editor, вы можете
определить в PDF профиле, должен ли PDF доку-
мент:

• Внедрить все шрифты.

• Внедрить все шрифты кроме стандартных 14
шрифтов.

• Внедрить все шрифты, которые не могут быть эму-
лированы для просмотра.

• Внедрить все шрифты, которые могут быть эмули-
рованы для просмотра.

Полное внедрение шрифта подразумевает, что весь
шрифт (то есть каждый символ данного шрифта)
будет скопирован в ваш PDF документ. Это особен-
но полезно, если этот документ должен быть ото-
бражен или напечатан на другом компьютере, кото-
рый может не содержать те же самые шрифты. 

Кроме того, если внедрен полный шрифт, вы може-
те редактировать текст в PDF документе на компью-
тере, который не содержит данный шрифт в системе.

Обратите внимание, что при внедрении полного
шрифта — (стандартный шрифт с кодовой страни-
цей Roman обычно содержит 256 знаков) — размер
файла PDF документа увеличится на 30–40 Kb для
одного Type 1 шрифта, или еще больше для одного
TrueType шрифта.

Внедрение подмножества шрифта (subset)

Используя Enfocus PDF Profile Editor, вы можете оп-
ределить в PDF профиле, должен ли PDF документ:

• Внедрить все символы шрифтов.

• Внедрить все символы шрифтов кроме стандарт-
ных 14 шрифтов.

• Внедрить все символы шрифтов, которые не могут
быть эмулированы для просмотра.

• Внедрить все символы шрифтов, которые могут
быть эмулированы для просмотра.

Вместо полного внедрения шрифта, вы можете вне-
дрить только подмножество шрифта — то есть то
количество символов шрифта, которое фактически
используется в тексте. Установка внедрения подмно-
жества шрифта (subset) позволяет вам сделать файл
как можно меньшим по размеру, что рекомендуется,
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если вы не планируете добавлять текст (и, следова-
тельно, большее количество символов шрифта) в
документ. 

Обратите внимание на то, что когда вы объединяете
два или больше PDF документов, которые имеют то
же самое подмножество шрифта, дублирующая ин-
формация о символах не удаляется из кодировки
файлов. Это приводит к неоправданному увеличе-
нию размера файла.

Однако если для вас не важно, увидят ли читатели
ваш документ с его первоначальными шрифтами,
(это может быть актуально, если вы используете
стандартную латиницу без каких-либо националь-
ных символов — Д.С.) не внедряйте шрифты вооб-
ще, и позвольте программе Acrobat самой делать
подстановку шрифтов, когда она необходима. Это
даст возможный самый наименьший по размеру
файл. 

Обнаружение точных имен шрифта

Один и тот же шрифт может иметь различные име-
на. Имя шрифта, который вы видите в вашем исход-
ном приложении, не обязательно точно соответст-
вует его “реальному” внутреннему имени.

Например, шрифт “Times” (Type 1), который вы ви-
дите в программе обработки текстов или в програм-
ме настольной издательской системы имеет Post-
Script имя “Times-Roman”. Тот же самый пример —
TrueType дубликат этого шрифта, — в программе
обработки текстов он показан как “Times New
Roman”, но его имя прописано в Adobe Acrobat как
“TimesNewRoman” (без пробелов).

Следовательно, если вы должны ввести имя шрифта
вручную в одно из окон диалога Enfocus PitStop Pro-
fessional, важно, чтобы вы вводили имя шрифта
точно так же, как он прописан в Adobe Acrobat. Вы
можете использовать файл PDF, чтобы найти точ-
ную орфографию имени шрифта.

Чтобы найти точное имя шрифта.

1. Используйте любое приложение, чтобы создать од-
ностраничный документ со шрифтом(ами),  точ-
ное имя которого(ых) вы хотите узнать.

2. Создайте файл PDF документа.

3. Откройте PDF файл в Adobe Acrobat и сделайте
одно из следующего:

• В программе Adobe Acrobat 4 выберите File > Do-
cument Info > Fonts.

• В программе Adobe Acrobat 5 выберите File > Docu-
ment Properties > Fonts.

4. Запишите имя шрифта(ов), используя точную ор-
фографию (прописные и строчные буквы, дефи-
сы, и т. п. — так как оно (они) показано(аны) в ок-
не диалога Font Info.

5. Нажмите OK.
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Э та глава предлагает краткое описание цвето-
вых моделей и основные понятия управления
цветом. Она также объясняет, как вы можете

использовать Enfocus PitStop Professional, чтобы по-
лучить точное высококачественное воспроизведе-
ние цветов в PDF документах.

Относительно управления цветом

Цветные мониторы и принтеры воспроизводят цвет
различными способами.

Система управления цветом (CMS — Color Manage-
ment System) — совокупность инструментальных
средств, предназначенных для регулирования раз-
личных возможностей сканеров, мониторов и прин-
теров, чтобы гарантировать соответствие цветов
при отображении на дисплее и в процессе печати.
Идеально, это означает, что цвета, отображенные на
вашем мониторе, точно представляют цвета заклю-
чительного вывода. Это также означает, что в идеале
различные программные приложения, мониторы и
операционные системы должны обрабатывать цвета
одинаково.

Цветовые модели

Цветовая модель RGB

Монитор использует красный, зеленый и синий свет
(RGB — Red, Green, Blue), чтобы создать цвета. Из
объединения всех трех цветов полной интенсивнос-
ти освещения получается белый цвет. RGB цвета ис-
пользуются для видео, и мониторов. Монитор ваше-
го компьютера создает цвет, пропуская лучи через
красный, зеленый и синий фосфор.

Цветовая модель RGB

Цветовая модель CMYK

При печати используется цветовая модель CMYK, в
которой три цвета прозрачной краски (голубой —
Cyan, пурпурный — Magenta и желтый — Yellow)
объединены с черным (отмеченным как K — blacK),
в разном процентном соотношении, чтобы создать
различные цвета. CMYK краски фильтруют белый
свет, который отражается от бумаги и вычитает
часть красного, зеленого и синего света из спектра.
Цвет, который мы видим, — то, что остается.

В теории, чистые голубые, пурпурные и желтые пиг-
менты краски при объединении должны поглощать
весь свет и воспроизводить черный. Но поскольку
все печатные краски содержат примеси, наложение
этих трех красок фактически образует грязный ко-
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ричневый цвет. Поэтому для образования истинно
черного, в цветовую модель отдельно добавлен
черный цвет, т. е. черная краска. Совокупность всех
этих красок для воспроизведения различных цветов
называется четырехкрасочной печатью.

В теории, смесь 100-процентных голубой, пурпурной
и желтой краски должны давать черный цвет; на
практике образуется грязно-коричневый.

Цветовая модель Gray

Цветовая модель Gray использует серые оттенки в
диапазоне от белого к черному. В этом случае, каж-
дый пиксел черно-белого изображения имеет значе-
ние яркости в пределах от 0 % (белый) до 100 %
(черный). Максимальное число градаций серого,
которое может производить большинство устройств
вывода — 256.

Цветовая гамма и 
цветовые пространства

Видимая область спектра содержит миллионы цве-
тов, но устройства, типа сканеров, мониторов и

принтеров могут воспроизводить только подмноже-
ство этого спектра. Это “подмножество” называется
цветовой гаммой. Гамма устройства определяет цве-
товое пространство, которое данное устройство мо-
жет воспроизводить. Например, монитор может от-
ображать более широкую гамму цветов, чем машина
офсетной печати может напечатать, используя цвета
CMYK. В то же время некоторые из цветов CMYK не
могут быть точно отображены на мониторе. Каждое
устройство имеет различную цветовую гамму.

AA.. Цветовая  гамма RGB. BB.. Цветовая  гамма CMYK. 

Для получения дополнительной информации о цве-
товой гамме и цветовых пространствах см.  встроен-
ную справку по Acrobat, выбирая в меню приложе-
ния Help > Acrobat Guide.

АппаратноBзависимый цвет

Аппаратно-зависимый цвет относится к установкам
устройства, на котором изображение создается или
выводится. Аппаратно-зависимый цвет подразуме-
вает калибровку всех устройств в рабочем потоке,
которые используются для получения точного цве-
товоспроизведения. Другими словами, устройства
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ввода данных (например, сканеры и цифровые ка-
меры) и устройства вывода данных (например, мо-
ниторы и принтеры) должны быть настроены в со-
ответствии друг с другом, чтобы достичь соответст-
вия цветов.

Различия могут быть даже между устройствами оди-
накового типа и одинаковой модели, поскольку у
них могут быть различные установки. Например,
мониторы могут иметь различную яркость или кон-
траст. 

Для получения дополнительной информации об
аппаратно-зависимых цветах, см. встроенную справ-
ку по Acrobat, выбирая Help > Acrobat Guide.

АппаратноBнезависимый цвет

Чтобы устранить, или, по крайней мере уменьшить,
цветовые различия между устройствами, вы можете
использовать систему управления цветом. Системы
управления цветом используют стандартную, неза-
висимую от устройства цветовую модель, например,
CIELab. Изображения связаны с профилем, который
содержит информацию относительно устройств вво-
да и вывода данных. Таким образом, если изображе-
ния будут выводиться на определенном устройстве,
они будут связаны с профилем этого целевого уст-
ройства.

Для получения дополнительной информации об ап-
паратно-независимом цвете, см. встроенную справ-
ку по Acrobat, выбирая Help > Acrobat Guide.

Переотображение цветов

Система  управления цветом позволяет вам переото-
бражать цвета так, чтобы они лучше всего соответ-
ствовали своему предназначенному использованию.
“Переотображение” (Remapping) означает, что цвета
цветового пространства одного устройства вывода
данных будут отображены в цветовом пространстве

другого устройства. Это переотображение делается
согласно определенному методу, называемому также
намерением прорисовки (rendering intent). Имеются
четыре основных метода переотображения или на-
мерения прорисовки:

• Перцептуальное переотображение.

• Насыщенное переотображение. 

• Относительное колорометрическое переотображе-
ние.

• Абсолютное колорометрическое переотображение. 

Перцептуальное переотображение

Человеческий глаз чувствителен к сочетаниям цве-
тов. Перцептуальное отображение меняет все цвета
в первоначальном цветовом пространстве, чтобы
перенести их в гамму другого цветового простран-
ства, но сохраняет отношения между цветами. По-
скольку отношения сохраняются, изменения в цве-
тах будут практически незаметны.

Перцептуальное переотображение масштабирует
первоначальную гамму (AA) в пределах гаммы цветово-
го пространства адресата (BB), но сохраняет отно-
шения между цветами.
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Насыщенное переотображение

Насыщенное переотображение воспроизводит пер-
воначальную насыщенность цветов изображения
при преобразовании в цветовое пространство целе-
вого устройства. При этом подходе, относительная
насыщенность цветов поддерживается от гаммы до
гаммы. Этот метод переотображения, прежде всего
предназначен для деловых графиков, где точные со-
четания цветов (как в фотографическом изображе-
нии) не столь важны, сколько — яркие насыщенные
цвета.

Насыщенное переотображение сдвигает все цвета
изображения к самой яркой возможной насыщенно-
сти (BB) гаммы. Сочетания цветов остаются теми
же самыми, но некоторые цвета становятся светлее
или темнее.

Относительное колорометрическое
переотображение

Цвета, которые находятся в пределах гамм обоих
устройств ввода и вывода, остаются без изменения.
Цвета, которые находятся вне гаммы устройства

вывода, обычно изменяются к цветам с той же са-
мой яркостью, но с другой насыщенностью.

Этот метод может значительно уменьшить общее
количество цветов в изображении, — если множест-
во различных цветов устройства ввода переотобра-
зятся к одному цвету устройства вывода.

Но этот метод соответствия полезен при объедине-
нии 2 профилей вывода для проверки. Так как гамма
устройства проверки (2) должна быть больше чем
гамма (1) профиля целевого устройства. 

Относительное колорометрическое переотображе-
ние: цвета вне гаммы (АА) заменяются цветами с той
же яркостью, но различной насыщенностью (BB).

Абсолютное колорометрическое 
переотображение

Цвета, которые находятся в пределах гамм обоих
устройств ввода и вывода, остаются без изменения.
Цвета, которые находятся вне гаммы устройства
вывода, изменяются к цвету на краю гаммы устрой-
ства вывода. Это может привести к потерям деталей
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в некоторых областях. Для большинства цветов гра-
дационной шкалы будет получено близкое соответ-
ствие. Этот метод предназначен для печати допол-
нительной (spot) краской.

Абсолютное колорометрическое переотображение:
цвета вне гаммы изменяются к цвету на границе
гаммы (BB). Цвета, которые не могут быть отобра-
жены в гамме целевого устройства, будут утеряны.

Дополнительные цвета (spot)

Дополнительный цвет (spot) это краска, которая пе-
чатается отдельно от системы четырехкрасочной пе-
чати CMYK. Такой цвет также иногда называют пла-
шечным цветом. Как правило, краска дополнитель-
ного цвета заранее изготавливается путем смеси три-
адных красок. Вы можете выбрать несколько систем
печати дополнительными красками и сотни различ-
ных дополнительных красок. В офсетной печати до-
полнительный цвет воспроизводится с использова-
нием отдельной печатной формы для данного до-
полнительного цвета. Четырехцветная печать, нап-
ротив, использует только четыре краски (CMYK: го-
лубая, пурпурная, желтая и черная) для воспроиз-
ведения всех цветов.

Если вы печатаете дополнительной краской в 100 %,
на вашей странице появляется густой непрозрачный
цвет (не имеющий точечной структуры). Оттенок
дополнительной краски, то есть не со 100 % -м нало-
жением, создается путем печати меньших растровых
элементов основного цвета.

Enfocus PitStop Professional дает возможность вам
выполнить следующие задачи, связанные с печатью
дополнительной краской:

• Создавать или редактировать дополнительный
цвет.

• Переотображать пиксельные изображения, в кото-
рых используется дополнительный цвет. 

• Дублировать дополнительный цвет.

Создание и редактирование 
дополнительного цвета

Вы можете использовать Enfocus PitStop Professional,
чтобы создать новый дополнительный цвет в Adobe
Acrobat, изменить имя дополнительного цвета или
соотношения красок его CMYK эквивалента. Этот
подход имеет то преимущество, что проще сохра-
нить эти цвета в вашем конечном документе, по
сравнению с возможными сложностями при управ-
лении дополнительным цветом в исходном файле и
в дизайнерских программах настольной издательс-
кой системы. Графика, которую вы импортируете в
программу настольной издательской системы, на-
пример, может иметь взаимные различия при опре-
делении дополнительного цвета. Или эти определе-
ния дополнительного цвета для графики могут от-
личаться от тех, которые вы определили в вашей
программе настольной издательской системы.

Чтобы создать или редактировать дополнительный
цвет:

1. Создайте или откройте PDF документ с цветным
объектом или текстом.
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2. Выберите объект или текст инструментом Select
Objects ( ).

3. Выберите Window > Show PitStop Inspector.

4. Нажмите кнопку Spot color.

Появится окно диалога Spot Color Picker.

5. Сделайте одно из следующего:

• Чтобы создать новый дополнительный цвет, наж-
мите New.

• Чтобы изменить имя или значения красок CMYK
эквивалента дополнительного цвета, выберите до-
полнительный цвет и нажмите Edit.

6. Введите или измените имя дополнительного цвета
и его значений красок CMYK эквивалента.

Рекомендуется давать дополнительным цве-
там уникальное имя, чтобы сделать их “до-
ступными для одновременной модификации”.
Например, фирменный стиль компании, для
которой вы делаете PDF документ, может
внезапно измениться, и тогда вам дадут ука-
зание, что цвет под названием Company дол-
жен быть изменен с зеленого на синий. В этом
случае вам надо будет только изменить
CMYK значения цвета Company. Все ссылки к
имени этого цвета могут остаться, как они
есть, а все объекты, которые используют
этот цвет, будут немедленно модифициро-
ваны и появятся в новом цвете.

7. В области Repository (библиотека) нажмите Save.

8. Сохраните свой цвет в своей библиотеке под точ-
но таким же именем.

Сохранение цвета в библиотеке сделает цвет доступ-
ным для других задач, которые выполняет Enfocus
PitStop Professional, например, выполнения глобаль-
ных изменений цвета. Тогда вы сможете отыскать
этот цвет в библиотеке цветов и повторно его ис-
пользовать. См. также раздел “Работа с библиотекой
цветов” на странице 141.
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Переотображение пиксельных 
изображений, созданных с применением
дополнительного  цвета 

Enfocus PitStop Professional позволяет вам переото-
бражать пиксельные изображения с дополнитель-
ными цветами любого цветового пространства в
любой другой цвет в PDF документе или библиотеке
цветов. Переотображение дополнительного цвета
может быть полезно, например, если вы должны
сделать цветоделение из PDF документа. В этом слу-
чае вы можете оставить первоначальное пиксельное
изображение с дополнительной краской неизменяе-
мым, но переотобразить определенную дополни-
тельную краску в соответствующий цвет в цветовом
пространстве CMYK.

Чтобы переотобразить дополнительный цвет:

1. Откройте PDF документ, в котором вы хотите
переотобразить дополнительный цвет.

2. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

3. Нажмите Image > закладка Remap. 

4. Выберите инструмент Select Objects  ( ) и выбе-
рите пиксельное изображение в вашем PDF доку-
менте, которое содержит дополнительный цвет.

5. Выберите один дополнительных цветов, которые
появятся в области Remap Spot Colors.

6. Сделайте одно из следующего:

• Чтобы переотобразить цвет выбранного объекта в
цвет CMYK или в любой другой дополнительный
цвет, выберите соответствующий целевой цвет из
раскрывающегося списка Remap to, как показано
на рисунке ниже.

AA..  CMYK цвета. 
BB..  Дополнительный цвет в выбранном объекте.

• Чтобы переотобразить выбранный цвет в любой
другой дополнительный цвет, который уже есть в
PDF документе, нажмите кнопку From Document на
закладке Remap.
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• Чтобы переотобразить выбранный цвет в любой
другой цвет из библиотеки цветов, нажмите From
Repository. Для получения дополнительной инфор-
мации о библиотеках цветов, см. раздел “Работа с
библиотекой цветов” на странице 141.

7. Нажмите Apply.

Нажмите кнопку Keep, чтобы сохранить вы-
бранный дополнительный цвет, как он есть
или нажмите кнопку Keep All, чтобы сохра-
нить все дополнительные цвета, как они есть.

Дублирование дополнительного цвета

Enfocus PitStop Professional дает возможность вам
дублировать объекты, содержащие дополнительные
цвета и создавать определяемый пользователем до-
полнительный цвет с той же самой формой скопи-
рованного объекта. Вы можете делать это, напри-
мер, чтобы создать форму для нанесения лака.

Чтобы дублировать дополнительный цвет:

1. Откройте PDF документ, в котором вы хотите соз-
дать новый дополнительный цвет, основанный на
форме выбранного объекта.

2. Выберите инструмент Select Objects  ( ).

3. Выберите объект, форму которого вы хотите ско-
пировать.

4. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

5. Выберите закладку Prepress > закладка Duplicate.

6. Нажмите кнопку New.

7. Введите имя для нового дополнительного цвета в
области Edit, например, “Лак”.

8. Выберите Overprint.

9. Нажмите Apply.

Работа с библиотекой цветов

Enfocus PitStop Professional позволяет вам работать с
библиотекой цветов. Эта библиотека цветов пред-
ставляет собой набор цветов, которые вы часто ис-
пользуете. Вы можете:

• Создать библиотеку из новых или существующих
цветов.

• Использовать цвета из библиотеки, применяя их
для текста или объектов в ваших PDF документах.

• Удалять цвета из библиотеки

Формирование библиотеки цветов

Вы можете составить библиотеку из тех цветов, ко-
торые вы часто используете в своем рабочем про-
цессе. Вы можете также создавать новые цвета и до-
бавлять их в свою библиотеку. Библиотека может
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содержать любое цветовое пространство, опреде-
ленное для Adobe PDF версии 1.3, включая дополни-
тельные цвета и цветовые пространства.

Чтобы создать библиотеку цветов:

1. Выберите инструмент Select Objects  ( ).

2. Щелкните на любом тексте или объекте в PDF до-
кументе с цветом, который вы хотите добавить в
библиотеку.

3. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

Появится панель Enfocus PitStop Inspector, которая
отобразит текущие установки цвета выбранного объ-
екта или текста, как показано на рисунке ниже.

4. В случае необходимости, измените цвет, исполь-
зуя движки, или выберите другую цветовую мо-
дель (Gray, RGB или CMYK), или дополнительный
цвет. См. также раздел “Изменение цвета текста”
на странице 101.

5. Под Repository нажмите Save.

6. Введите подробное имя для дополнительного цве-
та в окне диалога, как показано ниже.

7. Нажмите OK.

Указанный цвет теперь будет сохранен в вашей биб-
лиотеке цветов и может быть многократно исполь-
зован позже.

Использование цвета 
из библиотеки цветов

Как только вы сохранили ряд цветов в вашей биб-
лиотеке, вы можете окрашивать объекты или текст в
PDF документе в эти цвета.

Чтобы применить цвет из библиотеки к тексту или
объектам:

1. Выберите инструмент Select Objects  ( ).

2. Щелкните на любом тексте или графическом объ-
екте в PDF документе, к которому вы хотите при-
менить цвет из вашей библиотеки.

3. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

Появится панель Enfocus PitStop Inspector, которая
покажет текущие установки цвета выбранного текс-
та или объекта, как показано на рисунке ниже.

4. В области Repository нажмите Load.
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5. Выберите цвет в списке Color Names.

Вы увидите, что цвет выбранного текста или объ-
екта изменится в интерактивном режиме, как только
вы выберете нужный цвет.

6. Нажмите OK.

7. В случае необходимости, откорректируйте вы-
бранный цвет, используя перемещение движков
на панели Enfocus PitStop Inspector .

Удаление цветов из библиотеки

Вы можете легко удалить цвета из библиотеки, на-
пример, те цвета, которые вы больше не будете ис-
пользовать.

Чтобы удалить цвет из библиотеки:

1. Выберите инструмент Select Objects  ( ).

2. Выберите любой текст или объект в PDF документе.

3. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

4. В области Repository нажмите Load.

5. Выберите цвет, который вы хотите удалить, в спи-
ске Color Names.

Вы увидите, что цвет выбранного текста или объ-
екта изменится в интерактивном режиме, как только
вы выберете нужный цвет.

6. В области Selected нажмите Remove.

7. Нажмите Cancel.

Цвет будет удален из библиотеки, а выбранный
текст или объект будет восстановлен с его первона-
чальным цветом.

8. Сделайте одно из следующего:

• Чтобы изменить цвет объекта в пределах той же
самой цветовой модели (например, CMYK), пере-
местите сдвиг соответствующего цвета или введите
процентное значение в текстовом поле. Вы увиди-
те, что цвет текста или объекта постепенно изме-
няется (согласно перемещению движка).

• Чтобы изменить цвет объекта в другую цветовую
модель (Gray, RGB или CMYK), нажмите соответ-
ствующую кнопку и, в случае необходимости, пере-
местите соответствующий движок или введите про-
центное значение в текстовом поле.

• Если ваш PDF документ содержит дополнительные
цвета, и вы хотите изменить цвет выбранного объ-
екта на один из этих дополнительных цветов, наж-
мите кнопку Spot Color. Выберите один из доступ-
ных дополнительных цветов в Spot Color Picker
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(Сортировщике дополнительных цветов), и наж-
мите OK.

Использование ICC профилей 
пиксельных изображений 

Вы можете проверить, присутствует ли в пиксель-
ном изображении ICC профиль или нет. Если нет, то
с помощью Enfocus PitStop Professional вы можете
применить ICC профиль к этому изображению.

Чтобы использовать ICC профили пиксельных изо-
бражений:

1. Выберите инструмент Select Objects  ( ).

2. Выберите Window > Show PitStop Inspector, чтобы
отобразить панель Enfocus PitStop Inspector.

3. Выберите объект (пиксельное изображение), в ко-
тором вы хотите проверить наличие ICC профиля.

4. Нажмите закладку Image.

На закладке Summary, появляющейся по умолча-
нию, будет показан ICC профиль выбранного изо-
бражения, если он присутствует.

Область на панели, где показывается ICC профиль
выбранного пиксельного изображения.

Чтобы снабдить изображение ICC профилем:

1. Выберите изображение, которое вы хотите снаб-
дить ICC профилем.

2. Выберите Window > Show PitStop Inspector.

3. Выберите Color > закладка Fill Color.

Enfocus PitStop Inspector отобразит список доступ-
ных ICC профилей, один из которых вы можете
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применить для выбранного пиксельного изображе-
ния, как показано на рисунке ниже.

4. Выберите профиль из списка и нажмите Tag Image.

Изображению будет присвоен выбранный профиль,
и название этого ICC профиля появится в списке
ICC Tagging на панели Enfocus PitStop Inspector.

В списке ICC Tagging показывается название 
ICC профиля выбранного изображения

Вы можете также удалить ICC профиль из изображе-
ния. Просто выберите изображение, вызовите па-
нель Enfocus PitStop Inspector, и нажмите кнопку
Untag Image.
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